15.12.2018, 06:32 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Anonymous

unregistriert

1

30.04.2006, 18:26

apt-get install ==Probleme

Hallo,

ich habe seit kurzem das Problem, keine Pakete mehr ?ber "apt-get" installieren zu k?nnen. Ich erhalte dann immer nicht erf?llte Abh?ngigkeiten, will ich wiederum die ben?tigten Pakete, wie z.B. libc6 installieren, f?hrt dies auch zu Fehlern.

Ein "apt-get update" hilft nicht.
Was kann man denn noch versuchen?

Vielen Dank.

[code:1]
root@LinuxPower:~# apt-get install lisa
Paketlisten werden gelesen... Fertig
Abh?ngigkeitsbaum wird aufgebaut... Fertig
Sie m?chten wahrscheinlich ?apt-get -f install? aufrufen, um dies zu korrigieren:
Die folgenden Pakete haben nichterf?llte Abh?ngigkeiten:
lisa: H?ngt ab: kdelibs4c2a (>= 4:3.5.1-1) soll aber nicht installiert werden
H?ngt ab: libgcc1 (>= 1:4.0.2) aber 1:4.0.1-4 soll installiert werden
H?ngt ab: libstdc++6 (>= 4.0.2-4) aber 4.0.1-4 soll installiert werden
rcconf: H?ngt ab: sysv-rc soll aber nicht installiert werden
E: Nichterf?llte Abh?ngigkeiten. Versuchen Sie ?apt-get -f install? ohne jeglich Pakete (oder geben Sie eine L?sung an).
///////////////////////////////////////////////////////////////////////
root@LinuxPower:~# apt-get install libc6
Paketlisten werden gelesen... Fertig
Abh?ngigkeitsbaum wird aufgebaut... Fertig
Sie m?chten wahrscheinlich ?apt-get -f install? aufrufen, um dies zu korrigieren:
Die folgenden Pakete haben nichterf?llte Abh?ngigkeiten:
libc6: H?ngt ab: tzdata soll aber nicht installiert werden
libc6-dev: H?ngt ab: libc6 (= 2.3.5-3) aber 2.3.6-7 soll installiert werden
rcconf: H?ngt ab: sysv-rc soll aber nicht installiert werden
usw.
[/code:1]

2

30.04.2006, 18:47

Hi,

er gibt doch eine M?glichkeit vor

apt-get install -f ...

oder versuch die angmeckerten Pakete einzeln zu installieren.

Gruss Guido

PS: hab so ein Problem zum Gl?ck noch nie gehabt, aber versuchs ruhig mal.

Anonymous

unregistriert

3

30.04.2006, 19:41

Klappt leider nich, gleiches resultat-aber nen Versuch wars wert.

4

30.04.2006, 20:20

Hi,

dann schau mal hier rein, vielleicht hilft das:

http://www.debian.org/doc/manuals/apt-howto/ch-erros.de.html

Gruss Guido

5

01.05.2006, 00:14

hi obiwan,
( klassischer name . . . )
;-)

kde ist 3.5.2 z.Zt.
lan-information-server ist gem?? message:

M?gliche Pakete:4:3.5.2-1+b1
Versions-Tabelle:
4:3.5.2-1+b1 0

wenn apt-get -f install
zweimal hintereinander nicht geht -
dann nochmals : apt-get update machen . . .

dann apt-get install kdebase
apt-get install libasound2 . . .

oder vorher versuchen: dpkg-reconfigure kdebase (oder lisa)
gruesse
ruex
.... eigentlich nicht schlecht ... dieses Linux ... bis auf das stundenlange Suchen nach ... einem richtigen ... Befehl ...

Anonymous

unregistriert

6

01.05.2006, 01:40

Problem gel?st

juhu kalppt alles wieder, danke f?r eure Antworten!
letztendlich war aber rcconf der ?belt?ter, der die Paketorganisation zerschossen hatte. Nach dessen deinstallation und einem" dpkg --configure -a" lief wieder alles. :)

Anonymous

unregistriert

7

27.10.2006, 23:58

ich hab genau das gleiche porblem, leider haben alle ratschl?ge bei mir nichts gen?tzt.

wenn ich versuche ein paket zu installieren kriege ich nur nciht erf?llte abh?ngigkeiten zur?ck. habe n upgrade gemacht, hat ohne probleme geklappt.

wen ich per apt-get update und apt-get install in allen formen und variationen versuche etwas zu installieren kommt immer nur irgendne bl?sinnige abh?ngigkeitsmeldung. wenn ich diese dann einzeln aufl?sne will kommen immer mehr untergeordnete raus die ich auch von hand l?sen m?sste. is n bisschen ?de so.

hat jemand nen klugen ratschlag? allein komme ich leider nicht mehr weiter

8

28.10.2006, 08:36

Hi,

poste doch mal den output

Gruss

Anonymous

unregistriert

9

28.10.2006, 13:23

Zitat von »"Ludwig Van"«

ich hab genau das gleiche porblem, leider haben alle ratschl?ge bei mir nichts gen?tzt.

wenn ich versuche ein paket zu installieren kriege ich nur nciht erf?llte abh?ngigkeiten zur?ck. habe n upgrade gemacht, hat ohne probleme geklappt.

wen ich per apt-get update und apt-get install in allen formen und variationen versuche etwas zu installieren kommt immer nur irgendne bl?sinnige abh?ngigkeitsmeldung. wenn ich diese dann einzeln aufl?sne will kommen immer mehr untergeordnete raus die ich auch von hand l?sen m?sste. is n bisschen ?de so.

hat jemand nen klugen ratschlag? allein komme ich leider nicht mehr weiter


du kannst unter kpackage oben reparieren anklicken dann l?d der die fehlenden packete runter! hat bei mir und cedega jedenfalls geklappt!!

10

28.10.2006, 14:25

Hi,

ich dachte wir reden ?ber apt. Was apt nicht kann, kann ein anderes Programm in der Regel auch ned....;)

Gruss Guido

11

28.10.2006, 14:46

Zitat von »"Ludwig Van"«

ich hab genau das gleiche porblem, leider haben alle ratschl?ge bei mir nichts gen?tzt.

wenn ich versuche ein paket zu installieren kriege ich nur nciht erf?llte abh?ngigkeiten zur?ck. habe n upgrade gemacht, hat ohne probleme geklappt.

wen ich per apt-get update und apt-get install in allen formen und variationen versuche etwas zu installieren kommt immer nur irgendne bl?sinnige abh?ngigkeitsmeldung. wenn ich diese dann einzeln aufl?sne will kommen immer mehr untergeordnete raus die ich auch von hand l?sen m?sste. is n bisschen ?de so.



Das ein upgrade fast immer funktioniert ist ja auch verst?ndlich. upgrade
l?st keine Abh?ngigkeiten auf w?rend ein dist-upgrade und auch ein Install die Abh?ngikeiten aufl?st, kracht es regelm??ig bei Knoppix. Knoppix ist ja ein Sammelsurium aus Sarge, Testing Unstable experimental Paketen und aus anderen Quellen. Man k?nnte vesuchen dem ?rger mit apt-pinning aus dem Wege zu gehen, ob das klappt ist allerdings fraglich.

Und Kpackage l??t auch nicht das Problem.
Was haben Windows und ein Uboot gemeinsam?
Kaum macht man ein Fenster auf, gehen die Probleme los.

EDV ist die Abkürzung für: Ende der Vernunft

Anonymous

unregistriert

12

28.10.2006, 15:08

Zitat



Das ein upgrade fast immer funktioniert ist ja auch verst?ndlich. upgrade
l?st keine Abh?ngigkeiten auf w?rend ein dist-upgrade und auch ein Install die Abh?ngikeiten aufl?st, kracht es regelm??ig bei Knoppix. Knoppix ist ja ein Sammelsurium aus Sarge, Testing Unstable experimental Paketen und aus anderen Quellen. Man k?nnte vesuchen dem ?rger mit apt-pinning aus dem Wege zu gehen, ob das klappt ist allerdings fraglich.

Und Kpackage l??t auch nicht das Problem.



bei mir schon

Anonymous

unregistriert

13

28.10.2006, 18:17

Zitat von »"guido17"«

Hi,

poste doch mal den output

Gruss


das ganze mal am beispiel vlc
[code:1]
root@HAL9000:/etc/pango# apt-get install vlc
Paketlisten werden gelesen... Fertig
Abh?ngigkeitsbaum wird aufgebaut... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unm?gliche Situation angefordert haben oder dass, wenn Sie die
instabile Distribution verwenden, einige erforderliche Pakete noch nicht
kreiert oder aus Incoming herausbewegt wurden.

Da Sie nur eine einzige Operation angefordert haben ist es sehr wahrscheinlich,
dass das Paket einfach nicht installierbar ist und eine Fehlermeldung ?ber
dieses Paket erfolgen sollte.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu l?sen:

Die folgenden Pakete haben nichterf?llte Abh?ngigkeiten:
vlc: H?ngt ab: libgtk2.0-0 (>= 2.8.0) aber 2.6.8-1 soll installiert werden
H?ngt ab: libice6 (>= 1:1.0.0) aber 4.3.0.dfsg.1-14 soll installiert werden
H?ngt ab: libnotify1 soll aber nicht installiert werden
H?ngt ab: libwxgtk2.6-0 (>= 2.6.3.2.1.5) soll aber nicht installiert werden
H?ngt ab: libxfixes3 (>= 1:4.0.1) soll aber nicht installiert werden
H?ngt ab: libxxf86vm1 soll aber nicht installiert werden
E: Kaputte Pakete
root@HAL9000:/etc/pango# [/code:1]

das mit "upgrade ohne probleme" muss ich leider korrigieren. ich hab gro?e probleme bekommen. nachdem ich, aus vielen gr?nden, neu installiert und dann upgrade durchlaufen lassen habe, kriege ich bei bestimmten programmen folgende fehlermeldung:

[code:1]aalban@HAL9000:~$ gaim

(gaim:23879): Pango-WARNING **: No builtin or dynamically loaded modules
were found. Pango will not work correctly. This probably means
there was an error in the creation of:
'/etc/pango/pango.modules'
You may be able to recreate this file by running pango-querymodules.

(gaim:23879): Pango-CRITICAL **: _pango_engine_shape_shape: assertion `PANGO_IS_FONT (font)' failed

Pango-ERROR **: file shape.c: line 75 (pango_shape): assertion failed: (glyphs->num_glyphs > 0)
aborting...
Abgebrochen[/code:1]

das gleiche problem hatte ich vor der neuinstallation schon, damals hat mozilla auch cnith funktioniert. jetzt gehts. der fehler kommt nur noch bei gaim :/

das is dreck, immer wenn ich irgendwas selbst l?se erschl?gt mich irgendwas womit ich nciht klar komme

14

28.10.2006, 18:48

Hi,


hmm welche knoppix verwendest Du ? Eventuell schon zu alt ?

Versuch mal ein "apt-get update" - dann ein "apt-get dist-upgrade"
und dann ein "apt-get install vlc"

Das dist-upgrade wird wahrscheinlich recht gro? ausfallen. Sichere vorher Deine Daten!!!!!!!!!!!!!!!!!!!!!!!!

Gruss Guido

Anonymous

unregistriert

15

28.10.2006, 19:16

version ist 4.irgendwas, leide rnciht das neuste.

hatte die 5.0-DVD, hatte aber enorme schwierigkeiten damit weil alles m?glcihe nicht klappe, deswegen hab ich auf die alte zur?ckgegriffen.

werds mal versuchen, danke f?r den tipp

16

28.10.2006, 19:23

Hi,

das d?rfte aber das Problem sein, da liege Welten zwischen der 4er und den aktuellen Paketen.....

Gruss


PS: Ich glaub auch ned, da? das dist-upgrade in so einem Fall klappt. Das muss ja fast in die Hose gehen.......

Anonymous

unregistriert

17

28.10.2006, 22:27

gut, w?re also einfacher neues iso zu machen und das draufzuspielen?

dist-upgrade lief auch ncih twirklich gut. irgendwo hat es sich beendet weil ein verzeichnis nciht leer war. dieses habe ich geleert, dann das update fortgef?hrt und d?mliche r?ckmeldungen beim entpacken bekommen.
[code:1]
(Lese Datenbank ... 96958 Dateien und Verzeichnisse sind derzeit installiert.)
Entpacke x11-common (aus .../x11-common_1%3a7.1.0-5_i386.deb) ...
dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/x11-common_1%3a7.1.0-5_i386.deb (--unpack):
versuche ?/usr/X11R6/bin? zu ?berschreiben, welches auch in Paket xserver-p9000 ist
Fehler traten auf beim Bearbeiten von:
/var/cache/apt/archives/x11-common_1%3a7.1.0-5_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@HAL9000:/etc/pango#[/code:1]

hats sinn sich dadrum zu k?mmern oder soll ich mir ne neuere version laden?

18

29.10.2006, 08:31

Hi,

besorg Dir was aktuelles. Am besten warten, bis entweder knoppix 5.1 oder die finale Kanotix 2006-1 erscheint. Wenn das dann installiert ist, versuchen es auch aktuell zu halten ;)

Gruss Guido

19

30.10.2006, 15:12

Wenn man die entsprechen Nerven hat , mit dpkg installeren Option --force-overwrite.
Was haben Windows und ein Uboot gemeinsam?
Kaum macht man ein Fenster auf, gehen die Probleme los.

EDV ist die Abkürzung für: Ende der Vernunft

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop