17.06.2019, 05:18 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Anonymous

unregistriert

1

11.02.2005, 14:30

Rettung f?r eine abgeknipste Debian-Installation via grub

Tachchen!

Wie kann ich o.g. Installation wieder herstellen oder besser gar booten? Als Vorbild dient mir gerade das SuSE-Rettungssystem, die hilft auf eine funktionierende Installation zu springen und gar diesen Kernel zu benutzen.

Gibt es eine solche M?glichkeit auch unter Knoppix?
Mein System lief ewiglich unter Debian sarge. Wenn ich nun boote erscheint Grub loading stage1.5. sowie wait, while loading - danach kommt nix mehr.

W?hrend beim letzten Mal die Kisten nur gerade 10 Mal gebootet werden musste, habe ich jetzt nach 25 Mal aufgegeben =;-)

Mit install-mbr habe ich herausgefunden, dass der MBR von /dev/hde (am PromiseFasttrak100) nicht in Ordnung ist, sprich nur M?ll enth?lt. ?berschreibe ich diesen einmal mit Lilo oder ?hnlichem, kann ich zwar nicht weiter booten (weil keine Konfiguration erstellt und grub gef?lligst zu funktionieren hat), aber es stehen immerhin vern?nftige Daten drin.

Mit welchen Bootparametern l?sst sich das alte System wieder booten? root=/dev/hde2 mag mich nicht.

Vielen Dank f?r die Hilfe.

solong,
Erik.

2

11.02.2005, 22:03

Hallo Erik,

> Gibt es eine solche M?glichkeit auch unter Knoppix?

Wie ist es mit folgendem Weg (wenn /dev/hde2 die
root-Partition ist):

Mit "knoppix 2" von der Knoppix-CD booten.

mkdir /tmp/abc
mount /dev/hde2 /tmp/abc

chroot /tmp/abc

/etc/grub.conf muesste dann die grub-Konfigurationsdatei
deines defekten Systems sein und mit /usr/sbin/grub kannst
du die GRUB-Shell starten, in der du mit "install" oder "setup"
grub installieren koennen muesstest (dazu kann ich aber nichts
sagen, da ich das mit grub noch nie gemacht habe).

Tschuess
Karl

Anonymous

unregistriert

3

12.02.2005, 07:35

Tachchen!

Wenn ich ?ber die chroot-Geschichte gehe (stand mal in einer FAQ), dann fliege ich zum einen aus der Kurve wg fehlender Zugriffsberechtigungen (scheinbar sind knoppix-root und System-root dann trotz gleicher UID und GID selbst bei gleicher Berechtigung nicht gleich) und zum anderen sammelt upgrade dertige Fehler, dass es keinen Sinn macht, sich darauf zu verlassen, da alles sich auf hd0,0 (ist zuf?llig eine swap) befindet.
Ich habe nun den lilo installiert und bin zumindest wieder auf mein System gekommen. Grub w?re mir lieber, aber der Einfachheit halber, lass ich es halt mal bei lilo.

solong,
Erik.

4

14.02.2005, 11:03

Zitat von »"Pfeifenraucher"«


Wenn ich ?ber die chroot-Geschichte gehe (stand mal in einer FAQ), dann fliege ich zum einen aus der Kurve wg fehlender Zugriffsberechtigungen (scheinbar sind knoppix-root und System-root dann trotz gleicher UID und GID selbst bei gleicher Berechtigung nicht gleich)


Sollte das nicht eher daran liegen, dass Partitionen defaultmaessig erstmal nur readonly gemountet werden?

Anonymous

unregistriert

5

14.02.2005, 18:20

Tachchen!

In meinem Fall wird die Partition per -rw gemountet. Die Problematik sollte jedoch darin zu finden sein, dass dass eigentliche /dev-Verzeichnis, jenes 'tote' auf der Partition und nicht das des laufenden Systems ist.

Wie gesagt, nun rennt es und ich habe erst einmal wenig Lust und Zeit mich weiter mit Grub zu besch?ftigen, obwohl das System ansich sehr gut und verst?ndlich ist.

solong,
Erik.

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop