22.09.2018, 12:12 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

1

06.06.2007, 18:00

LAN-Verweigerung

Hallo an alle,

lange habe ich gez?gert (ehe ich frage). Und gesucht und probiert: Ich schaffe es nicht eine einfache LAN-Verbindung von Knoppix (CD-boot) in mein Mininetz herzustellen. Die Netzkarte (3-Com Combo) wird erkannt und unter Win2k gibt es kein Problem.
Unter Knoppix kann ich den 2. PC nicht anpingen (Destination Host Unreachable, seine ip ist 192.168.0.1). Was mach ich nur falsch ?

Hier ein paar Infos (obwohl ich zweifle, da? sie hilfreich sind):

ifconfig -a

eth0 Protokoll:Ethernet Hardware Adresse 00:04:76:F2:24:64
inet Adresse:192.168.0.8 Bcast:192.168.0.255 Maske:255.255.255.0
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenl?nge:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:20 Basisadresse:0x8f80

lo Protokoll:Lokale Schleife
inet Adresse:127.0.0.1 Maske:255.0.0.0
inet6 Adresse: ::1/128 G?ltigkeitsbereich:Maschine
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:22 errors:0 dropped:0 overruns:0 frame:0
TX packets:22 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenl?nge:0
RX bytes:1100 (1.0 KiB) TX bytes:1100 (1.0 KiB)

resolv.conf

# Insert nameservers here
# nameserver 127.0.0.1

route -n

Kernel IP Routentabelle
Ziel Router Genmask Flags Metric Ref Use Iface
192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0

Hinweis: Ich habe schon mehrere Depressionsphasen hinter mir.

2

06.06.2007, 19:00

Hast Du die Ip von Hand vergeben ? Keinen dhcp im Netz ?
Zeigt "dmesg" was verd?chtiges ;) ?

3

06.06.2007, 20:00

Oh wie schnell !

Hallo Guido,

so schnell habe ich keine Antwort erwartet. Umso gr??er die Freude !

Zur Antwort auf Deine Fragen:

1. Am 2. Rechner h?ngt mit eigener eth-Karte die Fritz-Box. Sie weist
der erw?hnten Karte wohl die IP zu.

2. Die IP 192.168.0.8 habe ich in der Tat 'h?ndisch' vergeben.
(Automatisch geht nicht).

3. dmesg (und ich wei? nicht ob das verd?chtig ist ) sagt am Ende:
eth0: link is not ready. Falls n?tig, kann ich einen Ausschnitt von
dmesg liefern[/quote]

prh

Profi

Beiträge: 1 248

Geschlecht: Männlich

4

06.06.2007, 20:11

Hallo,
ich habe noch nie dhcp benutzt, also immer nur manuell.
Dazu brauchste die IP des Routers als gateway und als Nameserver nehme ich die Telecom IP 194.25.2.129 (oder so aehnlich?), broadcast setze ich = der PC-IP - damit laeuft dann bei mir das Knoppix-life und dsl.
LG
prh

5

07.06.2007, 09:21

Kabel mal gepr?ft, ob Du einen link hast ?

6

07.06.2007, 18:55

Kabel ?

Hallo Guido,

danke f?r die Antwort. Kabelverbindung besteht (altmodisch mit thin-Ethernet).

Starte ich auf beiden Rechnern das (ungeliebte) w2k, sind im Rechner B (mit 2 eth-Karten)
beide Karten (ipconfig /all) konfiguriert, wobei eine Karte mit der Fritz-Box verbunden ist,
(und daher seine IP mit DHCP bezieht) die zweite ist dem LAN gewidmet (und hat die IP
168.192.0.1).
Rechner A (auf dem ich Knoppix starte) hat unter w2k die Adresse 192.168.0.2. Er hat so
keine M?he Rechner B und ?ber den JANA-Proxy das Net zu erreichen. Auch das Disk-Sharingmit B ist kein Problem.

Unter Knoppix ist die Verbindung zu B in keiner Form m?glich.

Starte ich Knoppix auf B, wird die/eine Karte sofort aktiv, holt sich die Adresse ?ber DHCP
und (siehe diese Antwort) ist sofort am net. Rechner A erkennt jedoch (jetzt unter w2k)
B nicht mehr. Ping auf die IP (192.168.178.20 von DHCP, Fritz) erfolglos.
ifconfig auf B zeigt nur eine aktive Karte.

Was tun ?

RalfonLinux

Erleuchteter

Beiträge: 2 934

Geschlecht: Männlich

7

08.06.2007, 13:38

Sorry, aber in welchen Netzen bist du den jetzt unterwegs ?
Einmal schreibst du von 192.168.0.x/24 und dann von der FritzBox, welche normalerweise 192.168.178.x/24 verteilt.
Wenn du beide Rechner an der Fritz angeschlossen hast, wird sie als 192.168.178.254 einen Teufel tun, und deine Netze 192.168.0./x routen.
Da fehlt dir das Default Gateway

jm2c
Ralf
Auf Wunsch gibt es nur noch Text und keine Bilder mehr in der Signatur.
Keine ? ....... :evil:

Quellcode

1
2
3
4
5
6
7
8
.
    ~
   - -          M
   /V\         - *
  // \\        /V\
 /( _ )\      // \\
  ^~ ~^      /( _ )\
              ^~ ~^

8

08.06.2007, 18:10

Zwei zum Netz ?

Hallo Ralf,

danke f?r Deine Antwort. Mir wird wiedermal klar, wie schwierig es ist einen
scheinbar einfachen Sachverhalt zu erkl?ren.
Also ich bin nicht so vermessen, beide Rechner mit der Fritz.Box zu einem
flotten Dreier zu machen.

Nochmal (hoffentlich ganz einfach):

1. Man stelle sich zwei Rechner A und B vor. Auf A ist Knoppix gestartet,
auf B w2k.

2. A bekommt eth0 h?ndisch auf 192.168.0.8 (?brigens eine 3-Com XL
10/100 PCI-Combo) gesetzt. Bei B ist eth0 auf IP 192.168.0.1
(NEC2000-kompatible)

3. Der Mensch versucht ein ping von A auf B. Ergebnis
(Pustekuchen Ist Nicht Gut):
Destination Host Unreachable.

4. M?ge B jetzt eine zweite Karte bekommen, die von der Fritz-Box
bedient (DHCP) die IP 192.168.178.20 erh?lt (Realtek RTL8029)

5. Da? auf w2k ein Jana-Proxy l?uft, ist m.E unerheblich.

Kann es an der NEC2000 kompatiblen Karte auf B liegen ?

Gru?

Peter

9

08.06.2007, 21:05

Ist eth0 denn die 3com ???
Zeig mal die Ausgabe von "dmesg |grep eth"

Gruss

10

09.06.2007, 10:13

eth in dmesg

Hallo Guido,

Ich hoffe Dir/Euch nicht zu sehr auf den Geist zu gehen !

Der grep von dmesg zeigt kl?glich wenig, n?mlich nur:

eth0: setting half-duplex.
eth0: setting half-duplex.
ADDRCONF(NETDEV_UP): eth0: link is not ready
eth0: setting half-duplex.
ADDRCONF(NETDEV_UP): eth0: link is not ready

Da? es sich um eine 3-Com der genannten Art handelt, wei? ich aus
ipconfig unter w2k.
Ihr 'Gegner' ist besagte NEC2000-compatible auf dem Rechner B.
Nach manuellem setup ist der ping nur 'selbstbefriedigend' erfolgreich
(ping 192.168.0.8 ) , nach drau?en njet (nein).

Gru

11

10.06.2007, 07:37

Hi,

versuch mal folgendes:
als root

ifconfig eth0 down

ifconfig eth0 media 10base2 (du sagtest ja thin ethernet)

ifconfig eth0 up

Gruss

12

10.06.2007, 11:41

Setzen eth media

Hallo Guido,

danke f?r den neuen Versuch. Leider will
ifconfig eth0 media 10base2
nicht. Die Antwort ist:

port: SIOCSIFMAP: Die Operation wird nicht unterst?tzt.

Es scheint ein grunds?tzliches Problem mit meiner(-nen) Karten zu geben.
Das ethtool zeigt mit:

ethtool eth0:

Settings for eth0:
Supported ports: [ TP MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half
Advertised auto-negotiation: Yes
Speed: 10Mb/s
Duplex: Half
Port: MII
PHYAD: 24
Transceiver: internal
Auto-negotiation: on
Current message level: 0x00000001 (1)
Link detected: no

Dabei ist Link detected: no sicher ein ko-Hinweis.
Zudem: Supported link modes: 10baseT
scheint auf twisted-pair hinzuweisen. Also kann wohl 10base2 nicht
laufen. Das wiederum k?nnte am Treiber liegen, der thin-Ethernet
nicht (mehr) mag.

Gru?

Peter

13

10.06.2007, 12:19

Lan-Verweigerung - jetzt nicht mehr

Hallo Guido, hallo allen die sich bem?ht haben !

Heureka (ich habs): Es lag in der Tat am thin-Ethernet. Warum nur bin
ich so sp?t drauf gekommen, das thin gegen ein Hub auszutauschen.
Mit den Kabeln kam das "green light" und jetzt lie?en sich auch die
Rechner kreuz und quer pingen. Nachdem das Wiesel die Proxy-Einstel-
lungen erhalten hatte, war (und ist) auch die Netzverbindung ?ber Jana
ok. Also das Problem ist wohl als gel?st zu betrachten.
Jetzt kanns mit neuen Problemen weitergehen.

Gru?

Peter

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop