20.09.2018, 08:09 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Beiträge: 711

Geschlecht: Männlich

1

27.06.2009, 12:02

[gelöst] Knoppix/Tightvncserver und XP/Realvnc (Client): Maus/Tastatur geht nicht.

Du hast ein Terminal=false im Autostart, der vnc ist aber eigentl ne Terminalanwendung. Teste da mal ein

Terminal=true

und starte mal direkt den tightvncserver

Exec=/usr/bin/tightvncserver


So, nachdem der PC jetzt mit Monitor vernünftig mit Bildschirm läuft, habe ich deinen Vorschlag befolgt und Terminal=true eingegeben. Und ich habe tightvnc verwendet statt vnc4server. Der Start klappt auch automatisch. Aber ich habe dann das angehängte Bild ohne Taskleiste und ohne jede Möglichkeit, mit der Maus zu arbeiten. Und die Fenster, die ich direkt auf dem Schirm am PC aufmache, die sehe ich hier auch nicht.

Hier die aktuelle vncserver.desktop:

Quellcode

1
2
3
4
5
6
7
[Desktop Entry]
Version=1.0
Type=Application
Name=vncserver autostart
Comment=VNC Server beim Systemstart automatisch starten
Exec=/usr/bin/tightvncserver
Terminal=true


Hier noch die letzten Änderungen in der grub.cfg (kann man die lange Zeile umbrechen?):

Quellcode

1
2
3
4
5
6
### BEGIN /etc/grub.d/10_linux ###
menuentry "Knoppix USB FBDEV 60Hz vertikal h" {
	linux	/boot/linux ramdisk_size=100000 ro quiet keyboard=de xkeyboard=de vga=791 fb1024x768 lang=de vsync=60 xmodule=fbdev
	initrd	/boot/minirt.gz
}
### END /etc/grub.d/10_linux ###
»Cottonwood« hat folgende Datei angehängt:
  • 20090627-1.jpg (149,24 kB - 3 mal heruntergeladen - zuletzt: 27.06.2009, 12:11)
MfG. Cottonwood.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Cottonwood« (29.06.2009, 20:14)


Beiträge: 650

Geschlecht: Männlich

2

27.06.2009, 12:06

Dann teste nochmal mit terminal=false aber weiterhin den tightvnc und poste ob sich dann was ändert.


mfg Jack

Beiträge: 711

Geschlecht: Männlich

3

27.06.2009, 12:09

Ich habe das auch gleich ausprobiert gehabt. Egal ob tightvncserver oder vnc4server, Terminal=true oder =false: Immer dasselbe Ergebnis.
MfG. Cottonwood.

Beiträge: 650

Geschlecht: Männlich

4

27.06.2009, 12:11

Was passiert wenn du nen Rechtsklick auf den Desktop machst, kannst da was auswählen?

Beiträge: 711

Geschlecht: Männlich

5

27.06.2009, 12:14

Absolut nichts. Es ist, als ob ich da nur ein Bild anklicken würde.

Was mich irritiert, ist auch, dass ich bisher ja so einen grauen Hintergrund hatte. Der kommt jetzt nicht mehr.
»Cottonwood« hat folgende Datei angehängt:
  • 20090623-1.jpg (47,36 kB - 1 mal heruntergeladen - zuletzt: 27.06.2009, 12:16)
MfG. Cottonwood.

Beiträge: 650

Geschlecht: Männlich

6

27.06.2009, 12:24

Der graue Hintergrund ist der von root. Ich hab den vnc leider nicht unter der lxde sondern der KDE laufen aber da hab ich als user den normalen Desktop nur als root auch den grauen.

Das Problem ist evtl auch nicht die Startverknüpfung sondern irgendwas am Fenstermanager also der lxde.

Beiträge: 711

Geschlecht: Männlich

7

27.06.2009, 12:26

Mit dem grauen Hintergrund ging es aber noch.

Ich starte ihn noch einmal manuell und schaue, was passiert.
MfG. Cottonwood.

Beiträge: 711

Geschlecht: Männlich

8

27.06.2009, 12:32

Ist leider auch unverändert.
MfG. Cottonwood.

Beiträge: 650

Geschlecht: Männlich

9

27.06.2009, 12:34

mach mal aus

Zitat

Exec=/usr/bin/tightvncserver


ein

Zitat

Exec=su -c /usr/bin/tightvncserver root


damit startest du ihn als root und müsstest wieder den grauen Hintergrund kriegen.

Beiträge: 711

Geschlecht: Männlich

10

27.06.2009, 12:46

Quellcode

1
2
3
4
5
6
7
[Desktop Entry]
Version=1.0
Type=Application
Name=vncserver autostart
Comment=VNC Server beim Systemstart automatisch starten
Exec=su -c /usr/bin/tightvncserver root
Terminal=true


Jetzt geht er erst mal gar nicht mehr. :whistling:

Wenn ich ihn manuell starte:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
knoppix@Microknoppix:~$ tightvncserver root
TightVNC Server version 1.3.9

Usage: tightvncserver [<OPTIONS>] [:<DISPLAY#>]
       tightvncserver -kill :<DISPLAY#>

<OPTIONS> are Xtightvnc options, or:

        -name <DESKTOP-NAME>
        -depth <DEPTH>
        -geometry <WIDTH>x<HEIGHT>
        -httpport number
        -basehttpport number
        -alwaysshared
        -nevershared
        -pixelformat rgb<NNN>
        -pixelformat bgr<NNN>

See vncserver and Xtightvnc manual pages for more information.
knoppix@Microknoppix:~$ 


Und wenn ich ihn ohne "root" starte, dann ist es wieder wie vorher. Und er startet mit Microknoppix:1.log. Ist also die 1. Instanz.

Und wenn ich ihn mit sudo starte, bekomme ich einen Fehler:

Quellcode

1
2
3
knoppix@Microknoppix:~$ sudo tightvncserver
tightvncserver: Wrong type or access mode of /home/knoppix/.vnc.
knoppix@Microknoppix:~$


Ich hab hier auch noch die xstartup:

Quellcode

1
2
3
4
5
6
7
8
9
knoppix@Microknoppix:~/.vnc$ cat xstartup
#!/bin/sh

xrdb $HOME/.Xresources
xsetroot -solid grey
#x-terminal-emulator -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
#x-window-manager &
/etc/X11/Xsession
knoppix@Microknoppix:~/.vnc$ 
MfG. Cottonwood.

Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von »Cottonwood« (27.06.2009, 13:06)


Beiträge: 650

Geschlecht: Männlich

11

27.06.2009, 13:11

Um ihn als root zu starten musst erstaml mit su root werden und dann ganz normal über Befehl

tightvncserver


starteb

Beiträge: 711

Geschlecht: Männlich

12

27.06.2009, 13:22

Ich habe das gestartet, wie du es hier siehst:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
knoppix@Microknoppix:~/.vnc$ su
root@Microknoppix:/home/knoppix/.vnc# tightvncserver

You will require a password to access your desktops.

Password: 
Verify:   
Would you like to enter a view-only password (y/n)? n

New 'X' desktop is Microknoppix:1

Creating default startup script /root/.vnc/xstartup
Starting applications specified in /root/.vnc/xstartup
Log file is /root/.vnc/Microknoppix:1.log

root@Microknoppix:/home/knoppix/.vnc#


Das Ergebnis ist, dass ich jetzt vom XP aus arbeiten kann, aber auf dem Originalschirm nicht mehr ins Internet komme. Deshalb musste ich dort erst mal den Text eben als Datei wegspeichern.
Anschliessend konnte ich ihn auf dem XP-VNC-Client wieder einlesen und hier einfügen.

Den Schnappschuss habe ich aber vorher gemacht, nämlich beim 1. Versuch, mit der Maus und Rechtsklick auf dem Desktop zu arbeiten.

Das aktuelle Problem ist erst mal, dass es nicht automatisch gestartet werden kann. Später soll da kein Schirm mehr dran hängen. Das mit dem Internet ist also egal.
»Cottonwood« hat folgende Datei angehängt:
  • 20090627-2.jpg (58,83 kB - 2 mal heruntergeladen - zuletzt: 27.06.2009, 13:37)
MfG. Cottonwood.

Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von »Cottonwood« (27.06.2009, 13:30)


Beiträge: 650

Geschlecht: Männlich

13

27.06.2009, 14:06

Ich hab das damals über das Skript knoppix_autoconfig als root gestartet, wennst willst kann ich dir die betreffende Passage mal mailen und du fügst es bei dir ein.


mfg Jack

Beiträge: 711

Geschlecht: Männlich

14

27.06.2009, 14:06

Hängt vllt. mit dem INet-Prob zusammen: Mein Stick muss mal wieder neu aufgesetzt werden. Danach teste ich erst den Tightvncserver direkt. Wenn das wieder geht, versuche ich es noch mal mit dem Autostart.

#######################################

Es ist langsam zum K....

Ich kann nach jedem Direkttest des tightvncservers neu installieren.
Ich bin jetzt auf einen Stand zurückgegangen, wo noch keine Updates aus dem Internet gemacht waren und noch kein Autostart-Verzeichnis bestand.
Dann habe ich die Updates runtergeladen. - Booten ging noch.
Dann habe ich tightvnc installiert. - Booten ging auch noch.
Dann habe ich tightvncserver gestartet und die Passwörter eingegeben. Seitdem geht's nicht mehr.
Falls tightvncserver jemals gelaufen war, dann vor der Änderung der grub.cfg, wo noch der falsche Grafiktreiber verwendet wurde.
Ich denke mal, dass sich tightvnc nicht mit der Eee-Box verträgt. Ich mache dieselben Tests jetzt noch mit vnc4server. :wacko: X(
MfG. Cottonwood.

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Cottonwood« (27.06.2009, 18:53)


Beiträge: 650

Geschlecht: Männlich

15

27.06.2009, 18:35

Empirisch ist gut ;) , hast meine PN bekommen mit der Funktion?

Btw hast du schon die HD-Installation getestet?


mfg Jack

Beiträge: 711

Geschlecht: Männlich

16

27.06.2009, 19:18

Ich habe eben geschaut. Die Email ist angekommen. Die HD-Version habe ich noch nicht getestet. Ich habe erst gestern den Schirm richtig gehabt. So dass ich überhaupt was machen konnte.

Eben habe ich nochmal denselben Test gemacht mit tightvncserver incl. tightvnc-java. Hat auch nichts gebracht. Übrigens ist das Verhalten des "abgeschmierten" Systems wieder so, wie es was, als ich noch den falschen Grafiktreiber hatte. Kein Bild und nach ca. 5 Minuten autom. Shutdown.

Ich verstehe das richtig: Ich soll den tightvncserver bei deiner Variante überhaupt nicht von Hand starten, oder? Und das Java-Geraffel brauche ich auch nicht, oder?
MfG. Cottonwood.

Beiträge: 711

Geschlecht: Männlich

17

27.06.2009, 19:54

Ich habe ebenmal deine Version getestet.

Beim Starten fragt er nach einem Passwort. Ich habe einfach enter gedrückt. Danach kam eine Fehlermeldung.

Das ging aber viel zu schnell, um die zu lesen. Steht die in irgendeinem Logfile?
MfG. Cottonwood.

Beiträge: 650

Geschlecht: Männlich

18

27.06.2009, 20:03

Meine Variante wird durch das Skript knoppix_autoconfig gestartet. Du siehst sogar ne Meldung während des bootens des Systems, dass der VNC-Server gestartet wird. Wichtig dabei ist allerdings, dass du keinen PW-Prompt mehr benötigst und das klappt nur, wenn im Verz /root das PW für den VNC-erver gespeichert ist. Das ist in der Regel bei nem HD-Installierten System genau dann der Fall, wenn du den tightvnc als root genau 1 mal gestartet hast und das PW einmalig eingegeben hast.

Dann wird der VNC-Server als root bei jedem Booten des Systems gestartet es sei denn du verwendest in der grub.cfg den Bootparameter novnc.

Java brauchst in dem Fall nat auch nicht.

mfg Jack

Beiträge: 650

Geschlecht: Männlich

19

27.06.2009, 20:07

Zitat

Steht die in irgendeinem Logfile?


weiß ich nicht weil ich danach nie suchen brauchte. Dann funzt das wahrsch bei nem Live-System so nicht. Ich hab das so gemacht, dass ich Knoppix auf Platte hatte, den tightvnc als root in diesem System gestartet hab und er das PW im Verz /root gespeichert hat. Dann hab ichs wieder komprimiert und auf DVD gebrannt.
Ab da fragt er nicht mehr nach nem PW, weil das ja schon in /root hinterlegt ist.

Beiträge: 711

Geschlecht: Männlich

20

27.06.2009, 21:30

Jack, du bist der Allergrößte. Ich hatte das falsch verstanden mit dem "ohne Passwort". Ich habe jetzt das Passwort eingegeben und neu gestartet. Kam zwar auch ne Fehlermeldung. Irgendwas von vnc und not found. Aber es läuft alles.

Danke! Danke! Danke! Ich wünsche dir noch ein schönes Wochenende. 8) :thumbup: :rolleyes: :love:

Dies ist übrigens auf der XP-Tastatur über VNC mit Iceweasle auf der Eee-Box geschrieben worden.


##### >>>>> Nur das Bild wurde anschliessend auf XP eingefügt. <<<<< #####
»Cottonwood« hat folgende Datei angehängt:
  • 20090627-4.jpg (68,48 kB - 5 mal heruntergeladen - zuletzt: 28.06.2009, 00:09)
MfG. Cottonwood.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Cottonwood« (27.06.2009, 21:37)


Beiträge: 650

Geschlecht: Männlich

21

27.06.2009, 21:57

Freut mich zu hören dass es nu läuft :thumbsup: . Ich drück mal sämtliche Daumen, dass es diesmal nicht von so kurzer Dauer ist wie das letzte Mal und du mal richtig mit deinem neuen System arbiten kannst.


mfg Jack

Beiträge: 711

Geschlecht: Männlich

22

27.06.2009, 23:02

Das glaube ich schon. Ist ja aber auch nicht so schlimm. Ich brauche ja nicht einmal ein Image. Regelmäßig nach Änderungen sichern. Und bei "Bedarf" ;( einfach die Dateien zurück.

Im Gegensatz zu Windows treten die Fehler immer an derselben Stelle auf. 8o :thumbsup: :evil:
MfG. Cottonwood.

Beiträge: 650

Geschlecht: Männlich

23

27.06.2009, 23:16

Zitat

Im Gegensatz zu Windows treten die Fehler immer an derselben Stelle auf


Oh ja das leidige Win Fehler suchen. Ich hatte mein Live-System an meiner Freundin ihrem Netbook getestet. Lief alles außer Wlan, da fehlte der Treiber von Ralink. Gebootet hatte ich von USB-Stick. Als ich das System heruntergefahren habe wollte meine Freundin noch schnell was in Windows sehen und siehe da, die integrierte Webcam ging nicht mehr :S ...

Wer schuld war war klar ;) da nutzten keine Beteuerungen von wegen Win Platte nicht gemountet nix in Win gemacht usw usf.

Über Nacht hing das Teil an der Ladestation und siehe da am nächsten Morgen ging auch die Webcam wieder...


Btw wieviel hat eigentl der Asus gekostet, wenn ich fragen darf und washat der so alles an Bord?

Beiträge: 711

Geschlecht: Männlich

24

28.06.2009, 00:46

Ja, so sindse. :D

Gekostet hat sie 260€. Mehr war nicht drin. O-Preis 269€. Leider gibt die Beschreibung nichts her. Deshalb hab ich noch mal Windows gestartet um Everest runterzuladen. VNC Server auf der Box ist abgeschmiert. :thumbsup: ## :thumbsup: ## :thumbsup: ## :thumbsup: ## :thumbsup:

Also musste ich's an der Box direkt machen. Everest gestartet und Report erstellt. Wollte ich dann über das Netzwerk auf meinen PC holen. Findet das freigegebene Laufwerk nicht. :thumbup: 8o 8o Welch ein grandioser Abgang für das Windows XP. ^^

Also wieder Knoppix gestartet und XP-Laufwerke gemountet. Jappadappadu. Da ist die Datei. :whistling:

Download

Die Festplatte hat übrigens 160 GB. Es ist noch eine versteckte Recovery-Partition vorhanden.
MfG. Cottonwood.

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Cottonwood« (28.06.2009, 01:04)


Beiträge: 650

Geschlecht: Männlich

25

28.06.2009, 01:05

Bei dem Preis gibts nix zu meckern. Dass der VNC so instabil ist ist nat ärgerlich.

Beiträge: 711

Geschlecht: Männlich

26

28.06.2009, 01:13

Das war aber diesmal der VNC-Server unter Windows. :rolleyes: :D :D :D :whistling:
MfG. Cottonwood.

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop