19.12.2018, 11:37 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

1

01.08.2010, 16:30

Datenträger konnte nicht ins system eingebunden werden

Hallo @all


Bin absoluter Newbie was das thema linux knoppix angeht. Jedoch habe ich ein sehr großes Problem beim Hochfahren von meinem Rechner hat er chkdsk ausgeführt das wurde abgebrochen und jetzt ist meine Festplatte/Partition plötzlich leer keine Daten mehr vorhanden und ich weiß niocht wie ich diese wiederhestellen soll

beim Benutzen des Programms Knoppix v6.2.1 kommt folgender fehler wenn ich auf die platte zugreifen will:

i org.freedesktop.hal.device.volume.unknownfailure i

und ich kann nicht zugreifen

habe 2 festplatten im system, kann auf alle zugreifen bis auf die wo meine Daten drauf sind.

Leider hatte ich keine Datensicherung gemacht und jetzt fehlen mir wichtige uni daten


Hoffe mir kann wer helfen wie gesagt bin absolut neu hier und demnach was knoppix angebtrifft sehr hilflos



Vielen Dank

2

01.08.2010, 20:30

kann mir denn keiner helfen?



Vielen Dank


PS: sehe die festplatten nicht auf dem Desktop sondern nur wenn ich den Ordner Knoppix anklicke auf dem Desktop dann sehe ich die Festplatten

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »hises2010« (01.08.2010, 20:38)


klaus2008

Meister

Beiträge: 2 700

Geschlecht: Männlich

3

01.08.2010, 21:49

Hallo!

Erst einmal solltest Du in Erfahrung bringen, welche Gerätenamen die Partionen haben. Dazu öffnest Du einfach ein LXTerminal und gibst die Anweisung

Quellcode

1
sudo fdisk -l
ein. Den Inhalt zitierst Du dann bitte hier. Das geht einfach mittels Markieren + Copy 'n' Paste, falls der Knoppix-Rechner an das Internet angeschlossen ist.

Gruss Klaus

4

01.08.2010, 22:35

]Hallo,


nach der Eingabe von fdisk -1 erhielt ich folgende Infos welche ich abfotografiert und als ANHANG hochgeladen habe

[attach]474[/attach]

klaus2008

Meister

Beiträge: 2 700

Geschlecht: Männlich

5

01.08.2010, 23:01

Du hast ein Problem mit der Schriftart: Die Option ist ein kleine L und keine Ziffer 1.

6

02.08.2010, 00:14

Sorry,


jetzt nochmal das richtige Bild im Anhang

[attach]475[/attach]

klaus2008

Meister

Beiträge: 2 700

Geschlecht: Männlich

7

02.08.2010, 10:30

Jetzt sind die Daten der Festplatten bekannt. Du hast eine große (500,1 GB, /dev/sda) und eine kleine (250,1 GB, /dev/sdb) Festplatte eingebaut.

Auf beiden Festplatten ist jeweils eine Partition als bootfähig markiert (/dev/sda1 und /dev/sdb1). Welche von den beiden ist das Startlaufwerk von Windows? Auf welchem Laufwerk wurde chkdsk ausgeführt?

Ich würde jetzt Knoppix neu booten und sofort ein LXTerminal öffnen. Darin würde ich dann folgendes eingeben:

Quellcode

1
2
3
4
5
6
7
8
sudo mkdir /media/windowsC
sudo mkdir /media/windowsD
sudo mkdir /media/windowsE
sudo mkdir /media/windowsF
mount -t ntfs-3g -o uid=1000,gid=1000 /dev/sda1 /media/windowsC
mount -t ntfs-3g -o uid=1000,gid=1000 /dev/sdb1 /media/windowsD
mount -t ntfs-3g -o uid=1000,gid=1000 /dev/sdb5 /media/windowsE
mount -o uid=1000,gid=1000 /dev/sdb6 /media/windowsF

Irgendwann erscheint dann eine Fehlermeldung, oder alle Partitionen werden eingebunden und können benutzt werden.

8

02.08.2010, 16:06

chkdsk müsste auf der Festplatte D ausgeführt wurden sein.
Windows startet von festplatte C:


beim eingeben erscheint immer folgende meldung siehe anhang[attach]476[/attach]


habe eben noch einmal nachgeschaut auf die sdb5 kommt er nicht drauf und sagt die Fehlermeldung PLatte konnte nicht in das system eingebunden werden

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »hises2010« (02.08.2010, 16:23)


klaus2008

Meister

Beiträge: 2 700

Geschlecht: Männlich

9

02.08.2010, 16:30

Korrektur

Sorry! Ich habe das sudo vor den mount-Anweisungen vergesssen.

Quellcode

1
2
3
4
5
6
7
8
sudo mkdir /media/windowsC
sudo mkdir /media/windowsD
sudo mkdir /media/windowsE
sudo mkdir /media/windowsF
sudo mount -t ntfs-3g -o uid=1000,gid=1000 /dev/sda1 /media/windowsC
sudo mount -t ntfs-3g -o uid=1000,gid=1000 /dev/sdb1 /media/windowsD
sudo mount -t ntfs-3g -o uid=1000,gid=1000 /dev/sdb5 /media/windowsE
sudo mount -o uid=1000,gid=1000 /dev/sdb6 /media/windowsF

Die Befehle sudo mkdir /media/windowsC usw. legen jeweils einen Mountpoint an. Sie müssen nur einmal aus geführt werden. Es ist aber nicht schlimm, sie mehrfach auszuführen. Es gibt bloss eine Meldung, dass der jeweilige Mountpoint bereits existiert. Du kannst also bei den "sudo mount ..."-Anweisungen fortfahren.

10

03.08.2010, 00:11

nachdem ich das eingegeben habe erscheint folgendes bei sdb5 welches sich um meine platte handelt


siehe anhang[attach]477[/attach]

klaus2008

Meister

Beiträge: 2 700

Geschlecht: Männlich

11

03.08.2010, 07:35

Du hast ein Problem, welches sich mit Knoppix nicht lösen lässt, weil Knoppix über kein chdsk-Programm für NTFS-Partitionen verfügt. Siehe auch Festplatte wird mit HDD angezeigt, kann aber nicht zureifen.

Man könnte auch mit dem Programm dd auf einem externen Laufwerk ein Abbild der Partition erstellen. Das externe Laufwerk sollte für Linux idealerweise mit dem ext3-Dateisystem formatiert sein. Ein mit dem Dateisystem FAT32 formatiertes Laufwerk wird wegen der Größe der Abbilddatei nicht funktionieren. Mit dem Abbild könnte man anschließend eine Wiederherstellung der MFT aus der Kopie der MFT mittels testdisk versuchen. Laut http://www.cgsecurity.org/wiki/TestDisk_DE soll das Programm TestDisk nämlich "Bei NTFS die MFT (MasterFileTable = Hauptdateitabelle) unter Verwendung des Spiegels (MFT mirror) wiederherstellen" können. Für eine erfolgreiche Wiederherstellung des Datenträgers müsste der Zustand des MFT-Spiegels aber besser sein als derjenige der MFT. Ausprobiert habe ich das aber bisher nicht. Das Programm TestDisk ist auf der Knoppix-CD enthalten.

Gruss Klaus

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »klaus2008« (03.08.2010, 08:12)


Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop