24.08.2019, 05:17 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

1

22.05.2012, 13:39

6.7.1 - dist-upgrade meldet unerfüllte Abhängigkeiten

Tach zusammen,

ich bin neu im Forum und bei Knoppix. Habs mir auf einen Stick installiert.

Am Ende von update kommt, nach dem die Paketlisten gelesen wurden:

Zitat



Paketlisten werden gelesen... Fertig
W: Konflikt bei Distribution: http://packages.x2go.org stable Release (stable erwartet, aber squeeze bekommen)
W: Konflikt bei Distribution: http://packages.x2go.org testing Release (testing erwartet, aber wheezy bekommen)
W: Konflikt bei Distribution: http://packages.x2go.org unstable Release (unstable erwartet, aber sid bekommen)


Beim dist-upgrade kommt das:

Zitat


Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut
Statusinformationen werden eingelesen... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fehlgeschlagen
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
libpango1.0-0 : Hängt ab von: libpango1.0-common (>= 1.28.3-1+squeeze2) soll aber nicht installiert werden
python-pyatspi : Hängt ab von: python (>= 2.5) soll aber nicht installiert werden
Hängt ab von: python-support (>= 0.90.0) soll aber nicht installiert werden
Hängt ab von: at-spi (>= 1.30.1-3)
Hängt ab von: at-spi (< 1.30.1-3.1~)
Hängt ab von: python-pyorbit soll aber nicht installiert werden
Hängt ab von: python-gnome2 soll aber nicht installiert werden
E: Fehler: Unterbrechungen durch pkgProblemResolver::Resolve hervorgerufen; dies könnte durch zurückgehaltene Pakete verursacht worden sein.


Hab nix gebastelt, alles jungfräulich frisch.

Auf einem zweiten Stick passiert das gleiche.

2

22.05.2012, 16:17

Zitat

Hab nix gebastelt, alles jungfräulich frisch.
Eine Jungfrau macht kein Update oder gar Upgrade :-)
http://knoppix.net/wiki/Deutsch_Install_FAQ
Gruß Werner * Eigene Rescue-CD
remaster Grml * remaster Knoppix

3

11.06.2012, 10:51

Eine Jungfrau macht kein Update oder gar Upgrade :-)
http://knoppix.net/wiki/Deutsch_Install_FAQ


Danke für den Link. An eine Installation auf HDD dachte ich auch schon mal. Das lass ich jetzt aber auf jeden Fall mal.

Ich brauche es auf einem USB-Stick zum arbeiten. Da wären zumindest Sicherheitsupdates schön.

Wären Upgrades denkbar, wenn ich diese auf die Security-Repos beschränke?

klaus2008

Meister

Beiträge: 2 712

Geschlecht: Männlich

4

17.06.2012, 14:39

Wen es nur um Sicherheitsupdates geht, würde ich ein Terminal öffnen und die folgenden Befehle ausführen, um eine neue Datei mit den Softwarequellen anzulegen:

Quellcode

1
2
3
cd /etc/apt
sudo mv sources.list sources.list.original
sudo leafpad sources.list
Im Texteditor leafpad schreibe man dann die folgenden Zeilen

Quellcode

1
2
3
deb http://security.debian.org squeeze/updates main contrib non-free
# Knoppix repository
deb http://debian-knoppix.alioth.debian.org ./
Dann speichere man die neue Datei und beende den Texteditor. Anschließend führe man im Terminal die folgenden Befehle aus. Damit löscht man alte Paket aus dem Cache, aktualisiert die Paketliste und lädt schließlich die neuen Pakete herunter.

Quellcode

1
2
3
sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade 
Die Fragen beantwortet man jeweils mit j.

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop