24.10.2017, 04:13 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

1

02.06.2013, 11:59

Kein Zugriff auf Datenpartition WD MyBook Live

Ich habe folgendes Problem:

Auf einem WD MyBook Live Laufwerk habe ich Fotos gelagert - komm jedoch nicht mehr dran, da das Laufwerk nicht mehr bootet.
Um an die Daten zu kommen, habe ich die enthaltene Festplatte jetzt in einen Ubuntu-Rechner eingebaut.

Ergebnis:
- Die Platte wird als /dev/sda erkannt
- Die Systempartition /dev/sda1 kann ich problemlos mounten und darauf zugreifen
- via parted habe ich die gesuchte Datenpartition als /dev/sda4 identifiziert
- "mount" der /dev/sda4 schlägt fehl
- "fsck" durchgeführt - hat fehlerhafte Zahl an inodes und free blocks identifiziert und korrigiert
- danach ist fsck zufrieden und meint jetzt bei erneutem Aufruf, /dev/sda4 sei jetzt ok
- "mount" schlägt immer noch fehl
- Im syslog ("dmesg") findet sich die Fehlermeldung "EXT4-fs (sda4): error: bad block size 65536"

Kann mir jemand helfen, wie ich hier weiterkommen und wieder an meine Fotos kommen könnte?

Viele Grüße,
Fritz

2

03.06.2013, 08:19

Problem gelöst

Hab die Lösung gefunden!
Die block size scheint für diese Laufwerke richtig zu sein - man braucht nur das richtige tool, da "mount" damit nicht umgehen kann.

Lösung: fuseext2
Details siehe http://john-hunt.com/2013/04/25/recoveri…b-3tbor-similar

Einfach zur Info für alle, die auf ähnliche Probleme stoßen könnten.

Gruß Fritz
:)

RalfonLinux

Erleuchteter

Beiträge: 2 931

Geschlecht: Männlich

3

03.06.2013, 11:33

Hi Fritz,

dann bedanke ich mich doch schon mal im Namen aller WD-MyBook-User für die Rückmeldung

Ralf
Auf Wunsch gibt es nur noch Text und keine Bilder mehr in der Signatur.
Keine ? ....... :evil:

Quellcode

1
2
3
4
5
6
7
8
.
    ~
   - -          M
   /V\         - *
  // \\        /V\
 /( _ )\      // \\
  ^~ ~^      /( _ )\
              ^~ ~^

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop