13.12.2017, 02:39 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

1

05.06.2014, 11:07

[gelöst] Soundproblem Notebook HP Pavilion 15 n-010e7

Hallo
Ich bin ein Knoppixneuling und darum unerfahren.
Knoppix startet auf meinem Notebook tadellos. Sound funktioniert aber leider nicht.

Was ich alles probiert habe:
====================

Startparameter
knoppix alsa
knoppix alsa=es1938
kein Effekt

mit alsamixer herumgespielt, Lautstärke verändert:
kein Effekt

aplay -l und aplay -L (vgl. unten)
Mit aplay -L konnte ich mir die Audiokanäle anzeigen. Wenn ich dann in VLC media player die Soundarchitektur auf "Audioausgabe ALSA" und die Audiokanäle auf "5.1 Surround" einstelle, dann habe ich eine Zeit lang Sound. Dann habe ich aber wieder Probleme.

Hier meine Angaben zum Sound:
========================

knoppix@Microknoppix:~$ cat /proc/asound/cards
0 [Generic ]: HDA-Intel - HD-Audio Generic
HD-Audio Generic at 0xf0340000 irq 78
1 [Generic_1 ]: HDA-Intel - HD-Audio Generic
HD-Audio Generic at 0xf0344000 irq 79
knoppix@Microknoppix:~$ aplay -l
**** Liste der Hardware-Geräte (PLAYBACK) ****
Karte 1: Generic_1 [HD-Audio Generic], Gerät 0: ALC282 Analog [ALC282 Analog]
Sub-Geräte: 1/1
Sub-Gerät #0: subdevice #0
knoppix@Microknoppix:~$ aplay -L
null
Discard all samples (playback) or generate zero samples (capture)
pulse
PulseAudio Sound Server
default:CARD=Generic_1
HD-Audio Generic, ALC282 Analog
Default Audio Device
sysdefault:CARD=Generic_1
HD-Audio Generic, ALC282 Analog
Default Audio Device
front:CARD=Generic_1,DEV=0
HD-Audio Generic, ALC282 Analog
Front speakers
surround40:CARD=Generic_1,DEV=0
HD-Audio Generic, ALC282 Analog
4.0 Surround output to Front and Rear speakers
surround41:CARD=Generic_1,DEV=0
HD-Audio Generic, ALC282 Analog
4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=Generic_1,DEV=0
HD-Audio Generic, ALC282 Analog
5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=Generic_1,DEV=0
HD-Audio Generic, ALC282 Analog
5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=Generic_1,DEV=0
HD-Audio Generic, ALC282 Analog
7.1 Surround output to Front, Center, Side, Rear and Woofer speakers

Vielen Dank für die Hilfe.
Daniel

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »englerd« (11.06.2014, 23:34)


2

06.06.2014, 00:46

Problem gelöst

Mein Problem konnte ich lösen, indem ich folgende Datei erstellt habe:

/etc/asound.conf

Sie muss folgenden Inhalt haben:
pcm.!default {
type hw
card 1
}

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop