14.11.2019, 06:55 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren


28.03.2014, 16:57

knoppix 7.0.4 pxe boot problem, knoppix gurus please help me !

alo knoppix gurus! und hello, i really need your help please!

sorry my german studies are so far i'm not able to speak german correctly, i think it's better for you i speak english lol

are there knoppix specialists speaking english? i hope so

let me explain my problem

i would like to boot this livecd version over my network on my pxe server

my pxe server is running for ubuntu, clonezilla, and other stuff, working well

my problem is to make knoppix work...

as mentionned on knoppix's website, i've used the terminal server to obtain the kernel image and the minirt.gz file, and stored them on my pxe, and added an entry in my pxelinux/default:

label knoppix
kernel /knoppix/linux
append nfsdir= nodhcp lang=us vga=791 initrd=/knoppix/minirt.gz BOOT_IMAGE=knoppix

when i select knoppix in the menu of pxe boot, knoppix loads kernel, and minirt.gz, knoppix starts to boot, installs my network card
but stops after with this mouting error message:

trying to mount cd on mount /mnt-system -o ro,rsize=8192,wsize=8192,hard,nolock,intr
this should have succeeded failed
please enter nfs directory path (aka ""):

i've check my nfs share with success with another computer under ubuntu
i've tried this pxe boot with 2 laptops with the same error

at this time when i try 3 times to enter the path of the nfs share, th init script stops and i remain on a sh shell

under this shell, the same mounting command does not work: protocol not supported

my pxe server is configured with nfs v1, v2 and v3, and knoppix seems to use v3

so i'm stopped by a nfs mounting problem of the minirt.gz boot and init script

i've uncompressed and opened the minirt.gz init's script, but everything seems to be ok in it, it's like the minirt.gz system could not mount a nfs share

it seems to b a real bug no?

is there a real strong smart cute knoppix guru to help me please? not necessary do it but help me to point to the right direction??

thanks in advance




Beiträge: 2 728

Geschlecht: Männlich


28.03.2014, 18:14

Guten Tag!

There is an english speaking forum at http://knoppix.net/forum/forum.php

I think you should ask your question there.



02.09.2014, 13:37

Ich habe jetzt den Kernel 3.3.5 sowie den aktuellen Xserver in mein remastertes Knoppix aufgenommen. Trotzdem hat sich das Problem mit der fehlerhaften Darstellung der Schrift nicht gebessert. Außerdem funktionierte nach einem Upgrade das Networkmanager-Applet nicht mehr (Speicherfehler). Dafür fand sich Abhilfe: Ich installierte wicd nebst wicd-gtk und boote mit dem Bootparameter "nonetworkmanager". So funktioniert zumindest auf meinem Rechner das WLAN.
Our complete set of pass4sure test questions and University of Saint Joseph study guides you in exact way so you will pass your real EXIN with flying colors of mcsa training.

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop