18.11.2018, 16:16 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

1

03.10.2014, 11:14

[P] [7.4] Keine Verbindung zu WLAN Router

Hallo!

Ich kann keine WLAN-Verbindung zu meinem Router aufbauen.

Am PC verwende ich die Hardware USB-WLAN-Stick "TP-Link TL-WN422G".
Ich finde allerdings keine Indikatoren, die auf ein Problem mit Hardware und Treiber hindeuten, denn alle verfügbaren WLAN-Netze in der Umgebung werden richtig erkannt.

Quellcode

1
2
3
4
5
6
7
8
9
sudo nmcli dev wifi*  SSID                     MODUS  CHAN  RATE       SIGNAL  BARS  SICHERHEIT 
   Gastzugang               Infra  1     54 Mbit/s  35      ▂▄__  WPA1 WPA2  
   FRITZ!Box Fon WLAN 7270  Infra  10    54 Mbit/s  52      ▂▄__  WPA1 WPA2  
   FRITZ!Box 6340 Cable     Infra  1     54 Mbit/s  32      ▂▄__  WPA1 WPA2  
   NETGEAR                  Infra  6     54 Mbit/s  49      ▂▄__  --         
   FRITZ!Box Fon WLAN 7270  Infra  11    54 Mbit/s  19      ▂___  WPA1 WPA2  
   M-Net2009 EX             Infra  1     54 Mbit/s  30      ▂___  WPA2       
   AP_Netgear_nomap         Infra  1     54 Mbit/s  72      ▂▄▆_  WPA2       
   FRITZ!Box 6340 Cable     Infra  11    54 Mbit/s  27      ▂___  WPA1 WPA2


Der Verbindungsaufbau mit läuft in einen Timeout.

Quellcode

1
sudo nmcli dev wifi connect AP_Netgear_nomap password <password>Fehler: Zeitbeschränkung von 90 Sekunden ist abgelaufen.


Welche weiteren Informationen sind notwendig, um die Ursache für diesen Fehler zu ermitteln und zu beheben?

Alle anderen Geräte (Smartphone, Windows-PC, etc.) können ohne Einschränkung die Verbindung zum Router aufbauen.

Quellcode

1
2
3
4
route -nKernel-IP-Routentabelle
Ziel            Router          Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.100.1   0.0.0.0         UG    1024   0        0 eth0
192.168.100.0   0.0.0.0         255.255.255.0   U     0      0        0 eth0

Die Adresse 192.168.100.1 gehört zum Kabel-Router (=Fritz!Box) und nicht zum WLAN-Router.

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
ifconfig -aeth0      Link encap:Ethernet  Hardware Adresse 74:d4:35:1a:f6:0f  
          inet Adresse:192.168.100.94  Bcast:192.168.100.255  Maske:255.255.255.0
          inet6-Adresse: fe80::76d4:35ff:fe1a:f60f/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX packets:1752 errors:0 dropped:1 overruns:0 frame:0
          TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000 
          RX bytes:115433 (112.7 KiB)  TX bytes:1634 (1.5 KiB)
          Interrupt:20 Speicher:f7c00000-f7c20000 lo        Link encap:Lokale Schleife  
          inet Adresse:127.0.0.1  Maske:255.0.0.0
          inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
          UP LOOPBACK RUNNING  MTU:65536  Metrik:1
          RX packets:8 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:0 
          RX bytes:440 (440.0 B)  TX bytes:440 (440.0 B)wlan0     Link encap:Ethernet  Hardware Adresse 00:27:19:bf:32:81  
          inet6-Adresse: fe80::227:19ff:febf:3281/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX packets:13 errors:0 dropped:0 overruns:0 frame:0
          TX packets:82 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000 
          RX bytes:1907 (1.8 KiB)  TX bytes:14956 (14.6 KiB)


Quellcode

1
2
3
4
cat /etc/network/interfaces# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)# The loopback interface
# automatically added when upgrading
auto lo
iface lo inet loopback


Quellcode

1
2
3
4
5
6
7
8
9
sudo iwconfigwlan0     IEEE 802.11bgn  ESSID:"AP_Netgear_nomap"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: C4:04:15:6B:1A:2C   
          Bit Rate=90 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=48/70  Signal level=-62 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:118   Missed beacon:0


Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
sudo iwlistwlan0     13 channels in total; available frequencies :
          Channel 01 : 2.412 GHz
          Channel 02 : 2.417 GHz
          Channel 03 : 2.422 GHz
          Channel 04 : 2.427 GHz
          Channel 05 : 2.432 GHz
          Channel 06 : 2.437 GHz
          Channel 07 : 2.442 GHz
          Channel 08 : 2.447 GHz
          Channel 09 : 2.452 GHz
          Channel 10 : 2.457 GHz
          Channel 11 : 2.462 GHz
          Channel 12 : 2.467 GHz
          Channel 13 : 2.472 GHz
          Current Frequency:2.412 GHz (Channel 1)


Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
lsmodModule                  Size  Used by
ctr                     3535  2 
ccm                     6739  2 
arc4                    1928  2 
ath9k_htc              45890  0 
ath9k_common            7505  1 ath9k_htc
ath9k_hw              362787  2 ath9k_common,ath9k_htc
ath                    16784  3 ath9k_common,ath9k_htc,ath9k_hw
mac80211              393416  1 ath9k_htc
keucr                  50269  0 
x86_pkg_temp_thermal     4560  0 
coretemp                5228  0 
hid_logitech_dj         9187  0 
kvm_intel             122338  0 
kvm                   330990  1 kvm_intel
crct10dif_pclmul        4459  0 
crc32_pclmul            2691  0 
ghash_clmulni_intel     3730  0 
serio_raw               4214  0 
tpm_infineon            5521  0 
tpm_tis                 7237  0 
tpm                    19460  2 tpm_tis,tpm_infineon
ipv6                  277676  22 
i915                  658116  3 
drm_kms_helper         26545  1 i915
cfg80211              339620  4 ath,ath9k_common,mac80211,ath9k_htc
sbs                     6244  0 
sbshc                   3551  1 sbs
custom_method           1465  0 
acpi_ipmi               4277  0 
ipmi_msghandler        27642  1 acpi_ipmi
snd_hda_codec_realtek    44312  1 
snd_hda_codec_generic    41272  1 snd_hda_codec_realtek
8250_pci               31099  0 
e1000e                138777  0 
i2c_i801               12788  0 
ptp                     9176  1 e1000e
snd_hda_intel          17719  0 
pps_core                5816  1 ptp
snd_hda_controller     16945  1 snd_hda_intel
8250                   28269  1 8250_pci
lpc_ich                13561  0 
snd_hda_codec          78263  4 snd_hda_codec_realtek,snd_hda_codec_generic,snd_hda_intel,snd_hda_controller
serial_core            17665  1 8250


Quellcode

1
2
3
4
5
6
7
8
9
10
lsusbBus 002 Device 002: ID 8087:8000 Intel Corp. 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8008 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 005: ID 058f:6366 Alcor Micro Corp. Multi Flash Reader
Bus 003 Device 004: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 003 Device 003: ID 8564:1000  
Bus 003 Device 002: ID 0cf3:1006 Atheros Communications, Inc. TP-Link TL-WN322G v3 / TL-WN422G v2 802.11g [Atheros AR9271]
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


Quellcode

1
modprobe -c | grep -i "0cf3.*1006"alias usb:v0CF3p1006d*dc*dsc*dp*ic*isc*ip*in* ath9k_htc 


Quellcode

1
cat /etc/resolv.conf# Generated by NetworkManager


Quellcode

1
2
3
sudo rfkill list0: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: no



THX

klaus2008

Meister

Beiträge: 2 698

Geschlecht: Männlich

2

03.10.2014, 14:01

Hallo!

Der Vollständigkeit halber habe ich noch eine Frage:
Hast Du schon versucht, anstatt mit dem Programm nmcli mit dem Netzwerkmanager-Applet in der grafischen Umgebung eine Verbindung aufzubauen?

Gruß
Klaus

3

03.10.2014, 19:14

Ja.
Der Kreisel im Applet dreht sich dann unendlich lang ohne dass eine Verbindung hergestellt wird.

Gibt es nicht ein Log, in dem protokolliert wird, was nicht geht bzw. fehlschlägt?
Hallo!

Der Vollständigkeit halber habe ich noch eine Frage:
Hast Du schon versucht, anstatt mit dem Programm nmcli mit dem Netzwerkmanager-Applet in der grafischen Umgebung eine Verbindung aufzubauen?

Gruß
Klaus

klaus2008

Meister

Beiträge: 2 698

Geschlecht: Männlich

4

03.10.2014, 22:54

Wurde nach dem Passwort für das WLAN gefragt?

Zitat

Gibt es nicht ein Log, in dem protokolliert wird, was nicht geht bzw. fehlschlägt?

Man könnte die Kernelmeldungen anschauen. Dazu würde ich folgendermaßen vorgehen.
  1. Der USB-WLAN-Adapter wird herausgezogen.
  2. Das Netzwerkkabel wird entfernt.
  3. Es wird ein LXTerminal geöffnet.
  4. Mit dem Befehl

    Quellcode

    1
    
    sudo modprobe -r ath9k_htc
    wird das Kernelmodul für den USB-WLAN-Adapter entladen.
  5. Der USB-WLAN-Adapter wird wieder angeschlossen.
  6. Nach etwa einer halben Minaut wird im LXTrminal der Befehl

    Quellcode

    1
    
    dmesg |tail -n 30 
    ausgeführt. Der zeigt die letzten 30 Zeilen der Kernelmeldungen im LXTerminal an. So erfährt man, ob der USB-WLAN-Adapter erkannt wurde.
  7. Es wird versucht, mit dem Netzwerkmanager-Applet ein Verbindung aufzubauen.
  8. Im LXTerminal schaue man sich die letzen Zeilen der Kernelmeldungen an.

    Quellcode

    1
    
    dmesg |tail -n 30 
    Vielleicht erfährt man, was schief läuft.

Vielleicht hilft das weiter.

Gruß
Klaus

5

05.10.2014, 20:07

Willkommen im Kuriositäten-Kabinett

Jetzt wird's kurios... vielleicht auch etwas dubios.

Ich habe jetzt den Knoppix 7.4 Live USB-Stick an den 3. (in Worten: dritten) PC angeschlossen und gebootet.

Und siehe da:
Plötzlich funktioniert die WLAN-Verbindung zu Router und von dort ins Internet mittels Network-Manager.
Es war kein manueller Eingriff o.ä. notwendig... WLAN USB-Stick angeschlossen, SSID ausgewählt, Password eingegeben, und schon stand die Verbindung.

Dieser PC läuft mit einem ASRock Mainboard: A75M-ITX
http://www.asrock.com/mb/AMD/A75M-ITX/?cat=Specifications

Dies ist der finale Beweis, dass es nicht am WLAN USB-Stick, nicht am Treiber, nicht am OS liegt.

Aber woran liegt es dann?

THX

klaus2008

Meister

Beiträge: 2 698

Geschlecht: Männlich

6

10.10.2014, 21:33

Hast Du schon versucht, einen anderen USB-Anschluss zu verwenden (also mit HUB, ohne HUB, USB 2.0 oder USB 3.0)?

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop