21.10.2018, 09:02 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

1

07.10.2014, 11:42

Knoppix 7.4.2 startet nicht / hängt

Hallo,

ich wollte meinen alten Windows XP-Rechner auf Linux umrüsten und als Vorbereitung das System mal mit der Knoppix-DVD (Version 7.4.2) hochfahren. Das System funktioniert unter Windows XP reibungslos.

Leider hängt sich der PC während des Startvorgangs (diverse Male probiert) auf. Auch Live-DVDs anderer Linux-Systeme, beispielsweise die Ubuntu-DVD oder eine Debian-DVD, funktionieren nicht. Irgendwie hängt immer etwas. Ich habe ebenso eine ältere Knoppix-CD (Version 7.2.0) in einem anderen CD-Laufwerk probiert, und es hängt ebenso.

Auf meinem aktuellen PC mit anderer Hardware-Ausstattung startet dieselbe Knoppix-DVD einwandfrei.

Fehlerbeschreibung im einzelnen:
Nach dem anfänglichen "Splash-Screen" und dem Wechsel in die Textausgabe erscheint
----------------------------------------------------------------------------
Willkommen zu Knoppix 7.4 basierend auf MICROKNOPPIX
Linux Kernel 3.16.3-64, 2003 MB RAM
CPU 0: AMD Athlon 64 Processor 3000+ @ 2009 MHz, 512 KB Cache
Knoppix 7.4 gefunden in: /dev/sr0
>>> Starte im Live-Modus
>>> Bitte den Datenträger bis zum Herunterfahren nicht mehr entfernen!
INIT: Version 2.88 booting
GRAPHICS 0: NVIDIA Corporation NV34 [GeForce FX 5200 Ultra]
SOUND 0: NVIDIA Corporation nForce3 250Gb Ac'97 Audio Controller
----------------------------------------------------------------------------

... und dann hängt das System und läuft nicht weiter. Auch Start mit diversen empfohlenen "Cheat-Codes" führt zu nichts.

Ich habe dann sämtliche überflüssige Peripherie entfernt und das System nur mit DVD-Laufwerk, Graphikkarte, Maus und Tastatur (beides PS/2) hochgefahren, und zwar mit "debug"-Option in Knoppix.

Es erscheint längere Textausgabe und dann wie oben:
----------------------------------------------------------------------------
CPU 0: AMD Athlon 64 Processor 3000+ @ 2009 MHz, 512 KB Cache
Knoppix 7.4 gefunden in: /dev/sr0
Past mounting /mnt-system
sh: can't access tty:; job control turned off
/ #
----------------------------------------------------------------------------

... und dann hängt das System wieder.

Auch eine Prüfung der Knoppix-DVD ("testdvd"-Option) führt dazu, daß das System während der Prüfung ("Prüfe KNOPPIX/KNOPPIX ...") nicht weiterläuft und sich aufhängt. Aber wie erwähnt, funktioniert dieselbe DVD auf meinem anderen Rechner einwandfrei.
Nachtrag: Prüfung der Knoppix-DVD auf meinem anderen Rechner funktioniert und ergibt "alle Dateien in Ordnung".

Die Hardware-Konfiguration ergibt sich schon aus den Angaben oben. Auf der Hauptplatine (Asus K8N) ist ein Chipsatz NVidia nForce3 250 verbaut.

Was ist hier los oder zu tun? Besteht eine grundsätzliche Hardware-Inkompatibilität zwischen Knoppix und dieser Hauptplatine oder diesem Chipsatz? Nur so kann ich mir das derzeit erklären.

Vielen Dank für Hinweise!

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Felix-80« (07.10.2014, 18:04)


klaus2008

Meister

Beiträge: 2 695

Geschlecht: Männlich

2

07.10.2014, 21:09

Hallo!

Immer, wenn im Debug-Modus die Shell erscheint, kann man Befehle eingeben.
Damit der Bootvorgang fortgesetzt wird, muss die Shell beendet werden.
Das geschieht mit dem Befehl exit oder der Tastenkombination Strg-D.

Vielleicht hilft das weiter.

Gruß
Klaus

progi

Fortgeschrittener

3

07.10.2014, 21:32

Hallo Felix-80

Zitat

Auch eine Prüfung der Knoppix-DVD ("testdvd"-Option) führt dazu, daß das System während der Prüfung ("Prüfe KNOPPIX/KNOPPIX ...") nicht weiterläuft und sich aufhängt. Aber wie erwähnt, funktioniert dieselbe DVD auf meinem anderen Rechner einwandfrei.
Nachtrag: Prüfung der Knoppix-DVD auf meinem anderen Rechner funktioniert und ergibt "alle Dateien in Ordnung".


Darum vermute ich, daß diese DVD auf diesem Computer nicht richtig gelesen werden kann.

Darum würde ich die .iso-Datei auf diesen Computer kopieren, die DVD auf diesem Computer MÖGLICHST LANGSAM (neu) brennen (ev. nachdem du md5sum der .iso-Datei auf diesem geprüft hast).

Dann bootest du deinen Computer mit dieser DVD und testest diese (mit knoppix testdvd) und berichtest hier das Ergebnis

MfG
progi

4

08.10.2014, 20:47

Hallo,

danke für die Hinweise.

1. Es scheint tatsächlich - warum auch immer - ein Problem mit dem CD/DVD-Gerät zu geben. Ich habe versuchsweise das DVD-Laufwerk von meinem neuen PC in den "Knoppix-PC" eingebaut. Also das Laufwerk, auf dem die Boot-DVD auch hergestellt wurde. Jetzt läuft der Startvorgang störungsfrei durch. Allerdings nur dann, wenn man bezüglich der Graphikkarte einige Sonderoptionen setzt (nomodeset, nofb, nodrm, nocomposite, vga=normal). Ich mußte da verschiedenes durchprobieren.

2. Richtig funktionieren tut es dennoch nicht. Der graphische Knoppix-Desktop erscheint zwar nach einiger Zeit, läuft aber nicht stabil. Es kommt unvermittelt zu Abstürzen. Genauso funktionieren andere Linux-Installationen nicht störungsfrei.

Vermutlich das altbekannte Problem: die Hardware des PC (zusammengestellt Anfang 2005 und unter Windows XP noch völlig funktionstüchtig) ist nicht auf aktuelle Linux-Systeme abgestimmt, die wahrscheinlich schon modernere Hardware oder spezielle Gerätetreiber voraussetzen. Schade.

Ich werde die Arbeit jetzt einstellen und alles so lassen, wie es ist.

Danke nochmals.

5

09.10.2014, 10:48

Liegt es evtl. doch an Acer-Spezifika?

Hallo!

Ich glaube, ich habe das gleiche Problem wie Felix-80.
Ich könnte mir vorstellen, dass das Problem mit ASUS zu tun haben könnte.
Meine DVD ist ok, mit dieser lässt sich auch ein Knoppix-7.4.2 in einem VMWare-Player problemlos starten.
Aber es startet nicht - genau wie Felix-80 es beschrieben hat- nativ beim Rechnerstart.
Ich habe dies mehrmals mit 2 Asus-Laptops probiert: hier gibt jedes Mal das Problem (ASUS N75 1,5 Jahre alt - also noch nicht sooo alt - bzw. 4 Jahre alt ASUS N73).
Mit einem viel älteren Acer-Laptop habe ich mit derselben DVD keinerlei Probleme - alles läuft einwandfrei.
Ich habe allerdings noch keinerlei Boot-Parameter versucht.
Denn eigentlich sollte dies auch ohne solche funktionieren (wie eben bei meinem Acer-Laptop, wo alles ok ist oder wie auch innerhalb der VMWare-Umgebung).
Bitte auch um Hilfe!
Danke

6

09.10.2014, 11:21

Liegt es evtl. doch an ASUS-Spezifika?

Ich meinte natürlich ASUS-Spezifika und nicht Acer!

7

25.10.2014, 17:07

Versuch mal ein Linux V12.04 32bit, wenn Du Glück hast, läuft die. Liegt evtl. am Prozessor (PAE).
Gruss

knokps

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop