24.05.2017, 23:38 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

1

08.01.2016, 03:42

Mobiles Breitband: 1. Verbindung über Netzwerk-Manager-Applet wird abgebrochen / 2. Sicherheit

Hallo an alle.

1.
Zur Nutzung des Internets verwende ich einen Surfstick und eine SIM-Karte.

Mit dem Netzwerk-Manager-Applet 0.9.10.0 habe ich eine Mobile Breitbandverbindung eingerichtet.

Das surfen funktioniert.

Nach einiger Zeit wird die Verbindung automatisch getrennt und ich kann keine neue Verbindung herstellen.

Diese Fehlermeldung erscheint wenn ich den Rechner erneut mit dem eingerichteten Mobilen Breitband verbinden will:

(1) Creating object for path '/org/freedesktop/NetworkManager/ActiveConnection/1' failed in libnm-glib.
(Anstatt der 1 am Ende auch höhere Ziffern/Zahlen mit jedem Versuch).

Wenn ich den Browser beende, den Surfstick auswerfe, wieder anschließe und mich verbinden möchte erscheint dann diese Meldung:

(32) Connection 'O2 connection 1' is not available on the device ttyUSB3 at this time.

Auch das löschen der eingerichteten Mobilen Breitbandverbindung und das erneute einrichten bringt nichts.

Erst nach dem Neustart des Betriebssystems lässt sich wieder eine Verbindung herstellen!

Was muss ich tun, damit die Verbindung konstant bleibt und wie kann ich einen Neustart des BS umgehen?
(Ich weiß es steht in der Fehlermeldung, aber ich hab' [noch] keinen Plan davon).

-------------------------------------------

2.
Wie sicher ist eine Verbindung dieser Art überhaupt und wie kann ich sie möglichst sicher machen?

Viele Grüße

CyberEgo

klaus2008

Meister

Beiträge: 2 621

Geschlecht: Männlich

2

09.01.2016, 21:51

Hallo!

Ich würde erst einmal die Grundlagen klären:
  1. Welches Fabrikat hat der Surfstick? Dazu würde ich im LXTerminal bei angeschlossenem Surfstick die USB-ID erfragen:

    Quellcode

    1
    
    lsusb

  2. Gibt es Kernelmeldungen, die hilfreich sein könnten? Vielleicht kann man direkt nach dem Verbindungsabbruch mit dem Befehl

    Quellcode

    1
    
    dmesg | tail -n 20 
    im LXTerminal etwas Nützliches erfahren.
  3. Möglicherweise hilft auch die Ausgabe des Befehls

    Quellcode

    1
    
    dmesg | grep NetworkManager 
    etwas weiter.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »klaus2008« (09.01.2016, 21:56)


3

10.01.2016, 16:21

Hallo Klaus,

Dies ist der Surfstick:

Bus 001 Device 007: ID 12d1:1506 Huawei Technologies Co., Ltd. E398 LTE/UMTS/GSM Modem/Networkcard


nach:

dmesg | tail -n 20

erscheint:

[ 1987.920179] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[ 1987.920186] sr 11:0:0:0: [sr0]
[ 1987.920190] Sense Key : Medium Error [current]
[ 1987.920198] Info fld=0xfffc
[ 1987.920204] sr 11:0:0:0: [sr0]
[ 1987.920210] Add. Sense: Unrecovered read error
[ 1987.920217] sr 11:0:0:0: [sr0] CDB:
[ 1987.920221] Read(10): 28 00 00 00 ff fc 00 00 02 00
[ 1987.920242] blk_update_request: critical medium error, dev sr0, sector 262128
[ 1987.926588] sr 11:0:0:0: [sr0]
[ 1987.926597] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[ 1987.926603] sr 11:0:0:0: [sr0]
[ 1987.926608] Sense Key : Medium Error [current]
[ 1987.926616] Info fld=0xfffc
[ 1987.926621] sr 11:0:0:0: [sr0]
[ 1987.926627] Add. Sense: Unrecovered read error
[ 1987.926634] sr 11:0:0:0: [sr0] CDB:
[ 1987.926638] Read(10): 28 00 00 00 ff fc 00 00 02 00
[ 1987.926659] blk_update_request: critical medium error, dev sr0, sector 262128
[ 1987.926668] Buffer I/O error on dev sr0, logical block 32766, async page read



Nach:

dmesg | grep NetworkManager

passiert nichts.


Ich habe herausgefunden, dass wenn ich unter Verbindung bearbeiten nochmal den PIN eingebe (der steht da allerdings vorher schon, gebe ihn ja auch beim einhängen des Sticks ein, um die SIM-Karte frei zu schalten) und speichere, es ohne Neustart geht, das ist schon mal sehr viel weniger Umstand als neu zu booten... ;-)


Gruß
CyberEgo

klaus2008

Meister

Beiträge: 2 621

Geschlecht: Männlich

4

10.01.2016, 17:47

Zitat

[ 1987.926608] Sense Key : Medium Error [current]
[ 1987.926616] Info fld=0xfffc
[ 1987.926621] sr 11:0:0:0: [sr0]
[ 1987.926627] Add. Sense: Unrecovered read error
[ 1987.926634] sr 11:0:0:0: [sr0] CDB:
[ 1987.926638] Read(10): 28 00 00 00 ff fc 00 00 02 00
[ 1987.926659] blk_update_request: critical medium error, dev sr0, sector 262128
[ 1987.926668] Buffer I/O error on dev sr0, logical block 32766, async page read

Ich würde die DVD mit

Quellcode

1
 knoppix testcd 
booten, um zu testen, ob das Medium defekt ist.

5

11.01.2016, 18:16

Welche DVD?

Ich habe Knoppix auf einem USB 2.0

6

12.01.2016, 08:09

Auch bei einem USB-Stick mit einer Knoppix-Installation kann mit diesem cheatcode (knoppix testcd) die Integrität der großen, komprimierten Hauptdatei getestet werden.
Gruß Werner * Eigene Rescue-CD
remaster Grml * remaster Knoppix

klaus2008

Meister

Beiträge: 2 621

Geschlecht: Männlich

7

12.01.2016, 23:24

wvdial anstatt NetzwerkManager ausprobieren

Es könnte sein, dass die Kommunikation mit wvdial besser funktioniert als mit dem NetworkManager.

8

15.01.2016, 13:16

Erkennen einer UMTS-Karte

Hallo zusammen

Erlauben Sie mir dass ich mich hier anhänge, da ich ein änliches Problem habe.

Ich betrachte mich im Linuxumfeld als Anfänger, auch wenn ich schon seit einigen Jahren nur unter Linux - speziell Knoppix - im Internet surfe.

Dazu verwende ich zwei verschiedene ältere Laptops und Life-CDs, aus verschiedenen Linux-Zeitschriften.

Der Netzwerkzugang erfolgt dabei über eine UMTS-Karte im PCMCIA Schacht, wird aber von Linux wohl wie USB behandelt.

Bus 007 Device 002: ID 12d1:1003 Huawei Technologies Co., Ltd. E220 HSDPA Modem / E230/E270/E870 HSDPA/HSUPA Modem

Bis zur Koppix Version 7.3 ist eigentlich alles gut gelaufen.

Seit V7.4 laufe ich in die verschiedensten Fehler bei Verbinden mit dem Mobilen Netz.

Unter Version V7.4 gelingt es mir bisher überhaupt nicht (Fehlermelung werde ich noch nachliefern)

Unter der Version V7.5 (mit der bin ich gerade unterwegs) gelingt es oft nur mit viel Herumproblieren.
Selbst unter einer USB-Stick Variante mit persistentem Overlay ist bei einem Neustart das Verhalten nicht sicher.

Unter der Version V7.6 erhalte ich die gleiche Fehlermeldung wie oben beschrieben.
Ein knoppix testcd habe ich schon durchgeführt und keinen Fehler erhalten.

Wo kann ich einsteigen um wieder ein stabiles Verhalten zu erzeugen.

Im Vorraus schon Beste Dank

Nachtrag:
Fehlerbeschreibung für die Version 7.4
Beim booten wird der PIN der UMTS-Karte abgefragt, das endet aber in einer Endlosschleife, ohne allerdings die Karte zu sperren (mehr als 3 Versuche)
Unter Netzwerkverbindung.Hinzufügen wird ein Gerät HUAWEI vorgeschlagen.
Beim Versuch Verbindung herstellen kommt zuerst (oben rechts) die Meldung "Verbindung wurde getrennt"
Danach folgt wieder die Pin-Abfrage mit Endlosschleife.

lsusb ergibt:
BUS 007 Device 006 ID:0003 Huawei Technologies Co Ltd E220 HSDPA Modem / E230/E270/E870 HSDPA/HSUPA Modem

dmesg | tail -n 20 ergibt:[attach]901[/attach]


Nachtrag 2
Fehlerbeschreibung für die Version 7.6
knoppix testcd ergab alle Files in Ordnung

Booten ist erfolgreich ( Fujitsu Lifebook E8310 mit 4GB Ram) und UMTS-PIN wird abgefragt (ohne Endlosschleife).
Beim Versuch die Verbindung herzustellen erfolgt obige Fehlermeldung,siehe auch [attach]904[/attach]

Die Ausgabe von lsusb und dmesg ergaben
[attach]903[/attach]

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »KeyGKey« (15.01.2016, 21:13)


klaus2008

Meister

Beiträge: 2 621

Geschlecht: Männlich

9

16.01.2016, 18:54

Hallo!

Ich würde Knoppix 7.6 mit

Quellcode

1
knoppix nonetworkmanager
gefolgt von eventuell weiteren Cheatcodes booten und das Programm wvdial ausprobieren.
Aufgefallen ist mir, dass das Modem zwei Gerätenamen zugewiesen bekommt:

Quellcode

1
2
3
4
5
 [   57.799381] usbserial: USB Serial support registered for GSM modem (1-port)
[   57.799487] option 7-1:1.0: GSM modem (1-port) converter detected
[   57.799580] usb 7-1: GSM modem (1-port) converter now attached to ttyUSB0
[   57.799602] option 7-1:1.1: GSM modem (1-port) converter detected
[   57.799675] usb 7-1: GSM modem (1-port) converter now attached to ttyUSB1 
Welcher Anschluss wird vom NetzwerkManager verwendet?

10

17.01.2016, 00:47

Hallo!
Vielen Dank für die Antwort.

Ich habe Knoppix V7.6 jetzt mal mit dem Cheatcode "nonetworkmanager" gestartet. Dann ist das Netzwerk deaktiviert.

Der Versuch mit wvdial ergab: (siehe ganz unten)
[attach]905[/attach]

Wenn ich es richtig interpretiere fehlt ein Gerät "modem"; das scheint aber auch unter V7.5 zu fehlen, wo ich eine Verbindung hinbekomme (wenn manchmal auch mit Mühe).

Zu Punkt 2:
Wo kann ich nachschauen mit welcher Zuordnung des Gerätenames der NetworkManager arbeitet. Unter Knoppix hatte ich mich damit bisher nicht befassen müssen (Unter Puppy ist mir das unter gekommen).

Eventuell hängt damit auch meine Probleme mit der Version 7.5 zusammen. Denn dort bekomme ich manchmal in etwa die Meldung ttyUSB0 / ttyUSB1 ist zur Zeit kein Gerät zugeordnet. Dann muss ich im NetworkManager die Zuordnung (dort sehe ich aber kein ttyUSBx) löschen und neue Anlegen. Dann geht es wieder, manchmal aber auch erst nach einem Reboot (bei V7.5 bin ich mit einem USBStick unterwegs).

Wie erzeugt man so ein Gerät? Oder sollten die von Dir erwähnten zugewiesenen Gerätename genau dies erfüllen?

Beste Grüße und vielen Dank
Klaus

klaus2008

Meister

Beiträge: 2 621

Geschlecht: Männlich

11

17.01.2016, 04:07

Hallo!

Das Programm wvdial benutzt ohne spezielle Einstellungen das Gerät /dev/modem, welches bei dem verwendeten UMTS-Stick nicht existiert. Abhilfe schafft eine angepasste Konfigurationsdatei /etc/wvdial.conf, über die es im Internet zahlreiche Informationsseiten gibt. Da Knoppix auf Debian basiert, würde ich es zuerst mit den Informationen aus dem Debian-Wiki probieren.

Gemäß der Seite Wvdial im Debian-Wiki würde ich mit

Quellcode

1
sudo dpkg-reconfigure wvdial 
anfangen.
Falls die Konfigurationsdatei /etc/wvdial.conf bezüglich der Provider-Daten angepasst werden muss, hilft vielleicht die Seite Huawei E220 UMTS/GPRS Modem mit Linux (Ubuntu) weiter.
Bearbeiten kann man die Konfigurationsdatei z. B. mit dem Texteditor Leafpad:

Quellcode

1
sudo leafpad /etc/wvdial.conf 
(Speichern beim Beenden des Texteditors nicht vergessen)
Der Befehl

Quellcode

1
sudo pon.wvdial 
sollte laut Debian-Wiki das Modem aktivieren. Mit dem Befehl

Quellcode

1
sudo poff.wvdial 
sollte man das Modem wieder abschalten können.

Gruß
Klaus

12

17.01.2016, 09:47

Hallo

Vielen Dank für die promte Antwort. Ich hoffe ich habe niemanden um seinen Schlaf gebracht.

Für einen Linux Anfänger wie mich sieht das erste einmal wie eine kleine Herausforderung aus.
Ich werde mich aber (nach Systemwechsel) daran versuchen. Wie ich Neues weiß melde ich mich wieder.

Ich bin gerade mit V7.5 unterwegs und habe beim Booten wieder einmal das Verbindungs Problemchen gehabt.
[attach]906[/attach]

Beim letzten Boot mit diesem USBStick war die Verbindung vorhanden. Kann das mit der doppelten Namensvergabe zusammen hängen?
Wie kann ich diese verhindern?

Gruss
Klaus

13

18.01.2016, 21:54

Hallo

So ich weiß etwas mehr. Zumindest wie Frust entsteht.

Leider kam ich mit wvdial unter der Version 7.6 nicht weiter.

Daher bin ich auf die Version 7.3 umgestiegen, da funktioniert das Modem problemlos (bis jetzt jedenfalls) mit dem NetworkManager. Also hoffte ich dort weiter zu kommen.

wvdial kann ich dort so weit auch soweit bedienen und das Conf-File bearbeiten.

Bei fast allen Recherchen im Internet stoße ich auf die Kommando-Zeile

ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0

siehe z.B [attach]907[/attach]
Das dürfe auch genau das Modem sein das ich verwende.

Leider wird der Teil "+FCLASS=0" nicht korrekt ausgeführt.
[attach]908[/attach]

Auch der Teil "at+cgdcont=1 "ip","internet.t-d1.de"" wird ab dem "+" nicht akzeptiert.

Zur Zeit sieht mein Conf-File wie folgt aus:
[attach]909[/attach]

Zur Zeit bin ich noch nicht dazu gekommen dies auch mit einem anderen Linux-System zu testen.

Von Vorschlägen wie wvdial neu zu Installieren oder gar etwas in den Kernel zu compilieren möchte ich der Zeit Abstand nehmen, das geht schlicht über meine Verhältnisse.

Der Frust kommt natürlich vor allem daher dass unter Koppix V7.3 alles mit dem NetworkManager fein läuft, unter V7.4 und V7.6 es nicht klappt.
Vielleicht warte ich auf V7.7 .


Oder gibt es nicht doch eine Möglichkeit dem NetworkManager bei zu bringen nicht mit einem nicht vorhanden File/Pfad zuarbeiten.

Nichts für Ungut und beste Grüße
Klaus

14

27.01.2016, 15:22

Hallo noch ein mal
Ich habe jetzt mehrere Linux-Distibutionen als Livesysteme ausprobiert. Darunter Antix, Bohdi, Manjaro, MultiSystem, Puppy, Rosa, SalentOS, SymphonyOS, Debian, Ubuntu, usw. Bei fast allen gelang mit dem standardmäßigen Networkmanger ein Zugang ins Internet. Über wvdial gelang es mir aus verschiedensten Gründen nicht. Zum Teil fehlt mit einfach die Kenntnis der AT-commands und Config-Parameter, die ich beim Netwertmanager nicht benötige.
Erstaunlich ist halt dass es bei Knoppix 7.3 problemlos funktioniert bei 7.6 aber nicht und das gleiche Verhalten bei Ubuntu auftritt. Ubuntu 14.04 ok, Ubuntu 15.10 gleiche Fehlermeldung wie oben beschrieben.
Kann das etwas mit dem Kernelwechsel zu tun haben? Linux version 3.13.0-24-generic bei Ubuntu 14.04 und Linux version 4.2.0-16-generic bei Ubuntu 15.10 (Knoppix 7.3 : Linux-Kernel 3.13.0 / Knoppix 7.6 : Kernel 4.2.2 ?????)

Mein Fazit zur Zeit:
Ich bleibe beim (wenn auch veralten) Koppix V7.3 (evnt V7.5 klappt mit probieren; oder sogar V7.0.5 ist halt ziemlich flott) und warte auf die Version 7.7 -- man soll die Hoffung ja nie aufgeben.

Gruss Klaus

klaus2008

Meister

Beiträge: 2 621

Geschlecht: Männlich

15

27.01.2016, 18:00

Hallo!

Inzwischen ist eine neue Knoppix-Version (7.6.1) erschienen mit einem aktuelleren NetzwerkManager. Vielleicht lohnt es sich, diese Knoppix-Version auszuprobieren.

Gruß
Klaus

16

03.02.2016, 12:55

Hallo

Mit dem neuen Knoppix V7.6.1 (Kernel 4.2.6) komme ich wieder über mein UMTS-Modem ins Internet
Vielen Dank ich hoffe ich komme jetzt wieder weiter

Gruss Klaus

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop