21.11.2017, 16:45 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

31

11.12.2016, 10:12

Zitat

==> "Keine Netzwerkverbindung". Un nu?
Auch nicht nach reboot?
Gruß Werner * Eigene Rescue-CD
remaster Grml * remaster Knoppix

32

11.12.2016, 11:07

Hallo zusammen,

hi Werner, reboot kann nicht helfen, da ich bei meinem Bootsystem immer vom ORIGINAL-iso-File boote.
Das wird aber sicher nicht verändert!

Klaus, die 2 Zeilen muß ich noch ausprobieren, muß aber jetzt hier weg,
tschau Jochen

33

11.12.2016, 16:10

Merkwürden???

Jetzt bin ich (mit der 771) im Netz. Aber auf eine etwas merkwürdige Art:

1. "sudo modprobe b43" ===> keine weitere Reaktion

2. "dmsg | tail -n 20" ===> bash: dmsg: Kommando dmsg nicht gefunden.

Probehalber gebe ich die beiden Kommando noch ein parmal ein - aber immer die selbe Reaktion.

Dann nochmal mit dem LMB auf die Funktionsleiste: Überraschung! Das System bietet mir an, mich mit verborgenen Netzen zu verbinden!

Ein Versuch: Meine WLAN-Bezeichnug + WPA2 + Passwort und ich bin drin... Nur wie denn das???
Ich bin definitiv sicher, ICH habe nichts auf unsichtbar gestellt!
Übrigens, mit LMB erscheinen jetzt auch die sonst auch sichtbaren Netze.

Jetzt bist Du dran: Klaus! Erklär mal!

Gruß Jochen

klaus2008

Meister

Beiträge: 2 656

Geschlecht: Männlich

34

11.12.2016, 16:33

Du hast einen Schreibfehler bei "dmsg". Es sollte "dmesg" heißen.

Zeige uns doch noch einmal die Ausgabe von "lsmod" und "hwinfo --wlan".

Vermutung meinserseits war: Es fehlte der Treiber für den Netzwerkadapter mit dem Broadcom-Chipsatz. Dafür gibt es verschiedene Möglichkeiten. Eine ist b43.

Gruß
Klaus

35

11.12.2016, 17:15

Toll...

"lsmod | sort" bringt viele Zeilen, u.a. "ssb 39212 2 b43, ssb_hcd"

Der ganze Output:
knoppix@Microknoppix:~$ lsmod | sort
acpi_ipmi 3556 0
apple_bl 2288 0
applesmc 8718 0
arc4 1600 2
b43 337194 0
bcma 29688 1 b43
bluetooth 230144 24 bnep,btbcm,btrtl,btusb,btintel
bnep 7235 2
btbcm 4791 1 btusb
btintel 5344 1 btusb
btrtl 3072 1 btusb
btusb 21589 0
ccm 6079 2
cfg80211 309678 3 wl,b43,mac80211
custom_method 1281 0
fjes 15800 0
hid_appleir 2140 0
hid_logitech_dj 7787 0
hid_logitech_hidpp 13869 0
i2c_i801 13472 0
input_leds 2254 0
input_polldev 2550 1 applesmc
ipmi_msghandler 23917 1 acpi_ipmi
ipv6 248249 17
irqbypass 1984 1 kvm
kvm 341287 1 kvm_intel
kvm_intel 156095 0
lpc_ich 12569 0
mac80211 401460 1 b43
Module Size Used by
pcmcia 24795 1 ssb
radeon 1058580 4
rng_core 4290 1 b43
sbs 5812 0
sbshc 2880 1 sbs
sky2 35711 0
snd_hda_codec 61229 3 snd_hda_codec_idt,snd_hda_codec_generic,snd_hda_intel
snd_hda_codec_generic 38791 1 snd_hda_codec_idt
snd_hda_codec_idt 35242 1
snd_hda_core 37193 4 snd_hda_codec_idt,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
snd_hda_intel 18215 1
ssb 39212 2 b43,ssb_hcd
ssb_hcd 1925 0
tpm 21995 2 tpm_tis,tpm_infineon
tpm_infineon 4689 0
tpm_tis 7553 0
ttm 51741 1 radeon
wl 6130917 0

"hwinfo --wlan" bringt

knoppix@Microknoppix:~$ hwinfo --wlan
19: PCI 300.0: 0282 WLAN controller
[Created at pci.366]
Unique ID: y9sn.oN6+3ILSmn0
Parent ID: qTvu.bQ30eTbcr+3
SysFS ID: /devices/pci0000:00/0000:00:1c.1/0000:03:00.0
SysFS BusID: 0000:03:00.0
Hardware Class: network
Model: "Apple AirPort Extreme"
Vendor: pci 0x14e4 "Broadcom"
Device: pci 0x4312 "BCM4311 802.11a/b/g"
SubVendor: pci 0x106b "Apple Inc."
SubDevice: pci 0x0089 "AirPort Extreme"
Revision: 0x01
Driver: "b43-pci-bridge"
Driver Modules: "ssb"
Device File: wlan0
Features: WLAN
Memory Range: 0x90100000-0x90103fff (rw,non-prefetchable)
IRQ: 17 (no events)
HW Address: 00:16:cb:02:44:0c
Link detected: yes
WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13
WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472
WLAN encryption modes: WEP40 WEP104 TKIP CCMP
WLAN authentication modes: open sharedkey wpa-psk wpa-eap
Module Alias: "pci:v000014E4d00004312sv0000106Bsd00000089bc02sc80i00"
Driver Info #0:
Driver Status: ssb is active
Driver Activation Cmd: "modprobe ssb"
Driver Info #1:
Driver Status: wl is active
Driver Activation Cmd: "modprobe wl"
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #6 (PCI bridge)


Jetzt aber nochmal "dmesg | tail -n 20" bringt:

knoppix@Microknoppix:~$ dmesg | tail -n 20
[ 92.567104] ssb: Sonics Silicon Backplane found on PCI device 0000:03:00.0
[ 92.642930] b43-phy0: Broadcom 4311 WLAN found (core revision 10)
[ 92.666716] b43-phy0: Found PHY: Analog 4, Type 2 (G), Revision 8
[ 92.666732] b43-phy0: Found Radio: Manuf 0x17F, ID 0x2050, Revision 2, Version 0
[ 92.666737] b43-phy0 warning: 5 GHz band is unsupported on this PHY
[ 92.677616] Broadcom 43xx driver loaded [ Features: PNLS ]
[ 92.713109] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[ 92.880089] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[ 93.173405] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[ 436.230032] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[ 752.186679] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[ 867.876682] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[ 869.224099] wlan0: authenticate with 84:9c:a6:b5:cd:5d
[ 869.253497] wlan0: send auth to 84:9c:a6:b5:cd:5d (try 1/3)
[ 869.256743] wlan0: authenticated
[ 869.259968] wlan0: associate with 84:9c:a6:b5:cd:5d (try 1/3)
[ 869.265253] wlan0: RX AssocResp from 84:9c:a6:b5:cd:5d (capab=0x1411 status=0 aid=2)
[ 869.265678] wlan0: associated
[ 869.315225] wlan0: Limiting TX power to 20 (20 - 0) dBm as advertised by 84:9c:a6:b5:cd:5d
[ 907.925619] aufs may_rename_srcdir:453:URL Classifier[3827]: renaming dir who has child(ren) on multiple branches, is not supported


Tja das ist etwas viel output! Interpretation?

Wenn ich das richtig sehe, war das nicht mein Fehler. Irgenwo im Startup fehlt der Treiber für den Broadcom-Chipsatz,
wie Du schon richtig vermutetest.

Tja, also vielen Dank für Eure Hilfe und Geduld!

Gruß Jochen

klaus2008

Meister

Beiträge: 2 656

Geschlecht: Männlich

36

11.12.2016, 18:32

Interpretation: MAC-Adresse 84:9c:a6:b5:cd:5d gehört zum Accesspoint. Es konnte erfolgreich eine Verbindung aufgebaut werden.

Zukünftig sollte es genügen, nach dem Booten von der DVD den Befehl "sudo modprobe b43" auszuführen, um den fehlenden Treiber für das WLAN zu laden. Falls nicht, nochmal melden.

Gruß
Klaus

37

11.12.2016, 21:04

So isset!

Hallo Klaus, hallo Werner,

besten Dank für Eure Hilfestellung! Mit "sudo modpobe b43" läßt sich erreichen, daß man zumindest nach einem verborgenen Netzwerk suchen kann.
Dann geht alles ganz schnell: WLAN Namen eingeben, Sicherheit auf WPA2 einstellen und Passwort eingeben, FERTIG!!!

Nun sind auch die restlichen WLANs aus der Umgebung sichtbar.

Hab' ich noch was vergessen?

Gruß an alle! Jochen

38

21.12.2016, 12:40

WLAn verbindet nicht in 7.7.1

Hallo zusammen,

bei mir werden in 7.7.1 zwar verfügbare WLAN's gelistet, aber ich kann mich nicht verbinden!

Will ich mein relevantes Netz aktivieren:
linke Maus auf Netzwerksysmbol rechts unten, im drop down Netzwerk auswählen mit linker Maus ergibt sofort die Fehlermeldung "Verbindung fehlgeschlagen. Hinzufügen/ Aktivieren der Verbindung schlug fehl. (0) Die aktive Verbindung konnte nicht mit dem Gerät verbunden werden"
Also keine Frage nach dem Passwort...

Also rechte Maus auf Netzwerksymbol, "Verbindungen bearbeiten", WLAN ausgewählt, auf Registerkarte "Sicherheit" und Netzwerkschlüssel eingetragen und das ganze mit ok beendet und Fenster geschlossen -> nichts tut sich...

Also wieder linke Maus auf mein Netzwerk, jetzt kommt die Fehlermeldung: "Verbindung fehlgeschlagen. Aktivieren der Verbindung fehlgeschlagen. (2) Die Aktive Verbindung wurde entfernt, bevor sie initialisiert wurde"

Interessant auch Folgendes:
Schalte ich die Funknetzwerkverbindung per Schalter manuell ab und wieder an, werden keine Netzwerke mehr gelistet

Jetzt noch meine Konfig:
- 2005er Samsung R50 (NP-R50CV06/SEG) Laptop mit Windows XP
- WLAN-Router von O2
- aktuell nutze ich Knoppix 7.6.1 per live USB mit Persistenz (hier geht mein WLAN)
- live USB mit Persistenz mit 7.7.1 bringt das obige Problem (wird deshalb nicht genutzt)

Bitte, habt ihr hier Ideen?

Vielen Dank schon!

Schöne Grüße,

Lars

P.S.: ich hätte gerne Screenshots gemacht, aber in 7.7.1 gibt es den KSnap nicht mehr??

39

22.12.2016, 11:49

Zitat

Bitte, habt ihr hier Ideen?
Ja, erstmal die Fragen im posting #19 in diesem thread beantworten.

Was spricht gegen gnome-screenshot in Knoppix?
Gruß Werner * Eigene Rescue-CD
remaster Grml * remaster Knoppix

40

23.12.2016, 13:21

Hallo Werner,

habe die Konsole im 7.6.1 und im 7.7.1 bemüht, Ergebnis siehe Anhang. Wie gesagt, im 7.7.1 bekomme ich keine Funknetzwerkverbindung.

Screenshot: nutze Knoppix erst seit ca. 3 Monaten und bin noch dabei, Funktionen zu entdecken.... Im 7.6.1 gibt es den Menüeintrag Grafik/KSnapshot, den habe ich bisher immer genutzt. Im 7.7.1 fehlt der Menüeintrag, das gab eine kurze Panik... aber mittlerweile bin auch ich klüger :-)

Dankeschön!

Schöne Grüße,

Lars
»Lars B« hat folgende Dateien angehängt:
  • 7-6-1.txt (3,42 kB - 2 mal heruntergeladen - zuletzt: 24.12.2016, 10:57)
  • 7-7-1.txt (3 kB - 2 mal heruntergeladen - zuletzt: 24.12.2016, 10:58)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Lars B« (23.12.2016, 18:46)


klaus2008

Meister

Beiträge: 2 656

Geschlecht: Männlich

41

24.12.2016, 11:02

Hallo!

Wie sieht

Quellcode

1
dmesg | tail -n 30
nach dem erfolglosen Verbindungsversuch aus?

Gruß
Klaus

42

24.12.2016, 13:19

Hallo Klaus,

hoffe, meine kleine Versuchsreihe enthält alle notwendigen Infos (siehe Anhänge).

Schöne Weihnachten noch!

Schöne Grüße,

Lars
»Lars B« hat folgende Dateien angehängt:
  • 7-7-1_Teil-2.txt (11,06 kB - 5 mal heruntergeladen - zuletzt: 26.12.2016, 11:55)
  • 1.png (17,62 kB - 3 mal heruntergeladen - zuletzt: 26.12.2016, 12:00)
  • 2.png (18,63 kB - 2 mal heruntergeladen - zuletzt: 24.12.2016, 14:35)
  • 3.png (17,6 kB - 2 mal heruntergeladen - zuletzt: 24.12.2016, 14:35)

klaus2008

Meister

Beiträge: 2 656

Geschlecht: Männlich

43

24.12.2016, 14:52

Hallo!

Die interessanten Zeilen sind meiner Meinung nach folgende:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
[   37.643175] eth0: Setting MAC to 76:8a:3e:59:f0:69
[  264.513658] eth0: Setting MAC to 00:13:ce:6a:61:c5
[  264.687677] eth0: Setting MAC to ba:a2:2e:eb:1c:44
[  264.854621] eth0: Setting MAC to ba:a2:2e:eb:1c:44
[  310.728004] eth0: Setting MAC to 00:13:ce:6a:61:c5
[  310.864743] eth0: Setting MAC to 92:51:bd:56:85:16
[  311.003767] eth0: Setting MAC to 92:51:bd:56:85:16
[  652.016694] eth0: Setting MAC to 9e:40:9e:31:f2:dd
[  652.161206] eth0: Setting MAC to 9e:40:9e:31:f2:dd
[  909.037320] eth0: Setting MAC to 00:13:ce:6a:61:c5
[  909.190390] eth0: Setting MAC to 8e:7d:de:f5:15:c3
[  909.333625] eth0: Setting MAC to 8e:7d:de:f5:15:c3
[ 1251.014115] eth0: Setting MAC to a2:8d:7f:2c:5b:99
[ 1251.155578] eth0: Setting MAC to a2:8d:7f:2c:5b:99
[ 1287.453164] eth0: Setting MAC to 00:13:ce:6a:61:c5
[ 1287.622578] eth0: Setting MAC to 4a:21:33:2b:89:3c
[ 1287.822748] eth0: Setting MAC to 4a:21:33:2b:89:3c
[ 1345.805535] eth0: Setting MAC to 00:13:ce:6a:61:c5
[ 1345.957692] eth0: Setting MAC to fe:47:b3:d3:ba:ee
[ 1346.099914] eth0: Setting MAC to fe:47:b3:d3:ba:ee
Das Problem muss weiter eingegrenzt werden. Dafür müsste man jetzt eine Idee haben. (Vielleicht nach Weihnachten...)

Gruß
Klaus

44

27.12.2016, 09:02

Mich irritiert, daß bei "hwinfo -- network" vollig verschiedene MAC-Adressen gefunden werden und beim Test mit Knoppix 7.7.1 kein Ethernet Controller gelistet wird. Handelt es sich um zwei verschiedene Computer?
Gruß Werner * Eigene Rescue-CD
remaster Grml * remaster Knoppix

45

27.12.2016, 20:21

Nein, immer der selbe Laptop, gleiches Funknetzwerk, gleicher Router...
Auch sind beide Knoppix-Versionen auf USB mit Persistenz und Passwort installiert.
Lediglich die USB-Sticks sind von unterschiedlichen Herstellern und die Knoppix-Versionen sind natürlich unterschiedlich.

Zum Erzeugen vom 7.6.1 habe ich Knoppix 7.4.2 auf live-CD genutzt. Beim 7.7.1 bin ich mir nicht mehr sicher, ob ich es vom 7.4.2 oder vom 7.6.1 aus erzeugt habe.

Schöne Grüße,

Lars

46

27.12.2016, 22:57

Zitat

Zum Erzeugen vom 7.6.1 habe ich Knoppix 7.4.2 auf live-CD genutzt.
Versteh ich nicht; wie bist Du da vorgegangen?
Gruß Werner * Eigene Rescue-CD
remaster Grml * remaster Knoppix

47

28.12.2016, 11:25

na ja, mein erstes Knoppix war 7.4.2 - ich habe die ISO eben auf DVD entpacken lassen.
Mit dem LiLi (Linux Live USB Creator) hab' ich dann den ersten USB-Stick bespielt - aber auch noch ohne Persistenz, da LiLi hier nicht kooperativ war.
Also zurück zur Knoppix Homepage - hier gibt's den Hinweis: "flash-knoppix KNOPPIX_V7.7.1DVD-2016-10-22-DE.iso"
Also im 7.4.2 (vermutlich schon von USB laufend - hier war ich oben ungenau) die ISO's für 7.6.1 bzw. für 7.7.1 abgelegt, in der Konsole in das entsprechende Verzeichnis gewechselt, obigen Befehl angewendet und mich durch das Menü führen lassen - so hab' ich dann die zwei USB-Sticks bespielt (für 7.6.1 war der Befehl natürlich entsprechend angepasst).

Schöne Grüße,
Lars

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Lars B« (28.12.2016, 11:31)


Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop