15.10.2021, 21:52 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

1

26.09.2021, 23:54

Fehler bei der Installation vom Package code-insiders

Moin!
Ich habe einen Fehler (wie schon oben genannt) bei der Installation vom Package code-insiders

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
[~]$knoppix@Microknoppix>sudo apt-get -f install code-insiders Paketlisten werden gelesen… Fertig

Abhängigkeitsbaum wird aufgebaut.        
Statusinformationen werden eingelesen.… Fertig

Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass

Sie eine unmögliche Situation angefordert haben oder, wenn Sie die

Unstable-Distribution verwenden, dass einige erforderliche Pakete noch

nicht erstellt wurden oder Incoming noch nicht verlassen haben.

Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:



Die folgenden Pakete haben unerfüllte Abhängigkeiten:

 apt : Kollidiert mit: apt:amd64 aber 2.2.4 soll installiert werden

 apt:amd64 : Hängt ab von: libsystemd0:amd64

             Kollidiert mit: apt aber 2.1.18 soll installiert werden

 libapt-pkg6.0:amd64 : Hängt ab von: libsystemd0:amd64 (>= 221)

 libdbus-1-3:amd64 : Hängt ab von: libsystemd0:amd64

 libgbm1 : Beschädigt: libgbm1:amd64 (!= 20.3.4-1) aber 20.3.5-1 soll installiert werden

 libgbm1:amd64 : Beschädigt: libgbm1 (!= 20.3.5-1) aber 20.3.4-1 soll installiert werden

E: Fehler: Unterbrechungen durch pkgProblemResolver::Resolve hervorgerufen; dies könnte 
durch zurückgehaltene Pakete verursacht worden sein.


Beiträge: 1 105

Geschlecht: Männlich

2

27.09.2021, 00:22

Hallo.
Bist Du § wie Benutzer oder # wie Administrator?
Sudo brauchst wenn Du Benutzer bist $
wenn Du Administrator bist mit su =# brauchst eigentlich kein sudo.
sudo apt-get -f install
Ich glaube -f ist vor install falsch.
Befehl Install Option wenn -f eine Option ist
sudo apt-get install Option Programm

Beiträge: 1 105

Geschlecht: Männlich

3

27.09.2021, 00:50

oder Incoming noch nicht verlassen haben

Das kann bedeuten das die Synaptic-Paketverwaltung gerade läuft b.z.w. eingeschaltet ist.

4

27.09.2021, 18:59

das -f mal in jedem Falle weg lassen.
vorher mal ein apt update laufen lassen und sehen, was danach passiert.

Die Fehlermeldungen sagen in etwa, dass einige Pakete erneuert werden müssten, um das -f zu befriedigen. Dabei werden aber 64-Bit Pakete angezeigt und das ist sehr merkwürdig, weil Knoppix 32Bit ist und aus 32Bit Repos seine Pakete bezieht.
Ehrlich gesagt kann ich mir daher gar nicht erklären, wie es zu solchen Fehlermeldungen überhaupt kommt.

Du hast auch nicht erklärt, welches Knoppix du benutzt und auf welche Art und Weise. Das macht die Beurteilung im Detail natürlich mehr als unsicher.
Immer kann es sein, dass auch für das gerade aktuelle Knoppix keine Pakete mehr verfügbar sind, bzw die aktuell verfügbaren Pakete bereits für eine neuere Version als das in Knoppix verwendete Debian zur Verfügung stehen. Deshalb kann solch eine Installation also immer mal fehl gehen.
Doch in deinem Fall deuten die Fehler in eine andere Richtung und die ist merkwürdig für ein Knoppix.

EDIT:
in meiner VM, wo ein Knoppix 9.1 läuft, hat ein apt update eine ganze Reihe neuer Pakete eingelesen und es trat auch der Fall auf, dass die eben nicht mehr zur Version des Debian im Knoppix passen.
Ein anschließender apt search code-insider zeigt kein Ergebnis.
Daraus folgere ich auf die Schnelle, dass dieses Paket in den Repositries zu Knoppix (Debian 32Bit) gar nicht vorhanden ist und wundere mich umso mehr, wieso es bei dir gefunden wird, nur eben 64 Bit.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »pit234a« (27.09.2021, 19:50)


Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop