29.09.2022, 17:44 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

1

06.09.2022, 15:52

WLAN wird nicht angezeigt

Wertes Forum,
als Lehrer einer Schule versuche ich gerade, einen Satz von 20 alten Fujitsu Lifebook A555 mit i3 an Bord mit Knoppix 9.1 ans Laufen zu bekommen. Warum knoppix? Weil ich es am besten kenne und die Varianten mit Stick und vom Stick auf die Festplatte installieren mir bei solchen Mammutaufgaben das Leben leichter machen würde. Und, ist eine Installation von Schüler*Innen geschreddert worden, wäre sie in fünf Minuten wieder heile.

Ich versuche gerade eine aktuelle Version mit diversen Einstellungen zu erzeugen, die dann auf alle 20 Rechner aufgespielt werden kann, so dass damit Schüler*innen diese ausgeliehen bekommen können, um zu Hause damit arbeiten zu können.
Leider wird mir bei den Geräten kein WLAN angezeigt. Dieses ist im BIOS aktiviert, auch das WLAN-Lämpchen zeigt an, dass es eingeschaltet ist, aber Knoppix zeigt unten rechts keine aktiven Netze an, geschweige denn überhaupt eine WLAN-Option.
Als Linux-Laie habe ich folgende Befehle im Netz gefunden und angewendet:
lspci | grep -i wireless Ergebnis: 02:00.0 Network controller: Intel Corporation Wireless 7265 (rev 61)
iwconfig wlan Ergebnis: No such device
iwconfig lo no wireless extensions.
eth0 no wireless extensions.
Mehr Ahnung von Linux habe ich leider nicht. Vielleicht kann mir einer von Euch helfen und sagen, wie ich das Problem weiter einengen kann und was ich alles tun könnte, um das WLAN zu Laufen zu bringen? Ich hoffe, dass es nur ein fehlender oder falsch eingestellter Treiber ist, der sich auch von mir fixen lassen kann. Sonst müsste ich mir tatsächlich Alternativen überlegen, was ich ungerne tun würde. Solltet Ihr noch weitere Infos brauchen, sagt mir bitte, welche Befehle ich ausführen soll, damit ich die Listings hier einstellen kann.

Vielen Dank für Euer Lesen
Skipper

2

06.09.2022, 22:00

Intel Corporation Wireless 7265


sollte eigentlich funktionieren, nicht wegen Knoppix ist ja so geil, sondern wegen Knoppix hat Linux > 5 an Bord und so ab 4.2 sollte diese Karte unterstützt werden, lese ich jedenfalls im Internet.

Deshalb konzentriere ich mich mal zunächst auf die typischen Fehler, die nichts mit Unterstützung vorhandener HW zu tun haben: kleine Schalter oder Tastenkombinationen, die Wlan (+BT & alles) abschalten können. Diese Schalter können auch als SW-Tasten unter der Tastatur liegen und gemeiner Weise mal aus einem anderen Betriebssystem aktiviert worden sein (Flugzeug-Modus). Das neue System unterstützt womöglich nicht die Tastenkombination, um das zurück zu schalten.
Keine Ahnung, wie man da heraus kommt.
Sollte eigentlich im BIOS gehen, aber wer weiß?
Trotzdem: erst nochmal schauen, ob nicht irgendwelche HW-Schalter vorhanden sind.
Dann mal eine aktuelle Ubuntu Live booten und sehen, wie es da ist. Das gibt zumindest mehr Information.

Wenn du das gelöst hast und bevor du versuchst, Knoppix zu installieren, sollten wir vielleicht nochmal reden, aber das ist ein anderes Thema.

3

06.09.2022, 22:58

WLan = Funknetzwerk

Bei mir - mit Knoppix 8.6.1 etal - firmiert WLan unter "Funknetzwerke".
Unter "Verfügbar" sehe ich einige Netzwerke, die sich aber ständig ändern, keine Ahnung nach welchem Algorithmus.
Mein eigenes wird oft - wenn nicht sogar meist - dort nicht angezeigt. Ich muss es dann unter "Mit einem verborgenen Funknetzwerk verbinden ..." aus wählen und verbinden. Meist klappt es nicht im ersten Versuch aber schließlich doch.
Beim ersten mal muste ich den Netzwerknamen (Id / Kennung) - so weit ich mich erinnere - von Hand eintragen und natürlich auch das Password.
Wenn Du also deinen Netzwerknamen kennst versuche es mal so ( einschließlich des PW)

Gruss und viel Glück

4

07.09.2022, 23:41

Flugmodus ist es wohl nicht

Hallo,
@Pit: danke für die Info von Dir. Den Flugmodus hatte ich auch schon auf meiner Liste. Allerdings funktioniert das an und abschalten mit Tastenkombi scheinbar gut. Die entsprechende Kontrolllampe geht an und zeigt damit, dass die Funknetze eingeschaltet sein sollten. Auch im Bios ist es zugeschaltet. Ich gehe also davon aus, dass dieses nicht der Grund ist. Auf Dein Angebot bezüglich Nachfrage wegen Schulcomputern komme ich gerne zurück. Bin gespannt, was Du noch für Tipps hast.
@KeyGKey: Das hatte ich auch schon gedacht. Hatte nur gehofft, dass ich die automatische Einwahl irgendwie aktivieren kann, damit die Schüler*innen sich damit dann auch selber in ihr häusliches Netz einwählen können. Alles andere wäre für Anfänger zu kompliziert, denke ich. Aber ich werde Deinen Ansatz beim nächst möglichen Zeitpunkt ausprobieren. (Muss nur schauen, wie ich an alle die abgefragten Daten kommen soll)

Ich melde mich, wenn ich in der Schule war, um es auszuprobieren.
Vielen Dank schon einmal
Skipper

5

08.09.2022, 07:32

Hatte nur gehofft, dass ich die automatische Einwahl irgendwie aktivieren kann


man muss ja immer erst mal die passende Passphrase eingeben, damit man in ein Netz einloggen kann. (ungesicherte Netze sollten wir ganz vergessen).
Das kann also jedenfalls nicht automatisch erfolgen.
Hat man aber erst mal die Prozedur durchlaufen, "merkt sich das Knoppix" und macht es dann in Zukunft automatisch. Wenn man eine Overlay hat.

6

09.09.2022, 18:59

Kurze Empfehlung wegen "Installation"

Wenn du das gelöst hast und bevor du versuchst, Knoppix zu installieren, sollten wir vielleicht nochmal reden, aber das ist ein anderes Thema.


Seit langem schon möchte ich nicht mehr in dieses Forum sehen und dann stolpere ich immer wieder über Beiträge, wo ich denke, etwas sagen zu müssen.
So auch dabei.
Deshalb will ich die wenigen Sachen einfach benennen, auch, wenn das hier nicht hin gehört.
Und vorab: das ist teilweise meine eigene Meinung, es gibt auch andere.

Unzweifelhaft bleibt aber, dass Knoppix ein Live-System ist und deshalb so ähnlich zu betrachten ist, wie ein Embedded-System. Es hat den Charakter des Unveränderlichen. Alle Änderungen am System finden in der Overlay statt, sonst nirgendwo.

Am allereinfachsten "installierst" du das laufende, aktuelle Knoppix mittels Flash-install auf dem internen Datenträger und wählst dazu eine zusätzliche Overlay-Datei in maximaler Größe.
Anschließend veränderst du das Knoppix, wie es dir passt.

Änderungen syslnx64.cfg, syslnx32.cfg und syslinux.cfg je nach System und wie gewünscht durchführen. Beispiele, die ich je nachdem für sinnvoll halte, sind

Quellcode

1
no3d nozram noswap nostartsound tz=Europe/Berlin

von hinten, weiß ich grad gar nicht, ob das noch wirkt. Die tz sollte die System-Uhr entkoppeln, was aber in deinem Fall gar nicht wichtig ist, wenn Knoppix das einzige System auf dem PC ist. Probleme gibt es nur in der Deutung der Systemuhr zur Zeitzone zwischen installierten Systemen und dem Knoppix in Live.
nostartsound ist sicher in einer Schulklasse wünschenswert, aber auch mir persönlich lieb. Ich will ja nicht damit auffallen, dass ich ein Knoppix gestartet habe.
noswap ist auch eher eine Sache, auf einem Live-System und ich stelle die hier nur ein, weil du dir natürlich auf einem "fest" installierten System auch eine SWAP anlegen und mit Knoppix nutzen kannst.
nozram ist meine eigene Überzeugung und hat auch was mit SWAP und RAM zu tun, führt hier zu weit, ich mag es halt nicht.
no3d ist vielleicht wichtig. Also ich mag das auch nicht, aber 3D schluckt sehr viele Ressourcen und es sollte deshalb vielleicht gleich ausgeschaltet werden.
Das sollen aber nur Beispiele sein und der Hinweis, welche Dateien du bearbeiten und dann auf alle Systeme übertragen kannst.

Ansonsten sind alle Änderungen in der Overlay und wenn du die Datei gewählt hattest, brauchst du diese nur zu kopieren und von Rechner zu Rechner wieder einzusetzen und schon hast du lauter "Klone" deiner Einstellungen und Settings.

Beiträge: 1 414

Geschlecht: Männlich

7

10.09.2022, 14:19

Hallo.
Geh mal auf Knoppix/Netzwerk suchen/mounten siehst Du dann den Router? Den kannst Du dann Benutzen.
Dieses ist im BIOS aktiviert,
Das reicht nicht aus Du brauchst bestimmt einen W-LAN Router

8

11.09.2022, 22:03

Unter "Verfügbar" sehe ich einige Netzwerke, die sich aber ständig ändern, keine Ahnung nach welchem Algorithmus.
Mein eigenes wird oft - wenn nicht sogar meist - dort nicht angezeigt.


Da kommt nun von mir eine Breitseite, die nicht wirklich begründet ist.
Ich glaube, dass die Schöpfer der WLan-Technologie nicht damit gerechnet hatten, dass einem einzigen Nutzer mehr als als ein Dutzend verschiedene AccessPoints (AP) zur Verfügung stehen könnten.
Vermutlich sind deshalb die Anzeigen der erkannten APs ein wenig wackelig geraten.
Meist werden die n stärksten AP angezeigt. Die Anzeige wird dann etwa einmal je Sekunde erneuert (das ist nun alles erfunden und nur meine Erklärung, ohne jede Evidenz).
Angenommen, es geht gerade dann, wenn neu gescannt wird, jemand vor dem AP vorbei und schwächt das Signal oder ein Bus fährt vorbei oder ich wackele gerade ein wenig mit dem Laptop oder vielleicht ist es eben nur Glück, weshalb ein AP gerade noch angezeigt wird und andere nicht.

Dass dein eigener AP dort eher nicht gelistet ist, obwohl der doch näher sein und deshalb auch ein starkes Signal zur Verfügung stellen sollte, ist merkwürdig, aber zunächst noch nicht absonderlich.
Dass du dann aber Probleme hast, überhaupt mit deinem Netzwerk zu verbinden und zwar sporadisch? ist wieder ein anderes Ding.

Mir ist derzeit nicht klar, wie dein Knoppix läuft?
-von welchem Medium
-wie installiert
-hast du Overlay

-wann geht nicht mit deinem WLan
-wie ist es mit LAN


Grundsätzlich müssen sich da zwei Seiten finden.
Die eine Seite ist der AP, die andere dein PC. Der AP bietet einen Dienst an, dein PC muss entsprechend konfiguriert sein.
zB gibt es AP, die auf einen bestimmten Ländercode eingestellt sind. US oder China, geht meist nicht mit DE auf dem Laptop.
Meine Firma (und auch ich in meinem privaten Netz) hat Restriktionen vergeben und lässt nur bestimmte MAC-Adressen zu, also zB nur meinen Firmen-Laptop. Aber damit nicht genug, das Betriebssystem verlangt einen bestimmten Verbindungsvorgang und wenn der nicht erfüllt wird, werde ich wieder rausgeschmissen. Es gibt also keine Möglichkeit, mich mit meinem privaten (nicht registriertem) PC, überhaupt zu verbinden.

Aus dem bisherigen Text erschließen sich zu wenig Informationen, um in diesem komplexen Umfeld wirklich etwas sagen zu können.
Oder ich erkenne sie nicht oder habe sie überlesen oder schon wieder vergessen.

9

12.09.2022, 15:32

WLAN gerade nicht verfügbar

Hallo, liebe Forumsherfer*innen,
leider war die letzte Woche unser WLAN down, so dass ich in der Schule nicht experimentieren konnte. Jetzt geht es, zumindest zeitweise, wieder. (Schule ist schon toll...)
@ ubuntuli: Habe Deinen Weg beschritten und folgendes unter SMB Netzlaufwerke angezeigt bekommen:
n Server+Share mauell eingeben (/server/share)
Mehr kann ich da leider nicht rauslesen. Da gibt es dann nur Abbrechen und OK. Bei OK werden dann Login und PW für Share abgefragt.

@ pit: Danke für die umfangreichen Infos (von denen ich mal wieder nicht alle ganz verstehe, weil ich zu wenig dauerhaft mit Linux zu tun habe). Ich werde damit experimentieren und mein eigenes Live System erstellen. Aber da waren schon ein paar Tipps bei, die mir bestimmt helfen werden (no3d, z.B.)

Eine Sache kann noch der Grund für meine Probleme sein (ist mir selber aber quasi heute erst siedend heiß wieder eingefallen, sorry...): Ich habe am Anfang das System als minimal auf den Stick überspielt, um wenig unnötigen Ballast an die Schüler*innen weiterzugeben (eventuelle Spiele, zehntausende Netzwerkeinstellungen, etc.). Vielleicht ist dabei der "Luxus" der einfachen WLAN Anmeldung verloren gegangen? Wenn ja, wäre das ungünstig, da ich sonst einen weiten Weg noch einmal gehen müsste, um alles wieder bis herhin aufzubauen...
Ich werde es in den nächsten Tagen noch einmal mit einem vollständigen Knoppix versuchen und dann berichten, was sich ergeben hat. Vielleicht kann man dann etwas darüber sagen, wie es wieder zu fixen ist.
Ich danke Euch aber für Eure Unterstützung bis hierhin. Ich lerne immer sehr viel dabei.
Gruß
Skipper

10

12.09.2022, 17:31

Geh mal auf Knoppix/Netzwerk suchen/mounten

@Ubuntuli
Bei mit gibt es nur ein "Knoppix/Netzlaufwerk suchen/mounten "
Dazu sollte man aber schon mit einem Netzwerk verbunden sein.
Netzwerkverbindungen kann ich über "Unten rechts" die kleinen Säulen oder über "Systemwerkzeuge/Netzwerkdiagnosen/Netzwerkgeräte einrichten" bearbeiten.
Aber ich glaube es ist nicht Skippers Problem dorthin zu gelangen.

@Skipper
Gibt es denn einen Lan-Anschuß und funktionier der?

11

12.09.2022, 17:51

1) Dass dein eigener AP dort eher nicht gelistet ist, obwohl der doch näher sein und deshalb auch ein starkes Signal zur Verfügung stellen sollte, ist merkwürdig, aber zunächst noch nicht absonderlich.
Dass du dann aber Probleme hast, überhaupt mit deinem Netzwerk zu verbinden und zwar sporadisch? ist wieder ein anderes Ding.

2) Mir ist derzeit nicht klar, wie dein Knoppix läuft?
-von welchem Medium
-wie installiert
-hast du Overlay

3) -wann geht nicht mit deinem WLan
-wie ist es mit LAN

4) Meine Firma (und auch ich in meinem privaten Netz) hat Restriktionen vergeben und lässt nur bestimmte MAC-Adressen zu,


1) Mein eigener AP ist "natürlcih" das stärkst Signal und ist ein TP-Link LTE-Modem

2) Ich verwende meist Knoppix 8.6.1 als USB-Flash-"Instllation" mit einem Overlay

3) Lan ist problemlos habe ich aber meist nicht zur Verfügung. Das WLan selbst läuft eigendlich ganz gut wenn ich verbunden bin. Nur das Verbinden hackelt etwas - woran ich mich aber fast schon gewöhnt habe.


4) Das würde ich auch gerne machen. Geht aber mit dem TP-Link nicht. Wenn ich es richtig verstanden habe könnte ich IP-Adressen ausschließen - was natürlich Quatsch ist.
Ich hatte mal eine Netgear LTE-Modem zur Verfügung das ging das mit der MAC-Addresse und war dann auch eingerichtet

12

12.09.2022, 20:12

Netzwerkverbindungen kann ich über "Unten rechts" die kleinen Säulen oder über "Systemwerkzeuge/Netzwerkdiagnosen/Netzwerkgeräte einrichten" bearbeiten.
Aber ich glaube es ist nicht Skippers Problem dorthin zu gelangen.

ubuntuli hatte da irgendwas anderes im Kopf. Wie du es sagst, sollte es funktionieren und auch in 9.1 ist es noch so.
Eine Sache kann noch der Grund für meine Probleme sein (ist mir selber aber quasi heute erst siedend heiß wieder eingefallen, sorry...): Ich habe am Anfang das System als minimal auf den Stick überspielt, um wenig unnötigen Ballast an die Schüler*innen weiterzugeben (eventuelle Spiele, zehntausende Netzwerkeinstellungen, etc.). Vielleicht ist dabei der "Luxus" der einfachen WLAN Anmeldung verloren gegangen? Wenn ja, wäre das ungünstig, da ich sonst einen weiten Weg noch einmal gehen müsste, um alles wieder bis herhin aufzubauen...

Minimalversion bei 861 kenne ich jetzt nicht. Afaik wurde das erst wieder mit 9.1 möglich, weil die Teile von Knoppix hier entsprechend aufgeteilt wurden. Zuvor konnte nur die Overlay weggelassen werden, meine ich. Ein Versuch mit 9.1 lohnt sich in jedem Fall, obwohl es ja demnächst auch schon wieder eine neue Version geben könnte.
Innerhalb einer Version landen so gut wie alle Änderungen in der Overlay.
Das bedeutet, man braucht nur die Overlay weg zu lassen und schon hat man den Auslieferungszustand. Hatte man bereits ein Remaster durchgeführt, wurde eine ältere Overlay zu einem KNOPPIX(n) und müsste dann ebenfalls weg gelassen werden.
Oder anders rum: wenn ich einem jungfräulichen System diese zusätzlichen Teile von Knoppix und die Overlay hinzugebe, habe ich alle Änderungen aufgespielt. Das macht also keine Arbeit.

Was mich wundert: dass du überhaupt bei jeder Verbindung nach dem Funknetz suchen musst. Deshalb fragte ich auch mal nach der Overlay. Knoppix merkt sich (naja, der Netzwerkmanager, der dort verwendet wird merkt sich das) mit welchen Netzwerken du schon verbunden warst und geht die der Reihe nach durch. Dabei müsste er dann eigentlich auch ein nicht auf der Oberfläche angezeigtes Netzwerk finden und einbinden und zwar innerhalb weniger Sekunden.
Es ist nun schwierig, Fehler zu lokalisieren. Mein Wissen reicht dazu nicht wirklich aus, schon gar nicht mit einem GNU/Linux als Unterbau.
Deshalb bleibt eigentlich nur der Rat für kleine Leute: Einzelteile tauschen und sehen, ob der Fehler mit wandert.
Was ich mir vorstellen könnte, ist eine Unverträglichkeit einzelner Kanäle oder auch Bänder. Es gibt manchmal eher Probleme im 5GHz Band, als bei 2,4GHz und manche Kanäle werden default belegt, also von vielen Anbietern benutzt. Da kann es schon mal helfen, am AccessPoint etwas fest einzustellen und einfach zu probieren, ob das was ändert.
Der nächste Tausch wäre dann HW, aber das wollen wir ja nicht. Hiermit meine ich, unterschiedliche WLan-Karten im PC zu probieren, oder eben auch mal andere PCs zu testen, wie die sich mit dem gleichen Knoppix verhalten. Das könnte eine einfache Möglichkeit sein, eine Fehlfunktion der SW nachzuweisen oder aus zu schließen.
Bleibt also der Tausch der SW. Hier bietet sich an, auf dem gleichen PC ein anderes System (Linux) zu booten und zu sehen, wie dieses sich verhält. Relativ einfach dürfte dazu ein anderes Knoppix genommen werden können, etwa ein 9.1, aber auch irgendein Ubuntu oder was weiß ich, kann zum Testen herhalten. Wichtig ist hierbei vor Allem, die Version des Linux, also des Kernels zu beachten. Funktioniert es grundsätzlich mit höheren Versionen besser, kann es gut sein, dass Knoppix einfach noch nicht so weit ist.

Dass wir nicht mit einem Blick in die Glaskugel sehen können, woran es fehlt, hast du ganz sicher eh nicht geglaubt. Dass dir hier nun niemand eine schnelle Lösung bietet, mag dich enttäuschen. Wir sind ja alle unbedarfte Endanwender und können nur vergleichen, wie Knoppix es bei uns macht und sehen, ob es bei dir was anders macht. Alleine schon deshalb wäre ein Wechsel auf 9.1 zu überlegen. Es ist halt aktuell. Ich kann persönlich gut verstehen, dass man bei einer Version hängen bleiben möchte. Auch in meinen Knoppix-Sticks steckt jedes Mal eine Menge Arbeit, um sie für mich anzupassen. Das will ich nicht bei jedem neuen Knoppix immer wieder machen. Aber ich selbst habe kein 861 mehr im Gebrauch und kann deshalb nicht nachsehen, wie da etwas vielleicht funktionierte.

13

12.09.2022, 21:40

kleiner Nachsatz

das tut nicht wirklich was zur Sache, aber soeben hatte ich einen Hänger eines APs. Nicht wie bei dir, eine Netzwerkadresse erhielt ich und alles sah gut aus, aber die Verbindung vom AP zum LAN funktionierte nicht.
Ein Reset des AP hatte dann geholfen.
OK, das ist etwa so, wie 1992 hatte ich mal den Fall, dass eine Putzfrau den Stecker des Computers gezogen hatte und anschließend bootete der nicht mehr, also kontrolliert zuvor alle mal eure Stecker. Ganz falsch ist das nie, aber man geht ja davon aus, dass das eh jeder immer macht.
Du hattest sicher schon mehrfach deinen AP neu gestartet.
Nur eben nochmal zusätzlich, wegen tauschen und co: wenn du andere AP zur Verfügung hast, sprich, "andere WLans", könnte das auch helfen, das Verhalten hier zu beobachten. Läuft es immer gleich, schließt das ziemlich sicher einen Fehler auf deinem eigentlichen AP aus.

14

12.09.2022, 22:11

Verfügbare Verbindungen

Das etwas unvorhersehbare Verhalten bei mir könnte aus einem Zusammenspiel verschiedener Einstellungen liegen.

Standard mäßig ist bei Knoppix wohl automatisch Verbinden eingestellt wenn man sich einmal mit einem Netzwerk verbunden hat.
Da ich das in der Regel nicht möchte habe ich das ausgeschaltet (unter Netzwerkdiagnose). Da hier in meiner Umgebung wohl einige Netzwerk aktiv sind rotieren diese unter den Verfügbaren. Dort hätte ich natürlich "mein" Netzwerk gerne immer sichtbar. Ob man das irgendwie einstellen kann weiß ich nicht. Zudem scheint mein AP in einen Art Schlafmodus zu gehen wenn niemand damit verbunden ist. Ich muss ihn dann per Knopfdruck wecken. Ob ich da was am AP ein stellen kann weiß ich nicht. Da ich mir über die Verborgenen Netzwerk behelfen kann ist für mich das kein wirklich großes Problem sonder nur etwas umständlich. Das war jetzt unter V8.6.1; wie das unter 9.1 aussieht werde ich mir noch mal anschauen.

15

12.09.2022, 22:38

Vorab entschuldige ich mich schon mal, denn ich bin gerade dabei Beiträge durcheinander zu werfen.
Es ist nämlich so, dass ich selbst mental beschränkt bin und auch an vielen Sachen mehr oder weniger gleichzeitig arbeite und dann fällt mir manchmal im Verlauf eines Threads gar nicht auf, dass sich die Fragestellung und/oder der Fragesteller geändert haben.
Das scheint auch diesmal der Fall zu sein.
Dafür Entschuldigung.

@KeyGKey
Hat dein Rechner keinen Knopf/Schalter/Tastenkombination, womit du WLan abschalten kannst?
Das wäre einfacher.
Ansonsten verbindet sich "Knoppix" ja nicht automatisch und ungefragt mit jedem Netzwerk. Gehen wir mal davon aus, dass inzwischen keine ungesicherten Netzwerke mehr existieren, dann brauchst du ja immer eine Berechtigung. Wenn du die einmal akzeptiert hast, kann sie doch weiter gelten?
Aber das ist natürlich die Sache eines jeden Anwenders und seine eigene Entscheidung.
Manchmal gibt es aber auch technisch unbegründete Hysterie und darüber sollte man dann auch reden können.
Viele Leute vertrauen alles ihrem Handy an und loggen sich auch in das nicht gesicherte WLan ihres Arztes ein und surfen fleißig, teilen alle Daten mit Facebook und Co. Sobald sie ihren PC benutzen, geraten sie in Panik und fürchten sich, nutzen dann Knoppix und Co und womöglich noch sicherer, als das ohnehin schon ist. Das ist auch gut so und vollkommen OK, entbehrt aber womöglich dann doch der letzten Konsequenz.
Was aber wieder ein Thema für einen neuen Thread wäre und hier nur mal gestreift werden soll.

16

13.09.2022, 01:39

RE: WLAN wird nicht angezeigt

iwconfig wlan Ergebnis: No such device

Bei mir ergibt der Befehl "iwconfig wlan" die gleich Nachricht.
Das WLan läuft bei mir auch nicht auf dem Gerät "wlan" sonder auf "wlan0".

Einsehen und einstellen kann ich das bei Knoppix 9.1 unter "Einstellungen/erweitere Netzwerkeinstellungen" (genau Schreibweise hab ich gerade nicht da ich aktuelle mit Knoppix 8.6.1 unterwegs bin)

unten rechts keine aktiven Netze an, geschweige denn überhaupt eine WLAN-Option.

Ist den unter "Leisten-Einstellungen" das Feld "Berachrichtigungsfeld" eingeschaltet? Bei mir sind dann ein "4 Säulen"-Ikon sichtbar auf das ich mich beziehe.
Dort werden bei mit die Netzwerke und deren Einstellungen gehandelt

17

13.09.2022, 01:39

WLan ein / aus

Der Rechner an dem ich gerade arbeite hat schon einen Schalter fürs Wlan, ist aber für mich recht schwer bedienbar und hat kein LED für die Anzeige sondern noch eine schlecht sichtbare liquid-cristal Anzeige. Aber insgesamt stellt es für mich ja auch kein größeres Problem dar.
Ich habe gerade mal Knoppix 9.1 getestet. Das verhalten entspricht der von 8.6.1 . Am Anfang sehe ich "mein" Netzwerk, nach einer Weile rotiere es aus der Anzeige der Verfügbaren heraus. Dann muss ich halt über die Verborgenen gehen.

, auch das WLAN-Lämpchen zeigt an, dass es eingeschaltet ist, aber Knoppix zeigt unten rechts keine aktiven Netze an, geschweige denn überhaupt eine WLAN-Option.

Ich kenne die Hardwaresituation und Netzwerkumgebung von Skipper nicht. Aber er meine das WLan-Lämpchen leuchte. Also sollte es am Rechner eingeschaltet sein, sofern es auch ein Netzwerk gibt könnte es aber so ähnlich sein wie bei mir

Ich hoffe Skipper stellt seine Situation noch mal dar

Beiträge: 1 414

Geschlecht: Männlich

18

15.09.2022, 13:09

Mit ifconfig kannst Du prüfen ob der W-LAN Router erkannt wird.
eth0: ist LAN Ethernet
usb0: ist USB-Tethering über mein Handy

Du müsstest eine Zeile w-lan: sehen.

19

15.09.2022, 18:47

Mit ifconfig kannst Du prüfen ob der W-LAN Router erkannt wird.

"IPCONFIG" kenne ich zwar noch aus Windowszeiten aber unter Knoppix und Lubuntu ist das standardmäßig für mich nicht verfügbar. Da hilft "iwconfig" oder "ip" (mit vielen Parameten) schon weiter

sorry das "If" war bei mit nicht gut zu lesen, aber auch das müsste ich installieren

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »KeyGKey« (15.09.2022, 19:08)


20

15.09.2022, 20:07

Da hilft "iwconfig" oder "ip" (mit vielen Parameten) schon weiter


so it is.
Das meine ich auch damit, dass ich mich da in der Linux-Welt zu wenig auskenne.
ifconfig ist der typische, "jahrhunderte" alte Unix-Befehl um Netzwerkkarten zu konfigurieren oder diese Konfiguration anzuzeigen. In meinem altmodischen FreeBSD tut es das noch immer.
Die Linux-Entwickler haben sich entschieden (evtl im Zusammenhang mit systemd?), hier was zu erneuern. Ob es dadurch auch besser wurde, weiß ich nicht. Immerhin stellen viele Distributionen auch immer noch die alten Befehle/Tools zur Verfügung, nur nicht per default.
In meinem System etwa kann ich auf dem Wlan-Gerät wlan0 (das ist normalerweise das erste Wlan-Gerät, was immer erstes Gerät hier meinen soll, denn, wenn ich mehrere habe, werde ich schon gezielt die Device-Einträge zuweisen wollen), also mit

Quellcode

1
ifconfig wlan0 scan
kann ich sehen, welche Netzwerke gefunden werden. Nicht so in einem Knoppix, obwohl es da offenbar noch ifconfig gibt (oder hatte ich das zusätzlich installiert?)
Diese modernen Tools, wie iwconfig und ip, kennt mein System gar nicht und ich sah nie einen Grund, mich damit zu befassen. Ich nutze kein Linux und Knoppix macht das normalerweise auf irgendeine mir unbekannte Art automatisch.

Whatever: die Ansicht der angebotenen AcessPoints (das sind ja nicht unbedingt alles Router), gibt einem ja nicht viel und sie wechselt mitunter von Sekunde zu Sekunde. Viel was anderes, also was auch in der Grafik angezeigt wird, erscheint da nicht.

Es trifft auch das Problem nicht exakt, das KeyGKey hier beschreibt.
Er kann sich ja verbinden, nur erfolgt das aus mysteriösen Gründen nicht automatisch, wie es bei mir passiert und eigentlich wohl bei Knoppix erfolgen sollte, nachdem man sich mal erfolgreich mit einem Netzwerk verbunden hatte. Derzeit habe ich etwa drei oder vier Sticks im Einsatz, die ein Knoppix 9.1 drauf haben und gelegentlich boote ich die auch in "fremden Netzwerken" und immer verbinden die sich zuverlässig in die einmal benutzten Netzwerke. Vollkommen automatisch. Das würde ich deshalb bei KeyGKey auch so erwarten.

Kurzum: ich kann es mir nicht erklären, was da über bereits erwähnte Dinge noch passiert und es fehlen mir die Kenntnisse, mit Linux weiter nach möglichen Fehlern zu suchen.
Deshalb wäre es hier angeraten, Art-nahe GNU/Linux-Distributionen, wie etwa Debian oder Ubuntu zu probieren und bei gleichem Verhalten in deren Foren um Rat zu fragen.

Davon abgesehen könnte man vielleicht versuchen, durch einen Eintrag in der rc.local beim Start immer die Verbindung zu einem festen Netzwerk zu setzen, wozu man aber die oben erwähnten neuen Befehle kennen müsste, um so etwas zu machen.

Beiträge: 1 414

Geschlecht: Männlich

21

16.09.2022, 13:20

aber auch das müsste ich installieren
ifconfig ist ein Linux Paket das auch in der Paketliste enthalten ist und kann auf jeder mir bekannten Linux Live-DVD und Knoppix Flash benutzt werden das musst Du nicht installieren. Ich kenne diesen Befehl seit Knoppix 6.1 und Ubuntu 9.04 2009

Beiträge: 1 414

Geschlecht: Männlich

22

16.09.2022, 13:58

kenne ich zwar noch aus Windowszeiten
Ich kenne die Geschichte Unix; Linux; Windows. Windows benutzt Linux-Pakeke aber ein anderes Dateiformat. zuerst gab es von MS das System DOS 8Bit dannach Windows 16Bit.

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »ubuntuli« (16.09.2022, 14:05)


Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop