19.07.2018, 13:55 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Anonymous

unregistriert

1

29.06.2006, 15:29

Probleme beim Starten eines zweiten X mit "startx -- :1

System: Knoppix 5 DVD

Knoppix l?uft normal im Grafikmodus mit init 5

Wenn ich jetzt versuche, eine zweite X session auf console 2 mit startx -- :1 zu starten, wechselt er in den Grafik-Modus, die Maus ist f?r ca. 3 Sekunden zu sehen und kann auch bedient werden, danach f?llt er wieder zur?ck in den Textmodus und zeigt folgende Meldungen an:

[code:1]
xauth: creating new authority file //.serverauth.3854
xauth: creating new authority file //.Xauthority
xauth: creating new authority file //.Xauthority

X: warning; process set to priority -11 instead of requested priority -10

X Window System Version 7.0.0
Release Date: 21 December 2005
X Protocol Version 11, Revision 0, Release 7.0
Build Operating System:Linux 2.6.12-1-686 i686
Current Operating System: Linux Knoppix 2.6.17 #4 SMP PREEMPT Wed May 10 13:53:45 CEST 2006 i686
Build Date: 16 March 2006
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Thu Jun 29 14:50:46 2006
(==) Using config file: "/etc/X11/xorg.conf"
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning: Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
> Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
Could not init font path element /usr/share/fonts/X11/TTF/, removing from list!
Could not init font path element /usr/share/fonts/X11/OTF, removing from list!
Could not init font path element /usr/share/fonts/X11/CID/, removing from list!
AUDIT: Thu Jun 29 14:50:51 2006: 3872 X: client 2 rejected from local host
Auth name: MIT-MAGIC-COOKIE-1 ID: -1
AUDIT: Thu Jun 29 14:50:53 2006: 3872 X: client 2 rejected from local host
Auth name: MIT-MAGIC-COOKIE-1 ID: -1
AUDIT: Thu Jun 29 14:50:54 2006: 3872 X: client 2 rejected from local host
Auth name: MIT-MAGIC-COOKIE-1 ID: -1
AUDIT: Thu Jun 29 14:50:54 2006: 3872 X: client 2 rejected from local host
Auth name: MIT-MAGIC-COOKIE-1 ID: -1
AUDIT: Thu Jun 29 14:50:54 2006: 3872 X: client 2 rejected from local host
Auth name: MIT-MAGIC-COOKIE-1 ID: -1
AUDIT: Thu Jun 29 14:50:54 2006: 3872 X: client 2 rejected from local host
Auth name: MIT-MAGIC-COOKIE-1 ID: -1

waiting for X server to shut down FreeFontPath: FPE "/usr/share/fonts/X11/misc:unscaled" refcount is 2, should be 1; fixing.

[/code:1]

Wenn ich versuche, Xnest :1 zu starten, bekomme ich:

[code:1]
Fatal Server Error:
Unable to open display "".
[/code:1]

Wo liegt das Problem?

Ciao
Frank

2

29.06.2006, 22:07

M?glich das es mit der Live CD/DVD nicht geht. Mein versuchs ebend ist auch fehlgeschlagen. Mit ein Debian SId gings. Die Rechner haben beide Identische Grafikarten von Matrox (MGA 550)
Was haben Windows und ein Uboot gemeinsam?
Kaum macht man ein Fenster auf, gehen die Probleme los.

EDV ist die Abkürzung für: Ende der Vernunft

Anonymous

unregistriert

3

01.07.2006, 22:34

Ich kann zwar ein zweites X mit xinit -- :1 starten (warum geht das, aber startx -- :1 nicht???), aber dann habe ich auf dem Display :0 Probleme: z. B. l??t sich der Konquerer nicht mehr ?ffnen.

4

03.07.2006, 16:43

startx ist ja ein Shell-Skript. Ich hab' mal bei mir reingeguckt (ist aber eine SUSE 10.1), da sieht es nach meinem Verstaendnis so aus, als muesse man zwingend das zu verwendende Display angeben, wenn man startx benutzt.

Ich hab' mal fix gegoogelt und hier scheint was genaueres zu stehen (nicht ausprobiert!):
http://www.ltn.lv/~aivils/de/faq-de.html

Zitat


startx -- :1 -xf86config X-2nd vt9


M?glicherweise geht es aber auch einfacher, wenn Du folgendes Feature benutzt:

KDE Menu -> Benutzer wechseln -> Neue Sitzung starten

Das funktioniert bei mir voellig reibungslos.

Anonymous

unregistriert

5

06.07.2006, 10:46

Zitat von »"Brack"«

M?glicherweise geht es aber auch einfacher, wenn Du folgendes Feature benutzt:
KDE Menu -> Benutzer wechseln -> Neue Sitzung starten
Das funktioniert bei mir voellig reibungslos.


Das kann ich leider nicht benutzen, da es sich um automatische Vorg?nge handelt (scriptgesteuert) und gar kein User davorsitzt (die Sessions werden ?ber VNC verwaltet).


Mein Problem scheint aber bei KNOPPIX 5 zu liegen:
Wenn ich mein altes KNOPPIX 3.9 auf der Hardware starte, funktioniert sowohl startx -- :1 als auch xinit -- :2 tadellos und auch alles parallel (screens 5, 6 und 7).

Ciao
Frank

6

06.07.2006, 11:34

Und was ist mit der etwas laengeren startx Zeile, die ich gepostet habe?

Das mit dem Davorsitzen: moeglicherweise kann man nachgucken, was dieser KDE Menueintrag genau macht und auf der konsole aufrufen...

Anonymous

unregistriert

7

06.07.2006, 13:40

Zitat von »"Brack"«

Und was ist mit der etwas laengeren startx Zeile, die ich gepostet habe?.


unter Knoppix 5.0.1:
startx -- :1 -xf86config X-2nd vt9

[code:1]

xauth: creating new authority file //.serverauth.3764

X Window System Version 7.0.0
Release Date: 21 December 2005
X Protocol Version 11, Revision 0, Release 7.0
Build Operating System:Linux 2.6.12-1-686 i686
Current Operating System: Linux Knoppix 2.6.17 #4 SMP PREEMPT Wed May 10 13:53:45 CEST 2006 i686
Build Date: 16 March 2006
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Thu Jul 6 13:33:03 2006
(EE) Unable to locate/open config file: "X-2nd"

xf86AutoConfig: Primary PCI is 2:0:0
Running "getconfig -X 70000000 -I /etc/X11,/usr/etc/X11,/usr/lib/xorg/modules,/usr/lib/X11/getconfig -v 0x10de -d 0x0110 -r 0xa1 -s 0x1043 -b 0x401d -c 0x0300"
sh: getconfig: command not found
(==) Using default built-in configuration (43 lines)

Fatal server error:
Cannot run in framebuffer mode. Please specify busIDs for all framebuffer devices

XIO: fatal IO error 104 (Connection reset by peer) on X server ":1.0"
after 0 requests (0 known processed) with 0 events remaining.
[/code:1]

8

06.07.2006, 13:52

Oh, wie bloed, das -xf86config gibt natuerlich eine zweite Konfigdatei an, die es natuerlich nicht gibt. Lass' das mal weg, vielleicht braucht er nur die Info, welches virtuelle Terminal er benutzen soll...

startx -- :1 vt9

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop