25.11.2017, 08:34 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

20.11.2014, 00:02

Probleme / Bugs in Knoppix v7.4.2

Hallo Zusammen,

irgendwie läuft Knoppix 7.4.2 (Booten von DVD) nicht so "rund", wie ich es von v7.2 gewohnt war. Vielleicht hab ich auch irgendetwas nicht beachtet. Am besten ich beschreibe mal die Punkte, die mir aufgefallen sind. (Falls es sich aber wirklich um Bugs handeln sollte, hoffe ich ganz stark, dass eine neue Version nicht erst zur CeBIT erscheint :-), da ich viele Punkte auch sehr gelungen in 7.4 finde.)

Falls zu Punkt 1 und 2 die genaue Fehlermeldung notwending sein sollte, kann ich die gerne nachliefern (schreibe gerade nicht an dem Rechner, an dem der Fehler auftritt). Aber so wie es mir scheint, müssten die Fehler wohl bei jedem auftreten.

Also hier mal die Probleme (in Klammern am Anfang immer die Architektur, bei der der Fehler auftaucht):

1. [32/64 Bit] 'wodim' ist nicht ausführbar
Beispielsweise liefert bereits 'wodim --devices' eine Fehlermeldung

2. [32/64 Bit] VirtualBox startet keine Virtuelle Maschine
Alle Versuche schlugen bis jetzt fehl, egal, ob nur ein ISO-Image gebootet werden sollte, oder auch nur ein leeres System ohne CD und Festplatte. Eine Fehlermeldung kommt bereits vor dem POST-Prozess.

4. [32/64 Bit] Fenstergröße verändern => hohe CPU-Belastung
Ein Verschieben eines Fensters zeigt diesen Effekt allerdings nicht.
Meine Grafikkarte hat einen AMD-Chip.



Bereits gelöst:
----------------------------------------
3. [32/64 Bit] PCManFM: Folgende Option fehlt unter 'Werkzeuge': Aktuellen Ordner als 'root' öffnen
Update (21.11.2014, 6:45h): OK, Danke an klaus2008. Die Entfernung der Option ist allerdings extrem traurig. Um eine entsprechende DVD zu bekommen bleibt einem dann nur das Remastern.

5. [64 Bit] PCManFM: NTFS mounten schlägt fehl
Bisher konnte man einfach auf eine NTFS-Partition klicken (als KNOPPIX-User in v7.2) und die Partition war gemountet. Dies geht nun nicht mehr. FAT scheint noch zu funktionieren, und auch die UNIX-Filesysteme.
Update (21.11.2014, 6:45h): Dies konnte ich bei einer erneuten Überprüfung jetzt nicht mehr feststellen. Merkwürdig trotzdem, warum es damals so war. Aber egal..

Nicht ganz so wichtig:
6. Uhrzeit geht 1 Stunde nach
Vermutlich geht die interne Uhr nun nicht mehr davon aus, dass die Uhr im BIOS auf UTC steht. Schade eigentlich. Ich hatte erst vor kurzem alle Systeme so konfiguriert, dass sie von UTC im BIOS ausgehen, scheint mir auch die vernünftigste Lösung zu sein, wenn man mit verschiedenen Systemen arbeitet. Hatte diesbezüglich ja auch hier im Forum den Tipp bekommen :-)
Update (21.11.2014, 6:45h): OK, Danke an Werner P. Schulz. Das neue Verhalten ist wohl so gewünscht.
----------------------------------------



Also, vielleicht kann mir ja jemand zu dem einen oder anderen Punkt einen Tipp geben und/oder ob die Probleme nur bei mir auftauchen.
Viele Grüße

Dieser Beitrag wurde bereits 5 mal editiert, zuletzt von »loomix« (21.11.2014, 07:35)


klaus2008

Meister

Beiträge: 2 656

Geschlecht: Männlich

2

20.11.2014, 15:07

Zitat

3. [32/64 Bit] PCManFM: Folgende Option fehlt unter 'Werkzeuge': Aktuellen Ordner als 'root' öffnen

Siehe zum Beispiel den Beitrag 16 im Thema Datenrettungmit Knoppix

3

20.11.2014, 18:17

Zitat

6. Uhrzeit geht 1 Stunde nach
Siehe Hint (9) zu den Cheatcodes
Gruß Werner * Eigene Rescue-CD
remaster Grml * remaster Knoppix

ubuntuli

Fortgeschrittener

Beiträge: 394

Geschlecht: Männlich

4

21.11.2014, 00:31

irgendwie läuft Knoppix 7.4.2 (Booten von DVD) nicht


1. [32/64 Bit] 'wodim' ist nicht ausführbar


ich kenne die möglichkeiten für dise Anzeige.
Du willst die 32 Bit Version installieren obwohl dein Rechnber 64 Bit ist.
Du brauchst die 64 Bit

5

21.11.2014, 01:50

1. [32/64 Bit] 'wodim' ist nicht ausführbar


ich kenne die möglichkeiten für dise Anzeige.
Du willst die 32 Bit Version installieren obwohl dein Rechnber 64 Bit ist.
Du brauchst die 64 Bit


Wie meinst Du das?
Installieren wollte ich nichts. Einfach DVD-Start und Befehl ausführen.
Würde das denn bedeuten, dass sämtliche Software nur in 32Bit vorliegt und ich beim 64-Bit-Start auch alle Software in 64-Bit nachinstallieren muss?

Also folgendes habe ich beobachtet:
1. Knoppix DVD 7.4.2 booten mit Cheatcode 'knoppix64 no3d', also 64Bit.
Danach im Terminal eingeben: wodim --devices
Folge: Fehlermeldung

2. Knoppix DVD 7.4.2 booten mit Cheatcode 'knoppix no3d', also 32Bit.
Danach im Terminal eingeben: wodim --devices
Folge: Fehlermeldung

Also sowohl bei 64 als auch bei 32 Bit kommt die Fehlermeldung. Installieren wollte ich nichts.
Es könnte höchstens noch sein, dass der Cheatcode 'knoppix no3d' auch wieder die 64Bit-Version startet. Da bin ich mir jetzt nicht mehr ganz sicher, aber ich meine er hat bei diesem Cheatcode nur 3,x GB RAM erkannt, was ja schon für 32Bit spricht.

Viele Grüße

ubuntuli

Fortgeschrittener

Beiträge: 394

Geschlecht: Männlich

6

21.11.2014, 02:19

Nicht das Du jetzt was falsch verstehst. 32 Bit Software läuft langsamer wie 64 Bit. Wenn Du jetzt beispielsweise eine Knoppix x.x 32Bit auf einen 64Bit Rechner installierst läuft das System nicht mit maximaler Geschwindigkeit.

7

21.11.2014, 02:29

Naja die Geschwindigkeit ist ja jetzt erst mal zweitrangig.
Mein Problem ist, dass wodim und virtualbox (und vielleicht auch andere Software) bei mir gar nicht funktionieren.

Wie ist es denn bei Dir?
Taucht der Fehler bei Dir nicht auf? Bei einem frischen DVD-Boot?

9

21.11.2014, 07:03

kannst Du "apt-get install virtualbox" im Terminal benutzen?

Also folgende Befehle ausgeführt:

Quellcode

1
2
3
su
apt-get update
apt-get install virtualbox
Ergebnis: Am Ende ein Fehler.
Die letzten Zeilen der Ausgabe sind:

Quellcode

1
2
3
4
5
6
7
...
DKMS: install completed.
[ ok ] Stopping VirtualBox kernel modules.
[FAIL] Starting VirtualBox kernel modules[....] modprobe vboxnetflt failed. Please use 'dmesg' to find out why ... failed!
 failed!
invoke-rc.d: initscript virtualbox, action "restart" failed.
Trigger für menu (2.1.46) werden verarbeitet ...
Keine Ahnung, ob uns die Ausgabe von 'dmesg' weiterbringt, und ob das mit der ursprünglichen Fehlermeldung zusammenhängt.

Aber mal abgesehen davon, müsste doch VirtualBox 'out of the box' funktionieren, also ohne dass man noch groß etwas installiert, oder?

In meinem nächsten Post werde ich mal die Fehlermeldungen nachliefern.

10

21.11.2014, 07:28

Also es wundert mich wirklich, dass bei euch die Fehler nicht auftauchen.
Wäre toll, wenn ihr mir das mal bestätigen könntet.

Die Fehler scheinen mir einfach von so grundlegender Natur zu sein, dass ich mir irgendwie gar nicht vorstellen kann, dass nur ich sie habe. Und meine Hardware ist jetzt auch nicht so exotisch, wobei es mir jetzt auch nicht nach einem Hardwareproblem aussieht, da ja alles bei Knoppix v7.2 problemlos klappte.

Also hier mal die Fehlermeldungen von 'wodim' und 'virtualbox', die sich auch nicht unterscheiden, egal ob als 32-Bit gebootet wurde oder als 64-Bit (gebootet immer von Knoppix DVD v7.4.2):

1. wodim

Eingabe:

Quellcode

1
wodim --devices
Ausgabe:

Quellcode

1
2
3
4
5
6
wodim: No such file or directory. 
Cannot open SCSI driver!
For possible targets try 'wodim --devices' or 'wodim -scanbus'.
For possible transport specifiers try 'wodim dev=help'.
For IDE/ATAPI devices configuration, see the file README.ATAPI.setup from
the wodim documentation.


2. VirtualBox

Eingabe:
virtualbox gestartet, Virtuelle Maschine erstellt mit Standardparametern, ohne HD, nur DVD, Virtuelle Maschine gestartet

Ausgabe, erstes Fenster:

Quellcode

1
2
3
4
5
6
Für die virtuelle Maschine Test konnte keine neue Sitzung eröffnet werden.
The virtual machine 'Test' has terminated unexpectedly during startup with exit code 1.
Details:
Fehlercode:NS_ERROR_FAILURE (0x80004005)
Komponente:Machine
Interface:IMachine {480cf695-2d8d-4256-9c7c-cce4184fa048}

Ausgabe, zweites Fenster, kurz danach:

Quellcode

1
2
3
4
5
6
7
8
RTR3InitEx failed with rc=-1912 (rc=-1912)

The VirtualBox kernel modules do not match this version of VirtualBox.
The installation of VirtualBox was apparently not successful. Executing

'/etc/init.d/vboxdrv setup'

may correct this. Make sure that you do not mix the OSE version and the PUEL version of VirtualBox.


Vor allem die zweite Fehlermeldung deutet schon darauf hin, dass das Problem mit 32Bit und 64Bit zu tun hat. Aber, wie gesagt, der Fehler tritt auch bei der 32Bit-Version auf.
Und

Quellcode

1
/etc/init.d/vboxdrv setup
brachte mich auch nicht weiter. Außerdem wäre es ja auch nicht sinnvoll, wenn man bei einer LiveDVD erst Korrekturen vornehmen muss, damit virtualbox funktioniert.

Probiert es doch mal aus, ob das bei euch wirklich problemlos klappt. Das würde mir schon sehr weiterhelfen.

PS:
In meinem ersten Post habe ich die bereits gelösten Probleme mit einem Update versehen.

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »loomix« (21.11.2014, 14:49)


Ähnliche Themen

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop