14.12.2017, 01:33 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

08.03.2006, 21:55

Knoppix 5.0 DVD CeBIT Edition bekannte Bugs

Hallo,

wer einen Fehler in Knoppix 5.0 DVD CeBIT Edition findet,
bitte hier eintragen.

Nachtrag: Wer einen Workaround fuer den Fehler weiss, sollte den
natuerlich nicht verschweigen.

Tschuess
Karl

Anonymous

unregistriert

2

10.03.2006, 10:43

Das Script mit Variable:

/usr/sbin/sambastart start

funktioniert nicht, d. h. die /etc/samba/smb.conf wird nicht korrekt aufgebaut. Die Partitionen erscheinen nicht als Share, auch wenn man dies mit Ja beantwortet.

Man kann also leider nicht bequem per Klick einen schnellen Samba-Server aufsetzen (siehe KNOPPIX --> Serverdienste --> Sambaserver starten)

Gru?, Martin

3

13.03.2006, 16:05

Hallo,

wenn ich auf meinem LapTop boote, kommt beim ersten Bootbildschirm
unter der Zeile "Knoppix V5.0.0-DVD ... RELEASE 2006-02-25" die
Fehlermeldung: "Unknown keyword in config file."

(Mit config file ist vermutlich boot/isolinux/isolinux.cfg gemeint.)

Ich kann mit den Tasten <F2> und <F3> nicht in die Kurz-Hilfe
wechseln. "knoppix 3" bringt die Fehlermeldung "Could not find
kernel image: knoppix". "linux 3" geht hingegen.

Wenn ich dagegen auf meinem PC boote, kommt keine Fehlermeldung
und alles funktioniert so, wie es soll.

Tschuess
Karl

4

14.03.2006, 21:36

Hallo,

dieser "Fehler" ist vermutlich sehr exotisch und einer, der wohl kaum
jemandem Probleme macht. Ich trage ihn nur der Vollstaendigkeit
halber ein.

Der Befehl "locale" gibt unter SuSE, ubuntu, debian in der Regel aus:
LANG=de_DE
LC_*=de_DE
LC_ALL=

Bei Knoppix ist es dagegen
LANG=de_DE
LC_*=de_DE
LC_ALL=de_DE

Bei Knoppix ist also auch LC_ALL gesetzt. Das bereitet Probleme
beim Aendern von LANG auf eine andere Sprache, da sich dann
LC_* nicht aendert.

Workaround, wenn Knoppix remastert wird oder auf der Festplatte
installiert wird: In /etc/profile, Zeile 18: "LC_ALL=""" zufuegen.

Tschuess
Karl

prh

Profi

Beiträge: 1 248

Geschlecht: Männlich

5

19.03.2006, 14:20

Auf meinem grossen 'Spielerechner' funzt Knoppix5 leider nur sehr schlecht:
die S-ATA Platte wird nicht erkannt,
der interne Kartenleser im Monitor wird nicht erkannt.
Beim Booten kommt nur der Pinguin und dann erstmal eine lange Pause mit schwarzem Bildschirm
System: amd64-3200+ / 1 GB-Ram / msi-K8T-MB / hda=ata200G / hdb=160G-S-ATA / LCD Dell 2405 FPW mit int. usb-Kartenleser


Als Vergleich hat das 'alte' Kanotix 2005-04 da keine Probleme.


P.S.: zum Vergroessern auf die Bilder klicken
LG
prh

6

19.03.2006, 16:11

Hi,

ja, wenn man es denn als Bug bezeichnen mag. Die Hardware ist ja recht frisch.
Auf einen Sony Vaio mit dem neuen centrino mit dualcore mag die knoppix auch nicht vern?nftig booten. Im Gegensatz zur Kanotix-Cebit2006 erkennt zeigt sie zwar zwei Tuxe aber bleibt sehŕ fr?h beim booten h?ngen.
Die aktuelle Kanotix zeigte zwar nur einen tux, konnte aber booten.


Gruss Guido

prh

Profi

Beiträge: 1 248

Geschlecht: Männlich

7

19.03.2006, 18:17

Zitat von »"guido17"«

Hi,

ja, wenn man es denn als Bug bezeichnen mag. Die Hardware ist ja recht frisch.
Hallo,
den PC hab ich seit Mai 2004. S-ATA Platten sind jetzt wirklich ein absolutes MUSS!

Es gibt auch was positives (bei beiden Linuxen): der Sound, eine externe usb Audigy NX, wird von beiden Systemen zumindest schon mal erkannt und es kommen auch Toene raus - (ob Stereo oder 5.1 weiss ich nicht) - das war in 2004 natuerlich noch nicht so.
Es ist aber auch noch eine WIN-TV-Nexus-S drin ...
LG
prh

8

19.03.2006, 18:40

Hi prh,


das mit der frischen Hardware hatte ich auf den neuen centrino bezogen :wink:

Gruss Guido

prh

Profi

Beiträge: 1 248

Geschlecht: Männlich

9

19.03.2006, 18:59

Zitat von »"guido17"«

Hi prh,


das mit der frischen Hardware hatte ich auf den neuen centrino bezogen :wink:

Gruss Guido
sorry Guido, ich dachte wirklich, Du meinst meine Kiste damit :oops:
LG
prh

10

28.03.2006, 13:00

Swappen in eine Datei geht nicht ?berall

Hallo,

wenn man mit "mkswap /tmp/swapfile" oder "mkswap /usr/local/swapfile"
eine Datei zum Swappen erstellt, meldet das anschliessende
"swapon /tmp/swapfile" bzw. "swapon /usr/local/swapfile" den Fehler
"Das Argument ist ungueltig".

"mkswap /swapfile" und dann "swapon /swapfile" geht.

Das koennte damit zusammenhaengen, dass /tmp bzw. /usr/local in der
ramdisk bzw. im UNIONFS liegen oder aber dass /tmp bzw. /usr
Softlinks sind.

Tschuess
Karl

Anonymous

unregistriert

11

09.04.2006, 15:41

In der Englischen Version, kommt am Schluss vom shotdown prozelss, die Meldung man solle jetzt die CD entnehmen und dann Return dr?cken.
Bug: Die CD kommt raus, geht dann aber sofort wieder rein :wink:

Ich hab noch einen Vorschlag f?r die Lautst?rke: Wenn Knoppix gebootet ist, ist der Ton immer sehr leise und man muss ihn jedes Mal von Hand hochstellen. Ich w?rde mich freuen, wenn die Start-Lautst?rke etwas lauter w?re.

MfG stev

12

13.04.2006, 19:08

So wie es Aussieht funktioniert [code:1]memtest[/code:1] mit knoppix 5.0 nicht mehr.

Wird mit folgender Meldung quittiert

[code:1]
Cannot Load a ramdisk with an old kernel image[/code:1]

Bei der Origanl DVD und meiner gebrannten.
Was haben Windows und ein Uboot gemeinsam?
Kaum macht man ein Fenster auf, gehen die Probleme los.

EDV ist die Abkürzung für: Ende der Vernunft

13

02.05.2006, 23:26

Hallo,

wenn ich das Programm sndconfig ueber

K -> Knoppix -> Konfiguration -> Soundkarten-Konfiguration

starte, bekomme ich die Fehlermeldung

"You don't seem to be running a kernel with modular sound
enabled (soundcore.o was not found in the module search path)..."

Der Kernel und sndconfig scheinen nicht zusammen zu passen.

Bei Knoppix 4.0.2 und 3.8 (alle mit Kernel 2.6) tritt der Fehler
auch auf. Bei Knoppix 3.7 (Kernel 2.4) tritt der Fehler nicht auf.
Da funktioniert sndconfig.

Tschuess
Karl

14

03.05.2006, 23:02

Besser w?re alsa und sndconfig passen nicht zusammen. Das findet man bei suche nach sndconfig http://packages.debian.org/oldstable/sound/sndconfig

[code:1]
Easy soundcard configuration

Sndconfig is a utility that lets you configure your soundcard easily. It was written originally for RedHat Linux, but now it is available for Debian GNU/Linux, too.

Sndconfig uses isapnp to detect common soundcards and writes a isapnp configuration to and module control lines for use with your sound card. It requires a kernel with OSS sound modules to be present.
Other Packages Related to sndconfig
[/code:1]
Was haben Windows und ein Uboot gemeinsam?
Kaum macht man ein Fenster auf, gehen die Probleme los.

EDV ist die Abkürzung für: Ende der Vernunft

15

23.05.2006, 23:49

Hallo,

der NFS-Kernel-Server scheint nicht zu funktionieren.

Details siehe www.elearnit.de/knoppix/forum/viewtopic.php?t=1339

Tschuess
Karl

16

02.06.2006, 19:14

Hallo

K -> Entwicklung -> MonoDevelop (beide Eintraege) startet nicht.

Der Befehl "monodevelop" in einer Konsole bringt den Fehler
"Cannot find /KNOPPIX/usr/etc/mono/1.0/machine.config".

Die Datei machine.config liegt unter /etc/mono/1.0, einen Softlink
oder eine Kopie konnte ich nicht erstellen, da /KNOPPIX ja auf der
nur lesbaren DVD ist.

Workaround: Die 5.0 DVD auf Festplatte installieren und machine.config
kopieren oder Knoppix 4.0.1 DVD oder 5.0.1 DVD verwenden. Da startet
Mono Develop.

Tschuess
Karl

Anonymous

unregistriert

17

14.06.2006, 11:59

Sorry,
ich hatte vorher nicht gesehen, dass Bugs und Workarounds hier eingetragen werden.

Zitat von »"mkurz"«

Das Script mit Variable:

/usr/sbin/sambastart start

funktioniert nicht, d. h. die /etc/samba/smb.conf wird nicht korrekt aufgebaut. Die Partitionen erscheinen nicht als Share, auch wenn man dies mit Ja beantwortet.

Man kann also leider nicht bequem per Klick einen schnellen Samba-Server aufsetzen (siehe KNOPPIX --> Serverdienste --> Sambaserver starten)

Den Workaround habe ich hier beschrieben (Beitrag vom 12.06.2006, 23:34):

http://www.elearnit.de/knoppix/forum/vie…er=asc&start=15

Viele Gr??e - nenem

Anonymous

unregistriert

18

03.11.2006, 22:42

Hallo!

Nach der Installation einer Knoppix 5.0(.1) CD oder DVD l?uft der hald nicht, lshal gibt eine Fehlermeldung. udev l?uft ebenfalls nicht, was der Grund f?r den nicht gestarteten hald ist. in /dev fehlen viele Ger?te, wie sda, sda1 ... sdb und weitere.

Abhilfe:

Anlegen des entsprechenden Links im SYSV-Init-Verzeichnis:

ln -s /etc/init.d/udev /etc/rcS.d/S03udev.sh

Nach dem Reboot laufen dann hald und udev.

Guido

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop