25.05.2018, 08:59 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Anonymous

unregistriert

1

20.10.2004, 08:10

Skype Knop3.4 HD /dev/dsp

Hallo,
habe das Programm Skype im Home Verzeichnis entpackt und kann es von da auch starten.
Eine Verbindung zum Internet besteht und ich kann evtl. Gespr?chspartner sehen.
Bei einem Verbindungsaufbau bekomme ich aber die Meldung, dass es ein Problem mit dem Audio device gibt.
Wenn ich das Programm als root starte funktioniert es tadelos.
Es wird also ein Problem mit den Rechten von /dev/dsp sein!?
Ich habe dann in /dev die Rechte von dsp (0 bis4) f?r alle freigegeben.
Der User ist auch in der gruppe audio.
Ansonsten klappt die audio Ausgabe des Systems gut. Ich kann alle Systemmeldungen h?ren
und auch mp3 etc funktioniert.
Was mu? ich ?ndern um auch als User mit Skype telefonieren zu k?nnen?
Gru? Tobbes

Anonymous

unregistriert

2

20.10.2004, 13:45

Moin tobbes,

solche Probleme kenne ich unter SuSE vom mplayer. Bei mir hat es was gebracht oss zu deaktivieren und nur alsa laufen zu lassen.

Anonymous

unregistriert

3

20.10.2004, 15:03

oss oder alsa

Tja, ich dachte es l?uft auf Knoppix 3.4 nur noch alsa.
Wie bekomme ich den raus was l?uft und stelle es evtl. ab?
Kann mir da lsmod helfen??
Gru? Tobbes

4

20.10.2004, 16:06

Moeglicherweise blockiert auch der artsd von KDE die Soundkarte. Also entweder Skype beibringen, artsd zu benutzen, oder diesen einfach abschalten.

Anonymous

unregistriert

5

21.10.2004, 11:59

leider nicht verstanden

Hallo, leider habe ich Deine Antwort nicht verstanden.
Nach was soll ich bei KDE genau suchen und welche Aufgabe hat das artsd?
Wie kann ich dann skype beibringen es zu benutzen, und wie kommt der Unterschied zwischen root und user zustande?
Ich dachte es liegt an irgendwelchen Rechten..
Danke, Gru? Tobbes

6

21.10.2004, 12:05

artsd ist der KDE Sound daemon. Der wird benutzt, um mehrere Soundquellen gleichzeitig auszugeben. Mit dem alten Kernel-Soundsystem OSS ging das naemlich nicht so einfach. Das neue, ALSA, kann das von sich aus. An sich braucht man den artsd also nicht. Laesst sich im Kontrollzentrum abschaten. Der Punkt muesste "Soundsystem" oder so heissen.

Das ist nur eine Moeglichkeit, quasi geraten. Wie lautet denn konkret die Fehlermeldung, die Du bekommst? Und wie testest Du?

Warum es als root geht, weiss ich nicht so recht. Bist Du komplett als root eingeloggt oder nur eine root-konsole?

Anonymous

unregistriert

7

21.10.2004, 13:04

problem with audio device

Hallo,
Die Fehlermeldung ist mau: wenn ich jemanden anrufe steht dort erst "ringing" und dann sofort "problem with audio device" oder ?hnlich.

Bin immer als user eingeloggt. Starte dann den Konquorer als root und f?hre dann das skype aus dem home Verzeichnis des Users aus.
Skype wird mit hilfe eines Skriptes installiert, das sich im Userverzeichnis entpackt und sofort funktioniert (oder funktionieren sollte).

Ich m?chte Skype halt beim Hochfahren schon starten und das ist als root doof. Sollte halt schon als Userprogramm laufen, weils ja auch im Internet h?ngt...
Ob der damoen l?uft, kann ich halt gerade nicht sagen(sitze vor nem anderen PC), ich w?rde ihn wahrscheinlich auch unter den laufenden Prozessen finden, oder?

Gru? Tobbes (Dank f?r die Gedult)

8

22.10.2004, 12:08

Stimmt, die ist wirklich mau. ;)

Vielleicht gibt es schoeneren Output, wenn Du

skype

ueber die Kommandozeile startest. Viele Programme schreiben noch zusaetzlich nach standard out, meistens ausfuehrlicher als die GUI Meldungen.

Sollte es am artsd (jo, unter den Prozessen zu finden) liegen, kannst Du es auch mit

artsdsp skype

probieren. Das wird dann aber beim Booten nicht gehen, weil zu dem Zeitpunkt noch keine KDE Sitzung laeuft, also auch kein artsd.

Anonymous

unregistriert

9

25.10.2004, 21:51

Fehlermeldungen

Hallo, sch?n das Du noch mit an dem Prob arbeitest...
Der Aufruf in Konsole "artsdsp skype" als user:
tobbes@Box:~/Skype/skype_ver-0_91_0_12$ artsdsp skype
Engine::init invoked. user is
Sound device is defined
Engine::init success
UI: Engine::Engine credentials loaded
SkyWindowBase::onlineStatusChanged setting pixmap
DialPad: DialPad
language selected: 3
Engine::init invoked. user is tobbes**
Sound device is defined
Engine::init success
UI: Lib::OnConnStatusChange status is 1, 1
Engine::customEvent Sky::Event::SKY_CONN_STATUS_EVENT
UI: Lib::OnConnStatusChange status is 1, 1
Engine::customEvent Sky::Event::SKY_CONN_STATUS_EVENT
UI: Lib::OnConnStatusChange status is 3, 3
Engine::customEvent Sky::Event::SKY_CONN_STATUS_EVENT
Profile::OnChange invoked. key is 28+
Profile::OnChange invoked. key is 14+
Profile::OnChange invoked. key is 29+
Profile::OnChange invoked. key is 28+
Engine::customEvent Sky::Event::SKY_PROFILE_CHANGE_EVENT ev->getKey() is 28+
Engine::customEvent Sky::Event::SKY_PROFILE_CHANGE_EVENT SkyLib::Profile::LOGGED_IN
UI: credentials saved
UI: version is 0 91
UI: Engine::getLatestVersionQuery query is /ui/2/91/en/getlatestversion?ver=0.91.0.12&uhash=6b9b1a88ce86270e7db3f61eb71d+++
SkyWindowBase::onlineStatusChanged setting pixmap
MainForm: profilePrivilegsUpdate
CallManager: lib->profile.GetOnlineStatus() 2
objectID 5
success
23
UI: CallManager: newCallHistory created
UI: WidgetCallListTab: initCallList
callList->count() 23
UI: Engine::addBuddy handle is 1
UI: new buddy heiner+++ created
UI: Engine::initBuddies invoked
Engine::customEvent Sky::Event::SKY_PROFILE_CHANGE_EVENT ev->getKey() is 146
Engine::customEvent Sky::Event::SKY_PROFILE_CHANGE_EVENT user_privilegs
MainForm: profilePrivilegsUpdate
Engine::customEvent Sky::Event::SKY_PROFILE_CHANGE_EVENT ev->getKey() is 292
Engine::customEvent Sky::Event::SKY_PROFILE_CHANGE_EVENT ev->getKey() is 281
Profile::OnChange invoked. key is 137
Engine::customEvent Sky::Event::SKY_PROFILE_CHANGE_EVENT ev->getKey() is 137
Engine::customEvent Sky::Event::SKY_PROFILE_CHANGE_EVENT online status is 2
SkyWindowBase::onlineStatusChanged setting pixmap
MainForm: profilePrivilegsUpdate
Search::OnChange invoked. key is 13
UI: Engine::searchBuddiesStatusChanged SkyLib::Search::FINISHED
UI: buddy found 1
UI: Engine::httpFinished data is 92
UI: version is 0 91
newVer: forced: no
newVer: ver: 92
buttons=6
UI: Engine::addBuddy handle is 1
CallManager: callTo : heinerkuehn
CallManager: placeCall: heinerkuehn
new P2P call
MainForm: newCallTab
QMetaObject::findSignal:Sky::OutgoingCall: Conflict with QObject::destroyed()
call: status: 1
Sky: Call: getStatus routing
UI: User::getAvatar no avatar, returning default avatar image
SingleCallManager: SingleCallManager
call: status: 1
Sky: Call: getStatus routing
OutgoingCallTab::init
WidgetCallTab::init
WidgetCallTab: updateTabIcon: STATE 0
open /dev/dsp: Kein passendes Ger?t gefunden
Call: OnChange: key 249
Call: OnChange: CALL_FAILUREREASON
UI: Call: SOUND_PLAYBACK_ERROR
Call: Problem mit dem AudiogerÀt
Call: OnChange: key 273
Call: OnChange: key 245
(null)
ItemManager: updateCallStatus
UI: User::getAvatar no avatar, returning default avatar image
call: status: 2
Sky: Call: getStatus failed
UI: Call: SOUND_PLAYBACK_ERROR
CallManager: callFinalize
callList->count() 1
Contains
isEmpty
WidgetCallListTab: newCallFinished
WidgetCallTab: updateTabIcon: STATE 1
CallManager: callFinalize
callList->count() 0
CallManager: callFinalize: removing noexisting call

Die Fehlermeldung im Prog und das Verhalten ist das gleiche!!!
Macht es Sinn die Ausgabe von Skype in der Konsole auch zu posten??
tobbes@Box:~/Skype/skype_ver-0_91_0_12$ skype
Engine::init invoked. user is
Sound device is defined
Engine::init success
UI: Engine::Engine credentials loaded
SkyWindowBase::onlineStatusChanged setting pixmap
DialPad: DialPad
language selected: 3
Engine::init invoked. user is tobbes.l
Sound device is defined
Engine::init success
Okay, das waren die ersten Zeilen.
Hilft das weiter??
Gru? Tobbes

10

25.10.2004, 22:09

Hm, das ist irgendwie auch nicht viel besser:

"open /dev/dsp: Kein passendes Ger?t gefunden"

Was ist denn mit

ls -l /dev/dsp

Falls das ein Link ist, wie sieht der Output fuer das Device aus, auf das der Link zeigt?

Anonymous

unregistriert

11

25.10.2004, 23:28

Ausgabe von ls...

Hallo, hier die Ausgabe des ls:

tobbes@Box:~$ ls -l /dev/dsp
crwxrwxrwx 1 root audio 14, 3 2001-04-15 02:44 /dev/dsp

K?nnte es doch an dem Besitzer root liegen??

Gru? Tobbes

12

26.10.2004, 15:08

Hm, eigentlich nicht, die Rechte sind ja so gesetzt, dass alle alles duerfen.

Du kannst natuerlich mal den Besitzer des Devices aendern, aber ich wuesste nicht, was das aendern sollte.

Ich weiss ja nicht, wieviel Aufwand Du noch treiben moechtest, aber Du kannst ja mal auf folgenden Seiten suchen, ob da was zu dem Problem bekannt ist und ggf. dort nochmal die Frage posten.

http://www.skype.com/
http://www.planetskype.de/

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop