24.04.2018, 18:14 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Anonymous

unregistriert

1

04.09.2006, 15:26

CUPS Problem

Hallo,

ich hoffe ich bin nicht im g?nzlich falschen Unterforum gelandet aber ich habe ein Problem mit CUPS und hoffe ihr k?nnt mir helfen. Und zwar funktioniert urpl?tzlich mein Drucker nicht mehr, vermutlich seit der Installation/Update von 'digikam' (die letzte ?nderung am System, die ich durchgef?hrt habe). Ich habe jetzt versucht den Drucker zu entfernen und dann neu hinzu zuf?gen allerdings erscheint in der 'Endger?teauswahl' von 'Drucker hinzuf?gen...' alle Felder bis auf die letzten beiden ausgegraut/ghosted. Daher ich kann weder einen parallelen Drucker, USB oder Netzwerkdrucker hinzuf?gen. ?ffne ich ein Browserfenster f?r 'localhost:631' erscheint zwar die Startseite von CUPS, diese jedoch nicht in Klartext, sondern der HTML source der Seite. Auch brachte die Deinstallation und Neuinstallation von CUPS mittels apt-get keine Besserung. Wei? jemand Rat?

/var/log/cups/error_log enth?lt folgendes:

I [04/Sep/2006:15:41:35 +0200] Saving job cache file "/var/cache/cups/job.cache"...
I [04/Sep/2006:15:41:35 +0200] Loaded configuration file "/etc/cups/cupsd.conf"
N [04/Sep/2006:15:41:35 +0200] Group and SystemGroup cannot use the same groups!
I [04/Sep/2006:15:41:35 +0200] Resetting Group to "root"...
I [04/Sep/2006:15:41:35 +0200] Cleaning out old temporary files in "/var/spool/cups/tmp"...
I [04/Sep/2006:15:41:35 +0200] Configured for up to 100 clients.
I [04/Sep/2006:15:41:35 +0200] Allowing up to 100 client connections per host.
I [04/Sep/2006:15:41:35 +0200] Creating CUPS default administrative policy:
I [04/Sep/2006:15:41:35 +0200] <Policy default>
I [04/Sep/2006:15:41:35 +0200] <Limit Send-Document Send-URI Cancel-Job Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job Suspend-Current-Job Resume-Job CUPS-Move-Job CUPS-Authenticate-Job>
I [04/Sep/2006:15:41:35 +0200] Order Deny,Allow
I [04/Sep/2006:15:41:35 +0200] Require user @OWNER @SYSTEM
I [04/Sep/2006:15:41:35 +0200] </Limit>
I [04/Sep/2006:15:41:35 +0200] <Limit Pause-Printer Resume-Printer Set-Printer-Attributes Enable-Printer Disable-Printer Pause-Printer-After-Current-Job Hold-New-Jobs Release-Held-New-Jobs Deactivate-Printer Activate-Printer Restart-Printer Shutdown-Printer Startup-Printer Promote-Job Schedule-Job-After CUPS-Add-Printer CUPS-Delete-Printer CUPS-Add-Class CUPS-Delete-Class CUPS-Accept-Jobs CUPS-Reject-Jobs CUPS-Set-Default>
I [04/Sep/2006:15:41:35 +0200] Order Deny,Allow
I [04/Sep/2006:15:41:35 +0200] AuthType Basic
I [04/Sep/2006:15:41:35 +0200] Require user @SYSTEM
I [04/Sep/2006:15:41:35 +0200] </Limit>
I [04/Sep/2006:15:41:35 +0200] <Limit All>
I [04/Sep/2006:15:41:35 +0200] Order Deny,Allow
I [04/Sep/2006:15:41:35 +0200] </Limit>
I [04/Sep/2006:15:41:35 +0200] </Policy>
I [04/Sep/2006:15:41:35 +0200] Full reload is required.
I [04/Sep/2006:15:41:35 +0200] Loaded MIME database from '/etc/cups': 0 types, 0 filters...
W [04/Sep/2006:15:41:35 +0200] add_banner: Banner "confidential" ("/usr/share/cups/banners/confidential") is of an unknown file type - skipping!
W [04/Sep/2006:15:41:35 +0200] add_banner: Banner "classified" ("/usr/share/cups/banners/classified") is of an unknown file type - skipping!
W [04/Sep/2006:15:41:35 +0200] add_banner: Banner "standard" ("/usr/share/cups/banners/standard") is of an unknown file type - skipping!
W [04/Sep/2006:15:41:35 +0200] add_banner: Banner "secret" ("/usr/share/cups/banners/secret") is of an unknown file type - skipping!
W [04/Sep/2006:15:41:35 +0200] add_banner: Banner "unclassified" ("/usr/share/cups/banners/unclassified") is of an unknown file type - skipping!
W [04/Sep/2006:15:41:35 +0200] add_banner: Banner "topsecret" ("/usr/share/cups/banners/topsecret") is of an unknown file type - skipping!
I [04/Sep/2006:15:41:35 +0200] Loading job cache file "/var/cache/cups/job.cache"...
I [04/Sep/2006:15:41:35 +0200] Full reload complete.
I [04/Sep/2006:15:41:35 +0200] Listening to 127.0.0.1:631 on fd 2...
I [04/Sep/2006:15:41:35 +0200] Listening to /var/run/cups/cups.sock on fd 3...

mfG.

2

04.09.2006, 16:07

Hallo sr,

> alle Felder bis auf die letzten beiden ausgegraut/ghosted.

genau das gleiche hatte ich heute Vormittag auch.

Du kannst mal mit dem Befehl "dpkg -l | grep cups" schauen,
welche Version von cups du installiert hast.

Mir ist aufgefallen, dass Knoppix von Haus aus cups 1.1.23-15 installiert hat.
Ich hatte durch Updates cups 1.2.2-2 installiert. Damit trat dann das
Problem auf.

Ich weiss aber nicht, ob und wie man z.B. mit apt-get eine bestimmte
Version von cups installieren kann, also z.B.
apt-get install cups --version 1.1.23-15

Tschuess
Karl

Anonymous

unregistriert

3

04.09.2006, 16:46

Ja, die 1.2.2-2 habe ich jetzt auch installiert. Man kann wohl ?ltere Version bei apt-get "festpinnen" indem man /etc/apt/preferences editiert.

4

04.09.2006, 17:50

Zitat von »"schock"«


Ich weiss aber nicht, ob und wie man z.B. mit apt-get eine bestimmte
Version von cups installieren kann, also z.B.
apt-get install cups --version 1.1.23-15

Muesste so gehen:

apt-get install cups=1.1.23-15

5

04.09.2006, 18:25

Hallo Brack,

> apt-get install cups=1.1.23-15

Danke. Im Prinzip ist das offensichtlich der Weg, aber

"apt-get install cupsys=1.1.23-15" ergibt "version 1.1.23-15 for cupsys was not found"

"apt-get install cupsys=1.2.2-2" geht.

Tschuess
Karl

6

04.09.2006, 18:51

Hi,

ich bin nicht sicher, ob es wirklich an cups liegt.
Bei mir druckt er mit dieser version.

Gruss Guido

Anonymous

unregistriert

7

04.09.2006, 19:02

@ schock

'apt-cache policy cupsys' zeigt dir die verf?gbaren Versionen, die kannst Du mit 'apt-get install xxx' installieren aber bei mir happerts dann an anderen Modulen von cups (wegen die Abh?ngigkeiten).

8

04.09.2006, 22:19

Hallo,

> ich bin nicht sicher, ob es wirklich an cups liegt.

oh je, Guido scheint recht zu haben.

> Bei mir druckt er mit dieser version.

Ich habe gerade nochmal testweise bei einer Live-CD mit
apt-get die ganzen cups Pakete auf 1.2.2-2 gebracht und
hier geht die Druckerkonfiguration jetzt auch.

> 'apt-cache policy cupsys' zeigt dir die verf?gbaren Versionen

Ja, aber nach dem Upgrade auf 1.2.2-2 wird 1.1.23-15 nicht
mehr angzeigt. Also ist doch dann ein Downgrade von 1.2.2-2
auf 1.1.23-15 nicht moeglich.

Tschuess
Karl

9

05.09.2006, 08:43

Hi,

@Karl

>> oh je ......

so schlimm ist das doch nicht, wenn der guido mal Recht hat ;)

Gruss Guido

10

05.09.2006, 09:41

Hallo Guido,

> so schlimm ist das doch nicht, wenn der guido mal Recht hat ;-)

nein, das sei dem guido gegoennt. :-)

Aber dass ich sr auf eine falsche Faehrte geschickt habe, ist bloed.

Tschuess
Karl

Anonymous

unregistriert

11

05.09.2006, 10:14

Es mu? wohl aber etwas damit zu tun haben, da? durch ein Update von 'digikam' alte CUPS Pakete entfernt werden und neue Versionen installiert.

Anonymous

unregistriert

12

05.09.2006, 11:02

Habe mal knoppix 5.0 frisch von DVD installiert, dann apt-get update && apt-get install cupsys. Im error_log steht wieder die gleiche Fehlermeldung, wie im ersten Beitrag. Der Aufruf von localhost:631 bringt wieder den Quelltext der CUPS Startseite hervor und zus?tzlich meldet cupsconfig, da? die Liste der Drucker nicht angefordert werden konnte, da irgendwas mit dem server nicht in Ordnung sei (das ist jetzt neu).

13

05.09.2006, 17:37

Hallo sr,

> dann apt-get update && apt-get install cupsys

hast du danach auch noch die anderen cups-Pakete, die "dpkg -l | grep cups"
anzeigt auf 1.2.2-2 aktualisiert?

> Im error_log steht wieder die gleiche Fehlermeldung, wie im ersten Beitrag

Was ist fuer dich die Fehlermeldung? Fuer mich sind das keine
Fehlermeldungen. Am Zeilenanfang steht z.B. immer ein I, N ode W.
Das interpretiere ich als Information, Notification und Warning,
aber nicht als Error.

Tschuess
Karl

Anonymous

unregistriert

14

05.09.2006, 18:11

Vorher:
ii cupsconfig-knoppix 0.5-9 Minimalistic cups configuration script for KNO
ii cupsys 1.1.23-12 Common UNIX Printing System(tm) - server
ii cupsys-bsd 1.1.23-12 Common UNIX Printing System(tm) - BSD commands
ii cupsys-client 1.1.23-12 Common UNIX Printing System(tm) - client progr
ii gnome-cups-manager 0.25-2.1 CUPS printer admin tool for GNOME
ii libcupsimage2 1.1.23-12 Common UNIX Printing System(tm) - image libs
ii libcupsys2 1.1.23-12 Common UNIX Printing System(tm) - libs
ii libcupsys2-dev 1.1.23-12 Common UNIX Printing System(tm) - development
ii libcupsys2-gnutls10 1.1.23-12 Common UNIX Printing System(tm) - dummy libs f
ii libgnomecups1.0-1 0.2.2-1 GNOME library for CUPS interaction
ii libgnomecupsui1.0-1 0.25-2.1 UI extensions to libgnomecups


Nachher:
ii cupsconfig-knoppix 0.5-9 Minimalistic cups configuration script for KNO
ii cupsys 1.2.2-2 Common UNIX Printing System(tm) - server
ii cupsys-bsd 1.2.2-2 Common UNIX Printing System(tm) - BSD commands
ii cupsys-client 1.2.2-2 Common UNIX Printing System(tm) - client progr
ii cupsys-common 1.2.2-2 Common UNIX Printing System(tm) - common files
ii gnome-cups-manager 0.31-2 CUPS printer admin tool for GNOME
ii libcupsimage2 1.2.2-2 Common UNIX Printing System(tm) - image libs
ii libcupsys2 1.2.2-2 Common UNIX Printing System(tm) - libs
ii libcupsys2-dev 1.2.2-2 Common UNIX Printing System(tm) - development
ii libcupsys2-gnutls10 1.2.2-2 Common UNIX Printing System(tm) - dummy libs f
ii libgnomecups1.0-1 0.2.2-5 GNOME library for CUPS interaction
rc libgnomecupsui1.0-1 0.25-2.1 UI extensions to libgnomecups
ii libgnomecupsui1.0-1c2a 0.31-2 UI extensions to libgnomecups

Mit 'Fehler' meinte ich nat?rlich die Warnungen.

15

05.09.2006, 18:35

Hallo sr,

> Nachher:
> ii cupsconfig-kno...

ich finde, das sieht gut aus.

> Mit 'Fehler' meinte ich nat?rlich die Warnungen.

Die Warnungen bezueglich der Bannerseiten sind wohl nicht so wild.
Diese Bannerseiten hat cups dann eben nicht im Angebot.

Tschuess
Karl

Anonymous

unregistriert

16

05.09.2006, 18:44

Die Warnungen sollte aber eigentlich nicht auftreten und auch das 0 Mimetype und 0 Filters ist doch etwas merkw?rdig. Als Installationstyp hatte ich ?brigens debian-like gew?hlt. Bleib nur die Frage, wieso funktioniert das einfach nicht? Da mu? ich mich entscheiden, entweder will ich drucken oder die Digikam benutzen ;-)

Anonymous

unregistriert

17

13.10.2006, 22:11

Ich hatte das gleiche Problem,

bei mir hat geholfen:

- cups deinstallieren (nicht mit apt-get remove) sondern dpkg --purge, das ist wichtig, weil damit auch alle Konfigurationsdateien entfernt werden.

- cups, foomatic sowie Treiber ppd Dateien neu installieren mittels apt-get

- Danach hatte ich bei der Druckereinrichtung Probleme, weil der "Drucker amParallelport nicht sichtbar war", gel?st durch chmod 0660 /dev/lpt0

Cups funktioniert jetzt wieder.

Auf keinen Fall irgendeine Software mittels KPackage, Synaptic oder Adept etc. installieren,
sondern ausschlie?lich auf der Konsole arbeiten mittels apt bzw. dpkg, ansonsten sind solche Probleme praktisch vorprogrammiert. Habe ich leider auch zu sp?t erfahren. Softwareinstallation mittels apt ist seitdem noch nicht einmal schiefgegangen.

Anonymous

unregistriert

18

13.10.2006, 23:27

Ah! Danke. Jetzt funktioniert's korrekt :-)

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop