22.04.2019, 15:02 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

17.03.2008, 13:52

Probleme bei Flash-Plugin Installation unter 5.1

Seit einiger Zeit nutze ich Knoppix (5.1er ISO) mit VMplayer (Host XP) rein zum Surfen und ein Ubuntu-Lifesystem zum Üben unter Linux.
Ich möchte Knoppix wegen des RAM-Systems generell als Surfbasis nutzen.
Zwingend benötige ich jedoch das Flash-Plugin und evtl. noch ein Anonymisierungtool wie zB. TOR.

Meine zwei unterschiedlichen Versuche den Linux-Download (rpm-Datei) zu installieren scheiterten kläglich. Einmal den einfachen Weg über den Aufruf unter Icewiesel, sowie den Installationsversuch über die Befehlszeile.
Beide Male erhielt ich folgende Rückmeldung:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
</tmp/flash-plugin-9.0.115.0-release.i386.rpm';echo RESULT=$?
Fehler: Failed dependencies:
    /bin/bash is needed by flash-plugin-9.0.115.0-release.i386
    /bin/sh is needed by flash-plugin-9.0.115.0-release.i386
    libX11.so.6 is needed by flash-plugin-9.0.115.0-release.i386
    libXext.so.6 is needed by flash-plugin-9.0.115.0-release.i386
    libXt.so.6 is needed by flash-plugin-9.0.115.0-release.i386
    libc.so.6 is needed by flash-plugin-9.0.115.0-release.i386
    libc.so.6(GCC_3.0) is needed by flash-plugin-9.0.115.0-release.i386
    libc.so.6(GLIBC_2.0) is needed by flash-plugin-9.0.115.0-release.i386
    libc.so.6(GLIBC_2.1) is needed by flash-plugin-9.0.115.0-release.i386
    libc.so.6(GLIBC_2.1.3) is needed by flash-plugin-9.0.115.0-release.i386
    libc.so.6(GLIBC_2.2) is needed by flash-plugin-9.0.115.0-release.i386
    libc.so.6(GLIBC_2.3) is needed by flash-plugin-9.0.115.0-release.i386
    libdl.so.2 is needed by flash-plugin-9.0.115.0-release.i386
    libdl.so.2(GLIBC_2.0) is needed by flash-plugin-9.0.115.0-release.i386
    libdl.so.2(GLIBC_2.1) is needed by flash-plugin-9.0.115.0-release.i386
    libfontconfig.so.1 is needed by flash-plugin-9.0.115.0-release.i386
    libfreetype.so.6 is needed by flash-plugin-9.0.115.0-release.i386
    libglib-2.0.so.0 is needed by flash-plugin-9.0.115.0-release.i386
    libgobject-2.0.so.0 is needed by flash-plugin-9.0.115.0-release.i386
    libgtk-x11-2.0.so.0 is needed by flash-plugin-9.0.115.0-release.i386
    libm.so.6 is needed by flash-plugin-9.0.115.0-release.i386
    libm.so.6(GLIBC_2.0) is needed by flash-plugin-9.0.115.0-release.i386
    libpthread.so.0 is needed by flash-plugin-9.0.115.0-release.i386
    libpthread.so.0(GLIBC_2.0) is needed by flash-plugin-9.0.115.0-release.i386
    libpthread.so.0(GLIBC_2.1) is needed by flash-plugin-9.0.115.0-release.i386
    libpthread.so.0(GLIBC_2.2) is needed by flash-plugin-9.0.115.0-release.i386
    libpthread.so.0(GLIBC_2.2.3) is needed by flash-plugin-9.0.115.0-release.i386
    libpthread.so.0(GLIBC_2.3.2) is needed by flash-plugin-9.0.115.0-release.i386
RESULT=1

Als Linux-Einsteiger stehe ich dem ziemlich ratlos gegenüber.
Was ist hier schiefgelaufen, oder wird hier vorher noch einiges andere benötigt? bzw. wie muß ich hier im vorgehen, wenn möglich bitte etwas im Deatail.

Gibt es für eine TOR-Nachinstallation evtl. auch ein kleines Howto für Einsteiger?

Noch zum Abschluß - wenn dies also installiert sein sollte möchte ich dies natürlich resistent haben.
Remastering dürfte wohl relativ schwierig für mich werden - kann ich dies auch über Knoppix -> Konfiguration -> "Permanentes Knoppix-Iso einrichten" einfacher erledigen? Und was ist das Nachteilige hierbei?

Gruß strolchi

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »strolchi« (17.03.2008, 13:57)


2

17.03.2008, 14:09

apt-get update

apt-get install flashplayer-mozilla

Gruß

3

17.03.2008, 15:53

Zitat

apt-get update
apt-get install flashplayer-mozilla
Danke guido17 für die Zeilen - aber als Linux-Einsteiger kann ich leider nichts damit anfangen..... ?(
Eine Kurzinfo was ich wo mit diesen Befehlen soll wäre sehr hifreich.....
Was habe ich bei meiner Installation falsch gemacht? oder war es falsche Flash-Plugin?
Ich stehe vollkommen im Wald...

Gruß strolchi

4

17.03.2008, 16:39

Hi,

sry - ich war eben a bisserl zwischen Tür und Angel.... ;)

Also ein fach bei bestehender Internetverbindung eine root-konsole öffnen ( strg-alt-F1 zurück mit strg-alt-F5 / F7 )
und die beiden Befehle nacheinander reintippen. Dazwischen natürlich enter *duck*

Gruß

5

17.03.2008, 17:44

Hi,

Danke -kein Problem :D
Ich hatte mir schon so etwas gedacht und zwiscchenzeitlich unter root diese beiden Zeilen mal mehrfach durchgespielt.....
Also zuerst mit "apt-get update" ein allg Update veranlaßt, damit die Basis ok ist....
Dann mit der Zeile "apt-get install flashplayer-mozilla" offensichtlich die eigentliche Installation des Plugins angestoßen.
Richtig verstanden...?
Ist auch einiges abgelaufen, jedoch ohne den gewünschten Erfolg.

Das Update wird nicht korrekt ausgeführt, mehrfaches "Packages Not Found" bzw. "...öffentlicher Schlüssel nicht verfügbar...." mit dem Hinweis doch
"opt-get update" einzugeben - was ich soeben gerade getan hatte.
Die Install. des Plugins gelang ebenfalls nicht - "Das Paket ist nicht verfügbar....." sowie"Paket flashplayer-mozilla hat keinen Installationskanditaten"

Was könnte ich alternativ noch tun...?

Gruß strolchi

6

17.03.2008, 18:28

Hi,
schnell im Nachgang eine Erfolgsmeldung.
Ein weiterer Test mit dem ...flashplugin-nonfree statt des ...flashplayer-mozilla hatte Erfolg - Der Browser spielt Flash ab... :thumbsup:

Nun zu meinem weiteren Problem - diese Installation resistent machen, wie schon angesprochen.
Sollte ich dies über Knoppix -> Konfiguration -> "Permanentes Knoppix-Iso einrichten" erledigen? Oder muß ich den komplexeren Weg über Remastering wählen?
Dann noch zu einer Anonymisierung wie zB. TOR - gibt es hierfür auch schon eine solch einfache Installation wie vor?
Wo kann man eigentlich diese Installationspakete finden?

Wenn Du mir da noch helfen könntest wäre das klasse.. :D

Gruß strolchi

7

17.03.2008, 20:25

Hi,

Pakete findest Du per apt.

Mit "apt-cache search Name" in unserem Fall wäre das "apt-cache search flash".

Ein apt-get update bringt Dich auf den aktuellen Stand - sollte man also zuerst machen.

Mit dem Speichern der Einstellungen - Versuch macht klug - soll heissen: Weiß ich nicht ;)

Mit dem tool zum anonymen surfen - brauch ich ned - hab keine Geheimnisse.... :)

Gruß

8

18.03.2008, 00:19

Danke Dir für die schnelle Hilfe.

Tja mit dem probieren ist das so eine Sache, bislang konnte ich einfach kein permanentes iso abspeichern - immer diverse Fehlermeldungen. :?: Werde halt weiter testen...

Wegen der Geheimnisse, darum geht es mir hierbei nicht. Ich gestatte es den Staatsorganen nicht mich als pauschal Verdächtigen zu behandeln. Mit wem ich korrespondiere geht grundsätzlich niemand etwas an. ;) (Unsere schlimme Vergangenheit ist mir eben noch sehr präsent...)

Gruß strolchi

9

16.03.2009, 16:25

ich habe das gleiche problem und wenn ich das mache was da steht dann kommt da libc6 configuring also son garaues schild und dann geht es nicht mehr weiter
lg Paul

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop