22.05.2018, 05:50 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

24.06.2009, 18:32

kann Perl-Skript nicht ausführen

Hi ihr Knoppix profis!

Ich hbae hier ein Skript von OzymanDNS (skript "nomde.pl")

wenn ich nun folgendes (als root) eingebe

./nomde.pl

bekomme ich folgende Fehlermeldung:

Can't locate Net/DNS.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.10.0 /usr/local/share/perl/5.10.0 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl .) at ./nomde.pl line 6.
BEGIN failed--compilation aborted at ./nomde.pl line 6.


woran liegt das?

Meine Knoppix-Vers ist 6,0,1 DE
hab den quellcode angehängt

Liebe Grüsse
»Barracuda« hat folgende Datei angehängt:
  • quell.txt (10,37 kB - 1 mal heruntergeladen - zuletzt: 25.06.2009, 22:20)

klaus2008

Meister

Beiträge: 2 680

Geschlecht: Männlich

2

24.06.2009, 19:32

Dir fehlt wohl das Paket libnet-dns-perl. Das (und weitere Perl-Pakete) lässt sich mittels der Synaptic Paketverwaltung nachinstallieren. http://packages.debian.org/de/sid/i386/l…s-perl/filelist

Gruss Klaus

3

24.06.2009, 23:41

okay danke, hab nun mit aptitude alle packages nachinstalliert. Aber hier weis ich nicht weiter (also weis nicht welches package mir fehlt)

Can't locate LWP/UserAgent.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.10.0 /usr/local/share/perl/5.10.0 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl .) at ./nomde.pl line 9

welches package ist das?

liebe grüsse

klaus2008

Meister

Beiträge: 2 680

Geschlecht: Männlich

4

25.06.2009, 08:23

libwww-perl sollte es sein. http://packages.debian.org/de/sid/all/libwww-perl/filelist
Auf der Seite http://packages.debian.org/de/sid/libwww-perl gibt es eine Suchfunktion, die auch nach dem Paketinhalt suchen kann. Einfach den Namen der fehlenden .pm eingeben und suchen lassen.

Gruss Klaus

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop