26.09.2018, 01:48 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

14.11.2010, 00:26

Python-Paketprobleme

Hallo!
Bin relativer Neuling bei Knoppix.

Wollte jetzt Anki installieren. Dafür muss aber Python installiert sein, was er offensichtlich nicht möchte. Das Problem ist jetzt, dass apt-get nicht mehr funktioniert, solange die Paketprobleme nicht gelöst sind. Habe es schon über apt-get -f install versucht. Ausgaben:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
root@Microknoppix:~# apt-get -f install
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut   	
Status-Informationen einlesen... Fertig
Abhängigkeiten werden korrigiert... Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht länger benötigt:
  libdb4.5
Verwenden Sie »apt-get autoremove«, um sie zu entfernen.
Die folgenden zusätzlichen Pakete werden installiert:
  python2.6-minimal
Vorgeschlagene Pakete:
  binfmt-support
Die folgenden NEUEN Pakete werden installiert:
  python2.6-minimal
0 aktualisiert, 1 neu installiert, 0 zu entfernen und 755 nicht aktualisiert.
22 nicht vollständig installiert oder entfernt.
Es müssen noch 0B von 1.423kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 5.005kB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren [J/n]? j
(Lese Datenbank ... 94813 Dateien und Verzeichnisse sind derzeit installiert.)
Entpacke python2.6-minimal (aus .../python2.6-minimal_2.6.6-6_i386.deb) ...
new installation of python2.6-minimal; /usr/lib/python2.6/site-packages is a directory
which is expected a symlink to /usr/local/lib/python2.6/dist-packages.
please find the package shipping files in /usr/lib/python2.6/site-packages and
file a bug report to ship these in /usr/lib/python2.6/dist-packages instead
aborting installation of python2.6-minimal
dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/python2.6-minimal_2.6.6-6_i386.deb (--unpack):
 Unterprozess neues pre-installation-Skript gab den Fehlerwert 1 zurück
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/python2.6-minimal_2.6.6-6_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


Daraufhin habe ich also versucht, anki zu deinstallieren (über apt-get remove anki). Die Fehlerangabe ist die gleiche.

Das Gleiche passiert, wenn ich über die Synaptic-Paketverwaltung gehe. Es gibt zwei fehlerhafte Pakete und ich kann sie weder deinstallieren/löschen, noch reparieren, sodass ich auch nichts anderes (Paket o.ä.) runterladen kann.

Hatte einer von euch schonmal ähnliche Probleme und/oder kann helfen?
MfG,
Laudatuse

klaus2008

Meister

Beiträge: 2 695

Geschlecht: Männlich

2

14.11.2010, 08:07

Hallo!

Das Problem, dass sich python2.6 nicht installieren lässt, habe ich auch schon gehabt. Die Lösung ist etwas umständlich.

Im folgenden wird versucht, die Knoppix 6.2.1 CD um das Paket anki zu ergänzen. Aus dem vorherigen Beitrag wissen wir, dass im Verlauf der Installation python2.6 installiert werden soll. Das scheitert an einem Paket, welches zu Compiz gehört, wie wir noch sehen werden. Damit Compiz aktualisiert werden kann, ist es am besten, wenn Compiz nicht läuft. Dazu wird am Bootprompt den Cheatcode no3d verwendet

Quellcode

1
knoppix no3d


Zuerst wird der Wert für APT::Cache-Limit heraufgesetzt, damit die Paketverwaltung ordentlich arbeitet

Quellcode

1
2
3
root@Microknoppix:/home/knoppix# nano -w /etc/apt/apt.conf.d/11cache-limit
root@Microknoppix:/home/knoppix# cat /etc/apt/apt.conf.d/11cache-limit 
APT::Cache-Limit "50331648";

Jetzt folgen einige Zeilen, die den vergeblichen Versuch dokumentieren, das Paket anki aus dem stable-Zweig zu installieren.

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
root@Microknoppix:/home/knoppix# apt-get update
Hole:1 http://ftp.de.debian.org stable Release.gpg [1.033B]
OK   http://ftp.de.debian.org stable/main Translation-de                       
Ign http://ftp.de.debian.org stable/contrib Translation-de                     
Ign http://ftp.de.debian.org stable/non-free Translation-de                    
Hole:2 http://ftp.de.debian.org testing Release.gpg [835B]                     
Hole:3 http://ftp.de.debian.org testing/main Translation-de [1.469kB]          
Ign http://debian-knoppix.alioth.debian.org ./ Release.gpg                     
Ign http://debian-knoppix.alioth.debian.org ./ Translation-de                  
Hole:4 http://volatile.debian.org stable/volatile Release.gpg [481B]           
Hole:5 http://security.debian.org stable/updates Release.gpg [835B]            
Ign http://volatile.debian.org stable/volatile/main Translation-de             
Ign http://security.debian.org stable/updates/main Translation-de              
Ign http://volatile.debian.org stable/volatile/contrib Translation-de          
Ign http://security.debian.org stable/updates/contrib Translation-de           
Ign http://volatile.debian.org stable/volatile/non-free Translation-de         
Ign http://debian-knoppix.alioth.debian.org ./ Release                         
Ign http://security.debian.org stable/updates/non-free Translation-de          
Hole:6 http://security.debian.org testing/updates Release.gpg [835B]           
Ign http://security.debian.org testing/updates/main Translation-de             
Ign http://security.debian.org testing/updates/contrib Translation-de          
Ign http://security.debian.org testing/updates/non-free Translation-de         
Ign http://debian-knoppix.alioth.debian.org ./ Packages/DiffIndex              
Ign http://debian-knoppix.alioth.debian.org ./ Packages                        
Ign http://debian-knoppix.alioth.debian.org ./ Packages                        
Hole:7 http://volatile.debian.org stable/volatile Release [40,7kB]             
Hole:8 http://security.debian.org stable/updates Release [40,8kB]              
Hole:9 http://debian-knoppix.alioth.debian.org ./ Packages [13,6kB]            
Hole:10 http://security.debian.org testing/updates Release [44,6kB]            
Ign http://volatile.debian.org stable/volatile/main Packages/DiffIndex         
Ign http://security.debian.org stable/updates/main Packages/DiffIndex          
Ign http://security.debian.org stable/updates/contrib Packages/DiffIndex       
Ign http://security.debian.org stable/updates/non-free Packages/DiffIndex      
Ign http://volatile.debian.org stable/volatile/contrib Packages/DiffIndex      
Ign http://security.debian.org testing/updates/main Packages/DiffIndex         
Ign http://volatile.debian.org stable/volatile/non-free Packages/DiffIndex     
Ign http://security.debian.org testing/updates/contrib Packages/DiffIndex      
Ign http://security.debian.org testing/updates/non-free Packages/DiffIndex     
Hole:11 http://volatile.debian.org stable/volatile/main Packages [7.843B]      
Hole:12 http://volatile.debian.org stable/volatile/contrib Packages [14B]      
Hole:13 http://volatile.debian.org stable/volatile/non-free Packages [791B]    
Hole:14 http://security.debian.org stable/updates/main Packages [340kB]        
Hole:15 http://security.debian.org stable/updates/contrib Packages [14B]       
Hole:16 http://security.debian.org stable/updates/non-free Packages [14B]      
Hole:17 http://security.debian.org testing/updates/main Packages [46,9kB]      
Hole:18 http://security.debian.org testing/updates/contrib Packages [14B]      
Hole:19 http://security.debian.org testing/updates/non-free Packages [14B]     
Ign http://ftp.de.debian.org testing/contrib Translation-de                    
Ign http://ftp.de.debian.org testing/non-free Translation-de                   
Hole:20 http://ftp.de.debian.org unstable Release.gpg [835B]                   
Hole:21 http://ftp.de.debian.org unstable/main Translation-de [1.505kB]        
Ign http://ftp.de.debian.org unstable/contrib Translation-de                   
Ign http://ftp.de.debian.org unstable/non-free Translation-de                  
Hole:22 http://ftp.de.debian.org experimental Release.gpg [835B]               
Ign http://ftp.de.debian.org experimental/main Translation-de                  
Ign http://ftp.de.debian.org experimental/contrib Translation-de               
Ign http://ftp.de.debian.org experimental/non-free Translation-de              
Hole:23 http://ftp.de.debian.org stable Release [73,8kB]                       
Hole:24 http://ftp.de.debian.org testing Release [89,9kB]                      
Hole:25 http://ftp.de.debian.org unstable Release [104kB]                      
Hole:26 http://ftp.de.debian.org experimental Release [103kB]                  
Ign http://ftp.de.debian.org stable/main Packages/DiffIndex                    
Ign http://ftp.de.debian.org stable/contrib Packages/DiffIndex                 
Ign http://ftp.de.debian.org stable/non-free Packages/DiffIndex                
Hole:27 http://ftp.de.debian.org testing/main Packages/DiffIndex [2.038B]      
Hole:28 http://ftp.de.debian.org testing/contrib Packages/DiffIndex [2.023B]   
Hole:29 http://ftp.de.debian.org testing/non-free Packages/DiffIndex [2.023B]  
Hole:30 http://ftp.de.debian.org unstable/main Packages/DiffIndex [2.038B]     
Hole:31 http://ftp.de.debian.org unstable/contrib Packages/DiffIndex [2.023B]  
Hole:32 http://ftp.de.debian.org unstable/non-free Packages/DiffIndex [2.023B] 
Hole:33 http://ftp.de.debian.org stable/main Packages [5.194kB]                
Hole:34 http://ftp.de.debian.org stable/contrib Packages [76,2kB]              
Hole:35 http://ftp.de.debian.org stable/non-free Packages [100kB]              
Hole:36 http://ftp.de.debian.org testing/main Packages [6.603kB]               
Hole:37 http://ftp.de.debian.org testing/contrib Packages [54,6kB]             
Hole:38 http://ftp.de.debian.org testing/non-free Packages [111kB]             
Hole:39 http://ftp.de.debian.org experimental/main Packages/DiffIndex [2.023B] 
Hole:40 http://ftp.de.debian.org experimental/contrib Packages/DiffIndex [2.023B]
Hole:41 http://ftp.de.debian.org experimental/non-free Packages/DiffIndex [2.023B]
Hole:42 http://ftp.de.debian.org unstable/main Packages [6.919kB]              
Hole:43 http://ftp.de.debian.org unstable/main Packages [6.919kB]              
Hole:44 http://ftp.de.debian.org unstable/contrib Packages [61,2kB]            
Hole:45 http://ftp.de.debian.org unstable/non-free Packages [121kB]            
Hole:46 http://ftp.de.debian.org experimental/main Packages [616kB]            
Hole:47 http://ftp.de.debian.org experimental/contrib Packages [4.861B]        
Hole:48 http://ftp.de.debian.org experimental/non-free Packages [10,6kB]       
Es wurden 23,2MB in 4Min 15s geholt (90,7kB/s)                                 
Paketlisten werden gelesen... Fertig
root@Microknoppix:/home/knoppix# apt-get install anki
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut       
Status-Informationen einlesen... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder dass, wenn Sie die
Unstable-Distribution verwenden, einige erforderliche Pakete noch nicht
erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben nicht-erfüllte Abhängigkeiten:
  anki: Hängt ab: python-qt4 (>= 4.4) soll aber nicht installiert werden
        Empfiehlt: python-matplotlib soll aber nicht installiert werden
E: Kaputte Pakete
root@Microknoppix:/home/knoppix# apt-get install anki python-qt4
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut       
Status-Informationen einlesen... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder dass, wenn Sie die
Unstable-Distribution verwenden, einige erforderliche Pakete noch nicht
erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben nicht-erfüllte Abhängigkeiten:
  python-qt4: Hängt ab: libqt4-assistant (>= 4.4.0) soll aber nicht installiert werden
              Hängt ab: libqt4-help (>= 4.4.0) soll aber nicht installiert werden
              Hängt ab: libqt4-svg (>= 4.4.0) soll aber nicht installiert werden
              Hängt ab: libqt4-test (>= 4.4.0) soll aber nicht installiert werden
              Hängt ab: libqt4-webkit (>= 4.4.0) soll aber nicht installiert werden
              Hängt ab: libqt4-xmlpatterns (>= 4.4.0) soll aber nicht installiert werden
E: Kaputte Pakete
root@Microknoppix:/home/knoppix# apt-get install anki python-qt4 libqt4-assistant libqt4-help libqt4-svg libqt4-test libqt4-webkit libqt4-xmlpatterns 
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut       
Status-Informationen einlesen... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder dass, wenn Sie die
Unstable-Distribution verwenden, einige erforderliche Pakete noch nicht
erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben nicht-erfüllte Abhängigkeiten:
  libqt4-assistant: Hängt ab: libqt4-network (= 4.4.3-1+lenny1) aber 4:4.5.3-4 soll installiert werden
                    Hängt ab: libqtcore4 (= 4.4.3-1+lenny1) aber 4:4.5.3-4 soll installiert werden
  libqt4-help: Hängt ab: libqt4-network (= 4.4.3-1+lenny1) aber 4:4.5.3-4 soll installiert werden
               Hängt ab: libqt4-sql (= 4.4.3-1+lenny1) aber 4:4.5.3-4 soll installiert werden
               Hängt ab: libqtcore4 (= 4.4.3-1+lenny1) aber 4:4.5.3-4 soll installiert werden
               Hängt ab: libqtgui4 (= 4.4.3-1+lenny1) aber 4:4.5.3-4 soll installiert werden
  libqt4-svg: Hängt ab: libqtcore4 (= 4.4.3-1+lenny1) aber 4:4.5.3-4 soll installiert werden
              Hängt ab: libqtgui4 (= 4.4.3-1+lenny1) aber 4:4.5.3-4 soll installiert werden
  libqt4-test: Hängt ab: libqtcore4 (= 4.4.3-1+lenny1) aber 4:4.5.3-4 soll installiert werden
  libqt4-webkit: Hängt ab: libqt4-network (= 4.4.3-1+lenny1) aber 4:4.5.3-4 soll installiert werden
                 Hängt ab: libqtcore4 (= 4.4.3-1+lenny1) aber 4:4.5.3-4 soll installiert werden
                 Hängt ab: libqtgui4 (= 4.4.3-1+lenny1) aber 4:4.5.3-4 soll installiert werden
  libqt4-xmlpatterns: Hängt ab: libqt4-network (= 4.4.3-1+lenny1) aber 4:4.5.3-4 soll installiert werden
                      Hängt ab: libqtcore4 (= 4.4.3-1+lenny1) aber 4:4.5.3-4 soll installiert werden
  python-qt4: Hängt ab: libqt4-designer (>= 4.4.0) soll aber nicht installiert werden
              Hängt ab: libqt4-script (>= 4.4.0) soll aber nicht installiert werden
E: Kaputte Pakete
root@Microknoppix:/home/knoppix# apt-get install anki python-qt4 libqt4-assistant libqt4-help libqt4-svg libqt4-test libqt4-webkit libqt4-xmlpatterns libqt4-network libqtcore4 libqt4-sql libqtgui4 libqt4-designer libqt4-script 
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut       
Status-Informationen einlesen... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder dass, wenn Sie die
Unstable-Distribution verwenden, einige erforderliche Pakete noch nicht
erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben nicht-erfüllte Abhängigkeiten:
  libqt4-assistant: Hängt ab: libqt4-network (= 4.4.3-1+lenny1) aber 4:4.6.3-4 soll installiert werden
                    Hängt ab: libqtcore4 (= 4.4.3-1+lenny1) aber 4:4.6.3-4 soll installiert werden
  libqt4-help: Hängt ab: libqt4-network (= 4.4.3-1+lenny1) aber 4:4.6.3-4 soll installiert werden
               Hängt ab: libqt4-sql (= 4.4.3-1+lenny1) aber 4:4.6.3-4 soll installiert werden
               Hängt ab: libqtcore4 (= 4.4.3-1+lenny1) aber 4:4.6.3-4 soll installiert werden
               Hängt ab: libqtgui4 (= 4.4.3-1+lenny1) aber 4:4.6.3-4 soll installiert werden
  libqt4-svg: Hängt ab: libqtcore4 (= 4.4.3-1+lenny1) aber 4:4.6.3-4 soll installiert werden
              Hängt ab: libqtgui4 (= 4.4.3-1+lenny1) aber 4:4.6.3-4 soll installiert werden
  libqt4-test: Hängt ab: libqtcore4 (= 4.4.3-1+lenny1) aber 4:4.6.3-4 soll installiert werden
  libqt4-webkit: Hängt ab: libqt4-network (= 4.4.3-1+lenny1) aber 4:4.6.3-4 soll installiert werden
                 Hängt ab: libqtcore4 (= 4.4.3-1+lenny1) aber 4:4.6.3-4 soll installiert werden
                 Hängt ab: libqtgui4 (= 4.4.3-1+lenny1) aber 4:4.6.3-4 soll installiert werden
  libqt4-xmlpatterns: Hängt ab: libqt4-network (= 4.4.3-1+lenny1) aber 4:4.6.3-4 soll installiert werden
                      Hängt ab: libqtcore4 (= 4.4.3-1+lenny1) aber 4:4.6.3-4 soll installiert werden
  libqtgui4: Hängt ab: libmng1 (>= 1.0.10) aber 1.0.9-1 soll installiert werden
E: Kaputte Pakete
root@Microknoppix:/home/knoppix# apt-get install anki python-qt4 libqt4-assistant libqt4-help libqt4-svg libqt4-test libqt4-webkit libqt4-xmlpatterns libqt4-network libqtcore4 libqt4-sql libqtgui4 libqt4-designer libqt4-script libqt4-sql libmng1 
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut       
Status-Informationen einlesen... Fertig
libmng1 ist schon die neueste Version.
libmng1 wurde als manuell installiert festgelegt.
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder dass, wenn Sie die
Unstable-Distribution verwenden, einige erforderliche Pakete noch nicht
erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben nicht-erfüllte Abhängigkeiten:
  libqt4-assistant: Hängt ab: libqt4-network (= 4.4.3-1+lenny1) aber 4:4.6.3-4 soll installiert werden
                    Hängt ab: libqtcore4 (= 4.4.3-1+lenny1) aber 4:4.6.3-4 soll installiert werden
  libqt4-help: Hängt ab: libqt4-network (= 4.4.3-1+lenny1) aber 4:4.6.3-4 soll installiert werden
               Hängt ab: libqt4-sql (= 4.4.3-1+lenny1) aber 4:4.6.3-4 soll installiert werden
               Hängt ab: libqtcore4 (= 4.4.3-1+lenny1) aber 4:4.6.3-4 soll installiert werden
               Hängt ab: libqtgui4 (= 4.4.3-1+lenny1) aber 4:4.6.3-4 soll installiert werden
  libqt4-svg: Hängt ab: libqtcore4 (= 4.4.3-1+lenny1) aber 4:4.6.3-4 soll installiert werden
              Hängt ab: libqtgui4 (= 4.4.3-1+lenny1) aber 4:4.6.3-4 soll installiert werden
  libqt4-test: Hängt ab: libqtcore4 (= 4.4.3-1+lenny1) aber 4:4.6.3-4 soll installiert werden
  libqt4-webkit: Hängt ab: libqt4-network (= 4.4.3-1+lenny1) aber 4:4.6.3-4 soll installiert werden
                 Hängt ab: libqtcore4 (= 4.4.3-1+lenny1) aber 4:4.6.3-4 soll installiert werden
                 Hängt ab: libqtgui4 (= 4.4.3-1+lenny1) aber 4:4.6.3-4 soll installiert werden
  libqt4-xmlpatterns: Hängt ab: libqt4-network (= 4.4.3-1+lenny1) aber 4:4.6.3-4 soll installiert werden
                      Hängt ab: libqtcore4 (= 4.4.3-1+lenny1) aber 4:4.6.3-4 soll installiert werden
  libqtgui4: Hängt ab: libmng1 (>= 1.0.10) aber 1.0.9-1 soll installiert werden
E: Kaputte Pakete

Das sieht nun so aus, als ob die Installation unmöglich wäre. Man kann aber apt-get anweisen, den testing/squeeze-Zweig zu verwenden.

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
root@Microknoppix:/home/knoppix# apt-get -t testing install anki python-qt4 libqt4-assistant libqt4-help libqt4-svg libqt4-test libqt4-webkit libqt4-xmlpatterns libqt4-network libqtcore4 libqt4-sql libqtgui4 libqt4-designer libqt4-script libqt4-sql libmng1 
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut       
Status-Informationen einlesen... Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht länger benötigt:
  libdb4.5
Verwenden Sie »apt-get autoremove«, um sie zu entfernen.
Die folgenden zusätzlichen Pakete werden installiert:
  blt gimp gimp-data javascript-common kakasi kakasi-dic libatk1.0-0
  libgail-common libgail18 libgegl-0.0-0 libgimp2.0 libglib2.0-0 libgsf-1-114
  libgsf-1-common libgtk2.0-0 libilmbase6 libjpeg62 libjs-jquery libncursesw5
  libopenexr6 libopenraw1 libphonon4 libpulse-mainloop-glib0 libpulse0
  libpython2.6 libqt4-dbus libqt4-opengl libqt4-qt3support libqt4-scripttools
  libqt4-xml librsvg2-2 librsvg2-bin librsvg2-common libsqlite3-0 libssl0.9.8
  python python-beautifulsoup python-brlapi python-dateutil python-glade2
  python-gtk2 python-matplotlib python-matplotlib-data python-minimal
  python-numpy python-pyparsing python-simplejson python-sip python-sqlalchemy
  python-sqlalchemy-ext python-tk python-tz python2.5 python2.5-minimal
  python2.6 python2.6-minimal qt4-qtconfig tcl8.5 tk8.5 ttf-lyx
  wwwconfig-common
Vorgeschlagene Pakete:
  dvipng blt-demo gimp-help-en gimp-help gimp-data-extras gvfs-backends
  apache2 httpd pulseaudio libqt4-dev python-doc python-profiler
  python-gtk2-doc ipython python-configobj python-excelerator
  python-matplotlib-doc python-scipy python-traits texlive-extra-utils
  texlive-latex-extra python-wxgtk2.8 python-qt3 python-numpy-doc
  python-numpy-dbg python-nose python-dev gfortran python-qt4-dbg
  python-sqlalchemy-doc python-psycopg2 python-mysqldb python-kinterbasdb
  python-pymssql tix python-tk-dbg python2.5-doc binfmt-support python2.6-doc
  python2.6-profiler tclreadline mysql-client postgresql-client apache
  apache-ssl
Empfohlene Pakete:
  libqt4-sql-mysql libqt4-sql-odbc libqt4-sql-psql libqt4-sql-sqlite
  libqt4-sql-sqlite2 libqt4-sql-ibase
Die folgenden Pakete werden ENTFERNT:
  python-sexy
Die folgenden NEUEN Pakete werden installiert:
  anki blt javascript-common kakasi kakasi-dic libilmbase6 libjs-jquery
  libopenexr6 libopenraw1 libphonon4 libpulse-mainloop-glib0 libpython2.6
  libqt4-assistant libqt4-help libqt4-scripttools libqt4-svg libqt4-test
  libqt4-webkit libqt4-xmlpatterns python-beautifulsoup python-dateutil
  python-glade2 python-matplotlib python-matplotlib-data python-pyparsing
  python-qt4 python-simplejson python-sip python-sqlalchemy
  python-sqlalchemy-ext python-tk python-tz python2.6 python2.6-minimal tcl8.5
  tk8.5 ttf-lyx wwwconfig-common
Die folgenden Pakete werden aktualisiert:
  gimp gimp-data libatk1.0-0 libgail-common libgail18 libgegl-0.0-0 libgimp2.0
  libglib2.0-0 libgsf-1-114 libgsf-1-common libgtk2.0-0 libjpeg62 libmng1
  libncursesw5 libpulse0 libqt4-dbus libqt4-designer libqt4-network
  libqt4-opengl libqt4-qt3support libqt4-script libqt4-sql libqt4-xml
  libqtcore4 libqtgui4 librsvg2-2 librsvg2-bin librsvg2-common libsqlite3-0
  libssl0.9.8 python python-brlapi python-gtk2 python-minimal python-numpy
  python2.5 python2.5-minimal qt4-qtconfig
38 aktualisiert, 38 neu installiert, 1 zu entfernen und 768 nicht aktualisiert.
Es müssen 83,3MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 115MB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren [J/n]? 
Hole:1 http://ftp.de.debian.org testing/main libncursesw5 5.7+20100313-4 [373kB]
Hole:2 http://ftp.de.debian.org testing/main libssl0.9.8 0.9.8o-2 [3.027kB]    
Hole:3 http://ftp.de.debian.org testing/main libsqlite3-0 3.7.3-1 [386kB]      
Hole:4 http://ftp.de.debian.org testing/main python-brlapi 4.2-4 [87,7kB]      
Hole:5 http://ftp.de.debian.org testing/main libglib2.0-0 2.24.2-1 [1.029kB]   
Hole:6 http://ftp.de.debian.org testing/main libatk1.0-0 1.30.0-1 [82,4kB]     
Hole:7 http://ftp.de.debian.org testing/main libgail-common 2.20.1-2 [453kB]   
Hole:8 http://ftp.de.debian.org testing/main libgail18 2.20.1-2 [339kB]        
Hole:9 http://ftp.de.debian.org testing/main libjpeg62 6b1-1 [88,0kB]          
Hole:10 http://ftp.de.debian.org testing/main libgtk2.0-0 2.20.1-2 [2.504kB]   
Hole:11 http://ftp.de.debian.org testing/main libgtk2.0-0 2.20.1-2 [2.504kB]   
Hole:12 http://ftp.de.debian.org testing/main librsvg2-common 2.26.3-1 [67,9kB]
Hole:13 http://ftp.de.debian.org testing/main libgsf-1-common 1.14.18-1 [87,7kB]
Hole:14 http://ftp.de.debian.org testing/main libgsf-1-114 1.14.18-1 [156kB]
Hole:15 http://ftp.de.debian.org testing/main librsvg2-2 2.26.3-1 [144kB]      
Hole:16 http://ftp.de.debian.org testing/main librsvg2-bin 2.26.3-1 [71,4kB]   
Hole:17 http://ftp.de.debian.org testing/main gimp 2.6.10-1 [4.532kB]          
Hole:18 http://ftp.de.debian.org testing/main libgimp2.0 2.6.10-1 [1.125kB]    
Hole:19 http://ftp.de.debian.org testing/main gimp-data 2.6.10-1 [11,6MB]      
Hole:20 http://ftp.de.debian.org testing/main gimp-data 2.6.10-1 [11,6MB]      
Hole:21 http://ftp.de.debian.org testing/main python-numpy 1:1.4.1-5 [1.927kB] 
Hole:22 http://ftp.de.debian.org testing/main python-gtk2 2.17.0-4 [1.414kB]   
Hole:23 http://ftp.de.debian.org testing/main libilmbase6 1.0.1-3 [119kB]      
Hole:24 http://ftp.de.debian.org testing/main libopenexr6 1.6.1-4.1 [261kB]    
Hole:25 http://ftp.de.debian.org testing/main libopenraw1 0.0.8-2 [144kB]      
Hole:26 http://ftp.de.debian.org testing/main libgegl-0.0-0 0.0.22-2+b1 [489kB]
Hole:27 http://ftp.de.debian.org testing/main libmng1 1.0.10-1+b1 [214kB]      
Hole:28 http://ftp.de.debian.org testing/main python2.6-minimal 2.6.6-6 [1.423kB]
Hole:29 http://ftp.de.debian.org testing/main python2.6 2.6.6-6 [2.387kB]      
Hole:30 http://ftp.de.debian.org testing/main python2.5 2.5.5-10 [2.928kB]     
Hole:31 http://ftp.de.debian.org testing/main python2.5-minimal 2.5.5-10 [1.216kB]
Hole:32 http://ftp.de.debian.org testing/main python-minimal 2.6.6-3+squeeze1 [32,7kB]
Hole:33 http://ftp.de.debian.org testing/main python 2.6.6-3+squeeze1 [167kB]  
Hole:34 http://ftp.de.debian.org testing/main libpython2.6 2.6.6-6 [985kB]     
Hole:35 http://ftp.de.debian.org testing/main qt4-qtconfig 4:4.6.3-4 [144kB]   
Hole:36 http://ftp.de.debian.org testing/main libqt4-qt3support 4:4.6.3-4 [1.422kB]
Hole:37 http://ftp.de.debian.org testing/main libqt4-designer 4:4.6.3-4 [5.648kB]
Hole:38 http://ftp.de.debian.org testing/main libqt4-script 4:4.6.3-4 [1.039kB]
Hole:39 http://ftp.de.debian.org testing/main libqt4-dbus 4:4.6.3-4 [267kB]    
Hole:40 http://ftp.de.debian.org testing/main libqt4-opengl 4:4.6.3-4 [330kB]  
Hole:41 http://ftp.de.debian.org testing/main libqtgui4 4:4.6.3-4 [5.166kB]    
Hole:42 http://ftp.de.debian.org testing/main libqt4-xml 4:4.6.3-4 [144kB]     
Hole:43 http://ftp.de.debian.org testing/main libqt4-sql 4:4.6.3-4 [146kB]     
Hole:44 http://ftp.de.debian.org testing/main libqt4-network 4:4.6.3-4 [548kB] 
Hole:45 http://ftp.de.debian.org testing/main libqtcore4 4:4.6.3-4 [2.513kB]   
Hole:46 http://ftp.de.debian.org testing/main libqt4-assistant 4:4.6.3-4 [45,4kB]
Hole:47 http://ftp.de.debian.org testing/main libqt4-help 4:4.6.3-4 [265kB]    
Hole:48 http://ftp.de.debian.org testing/main libqt4-scripttools 4:4.6.3-4 [320kB]
Hole:49 http://ftp.de.debian.org testing/main libqt4-svg 4:4.6.3-4 [202kB]     
Hole:50 http://ftp.de.debian.org testing/main libqt4-test 4:4.6.3-4 [95,2kB]   
Hole:51 http://ftp.de.debian.org testing/main libpulse0 0.9.21-3 [365kB]       
Hole:52 http://ftp.de.debian.org testing/main libpulse-mainloop-glib0 0.9.21-3 [161kB]
Hole:53 http://ftp.de.debian.org testing/main libphonon4 4:4.6.0really4.4.2-1 [156kB]
Hole:54 http://ftp.de.debian.org testing/main libqt4-xmlpatterns 4:4.6.3-4 [1.538kB]
Hole:55 http://ftp.de.debian.org testing/main libqt4-webkit 4:4.6.3-4 [6.418kB]
Hole:56 http://ftp.de.debian.org testing/main python-sip 4.10.2-1 [130kB]      
Hole:57 http://ftp.de.debian.org testing/main python-qt4 4.7.3-1+b1 [5.013kB]  
Hole:58 http://ftp.de.debian.org testing/main python-simplejson 2.1.1-1 [76,9kB]
Hole:59 http://ftp.de.debian.org testing/main python-sqlalchemy 0.6.3-3 [455kB]
Hole:60 http://ftp.de.debian.org testing/main python-beautifulsoup 3.1.0.1-2 [32,6kB]
Hole:61 http://ftp.de.debian.org testing/main anki 0.9.9.8.6-2.1 [1.213kB]     
Hole:62 http://ftp.de.debian.org testing/main tcl8.5 8.5.8-2 [1.563kB]         
Hole:63 http://ftp.de.debian.org testing/main tk8.5 8.5.8-1 [1.118kB]          
Hole:64 http://ftp.de.debian.org testing/main blt 2.4z-4.2 [1.591kB]           
Hole:65 http://ftp.de.debian.org testing/main wwwconfig-common 0.2.1 [22,7kB]  
Hole:66 http://ftp.de.debian.org testing/main javascript-common 7 [3.810B]     
Hole:67 http://ftp.de.debian.org testing/main kakasi-dic 2.3.5~pre1+cvs20071101-1 [917kB]
Hole:68 http://ftp.de.debian.org testing/main kakasi 2.3.5~pre1+cvs20071101-1 [71,3kB]
Hole:69 http://ftp.de.debian.org testing/main libjs-jquery 1.4.2-2 [75,8kB]    
Hole:70 http://ftp.de.debian.org testing/main python-dateutil 1.4.1-3 [54,1kB] 
Hole:71 http://ftp.de.debian.org testing/main python-glade2 2.17.0-4 [30,5kB]  
Hole:72 http://ftp.de.debian.org testing/main ttf-lyx 1.6.7-1 [178kB]          
Hole:73 http://ftp.de.debian.org testing/main python-matplotlib-data 0.99.3-1 [1.025kB]
Hole:74 http://ftp.de.debian.org testing/main python-pyparsing 1.5.2-2 [607kB] 
Hole:75 http://ftp.de.debian.org testing/main python-tz 2010b-1 [43,9kB]       
Hole:76 http://ftp.de.debian.org testing/main python-matplotlib 0.99.3-1 [2.228kB]
Hole:77 http://ftp.de.debian.org testing/main python-sqlalchemy-ext 0.6.3-3 [19,8kB]
Hole:78 http://ftp.de.debian.org testing/main python-tk 2.6.6-1 [43,4kB]       
Es wurden 74,8MB in 12Min 31s geholt (99,4kB/s)                                
(Lese Datenbank ... 84145 Dateien und Verzeichnisse sind derzeit installiert.)
Entferne python-sexy ...
(Lese Datenbank ... 84132 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereiten zum Ersetzen von libncursesw5 5.7+20090803-2 (durch .../libncursesw5_5.7+20100313-4_i386.deb) ...
Entpacke Ersatz für libncursesw5 ...
Vorbereiten zum Ersetzen von libssl0.9.8 0.9.8k-8 (durch .../libssl0.9.8_0.9.8o-2_i386.deb) ...
Entpacke Ersatz für libssl0.9.8 ...
Vorbereiten zum Ersetzen von libsqlite3-0 3.6.21-2 (durch .../libsqlite3-0_3.7.3-1_i386.deb) ...
Entpacke Ersatz für libsqlite3-0 ...
Vorbereiten zum Ersetzen von python-brlapi 4.1-4 (durch .../python-brlapi_4.2-4_i386.deb) ...
Entpacke Ersatz für python-brlapi ...
Vorbereiten zum Ersetzen von libglib2.0-0 2.22.4-1 (durch .../libglib2.0-0_2.24.2-1_i386.deb) ...
Entpacke Ersatz für libglib2.0-0 ...
Vorbereiten zum Ersetzen von libatk1.0-0 1.28.0-1 (durch .../libatk1.0-0_1.30.0-1_i386.deb) ...
Entpacke Ersatz für libatk1.0-0 ...
Vorbereiten zum Ersetzen von libgail-common 2.18.6-1 (durch .../libgail-common_2.20.1-2_i386.deb) ...
Entpacke Ersatz für libgail-common ...
Vorbereiten zum Ersetzen von libgail18 2.18.6-1 (durch .../libgail18_2.20.1-2_i386.deb) ...
Entpacke Ersatz für libgail18 ...
Vorbereiten zum Ersetzen von libjpeg62 6b-15 (durch .../libjpeg62_6b1-1_i386.deb) ...
Entpacke Ersatz für libjpeg62 ...
Vorbereiten zum Ersetzen von libgtk2.0-0 2.18.6-1 (durch .../libgtk2.0-0_2.20.1-2_i386.deb) ...
Entpacke Ersatz für libgtk2.0-0 ...
Vorbereiten zum Ersetzen von librsvg2-common 2.26.0-1 (durch .../librsvg2-common_2.26.3-1_i386.deb) ...
Entpacke Ersatz für librsvg2-common ...
Vorbereiten zum Ersetzen von libgsf-1-common 1.14.16-1 (durch .../libgsf-1-common_1.14.18-1_all.deb) ...
Entpacke Ersatz für libgsf-1-common ...
Vorbereiten zum Ersetzen von libgsf-1-114 1.14.16-1 (durch .../libgsf-1-114_1.14.18-1_i386.deb) ...
Entpacke Ersatz für libgsf-1-114 ...
Vorbereiten zum Ersetzen von librsvg2-2 2.26.0-1 (durch .../librsvg2-2_2.26.3-1_i386.deb) ...
Entpacke Ersatz für librsvg2-2 ...
Vorbereiten zum Ersetzen von librsvg2-bin 2.26.0-1 (durch .../librsvg2-bin_2.26.3-1_i386.deb) ...
Entpacke Ersatz für librsvg2-bin ...
Vorbereiten zum Ersetzen von gimp 2.6.8-1 (durch .../gimp_2.6.10-1_i386.deb) ...
Entpacke Ersatz für gimp ...
Vorbereiten zum Ersetzen von libgimp2.0 2.6.8-1 (durch .../libgimp2.0_2.6.10-1_i386.deb) ...
Entpacke Ersatz für libgimp2.0 ...
Vorbereiten zum Ersetzen von gimp-data 2.6.8-1 (durch .../gimp-data_2.6.10-1_all.deb) ...
Entpacke Ersatz für gimp-data ...
Vorbereiten zum Ersetzen von python-numpy 1:1.3.0-3+b1 (durch .../python-numpy_1%3a1.4.1-5_i386.deb) ...
Entpacke Ersatz für python-numpy ...
Vorbereiten zum Ersetzen von python-gtk2 2.16.0-2 (durch .../python-gtk2_2.17.0-4_i386.deb) ...
Entpacke Ersatz für python-gtk2 ...
Wähle vormals abgewähltes Paket libilmbase6.
Entpacke libilmbase6 (aus .../libilmbase6_1.0.1-3_i386.deb) ...
Wähle vormals abgewähltes Paket libopenexr6.
Entpacke libopenexr6 (aus .../libopenexr6_1.6.1-4.1_i386.deb) ...
Wähle vormals abgewähltes Paket libopenraw1.
Entpacke libopenraw1 (aus .../libopenraw1_0.0.8-2_i386.deb) ...
Vorbereiten zum Ersetzen von libgegl-0.0-0 0.0.20-1 (durch .../libgegl-0.0-0_0.0.22-2+b1_i386.deb) ...
Entpacke Ersatz für libgegl-0.0-0 ...
Vorbereiten zum Ersetzen von libmng1 1.0.9-1 (durch .../libmng1_1.0.10-1+b1_i386.deb) ...
Entpacke Ersatz für libmng1 ...
Wähle vormals abgewähltes Paket python2.6-minimal.
Entpacke python2.6-minimal (aus .../python2.6-minimal_2.6.6-6_i386.deb) ...
new installation of python2.6-minimal; /usr/lib/python2.6/site-packages is a directory
which is expected a symlink to /usr/local/lib/python2.6/dist-packages.
please find the package shipping files in /usr/lib/python2.6/site-packages and
file a bug report to ship these in /usr/lib/python2.6/dist-packages instead
aborting installation of python2.6-minimal
dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/python2.6-minimal_2.6.6-6_i386.deb (--unpack):
 Unterprozess neues pre-installation-Skript gab den Fehlerwert 1 zurück
Wähle vormals abgewähltes Paket python2.6.
Entpacke python2.6 (aus .../python2.6_2.6.6-6_i386.deb) ...
Vorbereiten zum Ersetzen von python2.5 2.5.4-3.1 (durch .../python2.5_2.5.5-10_i386.deb) ...
Entpacke Ersatz für python2.5 ...
Vorbereiten zum Ersetzen von python2.5-minimal 2.5.4-3.1 (durch .../python2.5-minimal_2.5.5-10_i386.deb) ...
Entpacke Ersatz für python2.5-minimal ...
Vorbereiten zum Ersetzen von python-minimal 2.5.4-9 (durch .../python-minimal_2.6.6-3+squeeze1_all.deb) ...
Entpacke Ersatz für python-minimal ...
Vorbereiten zum Ersetzen von python 2.5.4-9 (durch .../python_2.6.6-3+squeeze1_all.deb) ...
Entpacke Ersatz für python ...
Wähle vormals abgewähltes Paket libpython2.6.
Entpacke libpython2.6 (aus .../libpython2.6_2.6.6-6_i386.deb) ...
Vorbereiten zum Ersetzen von qt4-qtconfig 4:4.5.3-4 (durch .../qt4-qtconfig_4%3a4.6.3-4_i386.deb) ...
Entpacke Ersatz für qt4-qtconfig ...
Vorbereiten zum Ersetzen von libqt4-qt3support 4:4.5.3-4 (durch .../libqt4-qt3support_4%3a4.6.3-4_i386.deb) ...
Entpacke Ersatz für libqt4-qt3support ...
Vorbereiten zum Ersetzen von libqt4-designer 4:4.5.3-4 (durch .../libqt4-designer_4%3a4.6.3-4_i386.deb) ...
Entpacke Ersatz für libqt4-designer ...
Vorbereiten zum Ersetzen von libqt4-script 4:4.5.3-4 (durch .../libqt4-script_4%3a4.6.3-4_i386.deb) ...
Entpacke Ersatz für libqt4-script ...
Vorbereiten zum Ersetzen von libqt4-dbus 4:4.5.3-4 (durch .../libqt4-dbus_4%3a4.6.3-4_i386.deb) ...
Entpacke Ersatz für libqt4-dbus ...
Vorbereiten zum Ersetzen von libqt4-opengl 4:4.5.3-4 (durch .../libqt4-opengl_4%3a4.6.3-4_i386.deb) ...
Entpacke Ersatz für libqt4-opengl ...
Vorbereiten zum Ersetzen von libqtgui4 4:4.5.3-4 (durch .../libqtgui4_4%3a4.6.3-4_i386.deb) ...
Entpacke Ersatz für libqtgui4 ...
Vorbereiten zum Ersetzen von libqt4-xml 4:4.5.3-4 (durch .../libqt4-xml_4%3a4.6.3-4_i386.deb) ...
Entpacke Ersatz für libqt4-xml ...
Vorbereiten zum Ersetzen von libqt4-sql 4:4.5.3-4 (durch .../libqt4-sql_4%3a4.6.3-4_i386.deb) ...
Entpacke Ersatz für libqt4-sql ...
Vorbereiten zum Ersetzen von libqt4-network 4:4.5.3-4 (durch .../libqt4-network_4%3a4.6.3-4_i386.deb) ...
Entpacke Ersatz für libqt4-network ...
Vorbereiten zum Ersetzen von libqtcore4 4:4.5.3-4 (durch .../libqtcore4_4%3a4.6.3-4_i386.deb) ...
Entpacke Ersatz für libqtcore4 ...
Wähle vormals abgewähltes Paket libqt4-assistant.
Entpacke libqt4-assistant (aus .../libqt4-assistant_4%3a4.6.3-4_i386.deb) ...
Wähle vormals abgewähltes Paket libqt4-help.
Entpacke libqt4-help (aus .../libqt4-help_4%3a4.6.3-4_i386.deb) ...
Wähle vormals abgewähltes Paket libqt4-scripttools.
Entpacke libqt4-scripttools (aus .../libqt4-scripttools_4%3a4.6.3-4_i386.deb) ...
Wähle vormals abgewähltes Paket libqt4-svg.
Entpacke libqt4-svg (aus .../libqt4-svg_4%3a4.6.3-4_i386.deb) ...
Wähle vormals abgewähltes Paket libqt4-test.
Entpacke libqt4-test (aus .../libqt4-test_4%3a4.6.3-4_i386.deb) ...
Vorbereiten zum Ersetzen von libpulse0 0.9.21-1 (durch .../libpulse0_0.9.21-3_i386.deb) ...
Entpacke Ersatz für libpulse0 ...
Wähle vormals abgewähltes Paket libpulse-mainloop-glib0.
Entpacke libpulse-mainloop-glib0 (aus .../libpulse-mainloop-glib0_0.9.21-3_i386.deb) ...
Wähle vormals abgewähltes Paket libphonon4.
Entpacke libphonon4 (aus .../libphonon4_4%3a4.6.0really4.4.2-1_i386.deb) ...
Wähle vormals abgewähltes Paket libqt4-xmlpatterns.
Entpacke libqt4-xmlpatterns (aus .../libqt4-xmlpatterns_4%3a4.6.3-4_i386.deb) ...
Wähle vormals abgewähltes Paket libqt4-webkit.
Entpacke libqt4-webkit (aus .../libqt4-webkit_4%3a4.6.3-4_i386.deb) ...
Wähle vormals abgewähltes Paket python-sip.
Entpacke python-sip (aus .../python-sip_4.10.2-1_i386.deb) ...
Wähle vormals abgewähltes Paket python-qt4.
Entpacke python-qt4 (aus .../python-qt4_4.7.3-1+b1_i386.deb) ...
Wähle vormals abgewähltes Paket python-simplejson.
Entpacke python-simplejson (aus .../python-simplejson_2.1.1-1_i386.deb) ...
Wähle vormals abgewähltes Paket python-sqlalchemy.
Entpacke python-sqlalchemy (aus .../python-sqlalchemy_0.6.3-3_all.deb) ...
Wähle vormals abgewähltes Paket python-beautifulsoup.
Entpacke python-beautifulsoup (aus .../python-beautifulsoup_3.1.0.1-2_all.deb) ...
Wähle vormals abgewähltes Paket anki.
Entpacke anki (aus .../anki_0.9.9.8.6-2.1_all.deb) ...
Wähle vormals abgewähltes Paket tcl8.5.
Entpacke tcl8.5 (aus .../tcl8.5_8.5.8-2_i386.deb) ...
Wähle vormals abgewähltes Paket tk8.5.
Entpacke tk8.5 (aus .../tk8.5_8.5.8-1_i386.deb) ...
Wähle vormals abgewähltes Paket blt.
Entpacke blt (aus .../archives/blt_2.4z-4.2_i386.deb) ...
Wähle vormals abgewähltes Paket wwwconfig-common.
Entpacke wwwconfig-common (aus .../wwwconfig-common_0.2.1_all.deb) ...
Wähle vormals abgewähltes Paket javascript-common.
Entpacke javascript-common (aus .../javascript-common_7_all.deb) ...
Wähle vormals abgewähltes Paket kakasi-dic.
Entpacke kakasi-dic (aus .../kakasi-dic_2.3.5~pre1+cvs20071101-1_all.deb) ...
Wähle vormals abgewähltes Paket kakasi.
Entpacke kakasi (aus .../kakasi_2.3.5~pre1+cvs20071101-1_i386.deb) ...
Wähle vormals abgewähltes Paket libjs-jquery.
Entpacke libjs-jquery (aus .../libjs-jquery_1.4.2-2_all.deb) ...
Wähle vormals abgewähltes Paket python-dateutil.
Entpacke python-dateutil (aus .../python-dateutil_1.4.1-3_all.deb) ...
Wähle vormals abgewähltes Paket python-glade2.
Entpacke python-glade2 (aus .../python-glade2_2.17.0-4_i386.deb) ...
Wähle vormals abgewähltes Paket ttf-lyx.
Entpacke ttf-lyx (aus .../ttf-lyx_1.6.7-1_all.deb) ...
Wähle vormals abgewähltes Paket python-matplotlib-data.
Entpacke python-matplotlib-data (aus .../python-matplotlib-data_0.99.3-1_all.deb) ...
Wähle vormals abgewähltes Paket python-pyparsing.
Entpacke python-pyparsing (aus .../python-pyparsing_1.5.2-2_all.deb) ...
Wähle vormals abgewähltes Paket python-tz.
Entpacke python-tz (aus .../python-tz_2010b-1_all.deb) ...
Wähle vormals abgewähltes Paket python-matplotlib.
Entpacke python-matplotlib (aus .../python-matplotlib_0.99.3-1_i386.deb) ...
Wähle vormals abgewähltes Paket python-sqlalchemy-ext.
Entpacke python-sqlalchemy-ext (aus .../python-sqlalchemy-ext_0.6.3-3_i386.deb) ...
Wähle vormals abgewähltes Paket python-tk.
Entpacke python-tk (aus .../python-tk_2.6.6-1_i386.deb) ...
Verarbeite Trigger für python-support ...
/var/lib/dpkg/info/python-support.postinst: /usr/sbin/update-python-modules: /usr/bin/python: Defekter Interpreter: Datei oder Verzeichnis nicht gefunden
dpkg: Unterprozess installiertes post-installation-Skript gab den Fehlerwert 126 zurück
E: Sub-process /usr/bin/dpkg returned an error code (2)
An dieser Stelle versuche ich erst einmal, die schon vorbereiteten Pakete zu installieren, sofern das möglich ist

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
root@Microknoppix:/home/knoppix# dpkg -a --configure
Verarbeite Trigger für menu ...
Verarbeite Trigger für desktop-file-utils ...
Verarbeite Trigger für man-db ...
Richte libjs-jquery ein (1.4.2-2) ...
Verarbeite Trigger für fontconfig ...
Richte libjpeg62 ein (6b1-1) ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-minimal:
 python-minimal hängt ab von python2.6-minimal (>= 2.6.6-1~); aber:
  Paket python2.6-minimal ist nicht installiert.
dpkg: Fehler beim Bearbeiten von python-minimal (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
Richte tcl8.5 ein (8.5.8-2) ...
update-alternatives: Verwende /usr/bin/tclsh8.5, um /usr/bin/tclsh (tclsh) in Auto-Modus bereitzustellen.
Verarbeite Trigger für hicolor-icon-theme ...
Richte libssl0.9.8 ein (0.9.8o-2) ...
Richte python2.5-minimal ein (2.5.5-10) ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python:
 python hängt ab von python-minimal (= 2.6.6-3+squeeze1); aber:
  Paket python-minimal ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-support:
 python-support hängt ab von python (>= 2.5); aber:
  Paket python ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-support (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python2.6:
 python2.6 hängt ab von python2.6-minimal (= 2.6.6-6); aber:
  Paket python2.6-minimal ist nicht installiert.
dpkg: Fehler beim Bearbeiten von python2.6 (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
Richte gimp-data ein (2.6.10-1) ...
Richte libsqlite3-0 ein (3.7.3-1) ...
Richte libgsf-1-common ein (1.14.18-1) ...
Richte libpulse0 ein (0.9.21-3) ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-glade2:
 python-glade2 hängt ab von python (<< 2.7); aber:
  Paket python ist noch nicht konfiguriert.
 python-glade2 hängt ab von python (>= 2.5); aber:
  Paket python ist noch nicht konfiguriert.
 python-glade2 hängt ab von python-support (>= 0.90.0); aber:
  Paket python-support ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-glade2 (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-sqlalchemy:
 python-sqlalchemy hängt ab von python (>= 2.6.5-11~); aber:
  Paket python ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-sqlalchemy (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
Richte libmng1 ein (1.0.10-1+b1) ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-matplotlib:
 python-matplotlib hängt ab von python (<< 2.7); aber:
  Paket python ist noch nicht konfiguriert.
 python-matplotlib hängt ab von python (>= 2.5); aber:
  Paket python ist noch nicht konfiguriert.
 python-matplotlib hängt ab von python-support (>= 0.90.0); aber:
  Paket python-support ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-matplotlib (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-dateutil:
 python-dateutil hängt ab von python (>= 2.3); aber:
  Paket python ist noch nicht konfiguriert.
 python-dateutil hängt ab von python-support (>= 0.7.1); aber:
  Paket python-support ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-dateutil (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
Richte libopenraw1 ein (0.0.8-2) ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-gtk2:
 python-gtk2 hängt ab von python (<< 2.7); aber:
  Paket python ist noch nicht konfiguriert.
 python-gtk2 hängt ab von python (>= 2.5); aber:
  Paket python ist noch nicht konfiguriert.
 python-gtk2 hängt ab von python-support (>= 0.90.0); aber:
  Paket python-support ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-gtk2 (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
Richte libncursesw5 ein (5.7+20100313-4) ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-simplejson:
 python-simplejson hängt ab von python (<< 2.7); aber:
  Paket python ist noch nicht konfiguriert.
 python-simplejson hängt ab von python (>= 2.5); aber:
  Paket python ist noch nicht konfiguriert.
 python-simplejson hängt ab von python-support (>= 0.90.0); aber:
  Paket python-support ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-simplejson (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-numpy:
 python-numpy hängt ab von python (<< 2.7); aber:
  Paket python ist noch nicht konfiguriert.
 python-numpy hängt ab von python (>= 2.5); aber:
  Paket python ist noch nicht konfiguriert.
 python-numpy hängt ab von python-support (>= 0.90.0); aber:
  Paket python-support ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-numpy (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
Richte libilmbase6 ein (1.0.1-3) ...
Richte ttf-lyx ein (1.6.7-1) ...
Updating fontconfig cache for /usr/share/fonts/truetype/ttf-lyx
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-qt4:
 python-qt4 hängt ab von python (<< 2.7); aber:
  Paket python ist noch nicht konfiguriert.
 python-qt4 hängt ab von python (>= 2.5); aber:
  Paket python ist noch nicht konfiguriert.
 python-qt4 hängt ab von python-support (>= 0.90.0); aber:
  Paket python-support ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-qt4 (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
Richte kakasi-dic ein (2.3.5~pre1+cvs20071101-1) ...
Richte libglib2.0-0 ein (2.24.2-1) ...
Richte wwwconfig-common ein (0.2.1) ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-sqlalchemy-ext:
 python-sqlalchemy-ext hängt ab von python-sqlalchemy (= 0.6.3-3); aber:
  Paket python-sqlalchemy ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-sqlalchemy-ext (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von gimp:
 gimp hängt ab von python-gtk2 (>= 2.8.0); aber:
  Paket python-gtk2 ist noch nicht konfiguriert.
 gimp hängt ab von python (<< 2.7); aber:
  Paket python ist noch nicht konfiguriert.
 gimp hängt ab von python (>= 2.6); aber:
  Paket python ist noch nicht konfiguriert.
 gimp hängt ab von python-support (>= 0.90.0); aber:
  Paket python-support ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von gimp (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-sip:
 python-sip hängt ab von python (<< 2.7); aber:
  Paket python ist noch nicht konfiguriert.
 python-sip hängt ab von python (>= 2.5); aber:
  Paket python ist noch nicht konfiguriert.
 python-sip hängt ab von python-support (>= 0.90.0); aber:
  Paket python-support ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-sip (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von librsvg2-bin:
 librsvg2-bin hängt ab von python (>= 2.5); aber:
  Paket python ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von librsvg2-bin (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-tk:
 python-tk hängt ab von python (<< 2.7); aber:
  Paket python ist noch nicht konfiguriert.
 python-tk hängt ab von python (>= 2.5); aber:
  Paket python ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-tk (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-tz:
 python-tz hängt ab von python; aber:
  Paket python ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-tz (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-pyparsing:
 python-pyparsing hängt ab von python-support (>= 0.90.0); aber:
  Paket python-support ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-pyparsing (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
Richte tk8.5 ein (8.5.8-1) ...
update-alternatives: Verwende /usr/bin/wish8.5, um /usr/bin/wish (wish) in Auto-Modus bereitzustellen.
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libpython2.6:
 libpython2.6 hängt ab von python2.6 (= 2.6.6-6); aber:
  Paket python2.6 ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von libpython2.6 (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-brlapi:
 python-brlapi hängt ab von python (<< 2.7); aber:
  Paket python ist noch nicht konfiguriert.
 python-brlapi hängt ab von python (>= 2.6); aber:
  Paket python ist noch nicht konfiguriert.
 python-brlapi hängt ab von python-support (>= 0.90.0); aber:
  Paket python-support ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-brlapi (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-beautifulsoup:
 python-beautifulsoup hängt ab von python (>= 2.2); aber:
  Paket python ist noch nicht konfiguriert.
 python-beautifulsoup hängt ab von python-support (>= 0.90.0); aber:
  Paket python-support ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-beautifulsoup (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von anki:
 anki hängt ab von python; aber:
  Paket python ist noch nicht konfiguriert.
 anki hängt ab von python-support (>= 0.90.0); aber:
  Paket python-support ist noch nicht konfiguriert.
 anki hängt ab von python-qt4 (>= 4.4); aber:
  Paket python-qt4 ist noch nicht konfiguriert.
 anki hängt ab von python-simplejson (>= 1.7.3); aber:
  Paket python-simplejson ist noch nicht konfiguriert.
 anki hängt ab von python-sqlalchemy (>= 0.4.3); aber:
  Paket python-sqlalchemy ist noch nicht konfiguriert.
 anki hängt ab von python-beautifulsoup; aber:
  Paket python-beautifulsoup ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von anki (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
Richte libpulse-mainloop-glib0 ein (0.9.21-3) ...
Richte python-matplotlib-data ein (0.99.3-1) ...
Richte libgsf-1-114 ein (1.14.18-1) ...
Richte libqtcore4 ein (4:4.6.3-4) ...
Richte javascript-common ein (7) ...
Richte kakasi ein (2.3.5~pre1+cvs20071101-1) ...
Richte python2.5 ein (2.5.5-10) ...
Richte libqt4-network ein (4:4.6.3-4) ...
Richte libopenexr6 ein (1.6.1-4.1) ...
Richte libatk1.0-0 ein (1.30.0-1) ...
Richte libqt4-xml ein (4:4.6.3-4) ...
Richte blt ein (2.4z-4.2) ...
Richte libqt4-test ein (4:4.6.3-4) ...
Richte libqt4-xmlpatterns ein (4:4.6.3-4) ...
Richte libqt4-assistant ein (4:4.6.3-4) ...
Richte libqtgui4 ein (4:4.6.3-4) ...
Richte libqt4-sql ein (4:4.6.3-4) ...
Richte libqt4-svg ein (4:4.6.3-4) ...
Richte libgtk2.0-0 ein (2.20.1-2) ...
Richte libqt4-dbus ein (4:4.6.3-4) ...
Richte libqt4-opengl ein (4:4.6.3-4) ...
Richte librsvg2-2 ein (2.26.3-1) ...
Richte libgail18 ein (2.20.1-2) ...
Richte libphonon4 ein (4:4.6.0really4.4.2-1) ...
Richte librsvg2-common ein (2.26.3-1) ...
Richte libgail-common ein (2.20.1-2) ...
Richte libqt4-help ein (4:4.6.3-4) ...
Richte libgegl-0.0-0 ein (0.0.22-2+b1) ...
Richte libgimp2.0 ein (2.6.10-1) ...
Richte libqt4-webkit ein (4:4.6.3-4) ...
Richte libqt4-script ein (4:4.6.3-4) ...
Richte libqt4-designer ein (4:4.6.3-4) ...
Richte libqt4-scripttools ein (4:4.6.3-4) ...
Richte libqt4-qt3support ein (4:4.6.3-4) ...
Richte qt4-qtconfig ein (4:4.6.3-4) ...
Verarbeite Trigger für menu ...
Fehler traten auf beim Bearbeiten von:
 python-minimal
 python
 python-support
 python2.6
 python-glade2
 python-sqlalchemy
 python-matplotlib
 python-dateutil
 python-gtk2
 python-simplejson
 python-numpy
 python-qt4
 python-sqlalchemy-ext
 gimp
 python-sip
 librsvg2-bin
 python-tk
 python-tz
 python-pyparsing
 libpython2.6
 python-brlapi
 python-beautifulsoup
 anki

Jetzt kehre ich zur Fehlermaldung

Zitat


Wähle vormals abgewähltes Paket python2.6-minimal.
Entpacke python2.6-minimal (aus .../python2.6-minimal_2.6.6-6_i386.deb) ...
new installation of python2.6-minimal; /usr/lib/python2.6/site-packages is a directory
which is expected a symlink to /usr/local/lib/python2.6/dist-packages.
please find the package shipping files in /usr/lib/python2.6/site-packages and
file a bug report to ship these in /usr/lib/python2.6/dist-packages instead
aborting installation of python2.6-minimal
dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/python2.6-minimal_2.6.6-6_i386.deb (--unpack):
Unterprozess neues pre-installation-Skript gab den Fehlerwert 1 zurück
zurück. Es muss festgestellt werden, welche Datei die Installation verhindert.

Quellcode

1
2
3
4
5
6
7
8
root@Microknoppix:/home/knoppix# ls -l /usr/lib/python2.6/site-packages
insgesamt 104
-rw-r--r-- 1 root root 105728 26. Jan 2010  compizconfig.so
root@Microknoppix:/home/knoppix# dpkg -S compizconfig.so
python-compizconfig: /usr/lib/python2.5/site-packages/compizconfig.so
libcompizconfig0: /usr/lib/libcompizconfig.so.0.0.0
python-compizconfig: /usr/lib/python2.6/site-packages/compizconfig.so
libcompizconfig0: /usr/lib/libcompizconfig.so.0
Das Paket python-compizconfig stört also bei der Installation von python2.6. Daher wird versucht, dieses Paket zu deinstallieren und später ein aktuelleres zu installieren, welches dann mit python2.6 kompatibel ist.

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
root@Microknoppix:/home/knoppix# apt-get purge python-compizconfig
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut       
Status-Informationen einlesen... Fertig
Probieren Sie »apt-get -f install«, um dies zu korrigieren:
Die folgenden Pakete haben nicht-erfüllte Abhängigkeiten:
  compizconfig-settings-manager: Hängt ab: python-compizconfig (>= 0.8.2) soll aber nicht installiert werden
                                 Empfiehlt: python-sexy soll aber nicht installiert werden
  fusion-icon: Hängt ab: python-compizconfig soll aber nicht installiert werden
  python-minimal: Hängt ab: python2.6-minimal (>= 2.6.6-1~) soll aber nicht installiert werden
  python2.6: Hängt ab: python2.6-minimal (= 2.6.6-6) soll aber nicht installiert werden
E: Nicht erfüllte Abhängigkeiten. Versuchen Sie »apt-get -f install« ohne jegliche Pakete (oder geben Sie eine Lösung an).
root@Microknoppix:/home/knoppix# apt-get purge python-compizconfig fusion-icon
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut       
Status-Informationen einlesen... Fertig
Probieren Sie »apt-get -f install«, um dies zu korrigieren:
Die folgenden Pakete haben nicht-erfüllte Abhängigkeiten:
  compizconfig-settings-manager: Hängt ab: python-compizconfig (>= 0.8.2) soll aber nicht installiert werden
                                 Empfiehlt: python-sexy soll aber nicht installiert werden
  python-minimal: Hängt ab: python2.6-minimal (>= 2.6.6-1~) soll aber nicht installiert werden
  python2.6: Hängt ab: python2.6-minimal (= 2.6.6-6) soll aber nicht installiert werden
E: Nicht erfüllte Abhängigkeiten. Versuchen Sie »apt-get -f install« ohne jegliche Pakete (oder geben Sie eine Lösung an).
root@Microknoppix:/home/knoppix# apt-get purge python-compizconfig fusion-icon compizconfig-settings-manager
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut       
Status-Informationen einlesen... Fertig
Probieren Sie »apt-get -f install«, um dies zu korrigieren:
Die folgenden Pakete haben nicht-erfüllte Abhängigkeiten:
  python-minimal: Hängt ab: python2.6-minimal (>= 2.6.6-1~) soll aber nicht installiert werden
  python2.6: Hängt ab: python2.6-minimal (= 2.6.6-6) soll aber nicht installiert werden
E: Nicht erfüllte Abhängigkeiten. Versuchen Sie »apt-get -f install« ohne jegliche Pakete (oder geben Sie eine Lösung an).
root@Microknoppix:/home/knoppix# apt-get -f install
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut       
Status-Informationen einlesen... Fertig
Abhängigkeiten werden korrigiert... Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht länger benötigt:
  libdb4.5
Verwenden Sie »apt-get autoremove«, um sie zu entfernen.
Die folgenden zusätzlichen Pakete werden installiert:
  python2.6-minimal
Vorgeschlagene Pakete:
  binfmt-support
Die folgenden NEUEN Pakete werden installiert:
  python2.6-minimal
0 aktualisiert, 1 neu installiert, 0 zu entfernen und 769 nicht aktualisiert.
23 nicht vollständig installiert oder entfernt.
Es müssen noch 0B von 1.423kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 5.005kB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren [J/n]? 
(Lese Datenbank ... 86775 Dateien und Verzeichnisse sind derzeit installiert.)
Entpacke python2.6-minimal (aus .../python2.6-minimal_2.6.6-6_i386.deb) ...
new installation of python2.6-minimal; /usr/lib/python2.6/site-packages is a directory
which is expected a symlink to /usr/local/lib/python2.6/dist-packages.
please find the package shipping files in /usr/lib/python2.6/site-packages and
file a bug report to ship these in /usr/lib/python2.6/dist-packages instead
aborting installation of python2.6-minimal
dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/python2.6-minimal_2.6.6-6_i386.deb (--unpack):
 Unterprozess neues pre-installation-Skript gab den Fehlerwert 1 zurück
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/python2.6-minimal_2.6.6-6_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Wie man sieht, hilft apt-get -f install nicht weiter.

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
root@Microknoppix:/home/knoppix# dpkg -P python-compizconfig fusion-icon compizconfig-settings-manager
(Lese Datenbank ... 86774 Dateien und Verzeichnisse sind derzeit installiert.)
Entferne fusion-icon ...
Lösche Konfigurationsdateien von fusion-icon ...
Entferne compizconfig-settings-manager ...
/var/lib/dpkg/info/compizconfig-settings-manager.prerm: /usr/sbin/update-python-modules: /usr/bin/python: Defekter Interpreter: Datei oder Verzeichnis nicht gefunden
dpkg: Fehler beim Bearbeiten von compizconfig-settings-manager (--purge):
 Unterprozess installiertes pre-removal-Skript gab den Fehlerwert 126 zurück
/var/lib/dpkg/info/compizconfig-settings-manager.postinst: /usr/sbin/update-python-modules: /usr/bin/python: Defekter Interpreter: Datei oder Verzeichnis nicht gefunden
dpkg: Fehler beim Aufräumen:
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 126 zurück
Entferne python-compizconfig ...
Verarbeite Trigger für man-db ...
Verarbeite Trigger für hicolor-icon-theme ...
Verarbeite Trigger für desktop-file-utils ...
Verarbeite Trigger für menu ...
Fehler traten auf beim Bearbeiten von:
 compizconfig-settings-manager
root@Microknoppix:/home/knoppix# dpkg -a --configure
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-minimal:
 python-minimal hängt ab von python2.6-minimal (>= 2.6.6-1~); aber:
  Paket python2.6-minimal ist nicht installiert.
dpkg: Fehler beim Bearbeiten von python-minimal (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python:
 python hängt ab von python-minimal (= 2.6.6-3+squeeze1); aber:
  Paket python-minimal ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-support:
 python-support hängt ab von python (>= 2.5); aber:
  Paket python ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-support (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python2.6:
 python2.6 hängt ab von python2.6-minimal (= 2.6.6-6); aber:
  Paket python2.6-minimal ist nicht installiert.
dpkg: Fehler beim Bearbeiten von python2.6 (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-glade2:
 python-glade2 hängt ab von python (<< 2.7); aber:
  Paket python ist noch nicht konfiguriert.
 python-glade2 hängt ab von python (>= 2.5); aber:
  Paket python ist noch nicht konfiguriert.
 python-glade2 hängt ab von python-support (>= 0.90.0); aber:
  Paket python-support ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-glade2 (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-sqlalchemy:
 python-sqlalchemy hängt ab von python (>= 2.6.5-11~); aber:
  Paket python ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-sqlalchemy (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-matplotlib:
 python-matplotlib hängt ab von python (<< 2.7); aber:
  Paket python ist noch nicht konfiguriert.
 python-matplotlib hängt ab von python (>= 2.5); aber:
  Paket python ist noch nicht konfiguriert.
 python-matplotlib hängt ab von python-support (>= 0.90.0); aber:
  Paket python-support ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-matplotlib (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-dateutil:
 python-dateutil hängt ab von python (>= 2.3); aber:
  Paket python ist noch nicht konfiguriert.
 python-dateutil hängt ab von python-support (>= 0.7.1); aber:
  Paket python-support ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-dateutil (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-gtk2:
 python-gtk2 hängt ab von python (<< 2.7); aber:
  Paket python ist noch nicht konfiguriert.
 python-gtk2 hängt ab von python (>= 2.5); aber:
  Paket python ist noch nicht konfiguriert.
 python-gtk2 hängt ab von python-support (>= 0.90.0); aber:
  Paket python-support ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-gtk2 (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-simplejson:
 python-simplejson hängt ab von python (<< 2.7); aber:
  Paket python ist noch nicht konfiguriert.
 python-simplejson hängt ab von python (>= 2.5); aber:
  Paket python ist noch nicht konfiguriert.
 python-simplejson hängt ab von python-support (>= 0.90.0); aber:
  Paket python-support ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-simplejson (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-numpy:
 python-numpy hängt ab von python (<< 2.7); aber:
  Paket python ist noch nicht konfiguriert.
 python-numpy hängt ab von python (>= 2.5); aber:
  Paket python ist noch nicht konfiguriert.
 python-numpy hängt ab von python-support (>= 0.90.0); aber:
  Paket python-support ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-numpy (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-qt4:
 python-qt4 hängt ab von python (<< 2.7); aber:
  Paket python ist noch nicht konfiguriert.
 python-qt4 hängt ab von python (>= 2.5); aber:
  Paket python ist noch nicht konfiguriert.
 python-qt4 hängt ab von python-support (>= 0.90.0); aber:
  Paket python-support ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-qt4 (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-sqlalchemy-ext:
 python-sqlalchemy-ext hängt ab von python-sqlalchemy (= 0.6.3-3); aber:
  Paket python-sqlalchemy ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-sqlalchemy-ext (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von gimp:
 gimp hängt ab von python-gtk2 (>= 2.8.0); aber:
  Paket python-gtk2 ist noch nicht konfiguriert.
 gimp hängt ab von python (<< 2.7); aber:
  Paket python ist noch nicht konfiguriert.
 gimp hängt ab von python (>= 2.6); aber:
  Paket python ist noch nicht konfiguriert.
 gimp hängt ab von python-support (>= 0.90.0); aber:
  Paket python-support ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von gimp (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-sip:
 python-sip hängt ab von python (<< 2.7); aber:
  Paket python ist noch nicht konfiguriert.
 python-sip hängt ab von python (>= 2.5); aber:
  Paket python ist noch nicht konfiguriert.
 python-sip hängt ab von python-support (>= 0.90.0); aber:
  Paket python-support ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-sip (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von librsvg2-bin:
 librsvg2-bin hängt ab von python (>= 2.5); aber:
  Paket python ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von librsvg2-bin (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-tk:
 python-tk hängt ab von python (<< 2.7); aber:
  Paket python ist noch nicht konfiguriert.
 python-tk hängt ab von python (>= 2.5); aber:
  Paket python ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-tk (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-tz:
 python-tz hängt ab von python; aber:
  Paket python ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-tz (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-pyparsing:
 python-pyparsing hängt ab von python-support (>= 0.90.0); aber:
  Paket python-support ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-pyparsing (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libpython2.6:
 libpython2.6 hängt ab von python2.6 (= 2.6.6-6); aber:
  Paket python2.6 ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von libpython2.6 (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-brlapi:
 python-brlapi hängt ab von python (<< 2.7); aber:
  Paket python ist noch nicht konfiguriert.
 python-brlapi hängt ab von python (>= 2.6); aber:
  Paket python ist noch nicht konfiguriert.
 python-brlapi hängt ab von python-support (>= 0.90.0); aber:
  Paket python-support ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-brlapi (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-beautifulsoup:
 python-beautifulsoup hängt ab von python (>= 2.2); aber:
  Paket python ist noch nicht konfiguriert.
 python-beautifulsoup hängt ab von python-support (>= 0.90.0); aber:
  Paket python-support ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-beautifulsoup (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von anki:
 anki hängt ab von python; aber:
  Paket python ist noch nicht konfiguriert.
 anki hängt ab von python-support (>= 0.90.0); aber:
  Paket python-support ist noch nicht konfiguriert.
 anki hängt ab von python-qt4 (>= 4.4); aber:
  Paket python-qt4 ist noch nicht konfiguriert.
 anki hängt ab von python-simplejson (>= 1.7.3); aber:
  Paket python-simplejson ist noch nicht konfiguriert.
 anki hängt ab von python-sqlalchemy (>= 0.4.3); aber:
  Paket python-sqlalchemy ist noch nicht konfiguriert.
 anki hängt ab von python-beautifulsoup; aber:
  Paket python-beautifulsoup ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von anki (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 python-minimal
 python
 python-support
 python2.6
 python-glade2
 python-sqlalchemy
 python-matplotlib
 python-dateutil
 python-gtk2
 python-simplejson
 python-numpy
 python-qt4
 python-sqlalchemy-ext
 gimp
 python-sip
 librsvg2-bin
 python-tk
 python-tz
 python-pyparsing
 libpython2.6
 python-brlapi
 python-beautifulsoup
 anki
root@Microknoppix:/home/knoppix# dpkg -P python-compizconfig fusion-icon compizconfig-settings-manager
dpkg: Warnung: Ignoriere den Wunsch, python-compizconfig zu entfernen; es ist nicht installiert.
dpkg: Warnung: Ignoriere den Wunsch, fusion-icon zu entfernen; es ist nicht installiert.
(Lese Datenbank ... 86738 Dateien und Verzeichnisse sind derzeit installiert.)
Entferne compizconfig-settings-manager ...
/var/lib/dpkg/info/compizconfig-settings-manager.prerm: /usr/sbin/update-python-modules: /usr/bin/python: Defekter Interpreter: Datei oder Verzeichnis nicht gefunden
dpkg: Fehler beim Bearbeiten von compizconfig-settings-manager (--purge):
 Unterprozess installiertes pre-removal-Skript gab den Fehlerwert 126 zurück
/var/lib/dpkg/info/compizconfig-settings-manager.postinst: /usr/sbin/update-python-modules: /usr/bin/python: Defekter Interpreter: Datei oder Verzeichnis nicht gefunden
dpkg: Fehler beim Aufräumen:
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 126 zurück
Fehler traten auf beim Bearbeiten von:
 compizconfig-settings-manager

Jetzt ist das störende Paket python-compizconfig entfernt, so dass die Installation von python2.6 versucht werden kann.

Quellcode

1
2
3
4
5
6
root@Microknoppix:/home/knoppix# dpkg -i /var/cache/apt/archives/python2.6-minimal_2.6.6-6_i386.deb
(Lese Datenbank ... 86739 Dateien und Verzeichnisse sind derzeit installiert.)
Entpacke python2.6-minimal (aus .../python2.6-minimal_2.6.6-6_i386.deb) ...
Richte python2.6-minimal ein (2.6.6-6) ...
Linking and byte-compiling packages for runtime python2.6...
Verarbeite Trigger für man-db ...

Nachdem python2.6-minimal installiert werden konnte, sollte der Rest der Pakete problemlos installiert werden können.

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
root@Microknoppix:/home/knoppix# apt-get -f install
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut       
Status-Informationen einlesen... Fertig
Abhängigkeiten werden korrigiert... Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht länger benötigt:
  libdb4.5
Verwenden Sie »apt-get autoremove«, um sie zu entfernen.
Die folgenden Pakete werden ENTFERNT:
  compizconfig-settings-manager
0 aktualisiert, 0 neu installiert, 1 zu entfernen und 767 nicht aktualisiert.
24 nicht vollständig installiert oder entfernt.
Nach dieser Operation werden 4.166kB Plattenplatz freigegeben.
Möchten Sie fortfahren [J/n]? 
(Lese Datenbank ... 86903 Dateien und Verzeichnisse sind derzeit installiert.)
Entferne compizconfig-settings-manager ...
Verarbeite Trigger für desktop-file-utils ...
Verarbeite Trigger für man-db ...
Verarbeite Trigger für hicolor-icon-theme ...
Richte python2.6 ein (2.6.6-6) ...
Richte python-minimal ein (2.6.6-3+squeeze1) ...
Richte python ein (2.6.6-3+squeeze1) ...
running python rtupdate hooks for python2.6...
running python post-rtupdate hooks for python2.6...
Richte python-sqlalchemy ein (0.6.3-3) ...
Richte python-sqlalchemy-ext ein (0.6.3-3) ...
Richte python-support ein (1.0.6) ...
Richte libpython2.6 ein (2.6.6-6) ...
Richte python-sip ein (4.10.2-1) ...
Richte python-qt4 ein (4.7.3-1+b1) ...
Richte python-simplejson ein (2.1.1-1) ...
Richte python-beautifulsoup ein (3.1.0.1-2) ...
Richte anki ein (0.9.9.8.6-2.1) ...
Richte python-numpy ein (1:1.4.1-5) ...
Richte python-gtk2 ein (2.17.0-4) ...
Richte gimp ein (2.6.10-1) ...
Richte librsvg2-bin ein (2.26.3-1) ...
Richte python-dateutil ein (1.4.1-3) ...
Richte python-glade2 ein (2.17.0-4) ...
Richte python-pyparsing ein (1.5.2-2) ...
Richte python-tz ein (2010b-1) ...
Richte python-matplotlib ein (0.99.3-1) ...
Richte python-tk ein (2.6.6-1) ...
Richte python-brlapi ein (4.2-4) ...
Verarbeite Trigger für menu ...
Verarbeite Trigger für python-support ...
Die Fehler bei der Installation von python2.6 sind verschwunden.
Jetzt werden noch die Pakete für Compiz installiert.

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
root@Microknoppix:/home/knoppix# apt-get -t testing install python-compizconfig fusion-icon compizconfig-settings-manager
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut       
Status-Informationen einlesen... Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht länger benötigt:
  libdb4.5
Verwenden Sie »apt-get autoremove«, um sie zu entfernen.
Die folgenden NEUEN Pakete werden installiert:
  compizconfig-settings-manager fusion-icon python-compizconfig
0 aktualisiert, 3 neu installiert, 0 zu entfernen und 766 nicht aktualisiert.
Es müssen 758kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 4.841kB Plattenplatz zusätzlich benutzt.
Hole:1 http://ftp.de.debian.org testing/main python-compizconfig 0.8.4-2 [75,3kB]
Hole:2 http://ftp.de.debian.org stable/main fusion-icon 0.1.0-2 [30,9kB]
Hole:3 http://ftp.de.debian.org testing/main compizconfig-settings-manager 0.8.4-2 [652kB]
Es wurden 758kB in 7s geholt (97,1kB/s)                                        
Wähle vormals abgewähltes Paket python-compizconfig.
(Lese Datenbank ... 86716 Dateien und Verzeichnisse sind derzeit installiert.)
Entpacke python-compizconfig (aus .../python-compizconfig_0.8.4-2_i386.deb) ...
Wähle vormals abgewähltes Paket fusion-icon.
Entpacke fusion-icon (aus .../fusion-icon_0.1.0-2_all.deb) ...
Wähle vormals abgewähltes Paket compizconfig-settings-manager.
Entpacke compizconfig-settings-manager (aus .../compizconfig-settings-manager_0.8.4-2_i386.deb) ...
Verarbeite Trigger für menu ...
Verarbeite Trigger für desktop-file-utils ...
Verarbeite Trigger für hicolor-icon-theme ...
Verarbeite Trigger für man-db ...
Richte python-compizconfig ein (0.8.4-2) ...
Richte fusion-icon ein (0.1.0-2) ...
Richte compizconfig-settings-manager ein (0.8.4-2) ...
Verarbeite Trigger für python-support ...
Verarbeite Trigger für menu ...

Zusammenfassung der verwendeten Befehle:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
nano -w /etc/apt/apt.conf.d/11cache-limit
cat /etc/apt/apt.conf.d/11cache-limit 
apt-get update
apt-get install anki
apt-get install anki python-qt4
apt-get install anki python-qt4 libqt4-assistant libqt4-help libqt4-svg libqt4-test libqt4-webkit libqt4-xmlpatterns 
apt-get install anki python-qt4 libqt4-assistant libqt4-help libqt4-svg libqt4-test libqt4-webkit libqt4-xmlpatterns libqt4-network libqtcore4 libqt4-sql libqtgui4 libqt4-designer libqt4-script
apt-get install anki python-qt4 libqt4-assistant libqt4-help libqt4-svg libqt4-test libqt4-webkit libqt4-xmlpatterns libqt4-network libqtcore4 libqt4-sql libqtgui4 libqt4-designer libqt4-script libqt4-sql libmng1 
apt-get -t testing install anki python-qt4 libqt4-assistant libqt4-help libqt4-svg libqt4-test libqt4-webkit libqt4-xmlpatterns libqt4-network libqtcore4 libqt4-sql libqtgui4 libqt4-designer libqt4-script libqt4-sql libmng1 
dpkg -a --configure
ls -l /usr/lib/python2.6/site-packages
dpkg -S compizconfig.so
apt-get purge python-compizconfig
apt-get purge python-compizconfig fusion-icon
apt-get purge python-compizconfig fusion-icon compizconfig-settings-manager
apt-get -f install
dpkg -a --configure
dpkg -P python-compizconfig fusion-icon compizconfig-settings-manager
dpkg -a --configure
dpkg -P python-compizconfig fusion-icon compizconfig-settings-manager
dpkg -i /var/cache/apt/archives/python2.6-minimal_2.6.6-6_i386.deb
apt-get -f install
apt-get -t testing install python-compizconfig fusion-icon compizconfig-settings-manager


Vielleicht kann man das Verfahren abkürzen.

Gruss Klaus

Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von »klaus2008« (14.11.2010, 16:09)


3

19.11.2010, 23:43

Danke!

Das Problem ist aber, dass apt-get nicht funktioniert, solange die Paketrpobleme nicht gelöst sind. Ich kann im Moment also im Moment nichts installieren oder deinstallieren. Hab es auch schon über die Paketverwaltung versucht, das klappt auch nicht.

Hat jemand ne Ahnung, wie ich das reparieren kann?

MfG und danke,
Laudatuse

klaus2008

Meister

Beiträge: 2 695

Geschlecht: Männlich

4

20.11.2010, 08:36

Hallo Laudatuse!

Wenn apt-get nicht mehr funktioniert, würde ich zuerst

Quellcode

1
dpkg -a --configure
ausführen. Damit werden die bereits vorbereiteten Pakete eingerichtet, soweit dies möglich ist. Das Programm beendet sich dann höchst wahrscheinlich mit einer Fehlermeldung, die Du hier zitieren könntest. Vielleicht lässt sich dann eine Strategie zur weiteren Problemlösung entwickeln.

Wie sieht die Ausgabe von

Quellcode

1
ls -l /usr/lib/python2.6/site-packages
aus? Im Verzeichnis /usr/lib/python2.6/site-packages wirst Du höchst wahrscheinlich eine oder mehrere Dateien finden. Wie lautet die Ausgabe von

Quellcode

1
dpkg -S Dateiname
(Dabei ist Dateiname natürlich durch den richtigen zu ersetzen, also beispielsweise dpkg -S compizconfig.so )

Gruß Klaus

5

21.11.2010, 13:49

Ok, hier also die Fehlermeldung:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-minimal:
 python-minimal hängt ab von python2.6-minimal (>= 2.6.6-1~); aber:
  Paket python2.6-minimal ist nicht installiert.
dpkg: Fehler beim Bearbeiten von python-minimal (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python:
 python hängt ab von python-minimal (= 2.6.6-3+squeeze1); aber:
  Paket python-minimal ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-support:
 python-support hängt ab von python (>= 2.5); aber:
  Paket python ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-support (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python2.6:
 python2.6 hängt ab von python2.6-minimal (= 2.6.6-6); aber:
  Paket python2.6-minimal ist nicht installiert.
dpkg: Fehler beim Bearbeiten von python2.6 (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-glade2:
 python-glade2 hängt ab von python (<< 2.7); aber:
  Paket python ist noch nicht konfiguriert.
 python-glade2 hängt ab von python (>= 2.5); aber:
  Paket python ist noch nicht konfiguriert.
 python-glade2 hängt ab von python-support (>= 0.90.0); aber:
  Paket python-support ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-glade2 (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-sqlalchemy:
 python-sqlalchemy hängt ab von python (>= 2.6.5-11~); aber:
  Paket python ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-sqlalchemy (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-dateutil:
 python-dateutil hängt ab von python (>= 2.3); aber:
  Paket python ist noch nicht konfiguriert.
 python-dateutil hängt ab von python-support (>= 0.7.1); aber:
  Paket python-support ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-dateutil (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-gtk2:
 python-gtk2 hängt ab von python (<< 2.7); aber:
  Paket python ist noch nicht konfiguriert.
 python-gtk2 hängt ab von python (>= 2.5); aber:
  Paket python ist noch nicht konfiguriert.
 python-gtk2 hängt ab von python-support (>= 0.90.0); aber:
  Paket python-support ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-gtk2 (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-simplejson:
 python-simplejson hängt ab von python (<< 2.7); aber:
  Paket python ist noch nicht konfiguriert.
 python-simplejson hängt ab von python (>= 2.5); aber:
  Paket python ist noch nicht konfiguriert.
 python-simplejson hängt ab von python-support (>= 0.90.0); aber:
  Paket python-support ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-simplejson (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-numpy:
 python-numpy hängt ab von python (<< 2.7); aber:
  Paket python ist noch nicht konfiguriert.
 python-numpy hängt ab von python (>= 2.5); aber:
  Paket python ist noch nicht konfiguriert.
 python-numpy hängt ab von python-support (>= 0.90.0); aber:
  Paket python-support ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-numpy (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-sqlalchemy-ext:
 python-sqlalchemy-ext hängt ab von python-sqlalchemy (= 0.6.3-3); aber:
  Paket python-sqlalchemy ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-sqlalchemy-ext (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-sip:
 python-sip hängt ab von python (<< 2.7); aber:
  Paket python ist noch nicht konfiguriert.
 python-sip hängt ab von python (>= 2.5); aber:
  Paket python ist noch nicht konfiguriert.
 python-sip hängt ab von python-support (>= 0.90.0); aber:
  Paket python-support ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-sip (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-tk:
 python-tk hängt ab von python (<< 2.7); aber:
  Paket python ist noch nicht konfiguriert.
 python-tk hängt ab von python (>= 2.5); aber:
  Paket python ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-tk (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-tz:
 python-tz hängt ab von python; aber:
  Paket python ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-tz (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-pyparsing:
 python-pyparsing hängt ab von python-support (>= 0.90.0); aber:
  Paket python-support ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-pyparsing (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-brlapi:
 python-brlapi hängt ab von python (<< 2.7); aber:
  Paket python ist noch nicht konfiguriert.
 python-brlapi hängt ab von python (>= 2.6); aber:
  Paket python ist noch nicht konfiguriert.
 python-brlapi hängt ab von python-support (>= 0.90.0); aber:
  Paket python-support ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-brlapi (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-beautifulsoup:
 python-beautifulsoup hängt ab von python (>= 2.2); aber:
  Paket python ist noch nicht konfiguriert.
 python-beautifulsoup hängt ab von python-support (>= 0.90.0); aber:
  Paket python-support ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-beautifulsoup (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 python-minimal
 python
 python-support
 python2.6
 python-glade2
 python-sqlalchemy
 python-dateutil
 python-gtk2
 python-simplejson
 python-numpy
 python-sqlalchemy-ext
 python-sip
 python-tk
 python-tz
 python-pyparsing
 python-brlapi
 python-beautifulsoup


Dann also:

Quellcode

1
2
3
root@Microknoppix:~# ls -l /usr/lib/python2.6/site-packages
insgesamt 104
-rw-r--r-- 1 root root 105728 26. Jan 2010  compizconfig.so


und :

Quellcode

1
2
3
4
5
root@Microknoppix:~# dpkg -S compizconfig.so
python-compizconfig: /usr/lib/python2.5/site-packages/compizconfig.so
libcompizconfig0: /usr/lib/libcompizconfig.so.0.0.0
python-compizconfig: /usr/lib/python2.6/site-packages/compizconfig.so
libcompizconfig0: /usr/lib/libcompizconfig.so.0


MfG und vielen Dank,
Laudatuse

klaus2008

Meister

Beiträge: 2 695

Geschlecht: Männlich

6

22.11.2010, 07:24

Ich würde jetzt wie im Beitrag Nummer 2 versuchen, die Pakete python-compizconfig, fusion-icon und compizconfig-settings-manager zu entfernen:

Quellcode

1
dpkg -P python-compizconfig fusion-icon compizconfig-settings-manager


Falls das klappt, würde ich mit

Quellcode

1
dpkg -a --configure
fortfahren. Falls dass gelingt, könnte man

Quellcode

1
apt-get -f install
versuchen.

Dann müssten noch die entfernten Pakete für compiz installiert werden:

Quellcode

1
apt-get -t testing python-compizconfig fusion-icon compizconfig-settings-manager 


Gruß Klaus

7

26.11.2010, 13:54

Hi Klaus!

dpkg -P hat nicht funktioniert, er hat python-compizconfig und fushion-icon entfernt, aber bei compizconfig-seittings-manager kommt:

Quellcode

1
2
3
4
5
6
7
8
9
Entferne compizconfig-settings-manager ...
/var/lib/dpkg/info/compizconfig-settings-manager.prerm: /usr/sbin/update-python-modules: /usr/bin/python: Defekter Interpreter: Datei oder Verzeichnis nicht gefunden
dpkg: Fehler beim Bearbeiten von compizconfig-settings-manager (--purge):
 Unterprozess installiertes pre-removal-Skript gab den Fehlerwert 126 zurück
/var/lib/dpkg/info/compizconfig-settings-manager.postinst: /usr/sbin/update-python-modules: /usr/bin/python: Defekter Interpreter: Datei oder Verzeichnis nicht gefunden
dpkg: Fehler beim Aufräumen:
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 126 zurück
Fehler traten auf beim Bearbeiten von:
 compizconfig-settings-manager


Natürlich funktioniert dann auch

Quellcode

1
dpkg -a --configure 
nicht, sondern spuckt Abhängigkeitsprobleme aus.

Hast du noch ne Idee, wie ich weitermachen kann?

MfG,
Laudatuse

klaus2008

Meister

Beiträge: 2 695

Geschlecht: Männlich

8

26.11.2010, 14:24

Hallo!

Wenn das Verzeichnis /usr/lib/python2.6/site-packages leer ist, kann man vermutlich mit der Installation fortfahren.
Was zeigt

Quellcode

1
ls -l /usr/lib/python2.6/site-packages
an?
Was geschieht jetzt, wenn Du

Quellcode

1
dpkg -i /var/cache/apt/archives/python2.6-minimal_2.6.6-6_i386.deb
ausführst?
Wenn das gelingt, könnte man

Quellcode

1
apt-get -f install
oder nochmals

Quellcode

1
dpkg -a --configure
versuchen.

Gruß Klaus

9

27.11.2010, 11:53

Vielen Dank nochmal.

apt-get funktioniert jetzt wieder.

Hab nun also versucht, anki so zu installieren, wie du es oben gesagt hattest.

Problem tritt hier auf:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
apt-get -t testing install anki python-qt4 libqt4-assistant libqt4-help libqt4-svg libqt4-test libqt4-webkit libqt4-xmlpatterns libqt4-network libqtcore4 libqt4-sql libqtgui4 libqt4-designer libqt4-script libqt4-sql libmng1 
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut   	
Status-Informationen einlesen... Fertig
libqt4-assistant ist schon die neueste Version.
libqt4-help ist schon die neueste Version.
libqt4-svg ist schon die neueste Version.
libqt4-test ist schon die neueste Version.
libqt4-webkit ist schon die neueste Version.
libqt4-xmlpatterns ist schon die neueste Version.
libqt4-network ist schon die neueste Version.
libqt4-network wurde als manuell installiert festgelegt.
libqtcore4 ist schon die neueste Version.
libqtcore4 wurde als manuell installiert festgelegt.
libqt4-sql ist schon die neueste Version.
libqt4-sql wurde als manuell installiert festgelegt.
libqtgui4 ist schon die neueste Version.
libqtgui4 wurde als manuell installiert festgelegt.
libqt4-designer ist schon die neueste Version.
libqt4-designer wurde als manuell installiert festgelegt.
libqt4-script ist schon die neueste Version.
libqt4-script wurde als manuell installiert festgelegt.
libqt4-sql ist schon die neueste Version.
libmng1 ist schon die neueste Version.
libmng1 wurde als manuell installiert festgelegt.
Die folgenden zusätzlichen Pakete werden installiert:
  libpython2.6 python-matplotlib
Vorgeschlagene Pakete:
  dvipng ipython python-configobj python-excelerator python-matplotlib-doc
  python-scipy python-traits texlive-extra-utils texlive-latex-extra
  python-wxgtk2.8 python-qt3 python-qt4-dbg
Die folgenden NEUEN Pakete werden installiert:
  anki libpython2.6 python-matplotlib python-qt4
0 aktualisiert, 4 neu installiert, 0 zu entfernen und 788 nicht aktualisiert.
Es müssen noch 1.213kB von 9.439kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 34,4MB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren [J/n]? j
Hole:1 http://ftp.de.debian.org testing/main anki 0.9.9.8.6-2.1 [1.213kB]
Es wurden 1.213kB in 3s geholt (350kB/s)
Wähle vormals abgewähltes Paket libpython2.6.
(Lese Datenbank ... 
dpkg: Warnung: Dateilisten-Datei des Paketes »kdelibs4c2a« fehlt, nehme an, dass das Paket derzeit keine Dateien installiert hat.
(Lese Datenbank ... 15%
dpkg: Warnung: Dateilisten-Datei des Paketes »libarts1c2a« fehlt, nehme an, dass das Paket derzeit keine Dateien installiert hat.
(Lese Datenbank ... 35%
dpkg: Warnung: Dateilisten-Datei des Paketes »python2.6« fehlt, nehme an, dass das Paket derzeit keine Dateien installiert hat.
dpkg: nicht behebbarer fataler Fehler, Abbruch:
 Abschließender Zeilenvorschub fehlt in Dateilisten-Datei des Paketes »libwmf0.2-7«
E: Sub-process /usr/bin/dpkg returned an error code (2)


Das sind zum Teil andere Pakete als da bei dir steht. Dann hab ich also

Quellcode

1
2
3
dpkg -a --configure
root@Microknoppix:~# ls -l /usr/lib/python2.6/site-packages
ls: Zugriff auf /usr/lib/python2.6/site-packages nicht möglich: Datei oder Verzeichnis nicht gefunden


ausgeführt. Und hier gehts nicht weiter, weil er dieses python2.6/site-packages nicht findet. Dann hab ich ausgeführt:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
339
340
341
342
343
344
345
346
347
348
349
350
351
352
353
354
355
356
357
358
359
360
361
362
363
364
365
366
367
368
369
370
371
372
373
374
375
376
377
378
379
380
381
382
383
384
385
386
387
388
389
390
391
392
393
394
395
396
397
398
399
400
401
402
403
404
405
406
407
408
409
410
411
412
413
414
415
416
417
418
419
420
421
422
423
424
425
426
ls -l /usr/lib/python2.6
insgesamt 8504
-rw-r--r--  1 root root  13913  9. Okt 12:15 _abcoll.py
-rw-r--r--  1 root root  21104 27. Nov 10:31 _abcoll.pyc
-rw-r--r--  1 root root   7034  9. Okt 12:15 abc.py
-rw-r--r--  1 root root   6049 27. Nov 10:31 abc.pyc
-rw-r--r--  1 root root  33188  9. Okt 12:15 aifc.py
-rw-r--r--  1 root root  29424 27. Nov 10:32 aifc.pyc
-rw-r--r--  1 root root   2620  9. Okt 12:15 anydbm.py
-rw-r--r--  1 root root   2769 27. Nov 10:32 anydbm.pyc
-rw-r--r--  1 root root  11347  9. Okt 12:15 ast.py
-rw-r--r--  1 root root  12732 27. Nov 10:32 ast.pyc
-rw-r--r--  1 root root  11402  9. Okt 12:15 asynchat.py
-rw-r--r--  1 root root   8677 27. Nov 10:32 asynchat.pyc
-rw-r--r--  1 root root  20061  9. Okt 12:15 asyncore.py
-rw-r--r--  1 root root  18334 27. Nov 10:32 asyncore.pyc
-rw-r--r--  1 root root   1705  9. Okt 12:15 atexit.py
-rw-r--r--  1 root root   2203 27. Nov 10:31 atexit.pyc
-rw-r--r--  1 root root   7597  9. Okt 12:15 audiodev.py
-rw-r--r--  1 root root   8483 27. Nov 10:32 audiodev.pyc
-rwxr-xr-x  1 root root  11331  9. Okt 12:15 base64.py
-rw-r--r--  1 root root  10967 27. Nov 10:31 base64.pyc
-rw-r--r--  1 root root  21974  9. Okt 12:15 BaseHTTPServer.py
-rw-r--r--  1 root root  21535 27. Nov 10:32 BaseHTTPServer.pyc
-rw-r--r--  1 root root   5744  9. Okt 12:15 Bastion.py
-rw-r--r--  1 root root   6637 27. Nov 10:32 Bastion.pyc
-rw-r--r--  1 root root  20597  9. Okt 12:15 bdb.py
-rw-r--r--  1 root root  18449 27. Nov 10:32 bdb.pyc
-rw-r--r--  1 root root  14878  9. Okt 12:15 binhex.py
-rw-r--r--  1 root root  15773 27. Nov 10:32 binhex.pyc
-rw-r--r--  1 root root   2662  9. Okt 12:15 bisect.py
-rw-r--r--  1 root root   3163 27. Nov 10:32 bisect.pyc
drwxr-xr-x  2 root root   4096 27. Nov 10:31 bsddb
-rw-r--r--  1 root root  23110  9. Okt 12:15 calendar.py
-rw-r--r--  1 root root  28007 27. Nov 10:32 calendar.pyc
-rw-r--r--  1 root root  11508  9. Okt 12:15 CGIHTTPServer.py
-rw-r--r--  1 root root   9891 27. Nov 10:32 CGIHTTPServer.pyc
-rwxr-xr-x  1 root root  34474  9. Okt 12:15 cgi.py
-rw-r--r--  1 root root  32680 27. Nov 10:32 cgi.pyc
-rw-r--r--  1 root root  12155  9. Okt 12:15 cgitb.py
-rw-r--r--  1 root root  12425 27. Nov 10:32 cgitb.pyc
-rw-r--r--  1 root root   5372  9. Okt 12:15 chunk.py
-rw-r--r--  1 root root   5623 27. Nov 10:32 chunk.pyc
-rw-r--r--  1 root root  14962  9. Okt 12:15 cmd.py
-rw-r--r--  1 root root  13914 27. Nov 10:32 cmd.pyc
-rw-r--r--  1 root root  35266  9. Okt 12:15 codecs.py
-rw-r--r--  1 root root  36533 27. Nov 10:31 codecs.pyc
-rw-r--r--  1 root root   5999  9. Okt 12:15 codeop.py
-rw-r--r--  1 root root   6616 27. Nov 10:32 codeop.pyc
-rw-r--r--  1 root root  10217  9. Okt 12:15 code.py
-rw-r--r--  1 root root  10395 27. Nov 10:32 code.pyc
-rw-r--r--  1 root root   6150  9. Okt 12:15 collections.py
-rw-r--r--  1 root root   6611 27. Nov 10:31 collections.pyc
-rw-r--r--  1 root root   3459  9. Okt 12:15 colorsys.py
-rw-r--r--  1 root root   4025 27. Nov 10:32 colorsys.pyc
-rw-r--r--  1 root root   2543  9. Okt 12:15 commands.py
-rw-r--r--  1 root root   2477 27. Nov 10:32 commands.pyc
-rw-r--r--  1 root root   6984  9. Okt 12:15 compileall.py
-rw-r--r--  1 root root   6534 27. Nov 10:31 compileall.pyc
drwxr-xr-x  2 root root   4096 27. Nov 10:31 compiler
drwxr-xr-x  2 root root   4096 13. Nov 23:30 config
-rw-r--r--  1 root root  24509  9. Okt 12:15 ConfigParser.py
-rw-r--r--  1 root root  23232 27. Nov 10:31 ConfigParser.pyc
-rw-r--r--  1 root root   4136  9. Okt 12:15 contextlib.py
-rw-r--r--  1 root root   4127 27. Nov 10:32 contextlib.pyc
-rw-r--r--  1 root root  64452  9. Okt 12:15 cookielib.py
-rw-r--r--  1 root root  55052 27. Nov 10:32 cookielib.pyc
-rwxr-xr-x  1 root root  25669  9. Okt 12:15 Cookie.py
-rw-r--r--  1 root root  22346 27. Nov 10:32 Cookie.pyc
-rw-r--r--  1 root root  10996  9. Okt 12:15 copy.py
-rw-r--r--  1 root root  11375 27. Nov 10:31 copy.pyc
-rw-r--r--  1 root root   6800  9. Okt 12:15 copy_reg.py
-rw-r--r--  1 root root   5156 27. Nov 10:31 copy_reg.pyc
-rwxr-xr-x  1 root root   6258  9. Okt 12:15 cProfile.py
-rw-r--r--  1 root root   6115 27. Nov 10:32 cProfile.pyc
-rw-r--r--  1 root root  15730  9. Okt 12:15 csv.py
-rw-r--r--  1 root root  13170 27. Nov 10:32 csv.pyc
drwxr-xr-x  2 root root   4096 27. Nov 10:31 ctypes
drwxr-xr-x  2 root root   4096 27. Nov 10:31 curses
-rw-r--r--  1 root root	535  9. Okt 12:15 dbhash.py
-rw-r--r--  1 root root	756 27. Nov 10:32 dbhash.pyc
-rw-r--r--  1 root root 199273  9. Okt 12:15 decimal.py
-rw-r--r--  1 root root 155185 27. Nov 10:32 decimal.pyc
-rwxr-xr-x  1 root root  81102  9. Okt 12:15 difflib.py
-rw-r--r--  1 root root  61093 27. Nov 10:32 difflib.pyc
-rw-r--r--  1 root root   1126  9. Okt 12:15 dircache.py
-rw-r--r--  1 root root   1576 27. Nov 10:32 dircache.pyc
-rw-r--r--  1 root root   6449  9. Okt 12:15 dis.py
-rw-r--r--  1 root root   6350 27. Nov 10:31 dis.pyc
drwxr-xr-x 12 root root   4096 27. Nov 10:32 dist-packages
drwxr-xr-x  3 root root   4096 27. Nov 10:31 distutils
-rw-r--r--  1 root root 101516  9. Okt 12:15 doctest.py
-rw-r--r--  1 root root  80782 27. Nov 10:32 doctest.pyc
-rw-r--r--  1 root root  10599  9. Okt 12:15 DocXMLRPCServer.py
-rw-r--r--  1 root root   9921 27. Nov 10:32 DocXMLRPCServer.pyc
-rw-r--r--  1 root root   8820  9. Okt 12:15 dumbdbm.py
-rw-r--r--  1 root root   6547 27. Nov 10:32 dumbdbm.pyc
-rw-r--r--  1 root root   2804  9. Okt 12:15 dummy_threading.py
-rw-r--r--  1 root root   1295 27. Nov 10:32 dummy_threading.pyc
-rw-r--r--  1 root root   4418  9. Okt 12:15 dummy_thread.py
-rw-r--r--  1 root root   5383 27. Nov 10:32 dummy_thread.pyc
drwxr-xr-x  3 root root   4096 27. Nov 10:31 email
drwxr-xr-x  2 root root   8192 27. Nov 10:31 encodings
-rw-r--r--  1 root root   9470  9. Okt 12:15 filecmp.py
-rw-r--r--  1 root root   9592 27. Nov 10:32 filecmp.pyc
-rw-r--r--  1 root root  14143  9. Okt 12:15 fileinput.py
-rw-r--r--  1 root root  14870 27. Nov 10:32 fileinput.pyc
-rw-r--r--  1 root root   3239  9. Okt 12:15 fnmatch.py
-rw-r--r--  1 root root   3567 27. Nov 10:31 fnmatch.pyc
-rw-r--r--  1 root root  14911  9. Okt 12:15 formatter.py
-rw-r--r--  1 root root  19149 27. Nov 10:32 formatter.pyc
-rw-r--r--  1 root root   4699  9. Okt 12:15 fpformat.py
-rw-r--r--  1 root root   4719 27. Nov 10:32 fpformat.pyc
-rw-r--r--  1 root root  20073  9. Okt 12:15 fractions.py
-rw-r--r--  1 root root  18041 27. Nov 10:32 fractions.pyc
-rw-r--r--  1 root root  28739  9. Okt 12:15 ftplib.py
-rw-r--r--  1 root root  28022 27. Nov 10:32 ftplib.pyc
-rw-r--r--  1 root root   2162  9. Okt 12:15 functools.py
-rw-r--r--  1 root root   1921 27. Nov 10:32 functools.pyc
-rw-r--r--  1 root root   4380  9. Okt 12:15 __future__.py
-rw-r--r--  1 root root   4221 27. Nov 10:31 __future__.pyc
-rw-r--r--  1 root root   3020  9. Okt 12:15 genericpath.py
-rw-r--r--  1 root root   3272 27. Nov 10:31 genericpath.pyc
-rw-r--r--  1 root root   7328  9. Okt 12:15 getopt.py
-rw-r--r--  1 root root   6710 27. Nov 10:31 getopt.pyc
-rw-r--r--  1 root root   5549  9. Okt 12:15 getpass.py
-rw-r--r--  1 root root   4756 27. Nov 10:32 getpass.pyc
-rw-r--r--  1 root root  19890  9. Okt 12:15 gettext.py
-rw-r--r--  1 root root  15626 27. Nov 10:32 gettext.pyc
-rw-r--r--  1 root root   2249  9. Okt 12:15 glob.py
-rw-r--r--  1 root root   2395 27. Nov 10:31 glob.pyc
-rw-r--r--  1 root root  16754  9. Okt 12:15 gzip.py
-rw-r--r--  1 root root  14322 27. Nov 10:32 gzip.pyc
-rw-r--r--  1 root root   4993  9. Okt 12:15 hashlib.py
-rw-r--r--  1 root root   4252 27. Nov 10:31 hashlib.pyc
-rw-r--r--  1 root root  15995  9. Okt 12:15 heapq.py
-rw-r--r--  1 root root  12668 27. Nov 10:32 heapq.pyc
-rw-r--r--  1 root root   4531  9. Okt 12:15 hmac.py
-rw-r--r--  1 root root   4489 27. Nov 10:32 hmac.pyc
drwxr-xr-x  2 root root   4096 27. Nov 10:31 hotshot
-rw-r--r--  1 root root  18054  9. Okt 12:15 htmlentitydefs.py
-rw-r--r--  1 root root   6369 27. Nov 10:32 htmlentitydefs.pyc
-rw-r--r--  1 root root  12869  9. Okt 12:15 htmllib.py
-rw-r--r--  1 root root  20202 27. Nov 10:32 htmllib.pyc
-rw-r--r--  1 root root  13576  9. Okt 12:15 HTMLParser.py
-rw-r--r--  1 root root  12198 27. Nov 10:32 HTMLParser.pyc
-rw-r--r--  1 root root  45486  9. Okt 12:15 httplib.py
-rw-r--r--  1 root root  35533 27. Nov 10:32 httplib.pyc
-rw-r--r--  1 root root  17452  9. Okt 12:15 ihooks.py
-rw-r--r--  1 root root  20699 27. Nov 10:32 ihooks.pyc
-rw-r--r--  1 root root  47232  9. Okt 12:15 imaplib.py
-rw-r--r--  1 root root  44888 27. Nov 10:32 imaplib.pyc
-rw-r--r--  1 root root   3544  9. Okt 12:15 imghdr.py
-rw-r--r--  1 root root   4873 27. Nov 10:32 imghdr.pyc
-rw-r--r--  1 root root  26009  9. Okt 12:15 imputil.py
-rw-r--r--  1 root root  15959 27. Nov 10:32 imputil.pyc
-rw-r--r--  1 root root  38189  9. Okt 12:15 inspect.py
-rw-r--r--  1 root root  37033 27. Nov 10:31 inspect.pyc
-rw-r--r--  1 root root  66165  9. Okt 12:15 io.py
-rw-r--r--  1 root root  62712 27. Nov 10:32 io.pyc
drwxr-xr-x  2 root root   4096 27. Nov 10:31 json
-rwxr-xr-x  1 root root   1993  9. Okt 12:15 keyword.py
-rw-r--r--  1 root root   2113 27. Nov 10:31 keyword.pyc
drwxr-xr-x  4 root root   4096 27. Nov 10:31 lib2to3
drwxr-xr-x  2 root root   4096 12. Nov 19:07 lib-dynload
drwxr-xr-x  2 root root   4096 27. Nov 10:31 lib-tk
-rw-r--r--  1 root root  14171  9. Okt 12:15 LICENSE.txt
-rw-r--r--  1 root root   4282  9. Okt 12:15 linecache.py
-rw-r--r--  1 root root   3299 27. Nov 10:31 linecache.pyc
-rw-r--r--  1 root root  88483  9. Okt 12:15 locale.py
-rw-r--r--  1 root root  49071 27. Nov 10:32 locale.pyc
drwxr-xr-x  2 root root   4096 27. Nov 10:31 logging
-rw-r--r--  1 root root   6553  9. Okt 12:15 _LWPCookieJar.py
-rw-r--r--  1 root root   5589 27. Nov 10:32 _LWPCookieJar.pyc
-rw-r--r--  1 root root   6253  9. Okt 12:15 macpath.py
-rw-r--r--  1 root root   7669 27. Nov 10:32 macpath.pyc
-rw-r--r--  1 root root   3275  9. Okt 12:15 macurl2path.py
-rw-r--r--  1 root root   2815 27. Nov 10:32 macurl2path.pyc
-rwxr-xr-x  1 root root  75846  9. Okt 12:15 mailbox.py
-rw-r--r--  1 root root  75633 27. Nov 10:32 mailbox.pyc
-rw-r--r--  1 root root   7427  9. Okt 12:15 mailcap.py
-rw-r--r--  1 root root   7167 27. Nov 10:32 mailcap.pyc
-rw-r--r--  1 root root  14350  9. Okt 12:15 markupbase.py
-rw-r--r--  1 root root   9430 27. Nov 10:32 markupbase.pyc
-rw-r--r--  1 root root	410  9. Okt 12:15 md5.py
-rw-r--r--  1 root root	376 27. Nov 10:31 md5.pyc
-rw-r--r--  1 root root  33434  9. Okt 12:15 mhlib.py
-rw-r--r--  1 root root  33981 27. Nov 10:32 mhlib.pyc
-rw-r--r--  1 root root   7168  9. Okt 12:15 mimetools.py
-rw-r--r--  1 root root   8280 27. Nov 10:32 mimetools.pyc
-rw-r--r--  1 root root  18822  9. Okt 12:15 mimetypes.py
-rw-r--r--  1 root root  16838 27. Nov 10:32 mimetypes.pyc
-rw-r--r--  1 root root   6482  9. Okt 12:15 MimeWriter.py
-rw-r--r--  1 root root   7365 27. Nov 10:32 MimeWriter.pyc
-rwxr-xr-x  1 root root  15020  9. Okt 12:15 mimify.py
-rw-r--r--  1 root root  12189 27. Nov 10:32 mimify.pyc
-rw-r--r--  1 root root  24283  9. Okt 12:15 modulefinder.py
-rw-r--r--  1 root root  18939 27. Nov 10:32 modulefinder.pyc
-rw-r--r--  1 root root   5809  9. Okt 12:15 _MozillaCookieJar.py
-rw-r--r--  1 root root   4509 27. Nov 10:32 _MozillaCookieJar.pyc
-rw-r--r--  1 root root   4820  9. Okt 12:15 multifile.py
-rw-r--r--  1 root root   5449 27. Nov 10:32 multifile.pyc
drwxr-xr-x  3 root root   4096 27. Nov 10:31 multiprocessing
-rw-r--r--  1 root root   1866  9. Okt 12:15 mutex.py
-rw-r--r--  1 root root   2512 27. Nov 10:32 mutex.pyc
-rw-r--r--  1 root root   4111  9. Okt 12:15 netrc.py
-rw-r--r--  1 root root   3586 27. Nov 10:32 netrc.pyc
-rw-r--r--  1 root root	706  9. Okt 12:15 new.py
-rw-r--r--  1 root root	908 27. Nov 10:32 new.pyc
-rw-r--r--  1 root root  21135  9. Okt 12:15 nntplib.py
-rw-r--r--  1 root root  20986 27. Nov 10:32 nntplib.pyc
-rw-r--r--  1 root root  17752  9. Okt 12:15 ntpath.py
-rw-r--r--  1 root root  11582 27. Nov 10:32 ntpath.pyc
-rw-r--r--  1 root root   2239  9. Okt 12:15 nturl2path.py
-rw-r--r--  1 root root   1771 27. Nov 10:32 nturl2path.pyc
-rw-r--r--  1 root root  10271  9. Okt 12:15 numbers.py
-rw-r--r--  1 root root  13840 27. Nov 10:32 numbers.pyc
-rw-r--r--  1 root root   5248  9. Okt 12:15 opcode.py
-rw-r--r--  1 root root   5907 27. Nov 10:31 opcode.pyc
-rw-r--r--  1 root root  60849  9. Okt 12:15 optparse.py
-rw-r--r--  1 root root  53959 27. Nov 10:31 optparse.pyc
-rw-r--r--  1 root root   4603  9. Okt 12:15 os2emxpath.py
-rw-r--r--  1 root root   4518 27. Nov 10:32 os2emxpath.pyc
-rw-r--r--  1 root root  26338  9. Okt 12:15 os.py
-rw-r--r--  1 root root  26303 27. Nov 10:31 os.pyc
-rw-r--r--  1 root root   7899  9. Okt 12:15 pdb.doc
-rwxr-xr-x  1 root root  45329  9. Okt 12:15 pdb.py
-rw-r--r--  1 root root  43585 27. Nov 10:32 pdb.pyc
-rw-r--r--  1 root root 	64  9. Okt 12:15 __phello__.foo.py
-rw-r--r--  1 root root	123 27. Nov 10:32 __phello__.foo.pyc
-rw-r--r--  1 root root  44811  9. Okt 12:15 pickle.py
-rw-r--r--  1 root root  38437 27. Nov 10:31 pickle.pyc
-rw-r--r--  1 root root  74348  9. Okt 12:15 pickletools.py
-rw-r--r--  1 root root  57079 27. Nov 10:32 pickletools.pyc
-rw-r--r--  1 root root   9647  9. Okt 12:15 pipes.py
-rw-r--r--  1 root root   9428 27. Nov 10:32 pipes.pyc
-rw-r--r--  1 root root  20001  9. Okt 12:15 pkgutil.py
-rw-r--r--  1 root root  18954 27. Nov 10:31 pkgutil.pyc
-rwxr-xr-x  1 root root  53555  9. Okt 12:15 platform.py
-rw-r--r--  1 root root  39368 27. Nov 10:31 platform.pyc
drwxr-xr-x  2 root root   4096 27. Nov 10:31 plat-linux2
-rw-r--r--  1 root root  15185  9. Okt 12:15 plistlib.py
-rw-r--r--  1 root root  19212 27. Nov 10:32 plistlib.pyc
-rw-r--r--  1 root root   8416  9. Okt 12:15 popen2.py
-rw-r--r--  1 root root   9032 27. Nov 10:31 popen2.pyc
-rw-r--r--  1 root root  12388  9. Okt 12:15 poplib.py
-rw-r--r--  1 root root  13187 27. Nov 10:32 poplib.pyc
-rw-r--r--  1 root root   8003  9. Okt 12:15 posixfile.py
-rw-r--r--  1 root root   7700 27. Nov 10:32 posixfile.pyc
-rw-r--r--  1 root root  13119  9. Okt 12:15 posixpath.py
-rw-r--r--  1 root root  11142 27. Nov 10:31 posixpath.pyc
-rw-r--r--  1 root root  11932  9. Okt 12:15 pprint.py
-rw-r--r--  1 root root  10356 27. Nov 10:32 pprint.pyc
-rw-r--r--  1 root root   4869  9. Okt 12:15 pty.py
-rw-r--r--  1 root root   4899 27. Nov 10:32 pty.pyc
-rw-r--r--  1 root root  13282  9. Okt 12:15 pyclbr.py
-rw-r--r--  1 root root   9706 27. Nov 10:32 pyclbr.pyc
-rw-r--r--  1 root root   6238  9. Okt 12:15 py_compile.py
-rw-r--r--  1 root root   6924 27. Nov 10:31 py_compile.pyc
-rwxr-xr-x  1 root root  92980  9. Okt 12:15 pydoc.py
-rw-r--r--  1 root root  91146 27. Nov 10:32 pydoc.pyc
-rw-r--r--  1 root root 423126  9. Okt 12:15 pydoc_topics.py
-rw-r--r--  1 root root 407586 27. Nov 10:32 pydoc_topics.pyc
-rw-r--r--  1 root root   8574  9. Okt 12:15 Queue.py
-rw-r--r--  1 root root   9391 27. Nov 10:32 Queue.pyc
-rwxr-xr-x  1 root root   6968  9. Okt 12:15 quopri.py
-rw-r--r--  1 root root   6666 27. Nov 10:32 quopri.pyc
-rw-r--r--  1 root root  31966  9. Okt 12:15 random.py
-rw-r--r--  1 root root  25024 27. Nov 10:31 random.pyc
-rw-r--r--  1 root root   4296  9. Okt 12:15 repr.py
-rw-r--r--  1 root root   5400 27. Nov 10:31 repr.pyc
-rw-r--r--  1 root root  12966  9. Okt 12:15 re.py
-rw-r--r--  1 root root  13122 27. Nov 10:31 re.pyc
-rw-r--r--  1 root root  20152  9. Okt 12:15 rexec.py
-rw-r--r--  1 root root  24102 27. Nov 10:32 rexec.pyc
-rw-r--r--  1 root root  33295  9. Okt 12:15 rfc822.py
-rw-r--r--  1 root root  31990 27. Nov 10:32 rfc822.pyc
-rw-r--r--  1 root root   5866  9. Okt 12:15 rlcompleter.py
-rw-r--r--  1 root root   6057 27. Nov 10:32 rlcompleter.pyc
-rw-r--r--  1 root root   7014  9. Okt 12:15 robotparser.py
-rw-r--r--  1 root root   7804 27. Nov 10:32 robotparser.pyc
-rwxr-xr-x  1 root root   5413  9. Okt 12:15 runpy.py
-rw-r--r--  1 root root   3965 27. Nov 10:31 runpy.pyc
-rw-r--r--  1 root root   5091  9. Okt 12:15 sched.py
-rw-r--r--  1 root root   4987 27. Nov 10:32 sched.pyc
-rw-r--r--  1 root root  19050  9. Okt 12:15 sets.py
-rw-r--r--  1 root root  16885 27. Nov 10:32 sets.pyc
-rw-r--r--  1 root root  17884  9. Okt 12:15 sgmllib.py
-rw-r--r--  1 root root  15504 27. Nov 10:32 sgmllib.pyc
-rw-r--r--  1 root root	445  9. Okt 12:15 sha.py
-rw-r--r--  1 root root	419 27. Nov 10:31 sha.pyc
-rw-r--r--  1 root root   8078  9. Okt 12:15 shelve.py
-rw-r--r--  1 root root  10242 27. Nov 10:32 shelve.pyc
-rw-r--r--  1 root root  11137  9. Okt 12:15 shlex.py
-rw-r--r--  1 root root   7684 27. Nov 10:32 shlex.pyc
-rw-r--r--  1 root root   8632  9. Okt 12:15 shutil.py
-rw-r--r--  1 root root   9519 27. Nov 10:31 shutil.pyc
-rw-r--r--  1 root root   7341  9. Okt 12:15 SimpleHTTPServer.py
-rw-r--r--  1 root root   7648 27. Nov 10:32 SimpleHTTPServer.pyc
-rw-r--r--  1 root root  21906  9. Okt 12:15 SimpleXMLRPCServer.py
-rw-r--r--  1 root root  19541 27. Nov 10:32 SimpleXMLRPCServer.pyc
lrwxrwxrwx  1 root root 	31 27. Nov 10:31 sitecustomize.py -> /etc/python2.6/sitecustomize.py
-rw-r--r--  1 root root	234 27. Nov 10:31 sitecustomize.pyc
-rw-r--r--  1 root root  19139  9. Okt 12:15 site.py
-rw-r--r--  1 root root  18614 27. Nov 10:31 site.pyc
-rwxr-xr-x  1 root root  18228  9. Okt 12:15 smtpd.py
-rw-r--r--  1 root root  15818 27. Nov 10:32 smtpd.pyc
-rwxr-xr-x  1 root root  30388  9. Okt 12:15 smtplib.py
-rw-r--r--  1 root root  29397 27. Nov 10:32 smtplib.pyc
-rw-r--r--  1 root root   5973  9. Okt 12:15 sndhdr.py
-rw-r--r--  1 root root   7386 27. Nov 10:32 sndhdr.pyc
-rw-r--r--  1 root root  19999  9. Okt 12:15 socket.py
-rw-r--r--  1 root root  15885 27. Nov 10:31 socket.pyc
-rw-r--r--  1 root root  22032  9. Okt 12:15 SocketServer.py
-rw-r--r--  1 root root  22638 27. Nov 10:32 SocketServer.pyc
drwxr-xr-x  2 root root   4096 27. Nov 10:31 sqlite3
-rw-r--r--  1 root root  16507  9. Okt 12:15 sre_compile.py
-rw-r--r--  1 root root  11455 27. Nov 10:31 sre_compile.pyc
-rw-r--r--  1 root root   7137  9. Okt 12:15 sre_constants.py
-rw-r--r--  1 root root   6083 27. Nov 10:31 sre_constants.pyc
-rw-r--r--  1 root root  26878  9. Okt 12:15 sre_parse.py
-rw-r--r--  1 root root  19622 27. Nov 10:31 sre_parse.pyc
-rw-r--r--  1 root root	384  9. Okt 12:15 sre.py
-rw-r--r--  1 root root	517 27. Nov 10:31 sre.pyc
-rw-r--r--  1 root root  14670  9. Okt 12:15 ssl.py
-rw-r--r--  1 root root  13540 27. Nov 10:31 ssl.pyc
-rw-r--r--  1 root root   1718  9. Okt 12:15 stat.py
-rw-r--r--  1 root root   2683 27. Nov 10:31 stat.pyc
-rw-r--r--  1 root root	898  9. Okt 12:15 statvfs.py
-rw-r--r--  1 root root	618 27. Nov 10:32 statvfs.pyc
-rw-r--r--  1 root root  10621  9. Okt 12:15 StringIO.py
-rw-r--r--  1 root root  11494 27. Nov 10:31 StringIO.pyc
-rw-r--r--  1 root root  12449  9. Okt 12:15 stringold.py
-rw-r--r--  1 root root  12539 27. Nov 10:32 stringold.pyc
-rw-r--r--  1 root root  13522  9. Okt 12:15 stringprep.py
-rw-r--r--  1 root root  14486 27. Nov 10:31 stringprep.pyc
-rw-r--r--  1 root root  20745  9. Okt 12:15 string.py
-rw-r--r--  1 root root  19964 27. Nov 10:31 string.pyc
-rw-r--r--  1 root root  19754  9. Okt 12:15 _strptime.py
-rw-r--r--  1 root root  14926 27. Nov 10:32 _strptime.pyc
-rw-r--r--  1 root root 	82  9. Okt 12:15 struct.py
-rw-r--r--  1 root root	237 27. Nov 10:31 struct.pyc
-rw-r--r--  1 root root  47433  9. Okt 12:15 subprocess.py
-rw-r--r--  1 root root  34904 27. Nov 10:31 subprocess.pyc
-rw-r--r--  1 root root   1399  9. Okt 12:15 sunaudio.py
-rw-r--r--  1 root root   1987 27. Nov 10:32 sunaudio.pyc
-rw-r--r--  1 root root  16537  9. Okt 12:15 sunau.py
-rw-r--r--  1 root root  17976 27. Nov 10:32 sunau.pyc
-rwxr-xr-x  1 root root   2046  9. Okt 12:15 symbol.py
-rw-r--r--  1 root root   3021 27. Nov 10:32 symbol.pyc
-rw-r--r--  1 root root   7911  9. Okt 12:15 symtable.py
-rw-r--r--  1 root root  12503 27. Nov 10:32 symtable.pyc
-rwxr-xr-x  1 root root  11335  9. Okt 12:15 tabnanny.py
-rw-r--r--  1 root root   8293 27. Nov 10:32 tabnanny.pyc
-rwxr-xr-x  1 root root  86867  9. Okt 12:15 tarfile.py
-rw-r--r--  1 root root  73191 27. Nov 10:32 tarfile.pyc
-rw-r--r--  1 root root  21808  9. Okt 12:15 telnetlib.py
-rw-r--r--  1 root root  19855 27. Nov 10:32 telnetlib.pyc
-rw-r--r--  1 root root  17774  9. Okt 12:15 tempfile.py
-rw-r--r--  1 root root  19463 27. Nov 10:31 tempfile.pyc
drwxr-xr-x  2 root root   4096 27. Nov 10:31 test
-rw-r--r--  1 root root  16889  9. Okt 12:15 textwrap.py
-rw-r--r--  1 root root  11766 27. Nov 10:31 textwrap.pyc
-rw-r--r--  1 root root   1002  9. Okt 12:15 this.py
-rw-r--r--  1 root root   1239 27. Nov 10:32 this.pyc
-rw-r--r--  1 root root   7114  9. Okt 12:15 _threading_local.py
-rw-r--r--  1 root root   6367 27. Nov 10:32 _threading_local.pyc
-rw-r--r--  1 root root  31808  9. Okt 12:15 threading.py
-rw-r--r--  1 root root  27956 27. Nov 10:32 threading.pyc
-rwxr-xr-x  1 root root  12025  9. Okt 12:15 timeit.py
-rw-r--r--  1 root root  11801 27. Nov 10:32 timeit.pyc
-rw-r--r--  1 root root   3142  9. Okt 12:15 toaiff.py
-rw-r--r--  1 root root   3126 27. Nov 10:32 toaiff.pyc
-rw-r--r--  1 root root  16326  9. Okt 12:15 tokenize.py
-rw-r--r--  1 root root  13986 27. Nov 10:31 tokenize.pyc
-rwxr-xr-x  1 root root   2943  9. Okt 12:15 token.py
-rw-r--r--  1 root root   3830 27. Nov 10:31 token.pyc
-rw-r--r--  1 root root  11211  9. Okt 12:15 traceback.py
-rw-r--r--  1 root root  11637 27. Nov 10:31 traceback.pyc
-rwxr-xr-x  1 root root  30347  9. Okt 12:15 trace.py
-rw-r--r--  1 root root  22989 27. Nov 10:32 trace.pyc
-rw-r--r--  1 root root	879  9. Okt 12:15 tty.py
-rw-r--r--  1 root root   1311 27. Nov 10:32 tty.pyc
-rw-r--r--  1 root root   2323  9. Okt 12:15 types.py
-rw-r--r--  1 root root   2608 27. Nov 10:31 types.pyc
-rwxr-xr-x  1 root root  31179  9. Okt 12:15 unittest.py
-rw-r--r--  1 root root  34656 27. Nov 10:32 unittest.pyc
-rw-r--r--  1 root root  49853  9. Okt 12:15 urllib2.py
-rw-r--r--  1 root root  45130 27. Nov 10:32 urllib2.pyc
-rw-r--r--  1 root root  58148  9. Okt 12:15 urllib.py
-rw-r--r--  1 root root  50812 27. Nov 10:32 urllib.pyc
-rw-r--r--  1 root root  13618  9. Okt 12:15 urlparse.py
-rw-r--r--  1 root root  13432 27. Nov 10:32 urlparse.pyc
-rw-r--r--  1 root root   5778  9. Okt 12:15 UserDict.py
-rw-r--r--  1 root root   8802 27. Nov 10:31 UserDict.pyc
-rw-r--r--  1 root root   3644  9. Okt 12:15 UserList.py
-rw-r--r--  1 root root   6535 27. Nov 10:32 UserList.pyc
-rw-r--r--  1 root root   1627  9. Okt 12:15 user.py
-rw-r--r--  1 root root   1734 27. Nov 10:32 user.pyc
-rwxr-xr-x  1 root root   9687  9. Okt 12:15 UserString.py
-rw-r--r--  1 root root  14786 27. Nov 10:32 UserString.pyc
-rw-r--r--  1 root root  20944  9. Okt 12:15 uuid.py
-rw-r--r--  1 root root  21205 27. Nov 10:32 uuid.pyc
-rwxr-xr-x  1 root root   5938  9. Okt 12:15 uu.py
-rw-r--r--  1 root root   4227 27. Nov 10:32 uu.pyc
-rw-r--r--  1 root root  14172  9. Okt 12:15 warnings.py
-rw-r--r--  1 root root  12996 27. Nov 10:31 warnings.pyc
-rw-r--r--  1 root root  17952  9. Okt 12:15 wave.py
-rw-r--r--  1 root root  19336 27. Nov 10:32 wave.pyc
-rw-r--r--  1 root root  10087  9. Okt 12:15 weakref.py
-rw-r--r--  1 root root  13277 27. Nov 10:32 weakref.pyc
-rwxr-xr-x  1 root root  21354  9. Okt 12:15 webbrowser.py
-rw-r--r--  1 root root  18826 27. Nov 10:32 webbrowser.pyc
-rw-r--r--  1 root root   3353  9. Okt 12:15 whichdb.py
-rw-r--r--  1 root root   2243 27. Nov 10:32 whichdb.pyc
drwxr-xr-x  2 root root   4096 27. Nov 10:31 wsgiref
-rw-r--r--  1 root root	187  9. Okt 12:15 wsgiref.egg-info
-rw-r--r--  1 root root   5513  9. Okt 12:15 xdrlib.py
-rw-r--r--  1 root root   9079 27. Nov 10:32 xdrlib.pyc
drwxr-xr-x  6 root root   4096 27. Nov 10:31 xml
-rw-r--r--  1 root root  34865  9. Okt 12:15 xmllib.py
-rw-r--r--  1 root root  27166 27. Nov 10:32 xmllib.pyc
-rw-r--r--  1 root root  47775  9. Okt 12:15 xmlrpclib.py
-rw-r--r--  1 root root  41230 27. Nov 10:32 xmlrpclib.pyc
-rw-r--r--  1 root root  53092  9. Okt 12:15 zipfile.py
-rw-r--r--  1 root root  37547 27. Nov 10:32 zipfile.pyc
.

Hier werden die site-packages nicht aufgeführt.

Ich dachte, es könnte vlt. sitecustomize.py sein, wollte aber nachfragen, bevor ich wieder was zerstöre.

MfG,
Laudatuse

klaus2008

Meister

Beiträge: 2 695

Geschlecht: Männlich

10

27.11.2010, 13:19

Nach der Deinstallation des Paketes python-compizconfig wurde vermutlich auch das nun leere Verzeichnis /usr/lib/python2.6/site-packages gelöscht. Ich glaube, dass das kein Problem darstellt.

Die verwendeten Paketlisten sind möglicherweise nicht mehr aktuell. Ich würde daher

Quellcode

1
apt-get update
ausführen, bevor Du

Quellcode

1
apt-get -t testing install anki python-qt4 libqt4-assistant libqt4-help libqt4-svg libqt4-test libqt4-webkit libqt4-xmlpatterns libqt4-network libqtcore4 libqt4-sql libqtgui4 libqt4-designer libqt4-script libqt4-sql libmng1 
noch einmal ausführst. Vielleicht genügt auch

Quellcode

1
apt-get -t testing install anki
nach apt-get update.

Gruß
Klaus

11

27.11.2010, 14:18

Hab alles nochmal neu gemacht, incl. apt-get update.

Problem ist folgendes:

dpkg -a --configure gibt kein Ergebnis aus,d.h. das sieht so aus:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
 apt-get -t testing install anki python-qt4 libqt4-assistant libqt4-help libqt4-svg libqt4-test libqt4-webkit libqt4-xmlpatterns libqt4-network libqtcore4 libqt4-sql libqtgui4 libqt4-designer libqt4-script libqt4-sql libmng1
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut   	
Status-Informationen einlesen... Fertig
libqt4-assistant ist schon die neueste Version.
libqt4-help ist schon die neueste Version.
libqt4-svg ist schon die neueste Version.
libqt4-test ist schon die neueste Version.
libqt4-webkit ist schon die neueste Version.
libqt4-xmlpatterns ist schon die neueste Version.
libqt4-network ist schon die neueste Version.
libqt4-network wurde als manuell installiert festgelegt.
libqtcore4 ist schon die neueste Version.
libqtcore4 wurde als manuell installiert festgelegt.
libqt4-sql ist schon die neueste Version.
libqt4-sql wurde als manuell installiert festgelegt.
libqtgui4 ist schon die neueste Version.
libqtgui4 wurde als manuell installiert festgelegt.
libqt4-designer ist schon die neueste Version.
libqt4-designer wurde als manuell installiert festgelegt.
libqt4-script ist schon die neueste Version.
libqt4-script wurde als manuell installiert festgelegt.
libqt4-sql ist schon die neueste Version.
libmng1 ist schon die neueste Version.
libmng1 wurde als manuell installiert festgelegt.
Die folgenden zusätzlichen Pakete werden installiert:
  libpython2.6 python-matplotlib
Vorgeschlagene Pakete:
  dvipng ipython python-configobj python-excelerator python-matplotlib-doc
  python-scipy python-traits texlive-extra-utils texlive-latex-extra
  python-wxgtk2.8 python-qt3 python-qt4-dbg
Die folgenden NEUEN Pakete werden installiert:
  anki libpython2.6 python-matplotlib python-qt4
0 aktualisiert, 4 neu installiert, 0 zu entfernen und 788 nicht aktualisiert.
Es müssen noch 0B von 9.439kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 34,4MB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren [J/n]? j
Wähle vormals abgewähltes Paket libpython2.6.
(Lese Datenbank ... 
dpkg: Warnung: Dateilisten-Datei des Paketes »kdelibs4c2a« fehlt, nehme an, dass das Paket derzeit keine Dateien installiert hat.
(Lese Datenbank ... 15%
dpkg: Warnung: Dateilisten-Datei des Paketes »libarts1c2a« fehlt, nehme an, dass das Paket derzeit keine Dateien installiert hat.
(Lese Datenbank ... 35%
dpkg: Warnung: Dateilisten-Datei des Paketes »python2.6« fehlt, nehme an, dass das Paket derzeit keine Dateien installiert hat.
dpkg: nicht behebbarer fataler Fehler, Abbruch:
 Abschließender Zeilenvorschub fehlt in Dateilisten-Datei des Paketes »libwmf0.2-7«
E: Sub-process /usr/bin/dpkg returned an error code (2)
.

Und dann:

Quellcode

1
2
3
4
5
6
7
8
9
ot@Microknoppix:~# dpkg -a --configure
root@Microknoppix:~# ls -l /usr/lib/python2.6/site-packages
ls: Zugriff auf /usr/lib/python2.6/site-packages nicht möglich: Datei oder Verzeichnis nicht gefunden
root@Microknoppix:~# dpkg -S compizconfig.so
dpkg-query: Warnung: Dateilisten-Datei des Paketes »kdelibs4c2a« fehlt, nehme an, dass das Paket derzeit keine Dateien installiert hat.
dpkg-query: Warnung: Dateilisten-Datei des Paketes »libarts1c2a« fehlt, nehme an, dass das Paket derzeit keine Dateien installiert hat.
dpkg-query: Warnung: Dateilisten-Datei des Paketes »python2.6« fehlt, nehme an, dass das Paket derzeit keine Dateien installiert hat.
dpkg-query: nicht behebbarer fataler Fehler, Abbruch:
 Abschließender Zeilenvorschub fehlt in Dateilisten-Datei des Paketes »libwmf0.2-7«


Laut deinem ersten Post sollte das komplett anders aussehen und er hätte bei dpkg -a --configure etwas installieren sollen. Tut er bei mir aber nicht.

Danke, dass du dir so viel Zeit dafür nimmst.

MfG,
Laudatuse

klaus2008

Meister

Beiträge: 2 695

Geschlecht: Männlich

12

27.11.2010, 15:38

Du könntest noch folgendes versuchen

Quellcode

1
 apt-get -t testing install python2.6 kdelibs4c2a libarts1c2a libwmf0.2-7 
Damit werden vielleicht die Fehler behoben.

Gruß
Klaus

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop