24.10.2017, 02:08 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

09.08.2014, 12:59

Wie installiere ich PulsAudio für das neue Skype 4.3 richtig unter Knoppix 7.2 ?

Microsoft erlaubt unter Linux nur noch Skype ab Version 4.3
Nach der Installation dieser Version bekomme ich keine Audioquelle (Micro in der Webcam und USB-Lautsprecher) zum tönen... ?(
Wer hat eine Lösung?
Danke Monti.

ubuntuli

Fortgeschrittener

Beiträge: 372

Geschlecht: Männlich

2

09.08.2014, 20:21

einen Tipp kann ich dir geben.
Verabschiede dich von MS! Hast Du Linux oder Windows? Was möchtest Du?
Wenn Du Linux als Betriebssystem hast brauchst Du kein MS mehr! Das gilt auch für Skype.
Zum installieren im Terminal. „apt-get install skype"
das geht bei Ubuntu und bei Knoppix 6.7
auf meinem USB mit Knoppix 7.2 habe ich das noch nicht probiert.
Gruss ubuntuli.

Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von »ubuntuli« (09.08.2014, 20:53)


3

10.08.2014, 13:54

Ich möchte weiterhin unter Knoppix 7.2 skypen.
Das funktionierte auch noch bis vor kurzem mit der Skype Version 4.2.
Diese unterstützt aber der Besitzer von Skype (also Microsoft) nicht mehr.
Man muß die Version 4.3 installieren.
Diese benötigt die PulsAudio Treiber um zu funktionieren.
Wie installiere ich nun die PulsAudio Treiber richtig unter Knoppix 7.2 ?
Gruß Monti.

5

10.08.2014, 20:43

Hallo,

Zitat

Wie installiere ich nun die PulsAudio Treiber richtig unter Knoppix 7.2 ?

Ich würde es so versuchen: ein Terminal öffnen und folgende Befehle eingeben:

Quellcode

1
2
sudo apt-get update
sudo apt-get install pulseaudio pavucontrol

Mit pavucontrol sollte man dann die Audio Ein-/Ausgabegeräte auswählen können.
Weitere Infos findet man unter wiki.debian.org/PulseAudio.
MfG

6

11.08.2014, 19:23

Danke,
aber bei Eingabe von :
sudo apt-get install pulseaudio pavucontrol
Kommt bei meinem Laptop mit Knoppix 7.0 folgende Ausschrift:

Paketlisten werden gelesen...
Abhängigkeitsbaum wird aufgebaut....
Statusinformationen werden eingelesen....
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
libasan1 : Hängt ab von: libstdc++6 (>= 4.1.1) soll aber nicht installiert werden
libcilkrts5 : Hängt ab von: libstdc++6 (>= 4.1.1) soll aber nicht installiert werden
libgcc-4.9-dev : Hängt ab von: libgomp1 (>= 4.9.1-4) soll aber nicht installiert werden
libgl1-mesa-dri : Hängt ab von: libstdc++6 (>= 4.6) soll aber nicht installiert werden
libgl1-mesa-glx : Hängt ab von: libstdc++6 (>= 4.1.1) soll aber nicht installiert werden
libgsoap2 : Hängt ab von: libstdc++6 (>= 4.4.0) soll aber nicht installiert werden
libqt4-opengl : Hängt ab von: libqtcore4 (= 4:4.8.6+git49-gbc62005+dfsg-1) soll aber nicht installiert werden
Hängt ab von: libqtgui4 (= 4:4.8.6+git49-gbc62005+dfsg-1) soll aber nicht installiert werden
Hängt ab von: libstdc++6 (>= 4.1.1) soll aber nicht installiert werden
libubsan0 : Hängt ab von: libstdc++6 (>= 4.1.1) soll aber nicht installiert werden
pavucontrol : Hängt ab von: libatk1.0-0 (>= 1.12.4) soll aber nicht installiert werden
Hängt ab von: libatkmm-1.6-1 (>= 2.22.1) soll aber nicht installiert werden
Hängt ab von: libcairo-gobject2 (>= 1.10.0) soll aber nicht installiert werden
Hängt ab von: libcairo2 (>= 1.2.4) soll aber nicht installiert werden
Hängt ab von: libcairomm-1.0-1 (>= 1.6.4) soll aber nicht installiert werden
Hängt ab von: libcanberra-gtk3-0 (>= 0.25) soll aber nicht installiert werden
Hängt ab von: libgdk-pixbuf2.0-0 (>= 2.22.0) soll aber nicht installiert werden
Hängt ab von: libglib2.0-0 (>= 2.16.0) soll aber nicht installiert werden
Hängt ab von: libglibmm-2.4-1c2a (>= 2.36.2) soll aber nicht installiert werden
Hängt ab von: libgtk-3-0 (>= 3.0.0) soll aber nicht installiert werden
Hängt ab von: libgtkmm-3.0-1 (>= 3.8.1) soll aber nicht installiert werden
Hängt ab von: libpango-1.0-0 (>= 1.14.0) soll aber nicht installiert werden
Hängt ab von: libpangocairo-1.0-0 (>= 1.14.0) soll aber nicht installiert werden
Hängt ab von: libpangomm-1.4-1 (>= 2.27.1) soll aber nicht installiert werden
Hängt ab von: libpulse-mainloop-glib0 (>= 0.99.1) soll aber nicht installiert werden
Hängt ab von: libpulse0 (>= 4.0) aber 2.0-3 soll installiert werden
Hängt ab von: libsigc++-2.0-0c2a (>= 2.2.0) soll aber nicht installiert werden
Hängt ab von: libstdc++6 (>= 4.2.1) soll aber nicht installiert werden
perl : Hängt ab von: libdb5.3 soll aber nicht installiert werden
pulseaudio : Hängt ab von: libc6 (>= 2.15) aber 2.13-38+deb7u3 soll installiert werden
Hängt ab von: libfftw3-single3 soll aber nicht installiert werden
Hängt ab von: libpulse0 (= 5.0-6) aber 2.0-3 soll installiert werden
Hängt ab von: libstdc++6 (>= 4.1.1) soll aber nicht installiert werden
Hängt ab von: libudev1 (>= 183) soll aber nicht installiert werden
Hängt ab von: libwebrtc-audio-processing-0 soll aber nicht installiert werden
Hängt ab von: libasound2-plugins soll aber nicht installiert werden
Hängt ab von: pulseaudio-utils soll aber nicht installiert werden
Empfiehlt: pulseaudio-module-x11 soll aber nicht installiert werden
Empfiehlt: rtkit soll aber nicht installiert werden
Beschädigt: avahi-daemon (< 0.6.31-3) aber 0.6.31-1 soll installiert werden
virtualbox : Hängt ab von: libsdl1.2debian (>= 1.2.11) soll aber nicht installiert werden
Hängt ab von: libstdc++6 (>= 4.6) soll aber nicht installiert werden
Empfiehlt: libqtcore4 (>= 4:4.5.3) soll aber nicht installiert werden
Empfiehlt: libqtgui4 (>= 4:4.5.3) soll aber nicht installiert werden
virtualbox-qt : Hängt ab von: libqt4-network (>= 4:4.5.3) soll aber nicht installiert werden
Hängt ab von: libqtcore4 (>= 4:4.8.0) soll aber nicht installiert werden
Hängt ab von: libqtgui4 (>= 4:4.8.0) soll aber nicht installiert werden
Hängt ab von: libsdl1.2debian (>= 1.2.11) soll aber nicht installiert werden
Hängt ab von: libstdc++6 (>= 4.6) soll aber nicht installiert werden

Klappt nicht so einfach... :(

7

12.08.2014, 13:31

Hallo Monti,
habe gerade mal mit der Knoppix 7.0.5 CD getestet, ging ohne Probleme.
Vielleicht ist Knoppix 7.0 doch schon zu alt?
Für meine Test-Installation habe ich mit einem frischen Live-System gebootet (Cheatcode "knoppix noimage")
und es waren nur die "stable" Paketquellen aktiviert:

Quellcode

1
2
3
4
5
6
sudo apt-get update
sudo apt-get install pulseaudio pavucontrol
wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
sudo dpkg -i skype-install.deb 
sudo apt-get -f install
pulseaudio --start

Das Installationsprotokoll habe ich angehängt.

MfG
»l8night« hat folgende Datei angehängt:

8

13.08.2014, 20:52

Hallo,
erst mal recht vielen Dank für Deine Hilfe l8night.
Hab mein Knoppix 7.0 als HD Installation fest auf dem alten Laptop. Ins Internet gehe ich über seine USB 1.0 Schnittstelle
mittels Smartphone USB-Tethering. Da ich fast immer auf Montage (Monti) bin, hab ich auch keine Live-CD/DVD zur Hand.
Meine Festplatte ist nur 12 GB groß, was für größere Vollinstallationen von neueren Knoppixversionen nicht reicht.
Und ein Bereinigen des aktuellen Systems ist bestimmt nicht so leicht möglich, oder?
Ich denke ich werde 1 Wochenende opfern und alle Daten retten um Knoppix 7.0 neu aufzuspielen.
Klappt das für eine HD Istallation auch mit dem Cheatcode "knoppix noimage"?
HD Installation muß sein, weil 1.0 Stick und mechanisches Laufwerk zu langsam booten.
In jedem Fall,
Danke für die Hilfe !
Monti

9

15.08.2014, 11:43

Hallo,

Zitat

Meine Festplatte ist nur 12 GB groß, was für größere Vollinstallationen von neueren Knoppixversionen nicht reicht.

Für die aktuelle Knoppix 7.2 CD brauchst Du ca. 700MB, für die 7.4 DVD 4GB, dann bleiben immer noch 11 bzw. 8GB für eigene Daten / Programme.
Alte Knoppix-Versionen sollte man nicht verwenden, da Updates nur begrenzt möglich sind.

Zitat

Klappt das für eine HD Istallation auch mit dem Cheatcode "knoppix noimage"?

Ja. Ist zu empfehlen, wenn man Programme vor einer persistenten Installation erst mal testen will.
Es sollte dann aber genug RAM vorhanden sein, ich denke mindestens 1GB.

MfG

10

17.08.2014, 15:07

Hallo,
wenn man eine Knoppix-DVD auf seine Festplatte installiert, entpackt sich das Bestiebssystem. Es ist dann also wesentlich größer als seine komprimierte DVD oder Stick Variante. Knoppix 7.05, 7.2, 7.3 und die aktuelle 7.4 Version passen nicht mehr auf meine HD in der kompletten Version.
Die Installation macht das Own-Programm und darum noch einmal meine Frage, wie übergebe ich den knoppix noimage Parameter für eine HD-Installation an Own? Oder muß ich nach erfolgter Installation die menu.lst unter /boot/grub diesbezüglich abändern?
Danke
Monti

11

18.08.2014, 11:48

Hallo Monti,

ich meinte ein "Poor man's install", da wird nichts entpackt. Eine Anleitung findest Du im Knoppix-Wiki unter Hard_drive_Installation.
Den Cheatcode "noimage" könntest Du in der /boot/grub/menu.1st ergänzen, aber ich denke, das macht in diesem Fall keinen Sinn, da ja Skype persistent installiert werden soll.

MfG

12

24.08.2014, 19:22

Hallo l8night,
habe dank Deiner Hilfe auf meinem home-PC jetzt Skype 4.3 drauf und es funktioniert.
Aber bestimmte Anwendungen z.B. Minitube funktionieren nicht mit PulseAudio.
Kann man solchen Anwendungen mitteilen die Hardware mittels Alsa anzusprechen?
Auf dem Laptop muß ich erst für Platz sorgen um ein neueres Knoppix zu installieren. Und Skype installiere ich dann nach Deinen Vorgaben.
Danke.
MfG
Monti

Ähnliche Themen

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop