27.04.2017, 12:56 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

30.10.2016, 10:59

xscreensaver

hallo forum!

Ich nutze V7.7.1 auf einem USB-Stick.

Der Bildschirmschoner hat die Standardeinstellungen, also zB Aktivierung nach 10 Minuten.
Wenn der Bildschirmschoner aktiviert wird, dann ist der Bildschirm schwarz, ein Cursor ist zu sehen.
Mit der Maus kann man den Cursor bewegen.
Der Bildschirmschoner wird aber nicht de-aktiviert durch Tastendruck oder Mausbewegung.
Ein Neustart (via ALT F2) oder ein X-Restart (via STRG-ALT+Backspace) lösen das Problem, helfen mir aber nicht wirklich.
Ein Vergleich zwischen 7.6.1 und 7.7.1 (xscreensaver starten mit -verbose und -log <file>) zeigt, dass wohl alleine das benutzte DISPLAY die Ursache für mein Problem ist.

Meine Problemlösung:
~/.config/lxsession/LXDE/autostart ändern:
Startzeile von xscreensaver ergänzen um -display :0.0

Meine Fragen:
- Wo wird das DISPLAY vor dem Start von LXDE für den User knoppix definiert?
- Kennt jemand die Änderungen zwischen 7.6.1 und 7.7.1, die zu dem o.a. Effekt geführt haben?

Einen schönen Sonntag wünscht
Mathix :-)

Aktualisierung:
Meine Problemlösung greift nicht dauerhaft, das Thema ist also noch offen - mindestens für mich.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »mathix« (30.10.2016, 15:42)


2

30.10.2016, 18:04

xscreensaver - Graphikkartentreiber?

Hallo Forum!

Szenario: V7.7.1 auf USB-Stick, Rechner mit integriertem Graphikprozessor von Intel, Rechner mit AMD/Radeon.

Mein Problem scheint ein Graphikkartentreiber-Thema zu sein ...
Oder hat jemand andere Erkenntnisse?

Zu meiner Vermutung:
xscreensaver läuft problemlos auf AMD/Radeon, aber nicht auf einem Rechner mit integriertem Graphikprozessor von Intel.


Details:
i965-va-driver:i386i - 1.7.2-1 - VAAPI driver for Intel G45 & HD Graphics family (V7.6.1 hatte 1.6.2-1)
#
description: VGA compatible controller
product: 82Q35 Express Integrated Graphics Controller
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 02
width: 32 bits
clock: 33MHz
capabilities: msi pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:30 memory:d0080000-d00fffff ioport:1c70(size=8) memo
#
Fehlermeldung, die zeitgleich beim Umschalten vom xscreensaver-Bildschrimschoner auftritt:
[drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe A (start=84836 end=84837) time 209 us, min 1073, max 1079, scanline start 1066, end 1080


Was werde ich tun?
- auf eine Korrektur des Treibers warten
- xscreensaver de-aktivieren
- prüfen ob ein Fallback des o.a. Treibers auf die Version 1.6.2-1 möglich ist
- ggf. knoppix V7.7.1 mit Cheatcode starten - aber welchem?


Das war es dann für heute :-)
Einen schönen Abend wünscht
Mathix :-)

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop