23.11.2017, 01:16 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

20.10.2017, 01:02

KNOPPIX 8.1 speichert Dateien mit 0-Byte auf USB-Stick ab

In der neuen 8.1er Version gibt es ein Speicherproblem auf
USB-Datenträgern die mit FAT16/32 formatiert sind worauf
die Welt nur gewartet hat. Auf einem USB-Datenträger
welcher erstmals in der laufenden KNOPPIX Session
gemountet wurde (z.b mit sdb1) lassen sich darauf Dateien
abspeichern. Sie werden zuerst gecasht, und beim auswerfen
tatsächlich geschrieben. Soweit so, wie alles sein soll.

Der gleiche Datenträger, oder gar ein anderer, welcher
wieder mit sdb1 gemountet wird, speichert ab sofort
und zukünftig Dateien mit 0-Byte Größe ab.

Die einzigsten Notlösungen die momentan funktionieren um Dateien
wieder in voller Größe zu speichern sind entweder KNOPPIX neu zu
starten, oder einen weiteren USB-Datenträger als Dummy zuzulegen
und diesen immer wieder mit parted/GParted neu zu formatieren.
Das ganze Spiel wiederholt sich, sobald in der laufenden KNOPPIX
Session der Datenträger ausgeworfen wird und ein anderer
oder nochmal der gleiche eingelegt wird.



Wer es nicht glaubt,
der kann das Ganze mal nachstellen.

Bedingungen dazu
sind: KNOPPIX 8.1 und einen USB-Datenträger mit FAT16 oder FAT32
Formatierung.

Datenträger mit
NTFS Formatierung sind davon nicht betroffen.

Es ist mit andere
Rechner reproduzierbar, unabhängig ob KNOPPIX von DVD oder USB
gestartet wird, und egal ob mit 32bit oder 64bit Umgebung.


Und jetzt die Frage:

- Was läuft da in
der 8.1er Version im inneren vom Betriebssystem so quer dass das
passiert?

- Und wie lässt
sich das mit Skripten besser lösen als mit meinen Notlösungen?

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »Sittich« (25.10.2017, 02:31)


2

22.10.2017, 18:31

Wer es nicht glaubt,
der kann das Ganze mal nachstellen.


Das habe ich gerade mal versucht:

Quellcode

1
2
3
4
knoppix@Microknoppix:~$ uname -a
Linux Microknoppix 4.12.7-64 #13 SMP PREEMPT Tue Aug 15 04:56:38 CEST 2017 x86_64 GNU/Linux
knoppix@Microknoppix:~$ cat /mnt-system/KNOPPIX/kversion 
8.1-2017-09-05

Stick mit FAT32 eingelegt und gemounted und dann drei Testdateien angelegt und auf den Stick kopiert:

Quellcode

1
2
3
4
5
6
knoppix@Microknoppix:~$ mount | grep sdc
/dev/sdc1 on /media/sdc1 type vfat (rw,nosuid,nodev,relatime,uid=1000,gid=1000,fmask=0000,dmask=0000,allow_utime=0022,codepage=850,iocharset=utf8,shortname=winnt,utf8,errors=remount-ro)
knoppix@Microknoppix:~$ dd if=/dev/zero of=/tmp/mytest bs=1M count=3
3+0 Datensätze ein
3+0 Datensätze aus
3145728 Bytes (3,1 MB, 3,0 MiB) kopiert, 0,00675776 s, 465 MB/s
Auf diese Weise nun jeweils den count um eins erhöht, um deutlich unterscheidbare Dateien zu erhalten und mit rsync kopiert:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
knoppix@Microknoppix:~$ rsync -v /tmp/mytest* /media/sdc1
mytest
mytest1
mytest2

sent 12,586,172 bytes  received 73 bytes  25,172,490.00 bytes/sec
total size is 12,582,912  speedup is 1.00
knoppix@Microknoppix:~$ ll /media/sdc1 | grep mytest 
-rwxrwxrwx 1 knoppix knoppix 3145728 Okt 22 16:05 mytest
-rwxrwxrwx 1 knoppix knoppix 4194304 Okt 22 16:05 mytest1
-rwxrwxrwx 1 knoppix knoppix 5242880 Okt 22 16:05 mytest2

Stick ausgehangen.

Quellcode

1
knoppix@Microknoppix:~$ umount /media/sdc1

Weitere Dateien erzeugt, wie oben, jeweils den Zähler erhöht:

Quellcode

1
2
3
4
5
6
7
knoppix@Microknoppix:~$ ll /tmp | grep mytest 
-rw-r--r-- 1 knoppix knoppix 3145728 Okt 22 16:03 mytest
-rw-r--r-- 1 knoppix knoppix 4194304 Okt 22 16:04 mytest1
-rw-r--r-- 1 knoppix knoppix 5242880 Okt 22 16:05 mytest2
-rw-r--r-- 1 knoppix knoppix 6291456 Okt 22 16:06 mytest3
-rw-r--r-- 1 knoppix knoppix 7340032 Okt 22 16:06 mytest4
-rw-r--r-- 1 knoppix knoppix 8388608 Okt 22 16:06 mytest5

Den Stick nun wieder eingebunden, wird wieder sdc und wieder den rsync laufen lassen und nachgesehen:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
knoppix@Microknoppix:~$ rsync -v /tmp/mytest* /media/sdc1
mytest
mytest1
mytest2
mytest3
mytest4
mytest5

sent 34,611,813 bytes  received 130 bytes  23,074,628.67 bytes/sec
total size is 34,603,008  speedup is 1.00
knoppix@Microknoppix:~$ ll /media/sdc1 | grep mytest 
-rwxrwxrwx 1 knoppix knoppix 3145728 Okt 22 16:08 mytest
-rwxrwxrwx 1 knoppix knoppix 4194304 Okt 22 16:08 mytest1
-rwxrwxrwx 1 knoppix knoppix 5242880 Okt 22 16:08 mytest2
-rwxrwxrwx 1 knoppix knoppix 6291456 Okt 22 16:08 mytest3
-rwxrwxrwx 1 knoppix knoppix 7340032 Okt 22 16:08 mytest4
-rwxrwxrwx 1 knoppix knoppix 8388608 Okt 22 16:08 mytest5


Ich merke an, dass die Dateien "sofort" im Ziel landeten und nicht erst beim aushängen synchronisiert wurde.

Das Vorhandensein der Dateien ist auch echt, ich habe das auf einem anderen System überprüft:

Quellcode

1
2
3
4
5
6
7
pit@senyo ~:- > ll /media/FAT32/ | grep -i mytest
-rwxr-xr-x  1 pit  pit  3145728 22 Okt. 16:08 MYTEST
-rwxr-xr-x  1 pit  pit  4194304 22 Okt. 16:08 MYTEST1
-rwxr-xr-x  1 pit  pit  5242880 22 Okt. 16:08 MYTEST2
-rwxr-xr-x  1 pit  pit  6291456 22 Okt. 16:08 MYTEST3
-rwxr-xr-x  1 pit  pit  7340032 22 Okt. 16:08 MYTEST4
-rwxr-xr-x  1 pit  pit  8388608 22 Okt. 16:08 MYTEST5
(Die Unterschiede in den Dateinamen ergeben sich aus den unterschiedlichen mount-Optionen hinsichtlich der verwendeten Codepage). Interessant finde ich, dass Knoppix "nachgeht". Die Zeit wird nicht korrekt gesetzt, der Erzeugungsstempel aber richtig vom zweitem System ausgelesen. Das habe ich auch nicht anders erwartet. Die Unterschiede in den Dateirechten hängen ebenfalls von den mount-Optionen ab und natürlich vom jeweiligen Nutzer.

Wenn ich das zusammenfasse, kann ich das von dir geschilderte Problem hier nicht nachvollziehen.
Habe ich etwas falsch verstanden?

3

23.10.2017, 14:40

Falsch verstanden nicht, aber was falsches gemacht. Du hast rsync und die Textkonsole benutzt. Vieeel zu viele Klimmzüge um Dateien auf einen USB-Stick zu verfrachten. Obwohl deine Methode sicher funktioniert! Hab ich ausprobiert.

Mach das mal so wie jeder "normale Benutzer" es auch tun würde:

Textkonsole bleibt geschlossen!


- USB-Stick einlegen;
- mit den gebotenen Graphischen Dateimanagern wie 'PCManFM' (zu finden in der Taskbar-Leiste) oder 'Dolphin' eine Datei kopieren;
- safely unmounten (PCManFM, Dolphin und co. bieten ja die Möglichkeiten dazu an);
- USB-Stick abziehen;
- Stick erneut einlegen (weil wir vom gedachten Fall ausgehen wir haben noch was vergessen zu kopieren);
- eine Weitere Datei kopieren;
- erneut Safely unmounten;
- Stick replug,

und siehe da jede weitere hinzugekommene Datei hat 0-Byte.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Sittich« (23.10.2017, 15:03)


4

23.10.2017, 16:46

Nein, sieht bei mir nicht danach aus.
Zur Zeit habe ich nur einen MacBook-Air verfügbar, auf dem Knoppix 8.1 boote. Das Touchpad ist nicht super gut zu bedienen unter Knoppix und ich arbeite ja auch lieber hier von meinem PC, weshalb ich mich nach Knoppix mit ssh verbinde und daher ganz natürlich solche Tests im Terminal durchführe. So kann ich die auch per copy_n_paste hier einstellen. Ich habe keine Verbindung über XRDP realisiert, das würde auch gehen, aber ich sehe ja den kleinen Laptop auf meinem Tisch und kann ihn auch bedienen, wenn es denn sein muss.
Also, zum Test.
Von Gestern hatte ich noch die Dateien mytest* auf dem Stick gespeichert. Die habe ich nun in einen Ordner test in meinem Knoppix-Home verschoben.
Dann den Stick ausgehangen, mit der Maus.
Dann wieder eingebunden und drei Dateien auf den Stick kopiert. Sie waren "sofort" dort. Danach Stick wieder mit der Maus augehangen und dann wieder eingebunden und eine weitere Datei kopiert: sofort im Ziel und in vollständiger Größe. Das habe ich mehrfach wiederholt und zum Schluss auch noch verschoben, anstatt zu kopieren. Dabei benutzte ich pcmanfm, den ich nicht nur unter Knoppix als meinen hauptsächlichen Dateimanager nutze. Alle Operationen wurden mit der Maus, bzw mit dem Touchpad durchgeführt. Der pcmanfm ist so eingestellt, dass er bei loslassen einer Datei in einem Fenster nachfragt, ob er sie kopieren oder verschieben (oder verknüpfen) soll. Ich hatte dabei zwei Fenster geöffnet und Dateien von Quellfenster nach Zielfenster kopiert, bzw verschoben. Es funktionierte immer, wie erwartet.

Dann probierte ich zwei ältere Dateien aus meinem ~, die ich also nicht zuvor angelegt hatte, sondern nach Erstellen des Sticks hierhin kopiert hatte.
Dieser Test verlief so, wie du das beschrieben hattest, mit der Ausnahme, dass die Dateien zunächst tatsächlich vollständig im Ziel erschienen waren und erst bei der Kontrolle mit erneut gemountetem Stick wurden sie mit 0-byte ausgegeben.
Es zeigte sich, dass die beiden verwendeten Dateien dem User root:root gehörten (und -rw-r--r-- gesetzt war). Ich hatte wohl als root die Dateien von einem anderen Knoppix übertragen gehabt und nicht anschließend den Besitzer überprüft.
Nachdem ich das nun änderte und die Dateien dem User knoppix:knoppix übergab, konnte ich sie wieder kopieren und sie landeten vollständig im Ziel und blieben auch bei der anschließenden Kontrolle vollständig.

Tückisch ist dabei, dass das gemountete FAT-System solche Dateirechte gar nicht kennt. Sie werden durch den mount-Befehl für das System quasi gefaket. Linux will Dateirechte sehen und deshalb gaukelt man ihm welche vor. Daher sieht das auch in der ersten Kontrolle des Ziels vollkommen unauffällig aus.
Weshalb hier allerdings eine falsche Größenangabe gemacht wird und nicht gleich eine Erklärung kommt, dass etwas mit den Dateirechten nicht passt, kann ich auch nicht verstehen.

Jedenfalls könnte das auch für dich ein Hinweis sein. Prüf doch mal die Dateirechte und Besitzer. Vielleicht siehst du auch etwas Auffälliges.

5

24.10.2017, 22:32

Ich habe nach deiner Testanordnung mehrere mytest-Dateien generiert und diese ins /home/knoppix Verzeichnis kopiert damit es nicht bereits Probleme mit Datei-Rechten gibt.

Zusätzlich habe ich einen dritten, recht modernen Rechner benutzt, damit die Problematik nicht an schlechter Treiberdunterstützung fürs Motherboard scheitert.

Und ich habe Sicherheitshalber nicht vom USB-Stick gebootet, sondern von DVD, dessen Download ich stets mit Prüfsummen-Check überprüfe. Auch die gebrannte ISO überprüfe ich stets beim allerersten benutzen mittels Boot-Promt „KNOPPIX testdvd“


Zusammengefasst: Auf einen „neuen“ Rechner die DVD (KNOPPIX 8.1) gestartet, und im Home-Verzeichnis die zuvor generierten mytest-Dateien bereitgestellt.


1. Mytest auf den USB-Stick kopiert → vollständig vorhanden;
nach safely replug,
2. Mytest kopiert → wieder nur 0-Byte Datei.


Kann machen was ich will. Ändert sich nichts.

Was mir immer wieder aufgefallen ist, ist dass wenn ich das erste mal eine Datei kopiere und nichts weiter unternehme, diese eben nicht sofort, wie bei dir auf den USB-Stick landet. Also ja, im Datei-Manager erscheint sie sofort, logisch. Aber die LED am Stick fängt erst gefühlte halbe Minute später an zu flackern. Es sei denn ich unmounte den Stick innerhalb der gefühlten halbe Minute, dann schreibt er auch sofort in echt.

Nur beim zweiten mal, nach replug passiert nix. Da kann ich auch gefühlte 15 Minuten warten und da flackert immer noch nix. Und wenn ich anschließend unmounte, dann flackert die LED kurz. So kurz das ich anhand dessen bereits ablesen kann: Aha, Dateiname hat KNOPPIX zwar angelegt, aber wieder mit 0-Byte Inhalt.


Und denn habe ich mal was probiert um zu sehen was passiert, dass man normalerweise nicht tun soll. Nämlich nach dem ersten erfolgreichen schreiben auf dem Stick, diesen einfach nur abgezogen, ohne zu unmounten. Das Ergebnis wie erwartet: Dateiname vorhanden, mit 0-Byte Inhalt.

Mir scheint fast so, als ob sich KNOPPIX ab einen weiteren replug sich mit dem leeren seines Cache Speicher und dem unmounten verhaspelt. Also noch während der Cache entleert wird bereits ausgehangen. Macht mir zumindest den Eindruck

Und meine nächste Vermutung ist, dass in der 8.1er Version irgend eine testing Library sich mit stable Komponenten im Betriebssystem, sein Unwesen treibt. Aber auch nur eine Vermutung.


Also ich weiß da echt nicht mehr weiter. Vor allem Ding: Bei dir geht es so wie es sich gehört, und bei mir mit unterschiedlichen 3 Rechnern, eine Prüfsummen getestete DVD, und nach deinen Testaufbau geprüft…, und trotzdem schlägt es bei mir fehl. Begreif ich nicht!
Und ich glaube auch deinen Ergebnissen. Du legst sogar die quasi die Beweise mit bei.

Also kein Plan was das soll


Danke das du einer derjenigen bist die sich die mühe machen, einer fremden Sache annehmen und hier reporten.


Ich guck mir noch an ob die 8.1er Version weitere schwerwiegende Bugs hat, – da kenne ich bereits einen: Nach CTRL + ALT + F1 für die erste Konsole, und wieder zurück in den graphischen Modus mit ALT + F5 führt eben nicht in den graphischen…, sondern liefert eine Fehlermeldung. Workaround: ‚init 2‘, und anschließend ‚init 5‘ in einer freien Konsole eintippen. - und wenn ja, denn zwitche ich wieder auf die 8.0 Version zurück. Hat zwar auch ihre Eigenheiten, in Zusammenhang mit meinen Netzlaufwerk (Projekt: Eisfair-Server), hab dafür auch einen Workaround geschaffen. Also abschließend kann ich aus Erfahrung sagen: Jede neue KNOPPIX-Version ist wie eine Pralinen Schachtel. Man weiß nie was (an neuen Bugs) drin ist. Und trotzdem freue ich mich auf jede neue. Gibt ja auch Verbesserungen.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Sittich« (27.10.2017, 13:32)


6

24.10.2017, 23:59

das ist wirklich irgendwie schräg.

Es gibt grundsätzlich die Mountoptionen sync oder async. Ich glaube, async ist immer, wenn nicht ausdrücklich sync genommen wird und bei USB-Sticks sollte man grundsätzlich sync nehmen. Ob es das für alle Dateisysteme gibt, kann ich nicht sagen, aber das würde für ein direktes und nicht weiter verzögertes Schreiben sorgen.
Ganz bewusst habe ich aber nicht manuell gemountet, sondern für den Test alles Knoppix machen lassen. Da wirkt irgendein Automatismus, der ja in der Regel gut funktioniert.
Meine 8.1er Version ist eine Spiel-Version. Ich nutze Overlay und habe damit einige Dinge verändert, nach meinem Geschmack angepasst und auch zusätzliche SW installiert. Ich glaube nicht, dass das wirklich einen Unterschied ausmacht. Aber, wer kann das letztlich schon sagen?
Dabei ist mir auch aufgefallen, dass in den Paketquellen zu dieser Version offenbar einige Entwicklungsversionen benutzt werden. Genau erinnere ich mich nicht mehr, was das alles so war. Einige meiner gewünschten Programme funktionierten nach der Installation nicht, bzw wurde bei manchen die Installation mit Fehlern abgebrochen. Deshalb wechsele ich auf meinen "produktiven" Knoppix-Sticks noch nicht und bleibe bei 7.7.1.
Überhaupt bin ich nicht unbedingt auf Neuerungen scharf. In meinem Alter bleibt man lieber bei gewohnten Dingen und für mich hat es seit Jahren keine wirklich guten Neuerungen mehr gegeben. Naja, vielleicht ZFS, aber das gibt es nun auch schon ziemlich lange.
Meine Einstellung hängt natürlich nicht nur mit meinen bescheidenen Ansprüchen zusammen, sondern auch an der Art und Weise, wie ich Knoppix nutze. Mein Arbeitssystem ist ein gutes, stabiles und recht aktuelles, freies, unixoides System und das ist fest installiert und als einziges System auf den jeweiligen Rechnern drauf. Ich nutze nicht sehr viel davon und komme damit gut hin. Knoppix brauche ich nur selten und könnte womöglich auch komplett darauf verzichten. Es blockiert mir aber einen Stick nicht weiter, ich kann ihn nach wie vor als Datenträger zwischen verschiedenen Systemen einsetzen und habe zusätzlich noch ein Knoppix drauf, das sich nach einiger Arbeit nahezu identisch zu meinem Hauptsystem verhält und bedienen lässt. Das ist ein gewisser Luxus, solch ein System in der Hosentasche zu haben, das auch noch auf beinahe jedem Rechner funktioniert.

Es wird einige Tage dauern, bis ich vielleicht dazu komme, einen weiteren Test mit der DVD durchzuführen.
Du kannst vielleicht mal suchen, ob es nicht bei Debian Beiträge zu einem solchen Verhalten gibt, oder herausfinden, woher der Automatismus in Knoppix (es wird identisch sein zu Debian) seine Optionen bekommt (da könnte es eine Konfigurationsdatei geben) und natürlich könntest du die man page zu mount lesen und mit den Optionen um sync spielen und sehen, was sich damit vielleicht erreichen lässt. Ein guter Anlaufpunkt für weitere Informationen ist immer das Ubuntu-Users Wikki.

7

25.10.2017, 00:26

Ähm, mit oder ohne Verschlüsselung der Overlay?




edit: ah, schade. Offenbar nicht mehr auf Sendung. Daher presche ich mal vor: Bei Verschlüsselten Overlay mehr als 3 mal ENTER drücken für falsches Passwort, startet KNOPPIX fallweise im Frischlings-Modus. Ohne Verschlüsselung -> Overlay-Image umzubennenen. Besser mit einem fremden BS machen, sonnst Teppich weg, auf den man steht.
Mit Extra Partition: Ich versuchs mal wie ein Kleinkind zu antworten: blblblbl! Keine Ahnung. Ich vermute mal vorübergehend die Partition verstecken. Aber dies wird den auch langsam riskant

Ich glaube auch nicht daran das es einen Unterschied macht ob mit oder ohne Overlay. Aber man weiß es eben nicht

Ich derweil werd sync/async mal nachgehen. Also wie noch in der 8.0er Version eingebunden wurde. In der 8.1er steht es bereits im 2. Beitrag. Nämlich nichts.

Quellcode

1
/dev/sdc1 on /media/sdc1 type vfat (rw,nosuid,nodev,relatime,uid=1000,gid=1000,fmask=0000,dmask=0000,allow_utime=0022,codepage=850,iocharset=utf8,shortname=winnt,utf8,errors=remount-ro)

Und Nichts bedeutest, so meine ich, dass vom Standardfall async ausgegangen wird. Aber da gucke ich gleich mal. Bin in kürze back

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Sittich« (25.10.2017, 01:15)


8

25.10.2017, 02:10

Back..., mit einer ernüchternden Antwort. Die Einhänge-modies in der 8.0 sind gleich der 8.1

Denn habe ich unter 8.0 den gleichen Testaufbau durchgeführt wie unter 8.1:

Also beim ersten schreiben macht KNOPPIX auch eine Verschnaufpause von rund einer halben Minute bis die LED aufflackert, wenn man als Benutzer nichts weiter macht.
Beim Zweiten mal auch eine Verschnaufpause. Nur halt gefühlte 15 Sekunden bis die LED flackert.
Beim dritten habe ich erst gar nicht so lange gewartet, sondern gleich nach dem kopieren ungemountet.
Alles da in Vollständigkeit! Verstehe sowieso nicht warum die lange Pause bis das BS auf die Idee kommt: Oh, ich sollte mal den Cache entleeren.

Leute, seit also gewarnt wenn Ihr mit KNOPPIX 8.1 USB-Sticks, vielleicht sogar USB-Festplatten, welche mit FAT16/32 formatiert sind, Dateien darauf speichern wollt. Es ist nicht mehr garantiert das diese vollständig ankommen. Lieber nochmal nachprüfen, sonst lange Nese

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Sittich« (25.10.2017, 02:29)


9

25.10.2017, 19:46

Ähm, mit oder ohne Verschlüsselung der Overlay?


Ich nehme Overlay-Partition und zwar in ext2.
Ich verschlüssele nichts auf meinem Knoppix Stick, das halte ich persönlich für überflüssig. Wenn ich was verschlüsseln möchte, dann sind das eher einzelne Dateien und dazu nehme ich GPG, weil das eben sehr praktisch ist.

Warum ext2? Weil ich reiserfs nicht mehr ganz zeitgemäß finde und es außerdem von meinem Hauptsystem gar nicht unterstützt wird. ext2 wird gut unterstützt und ich dachte, dass ich dann aus meinem FreeBSD heraus auch immer mal einen Zugriff auf meine Overlay-Partition haben kann. Das funktioniert in der Praxis nicht ganz so gut, weil FreeBSD streng ist und sehr oft erkennt, dass das Dateisystem nicht sauber ausgehängt wurde und dann ohne einen Dateisystem-Check nicht einbinden möchte. Innerhalb von GNU/Linux gibt es damit gar keine Probleme.

Meine beiden "produktiven" Knoppix-Sticks habe ich einmal in FAT und einmal in NTFS und jeweils mit einer unterschiedlich großen Overlay-Partition ausgestattet.
Die Sticks werden in Windows-PCs (für die ich sie leider ab und zu brauche) mit nur einer Partition erkannt. Die ext2 formatierte Overlay erscheint nicht.
In anderen Systemen werden die beiden Partitionen erkannt und ich kann sie nach Bedarf einbinden.
Eine Overlay-Partition ist der einfachste und auch sehr elegante Weg, Veränderungen an Knoppix zu realisieren und persönliche Settings zu erhalten. Als Speicherbereich für Austauschdaten nutze ich die Overlay-Partition ausdrücklich nicht und deshalb ist eine Verschlüsselung auch richtig unsinnig. Es liegt hier der Teil des Systems, den ich zusätzlich installiert habe. Und es liegt hier das $HOME von knoppix und deshalb ist es sehr einfach, nachdem ich mir eine nahezu identische Arbeitsfläche eingerichtet habe, auch meine Settings von meinem Hauptrechner zu migrieren. Deshalb arbeite ich mit Knoppix quasi identisch, wie auf meinem Hauptrechner zu Hause.

Das neue 8.1 liefert ein hybrid-Image. Es kann mittels dd auf einen Stick gebracht werden. Sobald es bootet, erweitert es die mitgelieferte Overlay-Partition auf den kompletten verfügbaren Speicher. Solch einen Stick habe ich angefertigt und nutze ihn zu Testzwecken, das Konzept passt aber nicht zu mir und meinem Umgang mit meinen Knoppix-Sticks.
Trotzdem habe ich in die Overlay-Partition wieder meine Einstellungen überspielt, denn ich arbeite mit meinen gewohnten Tastenkürzeln und ohne wabernde oder explodierende Fenster viel schneller, als auf einem Standard-Knoppix (oder irgendeinem anderen fertigen System).

Derzeit bin ich mit einigen Aktionen fernab meiner Rechner beschäftigt und nehme mir nur wenig Zeit dafür. Zwischen einem Film und einer Lektüre oder so, schaue ich aber gelegentlich auch ins Internet und dieses Forum. Antworten kann ich schon geben, das geht auch aus dem Bett. Dinge ausprobieren und etwa testen mag ich derzeit aber nicht.

10

27.10.2017, 11:48

So! Bin zurück geswitcht auf KN 8.0! Die Zustände wurden immer unhaltbarer!

Wollte eine ISO mit 4,6 GB auf einen USB-Stick mit NTFS Formatierung verfrachten, für weitere Vorgänge..., unmounten, noch alles OK. Stick replug, zwecks überprüfen ob alles komplett angekommen ist, denn die neuen, modernen USB-Sticks haben ja "neuerdings" alle keine Status LED mehr. Alles Da. Und beim zweiten mal abziehen, knackt KN einfach ab! Friert einfach ein!

Also wieder eine große test Odyssee gestartet (sowas kostet jedes mal wahnsinnig viel Lebenszeit und Nerven), um herauszufinden unter welche Bedingungen das passiert.

Antwort: Wieder mal ist KN 8.1 der Schuldige. Unter KN 8.0 kann ich sooft wie ich will den Stick remounten, repluggen,... KN 8.0 läuft weiter und KN 8.1 macht beim zweiten mal die Grätsche.

Wobei vermutlich weitere Bedingungen vorhanden sein müssen damit dieser Bug passiert. Vermutlich passiert es mit großen Speichersticks, wie 128 GB, denn bei tests mit einem 512 MB Stick lief das BS weiter. Aber ist ja egal! Fakt ist dass das wieder mal nur unter KN 8.1 passiert. Das reicht ja schon! Generalverdachtsmodus "aktiviert"!

Also dieser Thread hat sich für mich erledigt. Bin zurück auf 8.0. Blöd ist nur dass man bei nicht aktuellen Live-Distris immer größer werdende Abhängigkeitsprobleme bei den Software-Paketen bekommt. Deswegen renne ich ja den neuesten KN Versionen nach. Und wegen der Neugier auch.

So, bin raus aus diesem Thread!

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop