24.08.2019, 05:16 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

19.06.2019, 20:16

GnuPG mit Serpent funktioniert nicht, obwohl libgcrypt installiert ist

Hi,

ich bin noch (GnuPG) Knoppix-Einsteiger und möchte folgende symmetrische Verschlüsselungen nur im Terminal durchführen, ohne grafische Oberfläche.

Warum funktioniert der folgende Befehl mit SERPENT nicht, obwohl "libgcrypt 1.7.3-beta vorinstalliert angezeigt wird? Wie kann ich die anderen Algorithmen benutzen?
Liegt es an den Einstellungen oder fehlt irgendeine Installation auf Knoppix Live-DVD?

gpg2 -c --cipher-algo SERPENT geheim.txt

Der folgende Befehl funktioniert (weil TWOFISH in GnuPG schon integriert ist)

gpg2 -c --cipher-algo TWOFISH geheim.txt

Danke im voraus.

gpg --version

gpg (GnuPG) 2.1.15
libgcrypt 1.7.3-beta

Unterstützte Verfahren:
Öff. Schlüssel: RSA, ELG, DSA, ECDH, ECDSA, EDDSA
Verschlü.: IDEA, 3DES, CAST5, BLOWFISH, AES, AES192, AES256, TWOFISH,
CAMELLIA128, CAMELLIA192, CAMELLIA256

Beiträge: 638

Geschlecht: Männlich

2

20.06.2019, 01:31

Hallo.
Welche Version Knoppix benutzt Du?
Bei Knoppix 8.1 ist das Paket: libgcrypt20 1.7.9-1 LGPL Crypto library
installiert.

3

20.06.2019, 02:30

Hallo,

KNOPPIX_V7.7.1DVD-2016-10-22

Ich glaube nicht, dass eine neuere Version die Lösung ist. Warum sollte es mit meiner Version nicht funktionieren?

pit234a

Fortgeschrittener

4

20.06.2019, 11:11

Quellcode

1
2
3
4
pit@Celsius ~:- > gpg2 --output test.gpg2 -c --cipher-algo AES Führerschein.jpg
gpg: WARNUNG: Unsichere Zugriffsrechte des Home-Verzeichnis `/home/pit/.gnupg'
gpg: keyserver option 'include-disabled' is unknown
Datei 'test.gpg2' existiert bereits. Überschreiben (j/N)? j


Und das ist ganz genau, was du sagst: SERPENT gibt es nicht in gpg oder gpg2. Das sagt dir auch die Ausgabe des Befehls gpg2 --version , die du ja in deinem ersten Beitrag zitierst.
Ich sehe auch keine mögliche Option für SERPENT.

https://wiki.ubuntuusers.de/GnuPG/Symmet…l%C3%BCsselung/

edit:
ich muss das doch noch etwas erklären:
oben habe ich eine vorhandene Datei Führerschein.jpg mit dem -c --cipher-algo AES verschlüsselt und die neue, verschlüsselte Datei nach --output test.gpg2 geschrieben. Und das funktioniert denn auch bei mir. Das wollte ich nur zeigen, wenn ein gültiger Algo gewählt wird, funktioniert es eben, SERPENT ist kein gültiger Algo in gnupg.

Beiträge: 638

Geschlecht: Männlich

5

20.06.2019, 12:10

Ich glaube nicht, dass eine neuere Version die Lösung ist.

Das hatte ich mit meiner Frage nicht gemeint. Meine Frage war deshalb weil es mit 8.5 mehr als genug zum großen Teil ungelöste Probleme gibt.

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop