22.10.2018, 04:25 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Beiträge: 711

Geschlecht: Männlich

1

23.06.2009, 14:08

[gelöst] Knoppix vom USB-Stick: Bildschirm bleibt dunkel (nur Eee Box)

Kennt jemand das Problem? Ich habe einen mit einem Knoppix-Klon eingerichteten USB-Stick. Bei so viel Hilfe, wie ich sie bekommen habe, kann ich kaum davon sprechen, ich hätte ihn selbst eingerichtet. Danke noch einmal an JackCarver und FM_81. Es gilt natürlich immer noch:

Wenn ich jetzt den Stick auf dem Netbook meiner Frau starte, dann geht alles ganz normal. Er soll aber auf einem Asus Mini-PC laufen. ;(

Er bootet auch. Aber sobald das Kreuz auf schwarzem Hintergrund kommen soll, bleibt alles dunkel. :cursing:

Ich kann dann nur noch den PC über den Ausschaltknopf runterfahren. Sobald ich den Knopf drücke, ist das Bild wieder da. X(

Einen Everest-Report findet ihr hier. Den konnte ich ziehen, weil da glücklicherweise XP vorinstalliert war. Was ich aus Kostengründen eigentlich gar nicht haben wollte. :whistling: :D
MfG. Cottonwood.

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Cottonwood« (29.06.2009, 20:15)


Beiträge: 650

Geschlecht: Männlich

2

23.06.2009, 14:20

Wieviele Grafikausgänge hast du hinten am Board? Wenn mehr als einen steck den mal um und schau ob das Signal da anliegt. Sollten die Timings, mit denen der Moni angesteuert wird nicht passen, müsste der moni eigentl ne Meldung so wie "Signal out of range bringen".
Kannst du über STRG-ALT-F1 auf ne virtualle Konsole wechseln und hast da ein Bild?


mfg Jack

Beiträge: 711

Geschlecht: Männlich

3

23.06.2009, 16:08

Es ist genau ein Anschluss da. Und wenn ich mit strg+alt+f1 wechsle, kommt wieder ein Bild. ?(

Das letzte, was da drinnen steht, das ist

Quellcode

1
2
INIT: Entering runlevel: 5
root@Microknoppix:/#


Und nach wenigen Minuten fährt er dann von alleine runter.
MfG. Cottonwood.

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Cottonwood« (23.06.2009, 16:21)


Beiträge: 650

Geschlecht: Männlich

4

23.06.2009, 16:28

Erzwinge mal die Verwendung des vesa Treibers zunächst mal als Test ob damit ein Bild kommt. Ich schau mal nach dem Bootparameter dazu...argh Knoppix und Bootparameter ganz übel sach ich nur...

Find keinen, dann kannst du das folg machen:

Zunächst mal den Bootparameter knoppix 2 verwenden, also in der grub.cfg mit eintragen.
Dann startet Knoppix auf der Konsole erstmal und du solltest nochn Bild haben. Dann gib mc ein um den midnight commander zu öffnen und editiere die Datei /etc/X11/xorg.conf folg:

Aus der Zeile

Zitat

#Driver autoconfigured by...


mach ein

Zitat

Driver "vesa"


speichere die Datei schließ den mc und gib auf der Konsole init 5 ein um auf den Desktop zu kommen und schau mal ob du jetzt ein Bild hast.


mfg Jack

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »JackCarver« (23.06.2009, 16:44)


Beiträge: 711

Geschlecht: Männlich

5

23.06.2009, 16:32

Okay. Geht los.
MfG. Cottonwood.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Cottonwood« (23.06.2009, 16:43)


Beiträge: 650

Geschlecht: Männlich

6

23.06.2009, 16:47

Den mc musst zum Editieren noch so einstellen, dass er den internen Editor verwendet, sonst musst dich mit dem vi rumärgern...Geht über Konfiguration auf die du in der Konsole mit F9 kommst

Beiträge: 711

Geschlecht: Männlich

7

23.06.2009, 16:54

Kann ich nicht auch die Datei auf den Desktop kopieren und mit Leafpad bearbeiten?

Mist. Jetyt ist wieder die Tastatur falsch.

Ich kann die Yeile nicht finden.
»Cottonwood« hat folgende Datei angehängt:
  • xorg.conf.txt (7,25 kB - 2 mal heruntergeladen - zuletzt: 23.06.2009, 16:57)
MfG. Cottonwood.

Beiträge: 650

Geschlecht: Männlich

8

23.06.2009, 16:57

Zitat

Kann ich nicht auch die Datei auf den Desktop kopieren und mit Leafpad bearbeiten?


Dachte du hast keinen Desktop, da kein Bild?

Ich häng dir die gleich wieder ran...

Die Zeile hieß bissl anders :S , jetzt kannst du dir die auch auf den Stick kopieren, dann in die Konsole booten mit knoppix 2 und du findest die dann unter /mnt-system. Da mountet er den Stick rein. Dann kannst sie nach /etc/X11 kopieren und die vorhandene überschreiben

Prob ist du kriegst die nicht so einfach ins System, erst wenn alles entpackt ist und dazu muss Knoppix booten.
»JackCarver« hat folgende Datei angehängt:
  • xorg.conf.txt (7,23 kB - 3 mal heruntergeladen - zuletzt: 30.09.2009, 22:57)

Beiträge: 711

Geschlecht: Männlich

9

23.06.2009, 16:59

Dachte du hast keinen Desktop, da kein Bild?


Ich springe hier zwischen 4 Rechnern hin und her. Momentan komme ich auch gut an das Netbook.
MfG. Cottonwood.

Beiträge: 711

Geschlecht: Männlich

10

23.06.2009, 17:09

Hoffentlich bekomme ich das hin, bevor der automatisch wieder runterfährt.
MfG. Cottonwood.

Beiträge: 711

Geschlecht: Männlich

11

23.06.2009, 17:15

überschrieben habe ich sie. Und jetzt?
MfG. Cottonwood.

Beiträge: 650

Geschlecht: Männlich

12

23.06.2009, 17:15

Zitat

bevor der automatisch wieder runterfährt.


denke dieses Prob hast nicht auf der reinen Textkonsole. Dafür der Bootparameter knoppix 2

Beiträge: 711

Geschlecht: Männlich

13

23.06.2009, 17:17

Was meinst du mit "Bootparameter knoppix 2"? Aber ist jetzt vllt. nicht so wichtig. Was soll ich jetzt machen?

Ich versuche, den mit Tastatureingaben am Leben zu halten.
MfG. Cottonwood.

Beiträge: 650

Geschlecht: Männlich

14

23.06.2009, 17:29

Zitat

Was meinst du mit "Bootparameter knoppix 2


genauso wie lang=de schreibst du zusätzlich knoppix 2 in die Zeile der grub.cfg, dann startet er auf der Konsole runlevel2


Hast du die Dateien ausgetauscht? Dann gib mal auf der Tastatur init 5 ein und schau ob er ein Bild zeigt.

Beiträge: 711

Geschlecht: Männlich

15

23.06.2009, 17:33

Merkwürdiges Verhalten. Ich muss jedes Zeichen zweimal eingeben. Angezeigt wird's aber nur einmal.

Es hat nichts bewirkt. Aber ich bin mir auch nicht sicher, ob er es so empfangen konnte.

Ich mache jetzt mal das mit knoppix 2 und melde mich dann wieder.
Ich glaube, die vielen Eingaben haben ihn verwirrt.
MfG. Cottonwood.

Beiträge: 650

Geschlecht: Männlich

16

23.06.2009, 17:35

Wäre am Sichersten du startest erstmal im runlevel2 um da die Dateien auszutauschen und dann über init 5 in den Level 5 zu wechseln. Schreib einfach mal ein

knoppix 2

in die Zeile der grub.cfg wo der Kernel geladen wird und wo du ja schon lang=de hattest

Beiträge: 711

Geschlecht: Männlich

17

23.06.2009, 17:37

Hat eine kleine Veränderung gebracht. Statt "No signal" steht da jatzt "Out of Range". Ist aber kein Bild da.
Sind das jetzt Zeitprobleme? (Timings)
MfG. Cottonwood.

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Cottonwood« (23.06.2009, 17:46)


Beiträge: 650

Geschlecht: Männlich

18

23.06.2009, 17:49

Zitat

Hat eine kleine Veränderung gebracht. Statt "No signal" steht da jatzt "Out of Range".


Läuft jetzt mit vesa-Treiber? Also der ausgetauschten xorg?

Ja der steuert den Monitor falsch an, deswegen schaltet er um sich zu schützen ab, du brauchst die Daten zu dem Monitor, Auflösungen, Frequenzen und so

Beiträge: 711

Geschlecht: Männlich

19

23.06.2009, 17:52

Ja, das Xorg ist ausgetauscht.

Später soll der ja mal ohne Monitor laufen. Vielleicht wäre es eine Alternative, vncserver ans Laufen zu bringen. Ich hatte da was gefunden. Aber das ist von RHEL. Kann man das auch verwenden?

http://www.skullbox.net/vncserver.php
MfG. Cottonwood.

Beiträge: 650

Geschlecht: Männlich

20

23.06.2009, 17:55

Die verwenden wie suse rpm-Pakete, die kann man zwar über alien in manchen Fällen in ein deb umwandeln, aber ob du die Abhängigkeiten aufgelöst kriegst ist fraglich. Für vnc kannst doch den tight nehmen oder hat der zuwenig Funktionen?

Beiträge: 711

Geschlecht: Männlich

21

23.06.2009, 18:00

Das Problem ist ja doch, dass ich letztendlich weder Schirm noch Tastatur oder Maus dran habe. Die Kiste soll in einen Schrank an die Wand geschraubt werden. Ist etwas kleiner als das zugeklappte Netbook.
MfG. Cottonwood.

Beiträge: 650

Geschlecht: Männlich

22

23.06.2009, 18:03

Zitat

Das Problem ist ja doch, dass ich letztendlich weder Schirm noch Tastatur oder Maus dran habe.


Brauchst du ja auch nicht, ein LAN Kabel langt. Soll das ein File-Server werden?

Btw du hast ja nen integrierten Intel Grafikchip, du könntest auch noch

Driver "intel"

in der xorg statt vesa testen

Beiträge: 711

Geschlecht: Männlich

23

23.06.2009, 18:06

Lan Kabel langt? vncserver muss ja automatisch gestartet werden.

Ich tausche mal vesa gegen intel. Suchen und ersetzen.
MfG. Cottonwood.

Beiträge: 650

Geschlecht: Männlich

24

23.06.2009, 18:12

Zitat

Lan Kabel langt?

natürlich, hab das bei mir so am Laufen :D

Zitat

vncserver muss ja automatisch gestartet werden.


entweder über nen autostart der Desktops oder wenn ohne Desktop, dann den start in der knoppix_autoconfig eintragen. Die wird bei jedem Start abgearbeitet, das zieht aber ein Remastern von Knoppix nach sich.

Beiträge: 711

Geschlecht: Männlich

25

23.06.2009, 18:17

Oops. Jetzt habe ich wieder "No Signal". (Ja, ich habe die xorg.conf wieder nach /etc/X11 kopiert. Was muss man da eigentlich zum Überschreiben angeben? y oder j? Ich habe beides gemacht. Sicherheitshalber.)

Wo kann ich den den vnc besser starten. Dass ich auch alles machen kann, als säße ich davor?
MfG. Cottonwood.

Beiträge: 650

Geschlecht: Männlich

26

23.06.2009, 18:36

Wenn du nen richtigen Desktop unterm vnc haben möchtest dann startest ihn aus nem autostart der LXDE zb. Sonst hats ein graues Fenster kannst daraus aber auch KDE/LXDE Programme starten indem du die zb aus der Konsole heraus startest.

Ja du bräuchtest die Daten des Monitors, dann kann man versuchen ne Modeline für den Monitor in der xorg einzutragen. Zum überschreiben würd ich unter nem englischen System y nehmen unter nem deutschen j


mfg Jack

Beiträge: 711

Geschlecht: Männlich

27

23.06.2009, 18:40

Ich probiere das hier mal aus:

http://forum.vectorlinux.com/index.php?topic=6982.0

Sorry, nicht mehr da. Bleibt nur dieser Hinweis:

Zitat

Put *.desktop files of those applications in ~/.config/autostart, and they will get executed when the session starts.
MfG. Cottonwood.

Beiträge: 650

Geschlecht: Männlich

28

23.06.2009, 18:47

Wie du das machen musst hängt nat in erster Linie davon ab welchen Desktop Manager du verwendest, also ob gnome, KDE oder LXDE. Und da Knoppix die LXDE verwendet musst mal hier im Forum nach diesem Thread mit

"Firefox automat starten"

suchen. Da hat Klaus ne Lösung gepostet, die wohl auch geklappt hat

FM_81

Fortgeschrittener

29

23.06.2009, 18:48

Im GRUB einfach mal testweise in der Config in der Zeile

Quellcode

1
	linux	/boot/linux ramdisk_size=100000 ro quiet vga=791 lang=de
in

Quellcode

1
	linux	/boot/linux ramdisk_size=100000 ro quiet vga=791 lang=de vsync=60
ändern! 60Hz sind erst mal gut bei "Out of range" und für ein TFT genau richtig ...

OT: Übrigens, beim alten GRUB ging das mit Taste "C" und dann 2x Taste "E" auch während des Bootens?
Dieses Feature hat GRUB2 doch sicherlich auch, wenn vielleicht auch etwas anders?
ACHTUNG!
Ihre Systemleistung reicht nicht aus, um einen BLUE-SCREEN zu erzeugen!
Möchten Sie statt dessen einen GREEN-SCREEN sehen?

---- [Ja] ---- [Nein] ---- [Weiß noch nicht] ----

Beiträge: 711

Geschlecht: Männlich

30

23.06.2009, 18:54

@FM_81: Mache ich sofort.

@Jack: Der Link dazu ist auch im ersten langen Thread. Das schaue ich mir dann mal an.
MfG. Cottonwood.

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop