20.09.2019, 10:45 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

20.02.2010, 17:23

Problem bei HD-Installation Knoppix 6.2

Hallo,
ich habe folgendes Problem: Wollte heute Knoppix auf Festplatte ( neben Win XP ) installieren. Habe folgende Festplattenaufteilung - C Windows ca 20 GB
- D Daten & Programme ca 130 GB
Nun habe ich mit GParted "D" verkleinert und die Partition "F" mit ca 20 GB erstellt. Das ist jetzt aber, nach der Formatierung, ein logisches Laufwerk. Habe auch mit "nicht zugeordneten Bereich" versucht, Knoppix findet keine Partition zur Installation. Was kann ich noch machen?
Vielen Dank für eure Hilfe!

klaus2008

Meister

Beiträge: 2 714

Geschlecht: Männlich

2

20.02.2010, 22:43

Hallo!

F sollte mit dem Reiser-Dateisystem formatiert sein. Außerdem müsste man F noch soweit verkleinern, dass mehr als 1 GB für die swap-Partition bleibt. Letztere kann man ebenfalls mit GParted anlegen.

3

21.02.2010, 08:18

Vielen Dank für die Antwort, aber genau das hatte ich schon gemacht, bevor ich es mit dem " nicht zugeordneten Bereich" versucht habe. Leider hat weder das eine noch das andere funktioniert. War jetzt der Meinung, dass es daran liegt, dass es sich um ein logisches Laufwerk handelt? Wie kann ich das in ein primäres verwandeln, wenn`s nötig ist?

4

21.02.2010, 13:54

Jetzt kann ich folgende Ergänzung verkünden: Habe es geschafft, primäre Partitionen zu erzeugen. Eine mit 1 GB als Swap und eine mit knapp 19 GB mit reiserfs ( auch mit ext3 versucht ) sind formatiert. Trotzdem ist keine Installation möglich. Ich habe den ersten Punkt, "automatische Partitionierung" angeklickt. Ist doch richtig, oder? Und von da ab läuft alles im Kreis: " keine automatsche Prtitionierung möglich".
Woran kann das noch liegen?

5

21.02.2010, 15:28

So, jetzt habe ich die beiden Partitionen wieder gelöscht, und Knoppix hat sich in den freien Bereich installiert. ABER ich kann es nicht starten! GRUB zeigt mir nur Windows. Was mache ich ich jetzt?

klaus2008

Meister

Beiträge: 2 714

Geschlecht: Männlich

6

21.02.2010, 17:43

Es vermutlich fehlt in der menu.lst von Grub ein Eintrag der Form

Quellcode

1
2
3
title KNOPPIX
root (hd0,0)
kernel /boot/vmlinuz root=/dev/sda1 rootwait lang=de apm=power-off vga=791 nomce loglevel=0 quiet ramdisk_size=100000 lang=de vt.default_utf8=0 apm=power-off vga=791 nomce quiet loglevel=0 tz=localtime rw

Dabei müssen die Bezeichnungen root (hd0,0) und root=/dev/sda1 an das System angepasst werden!

7

21.02.2010, 19:50

Vielen Dan für die Hilfe!
Ich kann jetzt berichten, dass ich es geschafft habe. Es lag wahrscheinlich an einem Fehler beim kopieren der Datein während der Installation. Habe nochmal installiert und alles läuft prima.
Tschüß, bis zum nächsten Mal!

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop