11.12.2018, 22:25 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Anonymous

unregistriert

1

04.03.2006, 12:11

Laptop: W-Lan und externe USB Festplatte

nachdem die Bildschirmaufl?sung nun klappt, gehen die Probleme munter weiter (immer das Gleiche, aber doch leider immer anders, so dass ich trotz googlen nicht so recht schlau werde)

a) W-LAN Karte funktioniert nicht (D-Link, DWL-610)

beim Versuch, den Tipps auf der Seite http://www.canit.se/~oli/wl/ zu folgen und einen neuen Treiber zu intstallieren, habe ich festgestellt, dass auch

b) meine externe USB-Festplatte (Seagate 300GB, 4 Partitionen unter 100GB) nicht gemountet wird, die ich aber brauche, um an den Treiber zu kommen.

Mein Rechner ist ein alter Toshiba Satellite 2140CDS

[code:1]#cat /etc/fstab[/code:1] ergibt:
[code:1]usbfs /proc/bus/usb usbfs devmode=0666 0 0[/code:1]

[code:1]#dmesg [/code:1] zeigt fogendes an:
[code:1]usb 1-1: new full speed USB device using ohci_hcd and address 2
scsi0: SCSI emulation for USB Mass Storage devices
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
usb-storage: device found at 2
usb-storgae: waiting for device to settle before scanning
ieee1394: Initialized config rom entry ?ip1394?
snp2: $Rev: 1219 $Ben Collins .bcollins@debian.org
ieee1394: sbp2: Driver forced to serialize I/O (serialize_io=1)
Registering unionfs 20050921-1517
Real Time Clock Driver v1.12
apm: BIOS version 1.2 Flags 0x02 (Driver version 1.16ac)
[/code:1]

[code:1]#usbview [/code:1]erkennt das Ger?t korrekt als Seagate Festplattean (NEC Corporation USB - ST94811U2-RK)

Und beim Versuch, manuell zu mounten [code:1]#mount -t vfat /dev/sda /mnt/usb/[/code:1] kommt: [code:1]/dev/sda ist kein g?ltiges blockorientiertes Ger?t[/code:1]

:?: Wenn ich das richtig interpretiere, sind da doch Treiber geladen. Aber warum wird die Festplatte nicht eingeh?ngt? Irgendwo habe ich mal gelesen, dass Knoppix 4.0 noch nicht mit Festplatten ?ber 100GB zurecht kommt. Bezieht sich das wirklich auf die Festplatte und nicht auf die Partitionsgr??en? Wenn ja, was muss ich dann tun?

Anders bei der WLAN-Karte. Hier wirft [code:1]#dmesg [/code:1] folgendes aus:

[code:1]Linus Kernel Card Services
options: [pci][cardbus][pm]
PCI: IRQ 0 for device 0000:00:13.0 doesn?t match PIRQ mask - try pci=usepirqmask
PCI: No IRQ known for interrupt pin A of device 0000:00:13.0. Please try using pci=biosirq.
Yenta: CardBus bridge found at 0000:00:13:0 [1179:0001]
irq11: nobody cared!
[<c013a63e>] __report bad irq+0x22/0x78[/code:1]
usw, es folgen ca 25 weitere Meldungen dieser Art (note interrupt / do IRQ/common interrupt/do softirq/irq extit/do irq/common interrupt/const udelay/yenta probe irq/yenta get socket capabilities/yenta probe/pci device probe static/pci device probe device/driver attach/bus add driver/driver register/pci register/yenta socket init/sys init module/syscall call) dann geht's weiter mit:
[code:1]handlers: [<caabc3e8>](usb_hcd_irq+0x0/0x54 [usbcore])
Disabling IRQ11
Xenta: ISA IRQ mask 0x06b8, PCI irq 0
Socket status: 30000007[/code:1]

:?: Wie muss man diese Meldung interpretieren. Offenbar gibt es ein Problem mit einem Interrupt, oder?

:?: Was bedeutet "doesn't match PIRQ mask - try pci=usepirqmask"? Bezieht sich das "try" auf mich als Admin oder meint es die Einstellung, die der Rechner jetzt ?bernimmt?

:?: In der n?chten Zeile steht "please try", da gehe ich davon aus, dass ich gemeint bin. Wie und wo kann ich denn "pci=usebiosirq" konfigurieren? Macht es Sinn, das in diesem Fall zu probieren?

:?: Yenta scheint dann eine ganze Reige von M?glichkeiten durchzuspielen und am Schluss auch einen Treiber zu installieren. Warum wird als handler ein usb-irq ausgegeben? Der PCMCIA-Slot ist doch kein USB?

Danke im Voraus f?r die Nachhilfe in Sachen Linux.
:roll:
Dirk

2

04.03.2006, 13:01

Hi,

zur usb-Platte:

versuch mal: mount /dev/sda1 /mnt/wohinduwillst

Zu WLAN: Zeig mal Dein ifconfig -a und Dein iwconfig

Gruss Guido

Anonymous

unregistriert

3

04.03.2006, 13:25

Zitat von »"guido17"«

Hi,

zur usb-Platte:

versuch mal: mount /dev/sda1 /mnt/wohinduwillst

kommt wieder "kein g?ltiges blockorientiertes Ger?t"

Zitat



Zu WLAN: Zeig mal Dein ifconfig -a und Dein iwconfig


[code:1]lo Protokoll:Lokale Schleife
inet Adresse:127.0.0.1 Maske:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:8 errors:0 dropped:0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenl?nge:0
RX bytes:400 (400.0 b) TX bytes:400 (400.0 b)[/code:1]

iwconfig:

[code:1]lo no wireless extensions[/code:1]

4

04.03.2006, 14:44

Hi,

so mein Eintrag aus der etc/fstab f?r das usb-device sda1:

/dev/sda1 /sda1 vfat noauto,users,exec,umask=000 0 0


Dann versuch das mal.
Was ist denn auf der Platte drauf?

RalfonLinux

Erleuchteter

Beiträge: 2 936

Geschlecht: Männlich

5

04.03.2006, 20:09

Hallo dalex,

was zeigt den ein fdisk -l ?
Vielleicht wid deine USB-Platte ja auch unter /dev/sdd angesprochen.

Ralf
Auf Wunsch gibt es nur noch Text und keine Bilder mehr in der Signatur.
Keine ? ....... :evil:

Quellcode

1
2
3
4
5
6
7
8
.
    ~
   - -          M
   /V\         - *
  // \\        /V\
 /( _ )\      // \\
  ^~ ~^      /( _ )\
              ^~ ~^

Anonymous

unregistriert

6

05.03.2006, 10:11

@ Ralf: nein, mit fdisk werden nur die HD und die Swap Partition angezeigt

@Guido
Interessanter Effekt. Nach dem ?ndern der fstab hat sich der Bootvorgang mit folgender Fehlermeldung aufgeh?ngt:
[code:1]/etc/hotplug/usb.rc: line 269: 3997 Segmentation fault rmmod ohci-hcd > /dev/null 2>&1[/code:1]
Ich hab' dann genervt meine CD-ROM rausgekramt und wollte von dort booten, um die alte Version wieder herzustellen, doch aus irgendwelchen Gr?nden hat der Rechner nicht von der CD gebootet und ist regul?r hochgefahren, diesmal ohne Probleme - aber leider auch ohne neue Festplattensymbole auf dem Desktop :(

Auf der Platte sind jetzt drei Partitionen, alle Fat32. Die dritte ist noch leer, die erste ein Backup meines Windows-Rechners und auf der zweiten liegt z.Zt. eine Kopie der Knoppix DVD.

Was nun?

7

05.03.2006, 12:35

Moin,

ich steh gerade ein wenig auf dem Schlauch. Will heissen, ich kann nicht folgen, wie es bei Dir im Moment ausschaut.
Versteh ich das richtig, Du kannst jetzt auch alle Partitionen zugreifen, hast nur keine icons auf dem Desktop?


Gruss Guido

Anonymous

unregistriert

8

05.03.2006, 22:03

nein, leider blieb alles beim Alten. Mit fdisk finde ich keine Partitionen der USB Festplatte.

Was mir noch auff?llt: usbview startet nicht mehr. Bash meldet sich nach Abschicken nicht mehr zur?ck. Man muss den Root-Shell schlie?en, um weiterarbeiten zu k?nnen. Das Problem hatte ich vorgestern auch schon. Gestern meldete sich das Progamm aber, heute wieder nicht.

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop