01.12.2021, 07:30 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Anonymous

unregistriert

1

12.05.2005, 19:03

HP Scanjet 4200 unter Knoppix 3.81

Hallo Zusammen,

ich habe einen HP Scanjet 4200.

Diesen habe ich auch unter Knoppix 3.6 ans laufen bekommen. ?ber Sane.

Als erstes habe ich den Patch f?r das Backend installiert.
Danach habe ich das Backend 1.08 installiert (./configure;make;make install)
danach das Frontende 1.08
danach XSANE 0.93

hat alles wunderbar funktioniert.

Jetzt m?chte ich das gleiche unter Knoppix 3.81 machen.

Jetzt klappt es auf einmal nicht mehr.

Das Backend und Frontend von Sane bekomme ich installiert

Beim Installieren von XSANE (./configure) bekomme ich ganz zum Schluss folgende Meldung:

checking for GTK+ - version >= 2.0.0... no
*** Could not run GTK+ test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GTK+ is incorrectly installed.
checking for gtk-config... no
checking for GTK - version >= 1.2.0... no
*** The gtk-config script installed by GTK could not be found
*** If GTK was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GTK_CONFIG environment variable to the
*** full path to gtk-config.
checking for gimp-config... no
checking for gimptool... no
checking libgimp/gimp.h usability... no
checking libgimp/gimp.h presence... no
checking for libgimp/gimp.h... no
checking libgimp/gimpfeatures.h usability... no
checking libgimp/gimpfeatures.h presence... no
checking for libgimp/gimpfeatures.h... no
no

*** Could not run GIMP test program, checking why...
checking png.h usability... yes
checking png.h presence... yes
checking for png.h... yes
checking for png_create_info_struct in -lpng... yes
****************************************************************
ERROR: GTK-1.2.0 or newer is needed for compiling xsane
if you installed gtk as rpm make sure you also included
gtk-devel
****************************************************************

aber GTK ist doch genauso wie bei Knoppix 3.6 installiert.

Kann mir jemand bei dem Problem helfen.

Vielen Dank und bis dann

2

12.05.2005, 19:57

Wenn man die Paketliste von 3.8

ftp://ftp.uni-kl.de/pub/linux/knoppix/packages.txt

und der von 3.6 (zufaellig noch auf dem Rechner gehabt) sieht man den Unterschied

[code:1]
3.8
===
ii libgtk1.2 1.2.10-17 The GIMP Toolkit set of widgets for X

3.6
===
ii libgtk1.2 1.2.10-17 The GIMP Toolkit set of widgets for X
ii libgtk1.2-dev 1.2.10-17 Development files for the GIMP Toolkit
[/code:1]

Wie bei diesem Symptom nicht anders zu erwarten, fehlt auf der 3.8 das libgtk1.2-dev Paket. Das ist wahrscheinlich aus Platzgruenden nicht mehr dabei.

Das muesstest Du erstmal nachinstallieren.

Anonymous

unregistriert

3

14.05.2005, 14:30

Hallo,

ich habe die Dateien nachinstalliert. Die Fehlermeldung kommt jetzt nicht mehr. Aber der Scanner l?uft auch nicht. Kann bei Aufruf von XSANE den Scanner nicht finden. Scheint schon bei der SANE-Installation was schief gegangen zu sein.

Habe jetzt wieder Knoppix 3.6 draufgespielt .Jetzt funzt wieder alles.

bis dann

Carsten

Anonymous

unregistriert

4

07.07.2005, 12:08

Hallo,
Habe mir jetzt die 4.0 - Version besorgt. Dort erkennt er meinen Scanner. Beim Scannen scannt er das Bild aber nicht richtig. (fragementiert das Bild) und der Scanner h?rt sich auch nicht wirklich gut dabei an.

Bei meinem Notebook gibt es keine Probleme. Wie gesagt beim Knoppix 3.6 auch nicht am PC.

Kann mann xsane und sane komplett auch deinstallieren. Und wenn ja, wie geht das.

Ich w?rde dann nochmal die alten Versionen von Sane mit dem PAtch f?r den HP4200 installieren.

Danke und bis dann

ccharl75

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop