23.09.2017, 16:37 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

19.10.2011, 13:55

[erledigt - durch DVI-Anschluss umgangen] 6.7.1 und Grafikkarten-Erkennung debuggen?

[edit: habe die Headline geändert, weil es eben nicht mehr nur um Nvidia-Karte geht - sondern ich wieder an meiner alten Karte herumprobiere, da es wohl kein Hardwareproblem ist
- sondern es geht ganz grundsätzlich darum die Hardware-Erkennung einer Grafikkarte zu überprüfen
am 19.11.2011 Erledigt-Vermerk in Headline]

Hallo,

aus irgendwelchen Gründen funktioniert meine alte Grfikkarte die unter 6.2.1 funktioniert unter 6.7.1 nicht mehr. Die Auflösung wird nicht korrekt erkannt.
Nun habe ich gegen eine alte Nvidia-Karte getauscht und noch mehr probleme.

Bei der 1. Karte war das Rootterminal durchsichtig.
Die Nvidia-Karte läuft ganz genauso unter 6.2.1 aber unter 6.7.1 noch viel schlimmere Probleme.

Bei der Nvidial-Karte weiß ich im Moment auch gar nicht, wie ich die Symptome beschreiben soll, da diese wechseln, werde ich heute abend noch einmal experimentieren und dokumentieren.

Frage bis dahin: sind grundsätzliche Probleme mit alten Grafikkarten bekannt - wurden irgendwelche Treiber zwischen 6.2.1 und 6.7.1 einfach entfernt?


1. Karte:
noname? gem. http://www.ecombase.de/PRO/showthread.php?t=806983 - scheint dies eine Samsung Karte zu sein
drauf steht
XMX8L
VER: 1.o

Stempel drauf: 200 64 M

Chip1:
Conexantz
Bt869KRF
25869-16
E149923!

Chip2 AMIC
A276308AL-70
0044G
B7J08

auf dem Slotblech außen steht O09D
......................................................................................................................

Nvidia
180-10151-0000-A02

Aufklber
M/N: SP7228/64 MB
P/N: GeFORCE4 TI4200-8x/64MB

-------------------------------------------------------------------------------------------------------------------------
natürlich habe ich im Forum recherchiert
dort habe ich gefunden knoppix-als-mediacenter-tv-out-benutzen mit einem Link zu einem Kantonix-Forum

hier findet man um mehrere weitere Link-Verweise wie man Treiber nachinstalliert - http://www.kanotix.com/PNphpBB2-viewtopic-t-26277.html

allerdings alt vom 8.6.2010 (ev. in zwischenzeit eine ganz andere Debian-Version als Grundlage) - also ziemlich alt. Außerdem geht es um die Treisberinstallation für KDE (wie auch immer das dann mit LXDE genauso funktioniert)

Aber bevor ich das Anfange würde ich ganz gerne noch etwas mehr über den im Moment verwendeten Treiber herausbekommen.
Das ist auch keine gut handelbare Lösung - da es mir um ein Live-System geht, wäre das dann wieder mit remastern verbunden oder kann man Kernelmodule da brauche ich eine funktionsfähige Erkennung - mir würde ja auch die Einfache AGP-Karte ausreichen, wenn diese nur genausogut erkannt würde, wie mit Knoppix 6.2.1.

-----

Danke für Infos welcher Art auch immer.

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »the_idealist100« (19.11.2011, 11:39)


klaus2008

Meister

Beiträge: 2 648

Geschlecht: Männlich

2

19.10.2011, 20:25

Hallo!

Zitat

Bei der 1. Karte war das Rootterminal durchsichtig.

Das lässt sich in den Einstellungen des lxterminals beheben:
"Bearbeiten" -> "Einstellungen" -> "Hintergrund"
Auf der Karte "Stil" die "Deckkraft" auf einen höheren Wert (z. B. 255) einstellen.

Gruß
Klaus

3

19.10.2011, 23:24

Symptome nVidia

(edit wg. Tippfehler)
Hallo,

@Klaus
Danke für Deinen Hinweis.

Trotz des Hinweises würde ich gerne noch die nVidia-Karte zum Laufen bekommen.

Habe das nun noch einmal im Detail getestet - vor dem Start des Live-Systems muß der Monitor eingeschaltet sein - das ist schon immer so - damit die optimale Auflösung erkannt werden kann

folgende Meldungen/Symtome beim und nach dem Booten

(soweit man diese so mitschreiben kann)

INIT version 2,88 booting

Graphics0: nVidia Corporation NV28 [GeForce4 Ti 4200 AGP 98x]
Starting udfev [audio, graphics, input] ...
Starting syslog daemon (console 12) ...
Starting hardware detection and vonfiguration (hwsetup) ...

lange Zeit nach Bbild mit Linux Pinguin
schwarz-blau-weißes Bild
rechts unten 'KNOPPIX 6.7'
links oben Verknüpfung - sieht aus wie ein Ordner weist auf Knoppix

in der Taskleiste sieht man, der Prozessor ist ausgelastet

Mauszeiger in Form einer Hand

Anzeigeeinstellung - über Taskleiste aufgerufen - Auflösung korrekt erkannt 1680x1050 Bildwiederholfrequenz 60.0
(das entspricht der optimalen Einstellung für meinen Monitor)


Startmenü in der Taskleiste steht links heraus und ist nicht anklickbar

Am Monitor Knopf "Auto" paßt die Horizontalfreuqenz auf 64,67 an (korrekt gem Monitorhandbuch)
Die Breite des angezeigten bildes stimmt nun. Das STAARTMENÜ IN DER Taskleiste steht nun nicht mehr links über.

Trotz daß die Auslastungsanzeige in der Taskleiste nicht mehr volle Last zeigt

Symbole in der Tskleiste lassen sich nicht mehr selektieren
als wenn die Maus nicht richtig zielt?
(vorher hatte ich die Anzeigeeinstellungen hierüber ja schon gestartet)

selbst das Startmenü ist nicht mehr aktivierbar

--------------------------------------------------------------------------------------------------------------------------------

Hat hierzu jemand eine Idee, wie ich den Fehler eingrenzen könnte.

Danke.

the_idealist
es muss doch eigentlich gehen ;)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »the_idealist100« (30.10.2011, 20:32)


progi

Fortgeschrittener

4

20.10.2011, 10:25

Hallo idealist, ich zitiere aus einem Beitrag (zu Knoppix 6.4) :

Sollten Besitzer einer exotischen Nvidia-Karte gleich nach dem Booten einen dunklen oder zerwürfelten Bildschirm zu sehen kriegen, sollten sie nacheinander folgende Optionen auf dem Bootprompt versuchen:
knoppix xmodule=nouveau
knoppix xmodule=nv
knoppix xmodule=vesa
fb1280x1024

Sehr, sehr selten ist folgende Radikalkur nötig: »knoppix acpi=off noapic nolapic

vielleicht hilft Dir dies, vielleicht hast Du dies alles aber auch schon probiert
Voila

5

30.10.2011, 18:57

Unterschied Grafikkartensteuerung - 6.2.1 B und 6.7.1

[Tippfehler korrigiert 2.5.12]
Hallo,

erst einmal Danke an progi.

Habe mich nun dran gemacht die cheatcodes zu testen - und zwar erst einmal mit der alten Grafikkarte, die schließlich unter 6.2.1 B toll läuft.

Irgendwie will es mir nicht in den Kopf, dass etwas das unter einer älteren Version gut läuft auf der aktuellen gar nicht mehr tut.

Noch dazu ist das Verhalten bei Verwendung der cheatcodes einfach nur abwegig.

ohne cheatcode - startet das system zwar bis in die Anzeige - hängt sich dann aber auf

bei nouveau:
eigenartige Effekte in der Bildschirmanzeige während des startvorgangs - start menü geht nicht
beim 2. Versuch war der screen derart verschoben, dass der rechte Bereich auf der linken Bildschirmseite erschien

bei nv:
eine Zeit lang während des startens ein graphisches Muster auf dem screen - letzendlich wird Monitorauflösung 1680x105 erkannt Bildwiederholfrequenz 60.0
wähle im Menü das rootterminal aus
klicke während dem start irgendwie mit dem Maus in den Desktop (die Konsole sieht man noch nicht) und das ganze hängt sich auf

bei vesa
wird leider nur eine Auflösung von 1024xc768 Bildfwiderholfrequenz 0.0 erkannt
mein Knoppix 6.2.1B schafft ganz toll 1680 x 1050 !

Frage:
welche debug-Möglichkeit für die Grafikkarten-Erkennung gibt es eigentlich, wenn ein System nicht einmal bis in den Grafikmodus kommt, beim Start - gibt es eine Möglichkeit schon während der Hardwareerkennung noch bevor der X-Server aktiv ist bzw. im Grafikmodus arbeitet (ich weiß nicht ab wann X-Server bei Startprozeß benutzt wird - für den die Einstellungen in der xorg.conf wohl sind)

Gerade war ich noch auf der Spur - Buch von Heike Jurzik zu Debian 6 Sqeeze /etc/X11/xorg.conf analysieren zu wollen und zu vergleichen.
In der Hoffnung, dass HAL bei der Hardwareerkennung seine Einträge in die üblichen Dateien schreibt.
Ev. liege ich da aber absolut falsch - habe auf einer UBUNTU-Seite http://wiki.ubuntuusers.de/xserver
zwar ein bischen was gefunden - aber zwischen den Versionen muß sich mal die Verwendung von HAL und der Konfigurationsdatei immer man wieder hin- und hergeändert haben.
Erst wurde nur HAL verwendet (der macht wohl keine Einträge in xorg.conf - dann wurden wieder Einträge in xorg.conf berücksichtigt, wenn dort Einträge vorhanden (so verstehe ich das).

Frage:
wie arbeitet nun Knoppix 6.7.1?
Kann man das irgendwie debuggen, was da warum wie eingestllt wird.
Irgendwelche fehler im Unterschied zu 6.2.1 B finden indem man vergleicht.


Danke.

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »the_idealist100« (02.05.2012, 20:46)


progi

Fortgeschrittener

6

31.10.2011, 03:51

Hallo, idealist,
benützt Du knoppix-data.img & fromhd ?

Was passiert , wenn Du den Computer herunterfährst und dann
mit "knoppix acpi=off noapic nolapic screen=1680x1050 noimage" bootest

Zu Deinen Angaben :
"bei vesa wird leider nur eine Auflösung von 1024xc768 Bildfwiderholfrequenz 0.0 erkannt"
-> bist Du sicher ?

Was passiert, wenn Du den Computer herunterfährst (also AUSSCHALTEST) und dann mit "vesa noimage screen=1680x1050 " bootest,

(ev. dann noch ein Versuch vom Desktop aus : STRG+ALT+BACKSPACE )

Voila

Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von »progi« (31.10.2011, 11:28)


7

19.11.2011, 11:35

Danke für die Hilfe - Thema durch Hardwareänderung erledigt

Hallo,

wollte einfach noch einmal an alle, die mir Ratschläge gegeben haben, "Danke" sagen.

Ich habe so lange gebraucht, weil ich mit verschiedenen gebrauchten älteren Grafikkarten experimentiert hatte - überall das gleiche Problem.

Das Problem habe ich für mich jetzt umgangen, indem ich eine AGP-Grafikkarte mit sowohl VGA als auch DVI-Ausgang verwende.
Auch hier hatte ich mit dem VGA-Ausgang Probleme (weiß gar nicht mehr ob das gar nicht ging oder nur die Auflösung nicht klappte).
Aber mit dem DVI-Kabel klappt alles - und es geht rasant schnell - so lasse ich das nun - und wer weiß vielleicht ändert sich die Hardware so schnell das ich da niemals mehr mit konfrontiert werden. Für AGP-Karten gibt es ja kaum mehr Anschlüsse auf Motherboards.

Das mit Frequenz 0.0 war vermutlich ein Tipfehler -meine mich an 50.0 zu erinnern.

Mein Flachbildmonitor listet verschiedene Frequenzen zu den jeweiligen Auflösungen auf.
Das verstehe ich nicht - weil ich nicht verstehe warum ein Flachbildmonitor, verschiedene Frequenzen braucht.
Das ist aber eher eine Frage für ein Hardwareforum "Wieso braucht ein Flachbildmonitor - eine Vertikal- und Horizontalfrequenz, wenn es doch gar keinen Kathodenstrahl gibt der Bildpunkte eines Röhrenmonitors zum Leuchten anregt." (PS: ich kenne das auch von 7-Segement-Anzeigen, dass diese regelmäßig einen Refresh benötigen, damit man die Ausgabe weiterhin sieht - möglichst so oft bis es als stehendes Bild empfunden wird - nur warum tut das nicht die Bildschirmlogik sondern der PC?)

Nochmals "Danke".

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »the_idealist100« (02.05.2012, 20:22)


RalfonLinux

Erleuchteter

Beiträge: 2 931

Geschlecht: Männlich

8

21.11.2011, 13:07

Es rast zwar kein Kathodenstrahl mehr durch das Gehäuse, aber du hast trotzdem noch Zeilen und Spalten.
Bei einer physikalischen Auflösung von z.B. 1024x768 muss er halt innerhalb von 70Hz = 1/70 sec den Bildschirm geschrieben haben.
Also 1/70sec / 768 = 0,018ms pro Zeile = 53 kHz

Bei 1920x1080 und 70Hz sind es 75kHz Zeilenfrequenz

Bei 800x600 und 70Hz sind es 42kHz

Da er aber schneller kann (siehe 1920x1080) kann zur Qualitätsverbesserung die Frequenz hochgesetzt werden, er kann dann z.B. bei 800x600 mit 75kHz Zeilenfrequenz eine Bildfrequenz von 125Hz
Das Bild ist also entsprechend ruhiger.

Die Zeiten varieren aber, da er ja z.B. 800x600 umrechnen muss auf 1920x1080.

HtH
Ralf
Auf Wunsch gibt es nur noch Text und keine Bilder mehr in der Signatur.
Keine ? ....... :evil:

Quellcode

1
2
3
4
5
6
7
8
.
    ~
   - -          M
   /V\         - *
  // \\        /V\
 /( _ )\      // \\
  ^~ ~^      /( _ )\
              ^~ ~^

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop