20.11.2018, 21:45 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

12.11.2011, 14:43

Knoppix 6.7.1 und Zotac ZBOX = Grafikfehler

Hallo, ich bin neu hier und ein absoluter Neuling im Umgang mit Knoppix (ich hoffe aber nicht völlig unbegabt).
Folgendes Problem: Ich habe mir fürs Wohnzimmer eine Zotac ZBOX AD02 gekauft. Und zum versuchen und zum erlernen arbeite ich momentan mit Knoppix 6.7.1 auf USB-Stick (hatte auch schon Knoppix 6.7.0 aber selber Fehler). So nun zu meinem Problem... Wenn Koppix startet dann erscheint der erste Bildschirm wo die Graphikkarte und die Soundkarte und so erkannt und initialisiert werden (dies geschieht noch in einer sehr niedrigen Auflösung - [attach]633[/attach]). Dann schaltet Knoppix aber die Auflösung um (in eine hohe Auflösung - habe ich an meinem anderen PC geschaut was Knoppix da eigentlich tut) und ab da sehe ich nur noch Schnee oder schwarz ([attach]634[/attach]). DEr PC ist auch weiterhin an und läuft. Wenn ich zum Beispiel kurz warte und dann Strg+Alt+F1 drücke dann sehe ich ein anderes Schneebild auf dem Monitor, aber so kann ich halt nicht arbeiten :)
Ich habe folgende Befehle schon probiert, änderten aber nichts:
knoppix xmodule=nouveau
knoppix xmodule=nv
knoppix xmodule=vesa
fb1280x1024
knoppix acpi=off noapic nolapic
knoppix video=savagefb:off
Ich schätze mal dass Knoppix ab diesem Punkt die Grafikkarte nicht mehr richtig anspricht, aber wie kann ich das ändern? Treiber kann ich ja nicht installieren da ich im Knoppix selbst ja nichts mehr sehe!
Damit ihr wisst was ich meine habe ich mal 2 Bilder angehängt.
Wäre super wenn mir jemand bei meinem ersten Problem helfen könnte :)
Mac
In der ZBox ist eine AMD Radeon HD 6310 verbaut und ich bin am DVI angeschlossen, nicht am HDMI!
Nachtrag: Ich habe es (zum Teil) geschafft :) Ich habe alle Codes von dieser Seite versucht, nachdem mir klar wurde dass die nicht dauerhaft funktionieren.
ftp://mirror.informatik.uni-mannheim.de/…-cheatcodes.txt
Und mit dem Befehl "knoppix nodrm" läuft der PC an. Ich habe zwar keine genaue Ahnung was ich da getan habe, aber es funktioniert.
Könnte mir jetzt noch jemand erklären warum und was ich tun kann damit ich es nicht immer wieder eingeben muss!

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »maca100v6« (12.11.2011, 16:48)


klaus2008

Meister

Beiträge: 2 699

Geschlecht: Männlich

2

12.11.2011, 18:55

Hallo!

Jetzt wollte ich Dir noch ein paar Versuche vorschlagen, aber das Problem hast Du ja schon einigermaßen eingekreist. Mit dem Bootparameter nodrm wird die Hardwarebeschleunigung für die Grafikkarte im Kernel deaktiviert.

Wenn der Bootparameter permanent eingestellt werden soll, kann man bei einer Installation aui dem USB-Stick die Konfigurationsdatei /mnt-system/boot/syslinux/syslinux.cfg bearbeiten. Man lädt diese Datei in einen Texteditor (z. B. leafpad) und sucht die Zeile mit "TITLE knoppix". Danach kommt eine Zeile, die mit "APPEND" beginnt und eine Anzahl von Bootparametern beinhaltet. Daran kann man noch weitere Bootparameter wie beispielsweise nodrm anhängen. Nach dem Speichern kann man das System neu booten und sehen, ob alles funktioniert.

3

12.11.2011, 21:43

@ Klaus
Danke für die Antowrt! Okay, ich werde die Datei mal ändern.
Aber jetzt mal anders herum gefragt, warum funktioniert die Hardwarebeschleunigung nicht unter Knoppix? Bzw. kann ich irgend etwas tun damit die Hardwarebeschleunigung wieder richtig funktioniert? Zum Beispiel Knoppix auf die Festplatte installieren? Läuft das System dann stabiler?
Laut Suche in Google soll meine Grafikkarte nämlich unter Linux funktionieren?!?! Oder kann ich die Hardwarebeschleunigung ruhig aus lassen? Oder muss ich jetzt die Treiber (wo auch immer ich die finde :) ) jetzt im funktionierenden Knoppix installieren damit ich den Befehl "nodrm" nicht mehr benötige?
Viele Fragen, ich weiß :) Aber ich versuche zu lernen und zu verstehen was ich da eigentlich tue...
Mac

klaus2008

Meister

Beiträge: 2 699

Geschlecht: Männlich

4

13.11.2011, 11:46

Die "Stabilität" verbessert sich nicht durch eine Festplatteninstallation. Wenn eine dauerhafte Installation auf der Festplatte beabsichtigt ist, sollte man eine Linux-Distribution auswählen, von der bekannt ist, dass sie ohne große Probleme mit der Hardware funktioniert.

Übrigens habe ich den Eindruck gewonnen, dass die erfolgreichen Installationen den proprietären Grafiktreiber von AMD verwenden. Diesen bei Knopix 6.7.1 zu installieren, könnte schwierig werden.

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop