27.05.2017, 19:32 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Diebelsman

Anfänger

Beiträge: 11

Geschlecht: Männlich

1

12.04.2014, 16:41

Kein Sound über Boxen

Hallo,
ich nutze seit kurzem Knoppix7.2 von USB-Boot.
ich habe Logitech Z angeschlossen die wohl auch erkannt werden:
knoppix@Microknoppix:~$ cat /proc/asound/cards
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xd8100000 irq 42
1 [SAA7134 ]: SAA7134 - SAA7134
saa7134[0] at 0xd8000000 irq 17
2 [Speaker ]: USB-Audio - Z-10 USB Speaker
Logitech Z-10 USB Speaker at usb-0000:00:1d.1-1, full speed

Aus einem älteren Beitragvon Klaus 2008 habe ich das wie folgt nachgelesen:
Bei Knoppix 6.2.1 legte ich als Benuzer knoppix die Konfigurationsdatei /home/knoppix/.asoundrc mit dem folgenden Inhalt an:
Quellcode
1 defaults.ctl.card 1
2 defaults.pcm.card 1

Wenn ich das richtig verstanden habe, könnte das bei mir vermutlich auch helfen, wenn ich statt der 1 die 2 für Speaker eingebe.
Leider bin ich nicht so fit in der Materie und weiß nicht wie ich das umsetzen muß.
Kann mir jemand eine detailierte Anleitung geben, was ich dafür tun muss.
Vielen Dank vorab.

klaus2008

Meister

Beiträge: 2 624

Geschlecht: Männlich

2

12.04.2014, 17:28

Hallo!

Um die erwähnte Konfigurationsdatei anzulegen, könntest Du ein LXTerminal öffnen und den Befehl

Quellcode

1
leafpad /home/knoppix/.asoundrc 
ausführen. Dann erscheint ein (vermutlich noch leeres) Editorfenster, worin derfolgende Text (ohne die Zeilennummern) einzugeben ist.

Quellcode

1
2
defaults.ctl.card 2
defaults.pcm.card 2

Danach wird die Datei gespeichert. Nachdem der Editor beendet wurde, kann man mit der Tastenkombination Strg-Alt-Backspace die Arbeitsumgebung neu starten. Anschließend kann man die Musikwiedergabe ausprobieren.

Diebelsman

Anfänger

Beiträge: 11

Geschlecht: Männlich

3

12.04.2014, 18:03

Hallo und erstmal Danke für die Hilfe.
Nach der Eingabe von leafpad /home/knoppix/.asoundrckam erstmal in einem anderen Fenster eine Fehlermeldung:"Fehler beim lesen der Datei/home/knoppix/.asoundrc : Ist ein Verzeichnis
Ich habe das mit OK weggeklickt und in dem dann leeren Fenster den Text: defaults.ctl.card 2
defaults.pcm.card 2 reinkopiert.
Beim Speichern ging ein neues Fenster auf "Speichern unter" was wie ein Dateimanager ausseht. Dort habe ich mal als Name "Sound" eingegeben. ???keine Ahnung ob das richtig war???
Zur Folge hatte es dann beim Neustart der Arbeitsumgebung, das die Lautsprecher als entfernt gekennzeichnet wurden.
:?:
Jetzt habe ich auf jedenfall im Ordner /home/knoppix/.asoundrc eine Datei Namens Sound, mit dem Inhalt: defaults.ctl.card 2 defaults.pcm.card 2
Siehe auch Anhang
»Diebelsman« hat folgende Datei angehängt:

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Diebelsman« (12.04.2014, 18:22)


klaus2008

Meister

Beiträge: 2 624

Geschlecht: Männlich

4

12.04.2014, 19:35

Wie sieht im LXTerminal die Ausgabe des Befehls

Quellcode

1
ls -al /home/knoppix/.asoundrc 
aus?

Diebelsman

Anfänger

Beiträge: 11

Geschlecht: Männlich

5

12.04.2014, 19:50

knoppix@Microknoppix:~$ ls -al /home/knoppix/.asoundrc
insgesamt 5
drwxr-xr-x 2 knoppix knoppix 72 Apr 12 20:06 .
drwxr-xr-x 57 knoppix knoppix 1072 Apr 12 21:23 ..
-rw-r--r-- 1 knoppix knoppix 39 Apr 12 20:06 Sound

klaus2008

Meister

Beiträge: 2 624

Geschlecht: Männlich

6

12.04.2014, 20:31

Ich schlage vor, die Datei Sound nach /home/knoppix zu verschieben, das Verzeichnis /home/knoppix/.asoundrc zu löschen und die Datei Sound in .asoundrc umzubenennen. Das wären dann die folgenden Befehle:

Quellcode

1
2
3
mv /home/knoppix/.asoundrc/Sound /home/knoppix/Sound
rmdir /home/knoppix/.asoundrc
mv /home/knoppix/Sound /home/knoppix/.asoundrc 
Anschließend würde ich dann erneut mit Strg-Alt-Backspace die Umgebung neu starten.

Diebelsman

Anfänger

Beiträge: 11

Geschlecht: Männlich

7

13.04.2014, 11:04

Hallo Klaus,
also die Boxen laufen nun. Leider läuft parallel dazu auch der Sound über den Systemmonitor. Doch den kann ich über die Mutetaste am Bildschirm abstellen.
In den Einstellungen habe ich jetzt noch die in anliegendem Foto aufgeführten Einstellungen mit der Meldung ob die entfernten Geräte gelöscht werden sollen. Soll ich?
Weiter bin ich beim surfen auf folgende Seite gestoßen, die sich mit ähnlichem Problem beschäftigen und weitere Hinweise für die implementierung der Boxen dieses Typs geben. Leider für mich alles nur Fachchinesisch.
Auf jedenfall schonmal riesen Dank, jetzt habe ich wenigstens schonmal Sound mit dem man leben kann.
»Diebelsman« hat folgende Datei angehängt:

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop