29.04.2017, 17:33 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

04.02.2017, 21:16

ksnn ich mit der neuesten knoppix - meine Hardware testen - mit einem Hammerbug behaftet

hallo knoppix community guten Abend


also es geht um ein sehr ernstes Prolblem - zu dem es wohl mehrere Loesungsansaetze gibt: - ich hab seit langem mit einem sehr üblen bug zu tun. Und wegen dieses bugs bin ich angrewiesen auf den Betrieb von opensuse 13.2

jetzt kann ich mir vorstellen weiterzukommen mit

upgrade von opensuse 13.2 auf ein neueres system
paralellinstallation - um ein neueres zu testen....
den Text der Hardware mit einer Knoppixversion die einen neuen kernel hat - moeglichst den kernel 4.xy


also - nachdem ich mit dem Problem des "sich nicht ausschaltenden Rechners unter LEAP 42.1 noch eine weile herumgschlagen hatte, hab ich wieder
OpenSuse 13.2 installiert. Und siehe da: da läuft alles reibungslos - und nun bin ich

ein Thread hierzu: http://linux-club.de/forum/viewtopic.php?f=89&t=120853 - fast 4000 mal gelesen - u. vielfach kommentiert u. beantwortet
wovon ich heute ausgehe: ich gehe neuerdings davon aus dass ich es mit diesem Bug zu tun habe: https://bugzilla.kernel.org/show_bug.cgi?id=109051#c434
der Shutdown-process läuft nicht korrekt: es gibt einen Shutdown aber keinen poweroff:

weitere Versuche haben folgendes ergeben;:

- hab vorhin noch ubuntu 15.10 installiert - Shutdown-process läuft nicht korrekt
- openSuse Leap 42.1 - bekanntermassen läuft das auch nicht richtig.
- tumbleweed mit kernel 4.4.2.1 - auch hier das gleiche Verhalten: - Shutdown-process läuft - bis zum Login-Screen; dann friert alles ein u die Lüfter laufen weiter.

Fazit: lediglich mit Opensuse 13.2 läuft es gut. nur - nach einem Jahr auf opensuse 13.2 will ich davon weg - denn nun läuft der Support aus.




und jetzt denke ich dass ich wohl mit einer neuen knoppix version weitermachen will - und das mit einer neuen knoppix testen will - meint ihr dass ich damit weiterkomme u. herausfinden kann ob die neuenern linux-kernel zeigen dass der Hardware-fehler nun für die neueren linuxe __kein __ problem mehr ist.


freu mich von euch zu hoeren.


vg



apropos: auf der Seite auf der die Notebooks angeboten werden hab ich folgenden Hinweis gelesen;

http://www.notebooksbilliger.de/hp+14+r103ng


Frage; Was bedeutet das denn?! Wie kann ich die Installation in Legacy-Mode fahren...??

http://www.notebooksbilliger.de/produkt+…4+r103ng/page/2


Fragen hierzu;
- wie Installiere ich denn Leap 42.1 im Legacy-Mode? Komm ich dann um das UEFI herum?
- Linux mit dem Parameter "acpi=noirq" starten - kann ich das in GRUB unter LEAP 42.1 auch eintragen?
- Spielt denn der Bereitschaftsmodus auch eine Rolle - oben meint ein Käufer dass, um diesen nutzen zu können verwende er den Kernelparameter "clocksource=acpi_pm" ....

Update u. Zusammenfassung: Was ich in den letzten zwei Wochen noch gemacht habe ist Folgendes:

Leider gibt es mit Ubunut Probleme. Zuallerserst fiel mir das o.g Problem auf. Jedesmal wenn ich den Rechner runterfahre, hängt er sich beim Ubuntulogo auf. Das tut er bis zum heutigen Tag - obwohl ich mittlerweile auch diverse Bootoptionen ausprobiert habe.

- mit Ubuntu 15.10
- mit Ubuntu 16.04 - Live u. Installationsversion
- Mit Knoppix 7.6.1 - Liveversion
- mit Tumbleweed LEAP 42.1 - Live u. Installationsversion
- Mit Opensuse Leap 42.1

Mit den Bootoptionen unter GRUB 2 habe ich ferner diverses ausprobiert.

Fazit: nur mit Opensuse 13.2 läuft er problemlos - u. kann nach shutdown auch ein automat. poweroff....

btw;: Das BIOS ist auch total neu - F 39 von Insys - hab ich hochgezogen von Version F 21

Hier nun ein Update zu der Problematik - in form einer Übersicht des Themas. Nach vielem vielem eigenen ausprobieren hab ich gedacht, dass es sinnvoll ist, mal zu sehen wer noch dassselbe Problem hat - und welche Dinge schon versucht wurden die ich selber noch nicht ausprobiert habe.
Und siehe da: Es ist offensichtlich ein etwas umfangreicheres Thema - und so wie es aussieht haengt alles sehr eng zusammen mit der Rechnerarchitektur - u. ggf. im engen Sinne der CPU Penitum N3540

Die UBUNTU-Leute nennen die Platform ein Bay-Trail u. sagen dass es wohl weit u. breit die einzige ist, die irgendwie nicht kompatibel ist
mit Linux (su.). Eine kursorische Durchsicht durch die Threads zeigt dass es m.E. noch keine eindeutigen Loesungen gibt - nur Ansätze u. Versuche. Sucht man nach der CPU - insbes in Verbindung mit Linux... dann ergibt sich folgendes Bild:

wenn man in der Linux-Welt sucht nach Penitum N3540 - gibt es - allgem Infos:
http://www.notebookcheck.net/Intel-Penti…r.117416.0.html

..oder etwa hier die Suche nach Forenbeiträgen - in Verbindung mit Poweroff u Shutdown - in der Mint-Welt:
https://forums.linuxmint.com/search.php?keywords=n3540+

Linux Mint 17.2 not shuting down on a Laptop
https://forums.linuxmint.com/viewtopic.p…=n3540#p1144504

linuxmint freeze
https://forums.linuxmint.com/viewtopic.p…=n3540#p1141217

Suspend, shutdown, reboot hangs on Akoya E4214 Notebook.
https://forums.linuxmint.com/viewtopic.p…=n3540#p1035599

My shutdown problems all were solved with installing Linux Mint 17.2 64bit. And standard Bios settings.
The Bios seems a bit buggy with Legacy OS or the CSM setting enabled.

LM 17.1 Cinnamon fährt nicht runter (Gelesen 2074 mal) nicht gelöst
http://www.linuxmintusers.de/index.php?topic=24804.0


und in der Ubuntuwelt:

shutdown doesn't power off pc
http://ubuntuforums.org/showthread.php?t…n+3540+poweroff

Aufhängen beim Runterfahren
https://forum.ubuntuusers.de/topic/aufha…m-runterfahren/

Poweroff funktionert nicht - hängt sich immer auf.
https://forum.ubuntuusers.de/topic/power…t-sich-immer-a/

https://forum.ubuntuusers.de/topic/ubunt…auf-acer-aspir/



sehr interessant scheint mir dieser Beitrag zu sein:

shutdown-does-not-power-off-computer
http://askubuntu.com/questions/125844/sh…er-off-computer

Wie findet ihr denn den allerletzten Beitrag in Askubuntu - unter dem Thema shutdown-does-not-power-off-computer
und den Ideen - die Prozesse zu untersuchen die da noch laufen!?

Freu mich von Euch zu hoeren...
ps - anbei noch ein paar Daten:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
Festplatte /dev/sda: 465,8 GiB, 500107862016 Bytes, 976773168 Sektoren
Einheiten: Sektoren von 1 * 512 = 512 Bytes
Sektorgröße (logisch/physikalisch): 512 Bytes / 4096 Bytes
E/A-Größe (minimal/optimal): 4096 Bytes / 4096 Bytes
Festplattenbezeichnungstyp: gpt
Festplattenbezeichner: 6229C7C4-758C-450E-9D59-F59E2AE3CB11

Device     	Start   	End   Sectors   Size Type
/dev/sda1   	2048   1050623   1048576   512M EFI System
/dev/sda2	1050624  84951039  83900416	40G Microsoft basic data
/dev/sda3  968617984 976771071   8153088   3,9G Linux swap
/dev/sda4   84951040 968617983 883666944 421,4G Microsoft basic data

Partitionstabelleneinträge sind nicht in Festplatten-Reihenfolge.

martin@linux-vkhz:~> lsblk 
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda  	8:0	0 465,8G  0 disk 
├─sda1   8:1	0   512M  0 part /boot/efi
├─sda2   8:2	0	40G  0 part /boot/grub2/x86_64-efi
├─sda3   8:3	0   3,9G  0 part [SWAP]
└─sda4   8:4	0 421,4G  0 part /home
sr0 	11:0	1  1024M  0 rom  
martin@linux-vkhz:~> ^C
martin@linux-vkhz:~>                                                                                                                                                                       	 
                                                                                                                                                                                           	 
                                                      	



nun - ich glaub ich hab das problem jetzt mal umschrieben - freu mich von Tipps...
ps - ich habe noch keinen bugbericht geschrieben - sollte ich das denn noch machen!?
also es geht um ein sehr ernstes Prolblem - zu dem es wohl mehrere Loesungsansaetze gibt:

upgrade von opensuse 13.2 auf ein neueres system
paralellinstallation - um ein neueres zu testen....

also - nachdem ich mit dem Problem des "sich nicht ausschaltenden Rechners unter LEAP 42.1 noch eine weile herumgschlagen hatte, hab ich wieder
OpenSuse 13.2 installiert. Und siehe da: da läuft alles reibungslos - und nun bin ich
ein Thread hierzu: http://linux-club.de/forum/viewtopic.php?f=89&t=120853 - fast 4000 mal gelesen - u. vielfach kommentiert u. beantwortet

wovon ich heute ausgehe: ich gehe neuerdings davon aus dass ich es mit diesem Bug zu tun habe: https://bugzilla.kernel.org/show_bug.cgi?id=109051#c434
der Shutdown-process läuft nicht korrekt: es gibt einen Shutdown aber keinen poweroff:

weitere Versuche haben folgendes ergeben;:

- hab vorhin noch ubuntu 15.10 installiert - Shutdown-process läuft nicht korrekt
- openSuse Leap 42.1 - bekanntermassen läuft das auch nicht richtig.
- tumbleweed mit kernel 4.4.2.1 - auch hier das gleiche Verhalten: - Shutdown-process läuft - bis zum Login-Screen; dann friert alles ein u die Lüfter laufen weiter.

Fazit: lediglich mit Opensuse 13.2 läuft es gut. nur - nach einem Jahr auf opensuse 13.2 will ich davon weg - denn nun läuft der Support aus.

apropos: auf der Seite auf der die Notebooks angeboten werden hab ich folgenden Hinweis gelesen;

http://www.notebooksbilliger.de/hp+14+r103ng


Frage; Was bedeutet das denn?! Wie kann ich die Installation in Legacy-Mode fahren...??

http://www.notebooksbilliger.de/produkt+…4+r103ng/page/2


Fragen hierzu;
- wie Installiere ich denn Leap 42.1 im Legacy-Mode? Komm ich dann um das UEFI herum?
- Linux mit dem Parameter "acpi=noirq" starten - kann ich das in GRUB unter LEAP 42.1 auch eintragen?
- Spielt denn der Bereitschaftsmodus auch eine Rolle - oben meint ein Käufer dass, um diesen nutzen zu können verwende er den Kernelparameter "clocksource=acpi_pm" ....


Update u. Zusammenfassung: Was ich in den letzten zwei Wochen noch gemacht habe ist Folgendes:

Leider gibt es mit Ubunut Probleme. Zuallerserst fiel mir das o.g Problem auf. Jedesmal wenn ich den Rechner runterfahre, hängt er sich beim Ubuntulogo auf. Das tut er bis zum heutigen Tag - obwohl ich mittlerweile auch diverse Bootoptionen ausprobiert habe.

- mit Ubuntu 15.10
- mit Ubuntu 16.04 - Live u. Installationsversion
- Mit Knoppix 7.6.1 - Liveversion
- mit Tumbleweed LEAP 42.1 - Live u. Installationsversion
- Mit Opensuse Leap 42.1

Mit den Bootoptionen unter GRUB 2 habe ich ferner diverses ausprobiert.

Fazit: nur mit Opensuse 13.2 läuft er problemlos - u. kann nach shutdown auch ein automat. poweroff....

btw;: Das BIOS ist auch total neu - F 39 von Insys - hab ich hochgezogen von Version F 21

Hier nun ein Update zu der Problematik - in form einer Übersicht des Themas. Nach vielem vielem eigenen ausprobieren hab ich gedacht, dass es sinnvoll ist, mal zu sehen wer noch dassselbe Problem hat - und welche Dinge schon versucht wurden die ich selber noch nicht ausprobiert habe.
Und siehe da: Es ist offensichtlich ein etwas umfangreicheres Thema - und so wie es aussieht haengt alles sehr eng zusammen mit der Rechnerarchitektur - u. ggf. im engen Sinne der CPU Penitum N3540

Die UBUNTU-Leute nennen die Platform ein Bay-Trail u. sagen dass es wohl weit u. breit die einzige ist, die irgendwie nicht kompatibel ist
mit Linux (su.).

Eine kursorische Durchsicht durch die Threads zeigt dass es m.E. noch keine eindeutigen Loesungen gibt - nur Ansätze u. Versuche. Sucht man nach der CPU - insbes in Verbindung mit Linux... dann ergibt sich folgendes Bild:

wenn man in der Linux-Welt sucht nach Penitum N3540 - gibt es - allgem Infos:
http://www.notebookcheck.net/Intel-Penti…r.117416.0.html

..oder etwa hier die Suche nach Forenbeiträgen - in Verbindung mit Poweroff u Shutdown - in der Mint-Welt:
https://forums.linuxmint.com/search.php?keywords=n3540+

Linux Mint 17.2 not shuting down on a Laptop
https://forums.linuxmint.com/viewtopic.p…=n3540#p1144504

linuxmint freeze
https://forums.linuxmint.com/viewtopic.p…=n3540#p1141217

Suspend, shutdown, reboot hangs on Akoya E4214 Notebook.
https://forums.linuxmint.com/viewtopic.p…=n3540#p1035599

My shutdown problems all were solved with installing Linux Mint 17.2 64bit. And standard Bios settings.
The Bios seems a bit buggy with Legacy OS or the CSM setting enabled.

LM 17.1 Cinnamon fährt nicht runter (Gelesen 2074 mal) nicht gelöst
http://www.linuxmintusers.de/index.php?topic=24804.0


und in der Ubuntuwelt:

shutdown doesn't power off pc
http://ubuntuforums.org/showthread.php?t…n+3540+poweroff

Aufhängen beim Runterfahren
https://forum.ubuntuusers.de/topic/aufha…m-runterfahren/

Poweroff funktionert nicht - hängt sich immer auf.
https://forum.ubuntuusers.de/topic/power…t-sich-immer-a/

https://forum.ubuntuusers.de/topic/ubunt…auf-acer-aspir/



sehr interessant scheint mir dieser Beitrag zu sein:

shutdown-does-not-power-off-computer
http://askubuntu.com/questions/125844/sh…er-off-computer



Wie findet ihr denn den allerletzten Beitrag in Askubuntu - unter dem Thema shutdown-does-not-power-off-computer
und den Ideen - die Prozesse zu untersuchen die da noch laufen!?

nochmals; ich werde auf alle Faelle jetzt was machen: vieler Erfahrungsberichte u. Reparaturversuche denke ich dass es auf alle Faelle. ES scheint mit SystemD u dem Kernel - bzw. mit der Distribution 13. 2 eben doch noch am weitesten zu führen u. am "normalsten" zu laufen.


Freu mich von Euch zu hoeren...


ps - anbei noch ein paar Daten:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
Festplatte /dev/sda: 465,8 GiB, 500107862016 Bytes, 976773168 Sektoren
Einheiten: Sektoren von 1 * 512 = 512 Bytes
Sektorgröße (logisch/physikalisch): 512 Bytes / 4096 Bytes
E/A-Größe (minimal/optimal): 4096 Bytes / 4096 Bytes
Festplattenbezeichnungstyp: gpt
Festplattenbezeichner: 6229C7C4-758C-450E-9D59-F59E2AE3CB11

Device     	Start   	End   Sectors   Size Type
/dev/sda1   	2048   1050623   1048576   512M EFI System
/dev/sda2	1050624  84951039  83900416	40G Microsoft basic data
/dev/sda3  968617984 976771071   8153088   3,9G Linux swap
/dev/sda4   84951040 968617983 883666944 421,4G Microsoft basic data

Partitionstabelleneinträge sind nicht in Festplatten-Reihenfolge.

martin@linux-vkhz:~> lsblk 
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda  	8:0	0 465,8G  0 disk 
├─sda1   8:1	0   512M  0 part /boot/efi
├─sda2   8:2	0	40G  0 part /boot/grub2/x86_64-efi
├─sda3   8:3	0   3,9G  0 part [SWAP]
└─sda4   8:4	0 421,4G  0 part /home
sr0 	11:0	1  1024M  0 rom  
martin@linux-vkhz:~> ^C
martin@linux-vkhz:~>                                                                                                                                                                        	
                                                                                                                                                                                            	
                                                      	



nun - ich glaub ich hab das problem jetzt mal umschrieben - freu mich von Tipps...
ps - ich habe noch keinen bugbericht geschrieben - sollte ich das denn noch machen!?

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop