18.10.2018, 14:30 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

14.11.2011, 10:32

System hängt

Liebe Knoppix-Fans,

ich habe ein Problem mit Knoppix 6.7.1.. Die Version läuft bei mir als Live-System auf einem 4 GB-USB-Stick mit persistentem Modus auf einem Dual-Core 2 x 1,6 Ghz FSC S 7110 mit 2 Gb RAM. Um mal schnell im Internet ein bischen zu surften und E-Mails abzurufen oder irgendetwas per Online zu bestellen - eine feine Sache.

Seit ein ... zwei Wochen hängt sich das System regelmäßig auf. Die Prozessorlast liegt bei 100%, nix geht mehr. Manchmal hilft dann WLAN ausschalten, oft hilft auch das nicht mehr und ich muss mein Notebook neustarten.ich habe den Eindruck, irgendetwas hat sich da vollgemüllt. Unter Win nehme ich CCleaner und putze
damit das System, danach läuft wieder alles wie am Schnürchen. Gibt es sowas auch unter Knoppix?

Vielen Dank für Eure Tipps im Voraus und beste Grüße aus der trüben Naheregion

Thomas

RalfonLinux

Erleuchteter

Beiträge: 2 934

Geschlecht: Männlich

2

14.11.2011, 10:40

Einen CCleaner wirst du unter Linux nicht finden, da Linux keine Registry hat :-D

Öffne in solchen Fällen mal ein Terminal im Systemverwaltermodus und gib den Befehl "top" ein.
Es öffnet sich eine Tabelle, wo du sehen kannst wieviel Speicher/CPU eine Anwendung benötigt.
Vllt kannst du ja darüber den Übertäter ausfindig machen.

Dann mit "q" den top verlassen und mit "killal %PRGNAME%" (%PRGNAME% ersetzen durch die Anwendung) die Anwendung abschiessen.

Ralf
BTW: Es gibt einige Webseiten, welche "komisch" programmiert sind.
So finanzieren sie sich z.B. durch Werbung, welche von extern eingeblendet wird.
Wenn diese Werbung jetzt wieder externe Werbung aufruft, welche wiederum externe Werbung aufruft, kommst du in eine Schleife, die den Rechner ganz schön beschäftigen kann.
Du solltest also mal darauf achten, ob dir das immer bei den gleichen Webseiten geschieht, und dann der firefox/java/flash/... bei 100% liegt.
Auf Wunsch gibt es nur noch Text und keine Bilder mehr in der Signatur.
Keine ? ....... :evil:

Quellcode

1
2
3
4
5
6
7
8
.
    ~
   - -          M
   /V\         - *
  // \\        /V\
 /( _ )\      // \\
  ^~ ~^      /( _ )\
              ^~ ~^

3

14.11.2011, 19:02

Vielen dank, Ralf, für die rasche Antwort.

Ich werde Deine Tipps demnächst mal ausprobieren.

Beste Grüße - Thomas

4

16.11.2011, 14:38

Hallo Thomas und Ralf


Ich habe ein ähnliches Problem mit Knoppix 6.7.1.

Der Rechner tut nichts mehr.

Kein Tastendruck wird mehr beachtet.

Auch das kleine untere Fenster scheint nahe der Nullinie eingefroren zu sein.

Der Rechner kann nur durch einen Neustart wieder zum laufen gebracht werden.

Dieser Fehler tritt sowohl beim lesen von Texten (E-mail) als auch bei anderen Dingen unregelmäßig auf.

Ich bin ratlos. Was kann dagegen unternommen werden?


MfG:

Knoppixsurfer

progi

Fortgeschrittener

5

16.11.2011, 17:42

hi,
ist der screensaver bei Dir an oder aus ? -> ausschalten !
MfG
progi

6

23.11.2011, 13:21

Hallo progi


Habe alle aktiven Bildschirmschoner bis auf einen deaktiviert.

Außerdem wurden mit dem CompizConfig Einstellungs-Manager alle unnötigen Extras abgeschaltet.

(Wozu brauche ich beispielsweise "Wackelige Fenster" oder "Feuer auf dem Bildschirm"?

Jetzt läuft der Rechner jedenfalls wesentlich besser!


MfG:
Knoppixsurfer

7

16.12.2012, 13:28

Update:


Ich habe mein System jetzt ein ganzes Jahr beobachtet.

Meine erste Annahme (Verbesserung der Stabilität des Rechners) hat sich leider als Irrtum erwiesen.

Der Fehler ist trotz der in den vorigen Beiträgen gemachten Vorschläge nicht verschwunden.

Ob Iceweasel oder Firefox in verschiedenen Versionen, die im Laufe der Zeit installiert wurden, oder auch Libre Office.

Der Fehler tritt unregelmäßig, aber immer wieder auf.


MfG:
Knoppixsurfer

8

16.12.2012, 18:03

Zuerst Hardwarefehler ausschliessen!

Memtest86 mindestens 12 Std laufen lassen!
Lüfter laufen/ nicht verdreckt?
Motherboard optisch unauffällig?
alle Kabel fest?
eventuell Netzteil defekt?
usw

Bei Softwarefehler ist der Fehler eher durch ein ganz bestimmtes Verhalten reproduzierbar.
Gruß Werner * Eigene Rescue-CD
remaster Grml * remaster Knoppix

9

18.12.2012, 18:13

Hallo Werner

Zuerst Hardwarefehler ausschliessen!
Lüfter laufen/ nicht verdreckt?
Motherboard optisch unauffällig?
alle Kabel fest?
eventuell Netzteil defekt?
usw.


Da bei mir Windows und Ubuntu problemlos funktionieren,
ich die Lüfter und das Motherboard regelmäßig entstaube bzw. absauge,
und auch sonst nichts auffällig ist,
scheint die Hardware in Ordnung zu sein.

Im Laufe der Zeit ist mir jedoch aufgefallen, daß ein Neustart nur sehr selten notwendig ist.

Es genügt in der Regel, den Internetstecker für eine kurze Zeit zu ziehen, um den Rechner wieder zum laufen zu bringen.

Es gibt somit zwei Vermutungen, wo der wahrscheinlich softwarebedingte Fehler sein könnte.
1. Irgendein Vorgang in Knoppix bzw. den beiliegenden bzw. aktualisierten Programmen.
2. Irgendein Zugriff aus dem Internet.

Interessant ist es, daß der Fehler manchmal auch auftritt, wenn man z.B. nur die Tabellenkalkulation von Libre Office nutzt. Es also nicht vom System notwendig wäre, auf das Internet zuzugreifen.

Auch in so einem Fall genügt es in der Regel, den Internetstecker für eine kurze Zeit zu ziehen, um dann weiterrechen zu können.

MfG:
Knoppixsurfer

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop