26.04.2018, 03:44 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Anonymous

unregistriert

1

06.08.2006, 08:44

WLAN mit Dell Inspiron 1300 von Live CD 5.0

Bin Linux Anf?nger.
Wie kann ich nach erfolgreichem Start der Knoppix 5.o Live CD feststellen, ob meine DeLL Wireless 1370 WLAN Mini PCI Karte von Broadcom
erkannt wurde und eingebunden wurde?
wenn eingebunden, wie mu? ich im Knoppix Menue die Netwerkkarte u. das Funklan konfiguriren um meinen FritzBox Router auf meinem PC, oder andere Accesspoints zu erreichen.
Wenn Karte nicht erkannt wird, wie kann ich den windows Treiber BCMWL5.SYS ?ber das Menue NDISWRAPPER oder die Konsole einbinden?

2

06.08.2006, 08:58

Hi,


iwconfig teigt Dir, ob das device eingebunden ist.

ndiswrapper -i (Pfad zu den Win Dateien .sys und .inf)
ndiswrapper -l zeigt Dir, ob erfolgreich
modprobe ndiswrapper

dann ?ber knoppix-netzwerk konfigurieren

Gruss Guido

Anonymous

unregistriert

3

06.08.2006, 12:42

WLAN mit Dell Inspiron 1300 von Live CD 5.0

es klappt leider nicht. Bekomme keine Verbindung:
knoppix@1[knoppix]$ iwconfig
lo no wireless extensions.

eth0 IEEE 802.11b/g ESSID:"Hans" Nickname:"Broadcom 4318"
Mode:Ad-Hoc Frequency=2.472 GHz Cell: Invalid
Bit Rate=1 Mb/s
RTS thr:off Fragment thr:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

eth1 no wireless extensions.

sit0 no wireless extensions.

knoppix@1[knoppix]$

4

06.08.2006, 19:22

Hi,

das sieht doch gut aus.
Du hast schon mal eine WLAN-Karte die erkannt wird.
Jetzt kannst Du Dich ans konfigurieren machen. Entweder auf der konsole mit iwconfig (siehe man iwconfig), oder ?ber K-Menu-knoppix- netzwerk-funklan konfigurieren.

Wenn es nicht klappt, versuch erst einmal ohne Verschl?sselung und dann step by step. Kommst Du nicht klar, gib uns konkrete Fehlermeldungen.

Gruss Guido

Anonymous

unregistriert

5

07.08.2006, 11:02

WLAN Karte wird zwar erkannt aber ich bekomme nach der Funklan Konfiguration im KWIFIMANAGER weder meinen Router noch andere Funknetzwerke angezeigt, die unter windows alle erscheinen. Wie fogt Meldungen:
knoppix@1[knoppix]$ iwconfig
lo
no wireless extensions.

eth0
no wireless extensions.

eth1
IEEE 802.11b/g ESSID:"Hansi" Nickname:"Broadcom 4318"

Mode:Managed Frequency=2.472 GHz Access Point: Invalid

Bit Rate=1 Mb/s
RTS thr:off Fragment thr:off

Link Quality:0 Signal level:0 Noise level:0

Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0

Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0
no wireless extensions.

knoppix@1[knopp


netcardconfig
ifconfig eth1 192.168.178.22 netmask 255.255.0 broadcast 192.168.178.22 up

StOCSIFFLAGS: Datei oder Verzeichnis nicht gefunden

StOCSIFFLAGS: Datei oder Verzeichnis nicht gefunden

route and default ggggggw 192.168.178.1
SIOCADDRT:
Das Netzwerk ist nicht erreichbar

auto lo ethO eth1
Setze Nameserver in /etc/resolv.conf auf 192.168.178.1

6

07.08.2006, 14:02

Hi,


Deine Konfiguration bez?glich Ip ist falsch, oder nicht richtig abgeschrieben.
Stell da lieber auf dhcp. Hast Du denn mal ohne Verschl?sselung versucht ?

Versuch mal bitte " iwlist eth1 scanning"


Gruss Guido

Anonymous

unregistriert

7

07.08.2006, 17:54

Leider liegt es offensichtlich an der Knoppix LIVE CD.
iwlist eth1 scanning zeigt keine Serververbindung.
IP alle richtig, FritzBox auch DHCP eingeschaltet.
Bin mit meinem Latein am Ende.
Unter Windows XP klappt WLAN mit meinem PC, PDA u. Notebook problemlos. Alle Versuche mit u. ohne Verschl?sselung scheitern.
Es wird kein Access Point erreicht. Schade.
Mit PDA problemlos jeder Access Point in Deutschland, selbst in USA.
Offensichtlich klappt Knoppix Funklan nur nach Festplatteninstallatin.
Menuekonfiguration auch DHCP Broadcast erreicht keinen Access Point,
Funklan, Netzwerkkarte wollen anscheinend in eine Datei schreiben, die nicht im RAM abgelegt wird. Habe keine andere Erkl?rung.

RalfonLinux

Erleuchteter

Beiträge: 2 931

Geschlecht: Männlich

8

07.08.2006, 19:16

Hi dofeld,

welche Verschl?sselung ist auf deiner Fritz!Box eingetragen ?

Ich kann ohne Probleme via LiveCD ins Netz.

Wer gab dir 192.168.178.22 ?
Ist die WLAN-Karte eingeschaltet ?

Ralf
Auf Wunsch gibt es nur noch Text und keine Bilder mehr in der Signatur.
Keine ? ....... :evil:

Quellcode

1
2
3
4
5
6
7
8
.
    ~
   - -          M
   /V\         - *
  // \\        /V\
 /( _ )\      // \\
  ^~ ~^      /( _ )\
              ^~ ~^

9

07.08.2006, 19:41

Hi,

wenn Du gar nicht weiterkommst, dann versuch mal mit kanotix. Da sind in aktueller Version sehr aktuelle broadcom-Treiber dabei und es ist f?r Anf?nger etwas leichter zu konfigurieren - besonders mit wpa-Verschl?sselung.

Aber die ip-Daten hast Du nitt via dhcp, weil der broadcast 192.168.178.22 falsch ist und auch das subnet.
broadcast muss 192.168.178.255 sein und subnet 255.255.255.0 ;)

Wie weit bist Du vom Ap weg? Wenn Du es Dir zutraust, kannst Du auch mal testweise das modul f?r den Treiber entladen und mit Hilfe von ndiswrapper den xp-Treiber laden. Nur so zum testen.....


Gruss Guido

Anonymous

unregistriert

10

08.08.2006, 12:36

So nochmal ganz jungfreulich:
ich bin mit meinem Notebook in der N?he von mehreren Access Points auch kostenlosen
Starte Knoppix Live CD:
Was mu? ich vorher tun um die aktiven Access Points angezeigt zu bekommen(Netzwerkkarte, Funklan Aktivierung) und mich z.B. mit einem kostenlosen zu verbinden?

RalfonLinux

Erleuchteter

Beiträge: 2 931

Geschlecht: Männlich

11

08.08.2006, 20:37

Na, dann wollen wir mal schauen:

?ffne mal eine Konsole. Das ist der schwarze Monitor unten Links.
Dort gibst du ein[code:1]su
iwconfig[/code:1]
Du solltest jetzt mehrere Netzwerkkarten angezeigt bekommen.
Unteranderem eine, wo KEIN no wireless extensions. hintersteht.
Ich tippe mal auf eth1, also weiter[code:1]iwlist eth1 scanning[/code:1]nun solltest du eine Liste der verf?gbaren AccessPoints bekommen.
Wenn das so nicht ist (no scanning results) k?nnte mal ein [code:1]iwlist eth1 power[/code:1] helfen.

Sollte jetzt ein Current mode:off erscheinen, ist die WLAN-Karte abgeschaltet.
Bei mir hilft dann ein [code:1]iwpriv eth1 set_power 1[/code:1]
Also nochmal:[code:1]iwlist eth1 power[/code:1] Und nun sollte ein Current mode:on erscheinen.
Dann ein [code:1]iwlist eth1 scanning[/code:1] und du hast eine ?bersicht der verf?gbaren AP's

Nun such dir einen aus, der KEINE Verschl?sselung hat, und poste seine Ausgabe.
Dann k?nnen wir dir erkl?ren, wie es mit den erhaltenen Daten weitergeht.

HTH
Ralf
Auf Wunsch gibt es nur noch Text und keine Bilder mehr in der Signatur.
Keine ? ....... :evil:

Quellcode

1
2
3
4
5
6
7
8
.
    ~
   - -          M
   /V\         - *
  // \\        /V\
 /( _ )\      // \\
  ^~ ~^      /( _ )\
              ^~ ~^

Anonymous

unregistriert

12

09.08.2006, 09:16

Danke f?r die Vorschl?ge, aber wieder Fehlanzeige- siehe Konsolenmeldungen. Hier mu? das Problem liegen "broadcom bcm4318 Treiber AirForce One 54g"

knoppix@1[knoppix]$ su
root@1[knoppix]# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11b/g ESSID:off/any Nickname:"Broadcom 4318"
Mode:Managed Access Point: Invalid Bit Rate=1 Mb/s
RTS thr:off Fragment thr:off
Encryption key:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.

root@1[knoppix]# iwlist eth1 scanning
eth1 Interface doesn't support scanning : No such device

root@1[knoppix]# iwlist eth1 power
eth1

RalfonLinux

Erleuchteter

Beiträge: 2 931

Geschlecht: Männlich

13

09.08.2006, 10:07

Scheinbar ist die Firma Broadcom nicht bereit mit den Linuxianer zusammen zu arbeiten.

Es gibt grunds?tzlich in s?mtlichen Distributionen Probleme mit dem Broadcom 43xx, und es wird empfohlen, mit dem ndiswrapper zu arbeiten.

In einem italienischen Board habe ich folgendes gefunden:

Zitat


#ndiswrapper -i /mnt/hda1/SWSetup/SP27942A/bcmwl5a.inf
[percorso al driver Win, controlla se anche tu hai come driver WIN bcmwl5a.inf]

Risposta corretta:
Installing bcmwl5a
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2

# ndiswrapper -l [controlla i driver installati]
Risposta:
Installed ndis drivers:
airplus driver present
bcmwl5 driver present, hardware present
bcmwl5a driver present, hardware present [essenziale]
lsbcmnds driver present, hardware present
lstinds driver present
mrv8k51 driver present
netr33x driver present
prismnic driver present
wlanuig driver present
wlipnds driver present

#ndiswrapper -m [per sicurezza, puo' creare il device wlan0]
modprobe config already contains alias directive

E POI:
# rmmod bcm43xx [come al solito]
# rmmod ndiswrapper [come al solito]

ORA NON C'E' NULLA:
#iwconfig
#lo no wireless extensions.
#eth0 no wireless extensions.

TOGLIAMO ANCHE eth0:
# ifconfig eth0 down

NON c'e' NULLA DI NULLA:
# ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0#

#modprobe ndiswrapper [ritiriamo su ndiswrapper]

ED ECCO CHE ARRIVA LA WIRELESSA wlan0 [avevo messo prima i parametri in OScentre]:
# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11g ESSID:"pippo" Nickname:"default"
Mode:Managed Frequency:2.437 GHz Access Point: 00:13:10:66:FB:A6
Bit Rate=54 Mb/s Tx-Power:16 dBm
RTS thr=2347 B Fragment thr=2346 B
Encryption key:DB9D-E0AF-EE Security mode:open
Power Management:off


Die Zeilen mit f?hrendem # sind die von ihm eingetippten Befehle, alles andere sind Ausgaben.

M??test du mal Probieren.

Ralf
Auf Wunsch gibt es nur noch Text und keine Bilder mehr in der Signatur.
Keine ? ....... :evil:

Quellcode

1
2
3
4
5
6
7
8
.
    ~
   - -          M
   /V\         - *
  // \\        /V\
 /( _ )\      // \\
  ^~ ~^      /( _ )\
              ^~ ~^

Anonymous

unregistriert

14

09.08.2006, 10:25

Sehr seltsam, wenn ich nach gebooteter knoppix Live Cd mit NDISWRAPPER meinen windows xp bcmwl5.inf treiber vom gemounteten sda verzeichnis laden will- passiert garnichts.

15

09.08.2006, 11:57

Hi,

was heisst passiert nichts?
Du kannst mit ndiswrapper -l nachschauen, ob alles gebongt ist.

Vorher solltest Du aber das andere modul mit rmmod entladen.
und danach modprobe ndiswrapper

Gruss Guido

Anonymous

unregistriert

16

09.08.2006, 17:00

Leider kein Erfolg bcmwl5.inf treiber ist nicht ladbar.
Werde in den n?chsten Tagen die Live DVD von Suse 10 testen.
Vielleicht klappt es da. Auch mit Kannotix Live CD u. Mandriva Live CD klappe die Treiber Einbindung mit ndiswrapper nicht- weder ?ber Konsole noch ?ber Men?.

17

09.08.2006, 18:38

Hi,

was heisst denn klappt nicht? Was gibt ndiswrapper -l dann aus.
Sagt er dort invalid driver / hardware present ?

Gruss Guido


PS: Sonst gib mir mal einen link zu dem win-Treiber, dann teste ich das mal ohne hardware, ob er sich wirklich nicht einbinden l?sst.

RalfonLinux

Erleuchteter

Beiträge: 2 931

Geschlecht: Männlich

18

09.08.2006, 19:35

Zitat von »"dofeld"«

Sehr seltsam, wenn ich nach gebooteter knoppix Live Cd mit NDISWRAPPER meinen windows xp bcmwl5.inf treiber vom gemounteten sda verzeichnis laden will- passiert garnichts


Es passiert so richtig garnichts, so ?berhaupt nix ?
Keine Fehlermeldung, kein Beep, kein ....

Du arbeitest auf der Konsole, und auf ndiswrapper -l sagt er n?scht.
Dann gibt doch bitte mal whoami ein, und dann hoffe ich mal, das da nicht root steht, dann haben wir n?mlich den Fehler gefunden.

Ralf
Auf Wunsch gibt es nur noch Text und keine Bilder mehr in der Signatur.
Keine ? ....... :evil:

Quellcode

1
2
3
4
5
6
7
8
.
    ~
   - -          M
   /V\         - *
  // \\        /V\
 /( _ )\      // \\
  ^~ ~^      /( _ )\
              ^~ ~^

Anonymous

unregistriert

19

09.08.2006, 20:47

Hier die neuesten erfolglosen Ergebnisse:

knoppix@1[knoppix]$ whoami
knoppix
knoppix@1[knoppix]$

Meine windows Treiber habe ich auf USB Stick wie folgt kopiert:
BCM43XX.CAT 9,9 KB
bcmwI5.inf 539,9 KB
BCMWL5.SYS 414,4 KB

Wenn ich das Verzeichnis im Knoppix ndiswrapper tool eingebe z.B.
/media/sda1/Dell Wireless WLAN Card/Driver/bcmwI5.inf
kommt auf OK keine Meldung und das tool Fenster schlie?t sich

daf?r wieder meine Lieblingsmeldung: in der Konsole

knoppix@1[knoppix]$ ndiswrapper -l
No drivers installed
knoppix@1[knoppix]$

Anonymous

unregistriert

20

09.08.2006, 21:20

Hier der Link zu den Treibern:
http://ftp.us.dell.com/network/R115321.EXE
Nach download und extrahieren unter Driver

21

10.08.2006, 17:02

Hi,

wie Ralf schon vermutet hat, versuch das ganze als root in der Konsole. Nicht als user...
Nimm die Konsole und kein tool ;)

Gruss Guido

RalfonLinux

Erleuchteter

Beiträge: 2 931

Geschlecht: Männlich

22

10.08.2006, 23:03

@Guido

R?chel ....

;-)
Auf Wunsch gibt es nur noch Text und keine Bilder mehr in der Signatur.
Keine ? ....... :evil:

Quellcode

1
2
3
4
5
6
7
8
.
    ~
   - -          M
   /V\         - *
  // \\        /V\
 /( _ )\      // \\
  ^~ ~^      /( _ )\
              ^~ ~^

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop