20.06.2018, 07:35 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Anonymous

unregistriert

1

11.08.2006, 15:41

Knoppix 3.9. (newbie) WLAN mit DWL-G122

Hallo Allerseits,

ich habe Knoppix 3.9. auf mein altes Laptop (PIII, 500 Mhz, 6GB) installiert. Knoppix 3.9. erscheint mir als sinnvoll, weil dort das KDE noch nicht ganz so aufgebl?ht ist, wie bei anderen (neueren) Distributionen. Hab ich mal gelesen.

Mein Problem: Ich will mit WLAN ins Internet und es klappt nicht.

Ich habe einen WLAN Dongle DWL-G122 und einen T-Sinus 111 WLAN Router mit WEP. Mit dem USB Viewer wird mir der WLAN Dongle angezeigt.

Bei 'iwconfig' erhalte ich nur "lo no wireless extensions"

Ich hab es auch mit Ndiswrapper probiert. Aber ich bekomme die .inf-Datei gar nicht angezeigt, da auf der D-Link CD es nur eine Autorun.inf gibt und das ist wohl nicht die richtige.

Vielleicht habe ich auch ein How to ?bersehen. Kann mir jemand weiterhelfen.
Besten Dank schon im voraus !!!

Genschi

RalfonLinux

Erleuchteter

Beiträge: 2 931

Geschlecht: Männlich

2

11.08.2006, 16:36

Hallo genschi,

geh doch mal oben auf Suchen, und gib als Suchbegriff "DWL" "G122" ein.

Ralf
Auf Wunsch gibt es nur noch Text und keine Bilder mehr in der Signatur.
Keine ? ....... :evil:

Quellcode

1
2
3
4
5
6
7
8
.
    ~
   - -          M
   /V\         - *
  // \\        /V\
 /( _ )\      // \\
  ^~ ~^      /( _ )\
              ^~ ~^

Anonymous

unregistriert

3

11.08.2006, 18:46

Hallo Ralf,

> geh doch mal oben auf Suchen, und gib als Suchbegriff "DWL""G122" ein.

Diese Seiten habe ich auch schon gefunden, aber daraus werd ich leider nicht schlau. Ich krieg auch irgendwie die Treiber nicht organisiert, damit ich den Ndiswrapper benutzen kann. Ich hab ein englischen How To gefunden, aber da muss man irgendwie voll an den Dateien rumbasteln. Das ist mir zu kompliziert, da mir die Basics fehlen, was ich da mache.

4

11.08.2006, 18:49

Lesen und testen mu?t du schon selber

http://www.alpowious.net/linux/howto.php?id=wlan
Was haben Windows und ein Uboot gemeinsam?
Kaum macht man ein Fenster auf, gehen die Probleme los.

EDV ist die Abkürzung für: Ende der Vernunft

RalfonLinux

Erleuchteter

Beiträge: 2 931

Geschlecht: Männlich

5

12.08.2006, 17:33

Hi genschi,

ich wei? ja nicht wo du suchst, aber hier im Forum http://www.elearnit.de/knoppix/forum/search.php stehen doch Anleitungen zum DWL G122 ?

Und da ist nichts Englisches dabei.

?
Ralf
Auf Wunsch gibt es nur noch Text und keine Bilder mehr in der Signatur.
Keine ? ....... :evil:

Quellcode

1
2
3
4
5
6
7
8
.
    ~
   - -          M
   /V\         - *
  // \\        /V\
 /( _ )\      // \\
  ^~ ~^      /( _ )\
              ^~ ~^

6

12.08.2006, 17:57

Liefert genau 2 Treffer die Anfrage . Ein Treffer ist dieses hier. Der zweite Treffer ist auch nicht gerade hilfreich.
Was haben Windows und ein Uboot gemeinsam?
Kaum macht man ein Fenster auf, gehen die Probleme los.

EDV ist die Abkürzung für: Ende der Vernunft

RalfonLinux

Erleuchteter

Beiträge: 2 931

Geschlecht: Männlich

7

12.08.2006, 18:09

Also ich bekomme:
http://www.elearnit.de/knoppix/forum/viewtopic.php?t=1630&highlight=dwl+g122
http://www.elearnit.de/knoppix/forum/viewtopic.php?t=1461&highlight=dwl+g122
http://www.elearnit.de/knoppix/forum/viewtopic.php?t=1366&highlight=dwl+g122
http://www.elearnit.de/knoppix/forum/viewtopic.php?t=815&highlight=dwl+g122

und nat?rlich dieser Thread selber: http://www.elearnit.de/knoppix/forum/viewtopic.php?t=1733&highlight=dwl+g122


Z.T. beziehen sie sich auf weitere DWL's aber es hei?t immer: Nimm den ndiswrapper.

Also n?chster Suchlauf mit dem Key "ndiswrapper":
und es ergibt 67 Ergebnisse. Mit Sicherheit doppelte und Fehlinformationen, aber erstmal genug zu lesen.

Ralf
Auf Wunsch gibt es nur noch Text und keine Bilder mehr in der Signatur.
Keine ? ....... :evil:

Quellcode

1
2
3
4
5
6
7
8
.
    ~
   - -          M
   /V\         - *
  // \\        /V\
 /( _ )\      // \\
  ^~ ~^      /( _ )\
              ^~ ~^

Anonymous

unregistriert

8

13.08.2006, 12:41

Hallo,
nachdem ich jetzt gelesen und gelesen habe und auch ausprobiert habe, komm ich doch nicht weiter. Sorry deshalb brauch ich doch eure Hilfe nochmals.

Ich geb
lsusb ein und bekomme: Bus 001 Device 002: ID 07d1:3c03 D-Link System
D.h. mein Usb-Dongle wird erkannt. Das finde ich ja schon mal gut.

Jetzt habe ich ?ber das englische How To (http://aloriel.no-ip.org/files/How-To_D-Link_DWL-G122_USB_WiFi_dongle.pdf) die inf.Datei downgeloaded und ?ber ndiswrapper installiert.

Mit 'ndiswrapper -l' erhalte ich:
Installed ndis drivers:
dr71wu invalid driver!

Wie soll ich das interpretieren? Das es der falsche Treiber ist? Wenn ja, wo bekomme ich den richtigen her.
- auf der mitgelieferten CD kann ich die .inf-Datei nicht auslesen, da nur eine Setup.exe da ist
- auf D-Link wird die selbe Datei zum Download angeboten
- Mit Google hab ich auch nichts gefunden.

mfg Genschi

Anonymous

unregistriert

9

13.08.2006, 13:30

Bin jetzt glaub einen kleinen aber entscheidenden Schritt weiter.
hab nochmals die dr71wu.inf Datei mit ndiswrapper installiert.

Nun zeigt er mir an: 'driver present, hardware pesent'

aber mit 'iwconfig': lo no wireless extensions.
???

mfg
Genschi

RalfonLinux

Erleuchteter

Beiträge: 2 931

Geschlecht: Männlich

10

13.08.2006, 13:32

@Posting 12:41
Er behauptet, das der Treiber nicht mit der Hardware ?bereinstimmt.

Wenn ich mir deinen usb-id (07d1:3c03) ansehe, habe ich dort ein Problem.
Der 07d1:3c03 steht f?r einen DLink DWL-G122 Rev C1, welchen es lt. Homepage des Herstellers http://support.dlink.com/downloads/# ?berhaupt nicht gibt.

Weiterhin habe ich die Kennung 07d1:3c04 gefunden, welche den gleichen Chip verwendet, und der Treiber soll kompatibel sein. In seinen Zust?ndigkeitsbereich soll auch der 07d1:3c03 fallen.
Einen Versuch ist es wert, lade dir mal den Treiber f?r den WUA 1340 , vielleicht klappt es ja damit.

Ansonsten lad dir doch einfach die Windows-Treiber aus deiner Windows-Installation.

HTH
Ralf
Auf Wunsch gibt es nur noch Text und keine Bilder mehr in der Signatur.
Keine ? ....... :evil:

Quellcode

1
2
3
4
5
6
7
8
.
    ~
   - -          M
   /V\         - *
  // \\        /V\
 /( _ )\      // \\
  ^~ ~^      /( _ )\
              ^~ ~^

Anonymous

unregistriert

11

13.08.2006, 14:54

Hallo Ralf,

?ber http://www.d-link.de/ kann man sich f?r die Revision C die Windows-Treiber downloaden.
Die habe ich jetzt mal versuchsweise auf meinem Windows-Rechner installiert um an die inf-Dateien ranzukommen.

danach habe ich mit
- ndiswrapper -i die inf. installiert
- ndiswrapper -l die Meldung bekommen: dr71wu dirver present, hardware present
- ndiswrapper -m folgendes: Adding "alias wlan0 ndiswrapper"

und wie weiter jetzt?

RalfonLinux

Erleuchteter

Beiträge: 2 931

Geschlecht: Männlich

12

13.08.2006, 19:33

Du solltest jetzt bei einem iwconfig eine Netzwerkkarte (wlan0) angezeigt bekommen.

Dann geht es wie von kbdcalls am 11.8 18:49 beschrieben weiter.

Also iwconfig wlan0 channel ....
iwconfig wlan0 essid "...."
:
:

Ralf
Auf Wunsch gibt es nur noch Text und keine Bilder mehr in der Signatur.
Keine ? ....... :evil:

Quellcode

1
2
3
4
5
6
7
8
.
    ~
   - -          M
   /V\         - *
  // \\        /V\
 /( _ )\      // \\
  ^~ ~^      /( _ )\
              ^~ ~^

Anonymous

unregistriert

13

14.08.2006, 19:03

Mmmh, ich bin untr?stlich, aber...

wenn ich 'cat /etc/modprobe.d/ndiswrapper' eingebe erhalte ich: 'alias wlan0 ndiswrapper'. Soweit so gut.

Ich hab jetzt mal in die Datei /etc/modules in die letzte Zeile 'ndiswrapper' eingetragen.

iwconfig= lo no wireless extensions

Bei den ganzen Seiten zu ndiswrapper m?sste nach all dem bei iwconfig irgendetwas anderes kommen. Denn dort enden die HowTo und weiter geht's dann mit Kwifi. Soweit bin ich aber leider noch nicht :-(

Gr??le
Genschi

14

14.08.2006, 19:47

Hi,


ihr habt vergesssen, den ndiswrapper auch zu laden:

modprobe ndiswrapper als root ;)

Gruss Guido

Anonymous

unregistriert

15

14.08.2006, 19:51

Sorry, das ich es vergessen habe zu erw?hnen, aber das habe ich gemacht. Oder muss ich das nach jedem Neustart machen ?

Genschi

16

14.08.2006, 19:53

Hi,

jepp.

Wenn es l?uft kannst Du das modul ja nach /etc/modules kopieren.

Gruss Guido

17

14.08.2006, 19:55

Hast du den Treiber installiert. Was gibt denn [code:1]ndiswrapper -l[/code:1] ? Poste das mal exact.
Was haben Windows und ein Uboot gemeinsam?
Kaum macht man ein Fenster auf, gehen die Probleme los.

EDV ist die Abkürzung für: Ende der Vernunft

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop