20.11.2018, 19:36 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Anonymous

unregistriert

1

15.08.2006, 10:49

Kein pon dsl-provider nach neustart m?glich, pppoeconfig ok

Tja, nun hab ich das gleiche Problem das im Forum http://www.linux-user.de/Forum/user/00019251?expand_all=1 ausf?hrlich beschrieben wurde:

Knoppix 5.0.1 ist auf Festplatte installiert und pppoeconfig l?sst sich ausf?hren. Beim Neustart aber l?sst sich kein pon dsl-provider ausf?hren, auch die module pppoe usw. sind nicht geladen. Allerdings existieren die Eintr?ge in /etc/ppp/peers/dsl-provider und /etc/ppp/pap-secrets noch. Wenn man pppoeconfig dann wieder ausf?hrt, muss man nur die ersten beiden Schritte (Erkennung der Netzwerkkarte) durchf?hren, kann pppoeconfig dann abbrechen und pon dsl-provider klappt. Kann es sein dass die Verkn?pfung von eth0 und ppp0 noch nicht existert und hergestellt werden muss??

Was ich will: Mit einem Klick oder einfach nach dem Neustart schon eingeloggt sein (wie es ja pppoeconfig verspricht). Das funktioniert aber nicht, weil im Bootvorgang die Fehlermeldung erscheint, dass /etc/network/interfaces nicht gelesen werden kann, obwohl die Datei f?r alle User lesbar ist!

Wer wei?, welche Module ich laden muss (trage ich dann einfach in /etc/modules ein) und welche Sachen ich mit User-Rechten ausf?hren kann (schreib ich dann ein Shell Skript), damit die DSL-Einwahl klappt?

2

15.08.2006, 10:56

Poste mal ifconfig -a und die Modulliste [code:1]lsmod[/code:1] und die [code:1]/etc/network/interfaces[/code:1] da liegt vermutlich der Hund begraben.
Was haben Windows und ein Uboot gemeinsam?
Kaum macht man ein Fenster auf, gehen die Probleme los.

EDV ist die Abkürzung für: Ende der Vernunft

Anonymous

unregistriert

3

20.08.2006, 10:30

L?sung - Kurze Zusammenfassung

[b]Problemformulierung:[/b]

Beim Ausf?hren von pppoeconf klappt die DSL-Einwahl. Nach einem Neustart funktioniert aber nichts mehr. Grund daf?r (Bug) ist, dass die Netzwerkkarte (bei mir eth0) nicht aktiv ist.

[b]L?sung kurz:[/b]

modprobe pppoe
ifconfig eth0 up
pon dsl-provider

[b]L?sung lang (automatischer DSL-Start beim booten):[/b]

1. In /etc/modules (bzw. bei Knoppix z.B. /etc/modules-2.6.17) erg?nzen:
pppoe
pppox
ppp-generic

2. In /etc/init.d Shell Script eth0_dsl_start erstellen:
#! /bin/sh
#Start der Netzwerkkarte eth0
ifconfig eth0 up
#Start der DSL-Verbindung
pon dsl-provider

3. In /etc/rc5.d/ symbolischen Link darauf setzen:
ls -s ../init.d/eth0_dsl_start S95eth0_dsl_start

[b]Links, die auch dieses Problem beschreiben:[/b]
http://www.kubuntu.de/forum/forum.php?req=thread&id=91
http://forum.ubuntuusers.de/topic/12468/
http://www.faqs.org/docs/Linux-HOWTO/DSL-HOWTO.html
http://leaf.sourceforge.net/doc/bk02ch15s02.html

4

20.08.2006, 11:00

Das m??te auch einfacher gegen Zumindest bei einem original Debian Sid klappt das hervorragend

in der /etc/network/interfaces

[code:1]
iface dsl-provider inet ppp
provider dsl-provider
pre-up /sbin/ifconfig eth? up
[/code:1]
Was haben Windows und ein Uboot gemeinsam?
Kaum macht man ein Fenster auf, gehen die Probleme los.

EDV ist die Abkürzung für: Ende der Vernunft

Anonymous

unregistriert

5

19.11.2006, 12:13

Noch was zu meiner DSL-Bescheibung oben ...

Klartext: Man hat beim Rumprobieren sicherlich das Knoppixtool f?r die DSL-Einwahl mehrmals ausgef?hrt. Das f?hrt jedesmal zu Eintr?gen in /etc/network/interfaces, worauf diese Datei unbrauchbar wird ( sieht man beim Knoppix Start, wenn die Fehlermeldung erscheint)


Erg?nze in obiger Beschreibung folgenden Punkt.

4. Wahrscheinlich wurde pppoeconf zu Beginn mehrmals ausgef?hrt
und somit sind mehrere eth0 Eintr?ge in /etc/network/interfaces entstanden.
Also alle bis auf einen l?schen!!!

Anonymous

unregistriert

6

03.01.2007, 13:20

DSL Router ?ber IP Adresse konfigurieren

DSL Router konfigurieren

Hat man einen DSL-Router, so sollte man diesen direkt ?ber den Brower konfigurieren. Eine DSL-Modem Einwahl ist unn?tig.
Man tippt im Browser einfach http://192.168.2.1 (z.B. f?r T-Com Router) und gelangt in die Konfiguration des Routers.

Problem: Die Netzwerkkarte erkennt den DSL-Router nicht, der direkt im Browser ?ber die IP-Adresse angesprochen wird. (T-Com Router haben meist die IP 192.168.2.1)

Schritt 1: Pr?fung: Der Befehl 'ifconfig eth0' muss folgenden oder einen ?hnlichen eth0 Eintrag haben:

eth0 Protokoll:Ethernet Hardware Adresse ...
inet Adresse:192.168.2.100 Bcast:192.168.2.255 Maske:255.255.255.0
inet6 Adresse: ...

Schritt 2: /etc/network/interfaces
Wenn bei Schritt 1 der inet - Eintrag fehlt (2.Zeile) ist eth0 nicht f?r DHCP konfiguriert. Also muss /etc/network/interfaces wie folgt erg?nzt oder ge?ndert werden:

# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)

# The loopback interface
# automatically added when upgrading

auto lo
iface lo inet loopback


auto eth0
iface eth0 inet dhcp

Schritt 3: Netzwerk neu starten
/etc/init.d/networking restart

Und schon l?sst sich im Browser der DSL-Router aufrufen (http://192.168.2.1 f?r T-Com Router Speedport W 500)

Anonymous

unregistriert

7

11.01.2007, 15:27

Re: L?sung - Kurze Zusammenfassung

Zitat von »"mikichambiki"«



3. In /etc/rc5.d/ symbolischen Link darauf setzen:
ls -s ../init.d/eth0_dsl_start S95eth0_dsl_start


hi
soweit hab ich? s kapiert, aber bei 3. habert?s.

wie mache ich sowas???

hab zwar im netz gestoebert aber nix gescheites gefunden.

kann mir jemand weitehelfen?

mfg minikolf

8

11.01.2007, 17:16

Hi,

brauchst doch nur abtippen.

Gruss Guido

Anonymous

unregistriert

9

26.01.2007, 19:16

Re: L?sung - Kurze Zusammenfassung

Ich glaube dir ist hier ein kleiner Fehler unterlaufen.

Zitat von »"mikichambiki"«


3. In /etc/rc5.d/ symbolischen Link darauf setzen:
ls -s ../init.d/eth0_dsl_start S95eth0_dsl_start


richtig w?hre wohl eher:
[code:1]ln -s ../init.d/eth0_dsl_start S95eth0_dsl_start[/code:1]
oder
[code:1]ln -s /etc/init.d/eth0_dsl_start S95eth0_dsl_start[/code:1]

Au?erdem muss '/etc/init.d/eth0_dsl_start' ausf?hbar gemacht werden.
z.B. [code:1]chmod a+x /etc/init.d/eth0_dsl_start[/code:1]
Sollte ich mich geirrt haben korrigiert mich bitte.

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop