19.09.2018, 11:47 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Anonymous

unregistriert

1

06.11.2006, 10:02

wpa_supplicant || Scanning: OK Associating: OK, dann Abbruch

Sers ihr lieben Leute,

ich verf?ge seit neuestem ?ber das HP nc6000 Notebook, mit Intel Pro 2200 3B Karte (oder so ?hnlich...) f?rs WLAN. An meiner Wand h?ngt die FRITZ!Box Fon WLAN 7050, die ein WPA-PSK TKIP Netz ausstrahlt.

Da ich ein Linux Neuling bin, hatte ich erstmal gro?e Probleme, zu raffen, was ich mit dem seltsamen wpa_supplicant anfangen soll. Aber ich habe ihn irgendwann sogar zum laufen gebracht und war mit meinem Notebook auch im Netz --> gro?e Freude.

Aaaaaaber dann:
gestern abend disconnected, heute morgen neu angemacht, in die wpa_supplicant.conf die Netzinfos f?r meinen Unizugang eingetragen, der Supplicant kommt nur noch bis ASSOCIATING und kommt dann nicht weiter. Habe die .conf wieder zur?ckge?ndert, aber das Problem bleibt.

letzte Meldung (mit -dd aufgerufen):
[code:1]
State: SCANNING --> ASSOCIATING
wpa_driver_wext_associate
Setting authentication timeout: 60 sec 0 usec
EAPOL: External notification - EAP success=0
EAPOL: External notification - EAP fail=0
EAPOL: External notification - portControl=Auto
Wireless event: cmd=0x8b06 len=8
Wireless event: cmd=0x8b1a len=23
[/code:1]

weiter kommt er nicht, wiederholt nur immer bis dahin den Versuch, und ich bin mit meinem Latein am Ende, weil es m?sste ja eigentlich alles richtig sein, iss ja wieder so, wie vorher...

meine wpa_supplicant.conf

[code:1]
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
update_config=1
ap_scan=2

network={
ssid="BreathOfArgony"
scan_ssid=1
proto=WPA
key_mgmt=WPA-PSK
pairwise=TKIP
group=TKIP
psk='mein Passwort in verschl?sselt'
}

[/code:1]

Wenn ihr mir irgendwie helfen k?nnt, w?re super, ich wollte jetzt endlich mal mehr in Linux eintauchen, aber ich br?uchte vor allem dringend ein funktionierendes netzf?higes System, was mich bis dato immer wieder zu Windows zur?ckgeworfen hat. Aber diesmal will ich am Ball bleiben.

Achja... seid sanft mit mir, ich hab kein Plan, was ihr meint, wenn ihr zu viel hintergrundwissen voraussetzt. Ich hab ein Linux in a nutshell buch, falls ihr mich auf Befehle hinweisen wollt und ich bin nicht lesefaul, wenn ihr mich auf wichtige Internetseiten verweist, aber vermutlich m?sstet ihr mir recht schrittweise erkl?ren, was ihr meint...

LG
GothicFiction

Anonymous

unregistriert

2

06.11.2006, 10:06

Nachtrag:
habe meinen L?ppi gerade nebenbei weiterversuchen lassen, sich zu connecten, was ihm just nach abschicken meiner ebigen Nachricht auch gelungen ist, nach fast 30min. Jetzt hoab ich aber Sorgen zu disconnecten, nich, dasser wieder nich will...

Achja, ich hatte irgendwo was gelesen, dass man irgendwie daf?r sorgen muss, dass die karte sich beim disconnecten ordentlich abmeldet?!? K.A. wie man so etwas macht, ich lass den Supplicant immer in einer root Konsole laufen, und zwar mit -dd und zum beenden des connects strg + C. Iss bestimmt nich richtig, oder? Weil, wenn ichs als Demon laufen lass, hab ich kein Plan, wie mans abschaltet.

LG
GothicFiction

RalfonLinux

Erleuchteter

Beiträge: 2 934

Geschlecht: Männlich

3

06.11.2006, 14:04

Hallo GothicFiction,

ich habe bei mir etwas weniger eingetragen.

[code:1]ctrl_interface=/var/run/wpa_supplicant
ap_scan=2
network={
scan_ssid=1
ssid="Dein ESSID"
key_mgmt=WPA-PSK
psk="Dein PreSharedKey"
}
[/code:1]
Vielleicht hilft dir das ja weiter ?

Meine wpa_supplicant l?uft immer als D?mon, da ich nicht ohne das Laptop runterzufahren das Funk-Netzwerk ?ndere.
Wenn du diese Funktion aber ben?tigst, solltest du mit Hilfe von[code:1]kill `cat /var/run/wpa_supplicant/*.pid`[/code:1] einen geordneten R?ckzug antreten k?nnen.


Ralf
Auf Wunsch gibt es nur noch Text und keine Bilder mehr in der Signatur.
Keine ? ....... :evil:

Quellcode

1
2
3
4
5
6
7
8
.
    ~
   - -          M
   /V\         - *
  // \\        /V\
 /( _ )\      // \\
  ^~ ~^      /( _ )\
              ^~ ~^

Anonymous

unregistriert

4

06.11.2006, 15:55

Erstmal vielen Dank Ralf, zumindest weiss ich jetzt mal, wie ich ?berhaupt Prozesse kille :-). Deine Konfiguration l?uft bei mir ?brigens auch, wie gesagt, jetzt funktionierts gerade mal wieder. Wie kann man den schauen, welche PIDs gerade aktiv sind, bzw. Demons laufen?

Und ich hab nochwas gefunden: wpa_cli

[code:1]
#wpa_cli help

Selected interface 'eth1'
commands:
status [verbose] = get current WPA/EAPOL/EAP status
mib = get MIB variables (dot1x, dot11)
help = show this usage help
interface [ifname] = show interfaces/select interface
level <debug level> = change debug level
license = show full wpa_cli license
logoff = IEEE 802.1X EAPOL state machine logoff
logon = IEEE 802.1X EAPOL state machine logon
set = set variables (shows list of variables when run without arguments)
pmksa = show PMKSA cache
reassociate = force reassociation
reconfigure = force wpa_supplicant to re-read its configuration file
preauthenticate <BSSID> = force preauthentication
identity <network id> <identity> = configure identity for an SSID
password <network id> <password> = configure password for an SSID
new_password <network id> <password> = change password for an SSID
pin <network id> <pin> = configure pin for an SSID
otp <network id> <password> = configure one-time-password for an SSID
passphrase <network id> <passphrase> = configure private key passphrase
for an SSID
bssid <network id> <BSSID> = set preferred BSSID for an SSID
list_networks = list configured networks
select_network <network id> = select a network (disable others)
enable_network <network id> = enable a network
disable_network <network id> = disable a network
add_network = add a network
remove_network <network id> = remove a network
set_network <network id> <variable> <value> = set network variables (shows
list of variables when run without arguments)
get_network <network id> <variable> = get network variables
save_config = save the current configuration
disconnect = disconnect and wait for reassociate command before connecting
scan = request new BSS scan
scan_results = get latest scan results
get_capability <eap/pairwise/group/key_mgmt/proto/auth_alg> = get capabilies
ap_scan <value> = set ap_scan parameter
terminate = terminate wpa_supplicant
quit = exit wpa_cli
[/code:1]

Mit Terminate scheint mans im Sinne des Erfinders zu beenden. Ich werds jetzt einfach mal immer nur so machen. Wie packe ich dass den am besten in ein Script, damit ich daraus nen Start - Stop Knopf machen kann???

LG
GothicFiction

Anonymous

unregistriert

5

06.11.2006, 19:56

neue Info:

ab und an (mehr oder weniger regelm??ig) verliert sich die Connection und es tritt o.g. Problem auf. Bisher hilft:

wpa_cli disconnect
wpa_cli terminate
neustart wpa_supplicant

ob's damit immer klappt, k.A. ... Vor allem w?rd mich interessieren, wieso die Verbindung verloren wird, und erst nach terminieren wiedergefunden werden kann.

LG
GF

RalfonLinux

Erleuchteter

Beiträge: 2 934

Geschlecht: Männlich

6

07.11.2006, 22:05

Ich kenne den wpa_cli so nicht, aber eine Prozess-Liste erh?ltst du mit [code:1]ps faux[/code:1]

Das er das Netz erst nach der Terminierung findet, k?nnte z.B. daran liegen, das die ..*.pid -Datei noch existiert.
Wenn ich den Prozess noch einmal starte, kommt die Fehlermeldung, das der PID noch steht.
Ein einfaches L?schen der Datei, und es kann wieder los gehen.

Das du ?ftes den Connect verlierst, kann auch physikalische Gr?nde haben.
Ein Nachbar, welcher im "gleichen" Kanal funkt, ein Stahltgr?ger mitten auf Tischh?he,...
An meiner Fritz (7170) kam ca. alle 3 Minuten ein reconnect (ipw2100) nun habe ich hier ein ipw3945 stehen, und keine Probleme mehr.


Ralf
Auf Wunsch gibt es nur noch Text und keine Bilder mehr in der Signatur.
Keine ? ....... :evil:

Quellcode

1
2
3
4
5
6
7
8
.
    ~
   - -          M
   /V\         - *
  // \\        /V\
 /( _ )\      // \\
  ^~ ~^      /( _ )\
              ^~ ~^

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop