15.08.2018, 13:00 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

20.03.2009, 23:36

Wie kann ich den WlanTreiber rt2860 (eeePC 1000H) unter Knoppix 6.1 auf usb-disk installieren??

Hallo, nach extrem einfacher Installation von Knoppix 6.1 auf meinem USB stick und dem absolut problemlosen Betrieb auf meinem eeePC701 habe ich nicht lange gezögert und den Stick an meinen eeePC 1000H gesteckt, gebootet und dann das System auf der SD-karte installiert. Leider war das WLAN überhaupt nicht zu sehen. Nach einigen Recherchen habe ich eine Quelle gefunden in der für den 1000H die Ralink-Treiberinstallation beschrieben ist:

http://stadt-bremerhaven.de/2008/10/17/a…u-und-das-wlan/

Leider klappt die Installation nicht wie beschrieben. Beim Befehl "sudo make " gibt es die ersten Fehlermeldungen, weil ein Verzeichnis "build" offensichtlich nicht existiert.

Hat jemand in der Gemeinde so etwas schon für Knoppix 6.1 und den eeePC 1000H geschrieben? Oder ist jemand in der Lage, das so abzuändern, das es läuft?

Ich pack's jedenfalls nicht. ?(

Gruß

Andreas

Konfigurationen: eeePC 701 (Xandros und Knoppix 6.1 vom Stick); eeePC 1000H (XP und Knoppix von der SD-karte)

2

21.03.2009, 07:44

Hi,

hier hab ich was gefunden, wie jemand sie Karte recht simpel ans laufen bekommen hat.
Zwar nicht knoppix , aber auch ein debianbasierendes System....

http://sidux.com/PNphpBB2-viewtopic-t-14…ght-rt2860.html

Gruß

klaus2008

Meister

Beiträge: 2 692

Geschlecht: Männlich

3

21.03.2009, 11:46

Hallo!

Hier gibt es detaillierte Informationen über Debian und Ralink RT2860:
http://wiki.debian.org/rt2860sta

Gruss Klaus

4

21.03.2009, 12:25

Es kann aber gut sein, daß Du den modul-assistant erst per apt nachinstallieren musst. (brauchst Du, um das Paket zu bauen)

5

24.03.2009, 23:02

Lösung!

Hallo Leute,

dank eines sehr freundlichen Kollegens bin ich unter Knoppix 6.1 mit meinem eeePC 1000H im Forum.

Zuerst wie oben in dem Link beschrieben verfahren. bis zum Befehl "make".

Diese Variante gab bei mir aber eine Fehlermeldung:

knoppix@Microknoppix:~/Desktop/2008_0918_RT2860_Linux_STA_v1.8.0.0$ make
make -C tools
make[1]: Entering directory `/home/knoppix/Desktop/2008_0918_RT2860_Linux_STA_v1.8.0.0/tools'
gcc -g bin2h.c -o bin2h
make[1]: Leaving directory `/home/knoppix/Desktop/2008_0918_RT2860_Linux_STA_v1.8.0.0/tools'
/home/knoppix/Desktop/2008_0918_RT2860_Linux_STA_v1.8.0.0/tools/bin2h
cp -f os/linux/Makefile.6 /home/knoppix/Desktop/2008_0918_RT2860_Linux_STA_v1.8.0.0/os/linux/Makefile
make -C /lib/modules/2.6.28.4/build SUBDIRS=/home/knoppix/Desktop/2008_0918_RT2860_Linux_STA_v1.8.0.0/os/linux modules
make: *** /lib/modules/2.6.28.4/build: Datei oder Verzeichnis nicht gefunden. Schluss.
make: *** [LINUX] Fehler 2


Hier fehlt das Unterverzeichnis ...4/build, der eigentlich in Lenny dort vorhanden sein sollte (so hab ich die Erklärung verstanden). Der workaround ist:

# make LINUX_SRC=/usr/src/linux-headers-2.6.28.4
make -C tools
make[1]: Entering directory `/home/knoppix/Desktop/2008_0918_RT2860_Linux_STA_v1.8.0.0/tools'
gcc -g bin2h.c -o bin2h
make[1]: Leaving directory `/home/knoppix/Desktop/2008_0918_RT2860_Linux_STA_v1.8.0.0/tools'
/home/knoppix/Desktop/2008_0918_RT2860_Linux_STA_v1.8.0.0/tools/bin2h
cp -f os/linux/Makefile.6 /home/knoppix/Desktop/2008_0918_RT2860_Linux_STA_v1.8.0.0/os/linux/Makefile
make -C /usr/src/linux-headers-2.6.28.4 SUBDIRS=/home/knoppix/Desktop/2008_0918_RT2860_Linux_STA_v1.8.0.0/os/linux modules
make[1]: Entering directory `/UNIONFS/usr/src/linux-headers-2.6.28.4'
CC [M] /home/knoppix/Desktop/2008_0918_RT2860_Linux_STA_v1.8.0.0/os/linux/../../common/rtmp_init.o
LD [M] /home/knoppix/Desktop/2008_0918_RT2860_Linux_STA_v1.8.0.0/os/linux/rt2860sta.o
Building modules, stage 2.
MODPOST 1 modules
LD [M] /home/knoppix/Desktop/2008_0918_RT2860_Linux_STA_v1.8.0.0/os/linux/rt2860sta.ko
make[1]: Leaving directory `/UNIONFS/usr/src/linux-headers-2.6.28.4'
cp -f /home/knoppix/Desktop/2008_0918_RT2860_Linux_STA_v1.8.0.0/os/linux/rt2860sta.ko /tftpboot


Das war wohl der entscheidende Schritt, denn jetzt sehe ich die Karte mit" iwconfig"

knoppix@Microknoppix:~/Desktop/2008_0918_RT2860_Linux_STA_v1.8.0.0$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

ra0 RT2860 Wireless ESSID:"" Nickname:"RT2860STA"
Mode:Auto Frequency=2.437 GHz Access Point: Not-Associated
Bit Rate:1 Mb/s
RTS thr:off Fragment thr:off
Link Quality=100/100 Signal level:-88 dBm Noise level:-97 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0


und iwlist ra0 scanning funktioniert auch.

Vieleicht klappt's ja auch bei jemand anderem auf diese Art und Weise.

Andreas

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop