26.11.2014, 09:32 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Beiträge: 723

Geschlecht: Männlich

1

01.07.2009, 16:34

[gelöst] WLAN-Verbindung aktivieren

Was ist die normale Vorgehensweise, um das WLAN zu aktivieren?

(Diese Frage bezieht sich nicht auf meine Eee-Box. Ich möchte mit der Knoppix-CD mit WLAN ins Internet. Und zwar von meinem Notebook, wo der WLAN-Adapter erkannt wird).
MfG. Cottonwood.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Cottonwood« (02.07.2009, 22:14)


klaus2008

Meister

Beiträge: 2 344

Geschlecht: Männlich

2

01.07.2009, 16:50

Grundlegende Informationen über den Umgang mit Funknetzwerken und Debian: http://wiki.debian.org/WiFi/

Beiträge: 723

Geschlecht: Männlich

3

01.07.2009, 18:10

Ist das wirklich der normale Weg für jemanden, der mit Knoppix sein Notebook startet, keine Ahnung von nichts hat und nur mit WLAN ins Internet geht?

Das ist bei Windows XP aber wirklich einfacher.

Mein Problem ist hier, dass es mehrere Wege gibt und ich immer nicht weiss, ob ich mich wirklich auf dem einfachsten Weg befinde.

Ich habe also bei "How To Use" den Zweig "Other GUI" ausgewählt. -> 1. Anhang
Ich habe wicd installiert, interfaces geändert und wicd gestartet. -> 2. Anhang
Dann habe ich den Schlüssel eingetragen und bei Fritz!Box auf connect gedrückt, aber keine Verbindung bekommen. -> 3. Anhang

Wenn man sich diesen Beitrag anschaut, dann geht das offensichtlich ganz einfach. Aber ich finde das einfach nicht.
Es muss so einfach sein, dass es einfach niemand im Web beschreibt. :cursing:
»Cottonwood« hat folgende Dateien angehängt:
  • 20090701-2.jpg (195,4 kB - 10 mal heruntergeladen - zuletzt: 20.08.2014, 20:45)
  • 20090701-3.jpg (48,65 kB - 7 mal heruntergeladen - zuletzt: 06.04.2012, 14:02)
  • 20090701-4.jpg (100,69 kB - 4 mal heruntergeladen - zuletzt: 28.10.2009, 18:46)
MfG. Cottonwood.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Cottonwood« (01.07.2009, 19:02)


klaus2008

Meister

Beiträge: 2 344

Geschlecht: Männlich

4

01.07.2009, 19:15

Bei Knoppix 6 konnte ich bisher immer das Netzwerk-Manager-Applet verwenden. Geht das bei deinem Notebook nicht? Hast Du vor dem Verbindungsversuch mit dem Funknetzwerk das kabelgebundene Netzwerk abgeschaltet? Ist der Network Manager deinstalliert?

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »klaus2008« (01.07.2009, 19:27)


Beiträge: 723

Geschlecht: Männlich

5

01.07.2009, 21:23

Bei Knoppix 6 konnte ich bisher immer das Netzwerk-Manager-Applet verwenden. Geht das bei deinem Notebook nicht?

Netzwerk-Manager-Applet? Was ist das? Also Google:



Tray=Tablett. Was bedeutet das? Im Speicher? Schön. Was soll's, hauptsache es klappt. - Klar. Nur bei mir nicht:

Quellcode

1
2
3
4
5
6
7
root@Microknoppix:/# nm-applet

** (nm-applet:4044): WARNING **: <WARN>  applet_dbus_manager_start_service(): Could not acquire the NetworkManagerUserSettings service as it is already taken.  Return: 3

root@Microknoppix:/# /etc/init.d/NetworkManager restart
bash: /etc/init.d/NetworkManager: Datei oder Verzeichnis nicht gefunden
root@Microknoppix:/# 


Für einen absoluten Linux-Anfänger sind Schlagwörter nicht wirklich hilfreich. :whistling:

Besser wäre eine Erläuterung wie "Klicke auf...", "Gib ... ein". ;)

Hast Du vor dem Verbindungsversuch mit dem Funknetzwerk das kabelgebundene Netzwerk abgeschaltet?


Nö? Muss ich das? Und warum? Bisher war es nach jedem Versuch sowieso abgeschossen. ;)

Ist der Network Manager deinstalliert?


Warum sollte er? :?: 8|
MfG. Cottonwood.

klaus2008

Meister

Beiträge: 2 344

Geschlecht: Männlich

6

01.07.2009, 21:56

Zitat

wicd (Wireless Interface Connection Daemon) is an alternative to NetworkManager.
Daher dachte ich, dass man den NetworkManager Daemon stoppen sollte, bevor wicd gestartet wird. Beispielsweise

Quellcode

1
sudo /etc/init.d/network-manager stop


Wenn das Netzwerk Manager Applet läuft, gibt es ein Symbol im Panel zwischen dem Lautsprechersymbol und der Akkuanzeige. Dieser Bereich unten rechts wird wohl mit Tray gemeint sein. Einen Bereich, der Systemtray genannt wird, gibt es auch bei Windows XP. Der befindet sich dort ebenfalls unten rechts, wenn man die Leiste am unteren Bildschirmrand hat.

Gruss Klaus

Beiträge: 723

Geschlecht: Männlich

7

01.07.2009, 23:35

Zitat

wicd (Wireless Interface Connection Daemon) is an alternative to NetworkManager.
Daher dachte ich, dass man den NetworkManager Daemon stoppen sollte, bevor wicd gestartet wird. Beispielsweise

Quellcode

1
sudo /etc/init.d/network-manager stop


Ich glaube mich zu erinnern, dass der NetworkManager bei der Installation von wicd deinstalliert wurde.

Der 2. Versuch war aber nach Neustart.
MfG. Cottonwood.

klaus2008

Meister

Beiträge: 2 344

Geschlecht: Männlich

8

02.07.2009, 07:04

Zitat

Ich glaube mich zu erinnern, dass der NetworkManager bei der Installation von wicd deinstalliert wurde.
Ich installierte versuchshalber das wicd-Paket. Dabei wurden zwei Pakete, die zum Network Manager gehören, automatisch deinstalliert.
Wenn ich das Funknetzwerk ausgewählt habe, gibt es zuerst eine Verbindung, wie man an der Statuszeile des Clients erkennen kann. Anschließend wird die Verbindung aber wieder getrennt, wie man dem Systemprotokoll entnehmen kann.

Quellcode

1
dmesg


Gruss Klaus

Beiträge: 723

Geschlecht: Männlich

9

02.07.2009, 09:36

Wenn ich das Funknetzwerk ausgewählt habe, gibt es zuerst eine Verbindung, wie man an der Statuszeile des Clients erkennen kann. Anschließend wird die Verbindung aber wieder getrennt, wie man dem Systemprotokoll entnehmen kann.


Wo und wie wählst du das Funknetzwerk aus? An der grafischen Oberfläche finde ich nichts zum Auswählen.

Kannst du mal bitte das Systemprotokoll hier reinstellen.
MfG. Cottonwood.

klaus2008

Meister

Beiträge: 2 344

Geschlecht: Männlich

10

02.07.2009, 10:30

Systemprotokoll dauert etwas, weil ich gerade Windows laufen habe.

Zitat

Wo und wie wählst du das Funknetzwerk aus? An der grafischen Oberfläche finde ich nichts zum Auswählen.
Wenn ich den wicd-client starte mittels

Quellcode

1
wicd-client -n
erhalte ich ein Fenster mit der Übersicht der Netzwerke.
Beim Systemstart erschien bei mir in der "Tray" ein Symbol mit zwei Computern, die die Netzwerkverbindung symbolisieren. Beim daraufklicken erhielt ich das Auwahlfenster, allerdings ohne die Netzwerke, Erst nachdem ich den Refreshbutton gedrückt hatte, erhielt ich die Liste. Am Ende der Verbindungsaktivität erschien die Statuszeile "Verbunden mit 0%". Die Verwendung von Netzwerkprogrammen wie ping oder traceroute scheiterteten, weil das Netzwerk nicht erreichbar war.

Gruss Klaus

klaus2008

Meister

Beiträge: 2 344

Geschlecht: Männlich

11

02.07.2009, 13:10

Einstellungen überprüft

Ich testete nochmals den wicd-client. Klickt man afuf die Schaltfläche "Preferences" erscheint ein Fenster "Einstellungen" mit drei Karteikarten. Auf der Karte "External Programs" wählte ich im Abschnitt "DHCP Client" an Stelle von "Automatic", was empfohlen wird, den Punkt dhclient. Seitdem kann ich mich mit meinem Funknetzwerk verbinden und komme, wie man sieht, ins Internet.
Aktuell sieht der relevante Abschnitt des Systemprotokolls so aus:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
[  540.356699] usb 1-1: reset full speed USB device using uhci_hcd and address 2
[  540.784973] usb 1-1.1: new full speed USB device using uhci_hcd and address 5
[  540.913609] usb 1-1.1: configuration #1 chosen from 1 choice
[  541.014981] usb 1-1.1: reset full speed USB device using uhci_hcd and address 5
[  541.129996] phy1: Selected rate control algorithm 'pid'
[  541.132006] zd1211rw 1-1.1:1.0: phy1
[  541.132973] usb 1-1.1: New USB device found, idVendor=0cde, idProduct=001a
[  541.132982] usb 1-1.1: New USB device strings: Mfr=16, Product=32, SerialNumber=0
[  541.132991] usb 1-1.1: Product: USB Device
[  541.132997] usb 1-1.1: Manufacturer: ZyDAS
[  714.329517] usb 1-1.1: firmware: requesting zd1211/zd1211b_ub
[  714.458433] usb 1-1.1: firmware: requesting zd1211/zd1211b_uphr
[  714.733339] zd1211rw 1-1.1:1.0: firmware version 4725
[  714.794004] zd1211rw 1-1.1:1.0: zd1211b chip 0cde:001a v4810 full 00-11-3b AL2230_RF pa0 g---S
[  714.798897] cfg80211: Calling CRDA for country: DE
[  714.855521] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  780.723999] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  782.014669] wlan0: authenticate with AP XX:XX:XX:XX:19:b9
[  782.051670] wlan0: authenticate with AP XX:XX:XX:XX:19:b9
[  782.051877] wlan0: authenticated
[  782.051888] wlan0: associate with AP XX:XX:XX:XX:19:b9
[  782.056797] wlan0: RX AssocResp from XX:XX:XX:XX:19:b9 (capab=0x411 status=0 aid=3)
[  782.056814] wlan0: associated
[  782.058753] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[  783.255141] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  830.210345] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  830.229606] wlan0: deauthenticating by local choice (reason=3)
[  830.356983] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  831.396432] wlan0: direct probe to AP XX:XX:XX:XX:19:b9 try 1
[  831.418459] wlan0: direct probe to AP XX:XX:XX:XX:19:b9 try 1
[  831.418506] wlan0 direct probe responded
[  831.418516] wlan0: authenticate with AP XX:XX:XX:XX:19:b9
[  831.423445] wlan0: authenticated
[  831.423459] wlan0: associate with AP XX:XX:XX:XX:19:b9
[  831.426424] wlan0: RX AssocResp from XX:XX:XX:XX:19:b9 (capab=0x411 status=0 aid=3)
[  831.426434] wlan0: associated
[  831.428720] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[  841.596638] wlan0: no IPv6 routers present

Beiträge: 723

Geschlecht: Männlich

12

02.07.2009, 14:05

Ich danke dir.

Ich stelle das jetzt erst mal zurück, bis ich es auf der Eee-Box testen kann. Sieht ja so aus, als ob das nicht mehr so lange dauert.
Sonst müsste ich immer wieder neu von der KNOPPIX-CD starten und alles neu einrichten, wenn ich zwischendurch auf die Box will. :S
MfG. Cottonwood.

Beiträge: 723

Geschlecht: Männlich

13

02.07.2009, 21:19

So, bis jetzt lief das Ganze unter dem Thema Betriebsblindheit.

Weil es auf meiner Eee-Box rechts unten auf dem Schirm bislang kein WLan gab, habe ich auf dem Notebook (um das es hier geht) ebendort überhaupt nicht geschaut.

Und da (auf dem Notebook) gibt es ein WLan:

Das habe ich aber erst gefunden, nachdem ich es auf der Eee-Box dank eurer Hilfe einrichten konnte.


Aber wie dem immer so ist, habe ich gleich das nächste Problem. Es handelt sich hier um eine originäre, von der CD gestartete KNOPPIX 6.0.1-Version.

Was für ein Passwort will der hier von mir wissen? Woher muss ich das nehmen?
»Cottonwood« hat folgende Datei angehängt:
  • 20090702-6.png (106,38 kB - 12 mal heruntergeladen - zuletzt: 05.08.2013, 16:40)
MfG. Cottonwood.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Cottonwood« (02.07.2009, 21:36)


Beiträge: 651

Geschlecht: Männlich

14

02.07.2009, 21:28

Ist das Posting unter Festplatteninstallation nun hinfällig? Wegen gelöst?

edit:

eben erst deine PN gesehen ;)

Beiträge: 651

Geschlecht: Männlich

15

02.07.2009, 21:41

Das ist nur ein PW, damit nur du das Recht bekommst die WLAN-Verbindung zu nutzen bzw an ihr etwas zu ändern. Hat nix mit dem Key, den du für den Router brauchst zu tun. Du kannst das auch leer lassen.

edit:

ist zumindest unter der KDE so.

Beiträge: 723

Geschlecht: Männlich

16

02.07.2009, 21:46

Danke.

Was die SSID ist, das weiss ich. Das ist der Name des Routers, wie ich ihn immer und überall sehen kann. Aber was bitteschön ist bei BSSID einzugeben?
MfG. Cottonwood.

Beiträge: 651

Geschlecht: Männlich

17

02.07.2009, 21:49

Kannste leer lassen, ich brauchte das nicht, SSID langt.

Grade in google gelesen, dass das die MAC-Adresse des Routers ist. Bei meine T-Sinus findet man die unter Status->Details

Beiträge: 723

Geschlecht: Männlich

18

02.07.2009, 22:07

Danke. Danke. Danke.

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
- Device: wlan0 ----------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            ath5k_pci
  State:             connected
  Default:           no
  HW Address:        00:xx:xx:xx:13:50

  Capabilities:
    Supported:       yes
    Speed:           5 Mb/s

  Wireless Settings
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes
MfG. Cottonwood.

Beiträge: 651

Geschlecht: Männlich

19

02.07.2009, 22:12

Zitat

ath5k_pci



also doch ein Atheros Chip, sonderbar...dann haste das Ralink Modul wahrsch umsonst kompiliert.

Beiträge: 723

Geschlecht: Männlich

20

03.07.2009, 00:12

Verwirrend, nicht wahr. Ich bin auch immer durcheinander gekommen. Aber bei diesem Thread handelt es sich um das Notebook, nicht um die Eee-Box. ;)
MfG. Cottonwood.

Beiträge: 651

Geschlecht: Männlich

21

03.07.2009, 00:22

Ah ok, alles klar, Ralink auf Eee-Box, Atheros am Laptop ;)

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop