20.07.2018, 09:00 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Beiträge: 1 150

Geschlecht: Männlich

1

22.11.2011, 20:35

[gelöst] VirtualBox Netzwerk funktioniert nicht mehr

Hi,

ich habe mir einen neuen PC gebaut und wollte direkt mal VT-x ausprobieren, Knoppix bootet auch und es ist alles schön Schnell, nur das Netzwerk will nicht.
Die Netzwerkkarte scheint jedoch erkannt zu werden, da lspci entsprechend die Ausgabe bringt:

Quellcode

1
00:03.0 Ethernet controller: Advanced Micro Devices [AMD] 79c970 [PCnet32 LANCE] (rev 40)
Der Netzwerkmanager meint "Es sind keine Netzwerkgeräte verfügbar".

Knoppix: 6.7.1 /* Edit: 64 Bit */
VirtualBox: 4.1.6
Host: ArchLinux

Habt ihr vielleicht eine Idee?

Viele Grüße
Maxi

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »maxi_king_333« (23.11.2011, 16:33)


klaus2008

Meister

Beiträge: 2 688

Geschlecht: Männlich

2

22.11.2011, 20:57

Hallo, Maxi!

Eine Idee habe ich noch nicht. Wie sieht denn die Ausgabe von

Quellcode

1
ifconfig
in der Virtualbox aus? Hast Du schon andere Netzwerkadapter versucht?

Beiträge: 1 150

Geschlecht: Männlich

3

22.11.2011, 21:00

Hi Klaus,

Quellcode

1
ifconfig
bringt nur das Loopback-Interface.
Ein

Quellcode

1
ifconfig eth0 up
bringt auch keine Besserung sondern nur, dass kein Gerät gefunden wurde.

Probiert habe ich schon verschiedene Adapter im Bridge und NAT Modus.

/* Edit:
Im 32 Bit Modus geht es, aber das ist eher suboptimal, da die VM dann nicht den vollen Arbeitsspeicher ausnutzt,
'/

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »maxi_king_333« (22.11.2011, 21:06)


klaus2008

Meister

Beiträge: 2 688

Geschlecht: Männlich

4

22.11.2011, 22:10

Ich habe jetzt auf meinem "Aptosid 64 Bit"-System die Virtualbox auf 4.1.6 aktualisiert und Knoppix V6.7.1 DVD im "64 Bit"-Modus gestartet. Das System lief einwandfrei, soweit man das in der Kürze der Testphase sagen kann. Vielleicht tritt das Problem nur bei Deinem Host auf. Welche Kernelversion wird darauf verwendet?

Beiträge: 1 150

Geschlecht: Männlich

5

22.11.2011, 22:22

Version 3.1.1

Quellcode

1
Linux MaxiPC 3.1.1-1-ARCH #1 SMP PREEMPT Fri Nov 11 22:28:29 CET 2011 x86_64 Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz GenuineIntel GNU/Linux

6

22.11.2011, 23:02

Zitat

Im 32 Bit Modus geht es,...
Wenn du das nicht geschrieben hättest, würde ich fragen, ob du "angschlossen an Netzwerkbrücke" bereits probiert hast, die Nr bei "eth" mit der des Host übereinstimmt und das Häkchen bei "Kabel verbunden" gesetzt ist.
Gruß Werner * Eigene Rescue-CD
remaster Grml * remaster Knoppix

Beiträge: 1 150

Geschlecht: Männlich

7

22.11.2011, 23:17

Zitat

Im 32 Bit Modus geht es,...
Wenn du das nicht geschrieben hättest, würde ich fragen, ob du "angschlossen an Netzwerkbrücke" bereits probiert hast, die Nr bei "eth" mit der des Host übereinstimmt und das Häkchen bei "Kabel verbunden" gesetzt ist.
Ja, habe auch geschrieben, dass ich das schon Probiert habe. :D
Außerdem, wenn der Hacken bei "Kabel verbunden" nicht gesetzt ist, dann heißt es im Netzwerkmanager "nicht verbunden", es wird also trotzdem eine Netzwerkkarte erkannt.
Das ist auch gerade das seltsame, in beiden fällen erkennt lspci die Karte korrekt, nur irgendwie findet sie der Netzwerkmanager und auch ipconfig sie nicht.

klaus2008

Meister

Beiträge: 2 688

Geschlecht: Männlich

8

23.11.2011, 06:40

Ich weis jetzt nicht, ob es zu neuen Erkenntnissen führt, aber wie lauten die Ausgaben von

Quellcode

1
2
hwinfo --netcard
hwinfo --network

Verwendest Du die CD oder die DVD von Knoppix V6.7.1?

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »klaus2008« (23.11.2011, 06:45)


Beiträge: 1 150

Geschlecht: Männlich

9

23.11.2011, 14:57

Ich weis jetzt nicht, ob es zu neuen Erkenntnissen führt, aber wie lauten die Ausgaben von

Quellcode

1
2
hwinfo --netcard
hwinfo --network

Verwendest Du die CD oder die DVD von Knoppix V6.7.1?
netcard

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
12: PCI 03.0: 0200 Ethernet controller
  [Created at pci.318]
  UDI: /org/freedesktop/Hal/devices/pci_1022_2000
  Unique ID: 3hqH.g18wkxJX7ME
  SysFS ID: /devices/pci0000:00/0000:00:03.0
  SysFS BusID: 0000:00:03.0
  Hardware Class: network
  Model: "AMD PCnet - Fast 79C971"
  Vendor: pci 0x1022 "AMD"
  Device: pci 0x20600 "79c970 [PCnet32 LANCE]"
  SubVendor: pci 0x1022 "AMD"
  SubDevice: pci 0x2000 "PCnet - Fast 79C971"
  Revision: 0x40
  I/O Ports: 0xd020-0xd03f (rw)
  Memory Range: 0xf0000000-0xf0000fff (rw,non-prefetchable)
  Memory Range: 0xf0080000-0xf00fffff (rw,non-prefetchable)
  IRQ: 10 (no events)
  Module Alias: "pci:v00001022d00002000sv00001022sd00002000bc02sc00i00"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
network

Quellcode

1
2
3
4
5
6
7
8
9
12: None 00.0: 10700 Loopback
  [Created at net.124]
  Unique ID: ZsBS.GQNx7L4uPNA
  SysFS ID: /class/net/lo
  Hardware Class: network interface
  Model: "Loopback network interface"
  Device File: lo
  Link detected: yes
  Config Status: cfg=new, avail=yes, need=no, active=unknown


/* Edit:
32-Bit-Modus:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
11: PCI 03.0: 0200 Ethernet controller                          
  [Created at pci.318]
  UDI: /org/freedesktop/Hal/devices/pci_1022_2000
  Unique ID: rBUF.g18wkxJX7ME
  SysFS ID: /devices/pci0000:00/0000:00:03.0
  SysFS BusID: 0000:00:03.0
  Hardware Class: network
  Model: "AMD PCnet - Fast 79C971"
  Vendor: pci 0x1022 "AMD"
  Device: pci 0x2000 "79c970 [PCnet32 LANCE]"
  SubVendor: pci 0x1022 "AMD"
  SubDevice: pci 0x2000 "PCnet - Fast 79C971"
  Revision: 0x40
  Driver: "pcnet32"
  Driver Modules: "pcnet32"
  Device File: eth0
  I/O Ports: 0xd020-0xd03f (rw)
  Memory Range: 0xf0000000-0xf0000fff (rw,non-prefetchable)
  Memory Range: 0xf0080000-0xf00fffff (rw,non-prefetchable)
  IRQ: 19 (1992 events)
  HW Address: 08:00:27:8f:f7:1d
  Link detected: yes
  Module Alias: "pci:v00001022d00002000sv00001022sd00002000bc02sc00i00"
  Driver Info #0:
    Driver Status: pcnet32 is active
    Driver Activation Cmd: "modprobe pcnet32"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
Scheint also irgendwie die Treiber nicht zu laden...
*/

/* Edit:
Ich benutze die CD-Version
*/

/* Edit:
Ich habe jetzt mal versucht den Treiber mit modprobe pcnet32 zu laden.
Es sind aber anscheinend keine 64-Bit Kernel Module enthalten, das Verzeichnis /lib/modules/3.0.4-64 existiert nicht, hier müssten aber die Module liegen.
Die 32 Bit Module lassen sich auch logischer Weise nicht laden, die Frage ist, warum geht es bei dir, benutzt du die DVD Version, die die Treiber eventuell beinhaltet?
*/

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »maxi_king_333« (23.11.2011, 15:05)


klaus2008

Meister

Beiträge: 2 688

Geschlecht: Männlich

10

23.11.2011, 15:58

Nur die DVD von Knoppix V6.7.1 kann mit dem 64-Bit-Kernel arbeiten. Wie Du schon bemerkt hast, fehlt das Verzeichnis mit den Kernelmodulen 3.0.4-64.

Lade Dir doch die DVD herunter und reduziere die Pakete, bis nur noch die zusätzliche Unterstützung für den 64-Bit-Kernel hinzugekommen ist, und versuche das Ganze mit dem Squashfs zu remastern. Villeicht passt das System dann wieder auf eine CD. :)

Gruß
Klaus

Beiträge: 1 150

Geschlecht: Männlich

11

23.11.2011, 16:32

Nur die DVD von Knoppix V6.7.1 kann mit dem 64-Bit-Kernel arbeiten. Wie Du schon bemerkt hast, fehlt das Verzeichnis mit den Kernelmodulen 3.0.4-64.

Lade Dir doch die DVD herunter und reduziere die Pakete, bis nur noch die zusätzliche Unterstützung für den 64-Bit-Kernel hinzugekommen ist, und versuche das Ganze mit dem Squashfs zu remastern. Villeicht passt das System dann wieder auf eine CD. :)

Gruß
Klaus
Warum befindet sich dann der 64-Bit Kernel auf der CD? :D
Platzverschwendung... Dann werde ich mir mal die DVD herunterladen und ein bisschen abspecken,

Viele Dank und Viele Grüße
Maxi

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop