14.12.2018, 09:30 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Anonymous

unregistriert

1

27.09.2005, 10:52

N?chstes Prob. smbmount funzt, aber nicht beim booten...

Hi!

Ich m?chte ein Laufwerk hier von meinem WinXP Rechner in Linux einbinden und das automatisch beim start von Knoppix.

Wenn ich das in der konsole schreibe gehts:

smbmount //internetpc/D /home/sandman/winXP_d -o password=meinpasswort,rw

Wenn ich die Zeile als script in der init.d speicher und ?ber rc5.d den Link aufrufe gehts auch, aber beim booten kommt vollgende Fehlermeldung:

Error: Connection to 192.168.178.21 (network is unreachable)
2897: connection to internetpc failed
smb connection failed

Mhhh... Einer ne Idee?

Gru?
Fendi

2

27.09.2005, 12:01

Hallo Fendi,

> Mhhh... Einer ne Idee?

du koenntest die Zeile "smbmount //internetpc/D ..."
in /etc/rc.local eintragen, denn "/etc/rc.local is almost
the last script called at boot up" ( www.netbsd.org/guide/en/chap-rc.html ).

> Error: Connection to 192.168.178.21 (network is unreachable)

Das Netzwerk sollte verfuegbar sein, wenn /etc/rc.local beim Booten
aufgerufen wird.

Tschuess
Karl

Anonymous

unregistriert

3

27.09.2005, 12:54

Ok danke, werds mal versuchen.

Gru?
Fendi

-edit-

Mhh... es gibt aber kein rc.local in /etc

Was mach ich denn jetzt???

Es gibt:

rc0.d

bis

rc6.d

und

rc.boot

rcS.d

Wobei das alles ja nur Verzeichnisse sind.

4

27.09.2005, 17:15

Hallo Fendi,

> Mhh... es gibt aber kein rc.local in /etc

oh je, das gibt es offensichtlich nur bei SuSE, Red Hat...
aber nicht bei Debian/Knoppix.

> Was mach ich denn jetzt???

Selbst ist der Fendi! :-)
Kratz deine Chinesisch-Kenntnisse zusammen und lies
http://tavi.debian.org.tw/index.php?page=rc.local
(Fuehr die Befehle aus, die dort im grauen Kasten stehen.
Dann sollte es /etc/rc.local geben.)

Tschuess
Karl

Anonymous

unregistriert

5

27.09.2005, 18:57

Ok, h?ng mich mal rein! ;)

Is halt immer so hart alles auf eigene Faust rauszufinden wenn man eh nur den ganzen Tag am PC sitzt.... :twisted: Ich sterbe bestimmt mal an nem Herzinfarkt :oops:

-edit-
ahhhh jetzt ist die Seite auch noch down... :(

6

27.09.2005, 19:09

Hi Karl,

hier ist zwar nicht der Fendi, aber der neugierige Guido :lol:
Also die Datei gibt es bei mir auch nicht. Also selbst ist der.... auf den Link.Aber da k?tt nix! Nur bei mir, oder falscher Link? :wink:

Gruss Guido

Anonymous

unregistriert

7

27.09.2005, 19:37

Hi Guido!

Guck mal hier unter "Anfang und Ende" hab ich glaub ich was gefunden:

http://www.heise.de/ct/03/17/188/

Bin auch grad am testen...

Gru?
Fendi

-edit-
mhh... geht nat?rlich nicht, weil es ist ja nix anderes als das was ich schon versucht habe. :-/

8

27.09.2005, 19:47

Hallo Guido,

> Also die Datei gibt es bei mir auch nicht.

Welches Betriebssystem? Rote Fahne 2.0? ;-)
( www.heise.de/newsticker/meldung/11076 )

> auf den Link.Aber da k?tt nix! Nur bei mir, oder falscher Link?

Welcher Browser? lynx? ;-) Bei mir geht's.

Auf der Seite steht im Prinzip nicht viel mehr als

touch /etc/rc.local
chmod 755 /etc/rc.local
cd /etc/rc2.d
ln -s ../rc.local ./S99rc.local
cd /etc/rc3.d
ln -s ../rc.local ./S99rc.local

Tschuess
Karl

Anonymous

unregistriert

9

27.09.2005, 20:06

Mhhh ok, aber so hatte ich es ja gemacht, nur das ich die rc.local in dem Verzeichniss init.d erstellt habe.

Reingeschrieben habe ich dann das:

!#/bin/sh
smbmount //internetpc/D /home/sandman/winXP_d -o password=meinpass,rw

Es tut sich nix...

10

27.09.2005, 20:40

Hallo Fendi,

> aber so hatte ich es ja gemacht

fing der Name deines Scripts in rc5.d mit "S99" an?

S steht fuer Start = Beim Eintritt in das Level ausfuehren.
99 legt die Reihenfolge der Abarbeitung der Scripte fest.
01 = als erstes ... 99 = als letztes.

> !#/bin/sh
> Es tut sich nix...

Da muesste wenigstens eine Fehlermeldung kommen,
denn es muss "#!/bin/sh" heissen.

Tut sich was, wenn du "/etc/rc3.d/S99rc.local" auf der
Kommandozeile aufrufst?

Wenn ja, dann probier es mal mit

cd /etc/rc5.d
ln -s ../rc.local ./S99rc.local

Tschuess
Karl

Anonymous

unregistriert

11

27.09.2005, 21:02

Hallo Karl!

Ja hatte bei meinen ersten versuchen in rc5.d S99 davor stehen. Genau so wie du oben geschrieben hast hatte ich den Link gesetzt. Hatte es eben auch nochmal versucht, aber es geht nicht. Was mir aufgefallen ist, da? "smb connection failed" nicht mehr kommt! "connection failed to internetpc" kommt allerdings noch wenn ich es ?ber rc5.d versuche, wobei ich in rc2.d und rc3.d die Links auch noch mit drin habe.

Zu dem !#: Ui, da hatte ich mich vertippt! Es gab auch ne Fehlermeldung. Habs jetzt korrigiert :oops:

Von Hand kann ich das Script ?ber den Link in rc3.d starten! Das klappt.

Bei wechseln mit "init 3" als root(befinde mich in rc5.d) passiert eigentlich gar nix. Ich merke jedenfalls nix und ausgef?hrt ist auch nichts.

wie kann ich denn den kompletten bootvorgang mit verfolgen? Ich glaub man sieht nicht alles, oder?

mhhh... warum gibts bei knoppix dieses verdammte rc.local nicht standartm??ig!?!? :( Das kann doch nicht so schwer sein....

12

27.09.2005, 23:01

Hallo Fendi,

> Von Hand kann ich das Script ?ber den Link in rc3.d starten! Das klappt.

Gut. :-)

> wie kann ich denn den kompletten bootvorgang mit verfolgen?

In der Datei /etc/inittab steht vermutlich "id:5:initdefault". Zum Testen
kannst du das aendern in "id:3:initdefault".
Wenn du neu bootest, solltest du am Ende des Bootvorganges die
Ausgaben vom Script /etc/rc3.d/S99rc.local sehen. (Schreib einfach
"echo hallo" [ohne "-Zeichen] in das Script, damit es "hallo" ausgiebt.)

(Mit dem Befehl "init 5" kannst du dann wieder in den Runlevel 5 booten.)

Tschuess
Karl

Anonymous

unregistriert

13

29.09.2005, 08:28

Hallo Karl!

Hab jetzt was gefunden was auch klappt!

Ich poste einfach mal den Link. Ist ein anderes Forum.

http://www.debianforum.de/forum/viewtopic.php?t=52337&highlight=

In die /etc/fstab muss ein Eintrag rein! Hat auf anhieb geklappt! Geil!

Aber vielen Dank auch f?r Deine Hilfe!!!! :)

Gru?
Fendi

14

29.09.2005, 09:33

Hallo Fendi,

> In die /etc/fstab muss ein Eintrag rein!

sehr interessant, dass das moeglich ist.

Tschuess
Karl

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop