15.10.2019, 14:22 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

20.11.2005, 17:22

Druckserver im WLAN-Router nutzen

Hallo Leute,

ich komm mal wieder nicht weiter. Ich m?chte unter Linux meine Drucker nutzen. Sie h?ngen beide an 2 Routern mit Druckerschnittstelle. Eigentlich sollten sie unter tcp Port 9100 angesprochen werden. Nach ein weing googlen fand ich heraus, da? es tcp Port 515 ist. Bei der Cupseinrichtung lasse ich das Netz auf dem port absuchen und er findet beide Router. Nur drucken tut nix.
Gut der eine ist ein Canon i550 - scheint generell Probleme zu machen. Aber der andere ist ein Epson Stylus Color 740, der sollte eigentlich laufen. (tut er bei direktem Anschluss auch)
Hat jemand von Euch Erfahrungen mit einer solchen Anschaltung?

Gruss Guido

PS: Ansonsten rennt das Netzwerk :wink:

2

21.11.2005, 10:58

Hallo Guido,

ich habe etwas aehnliches letzte Woche gemacht und hatte
keine Probleme mit dem Drucken uebers Netz
(ich musste nur die richtige PPD-Datei herausfinden).

Verwendest du beim Drucken uebers Netz und beim
direkten Anschluss des Druckers am Rechner die gleiche
PPD-Datei?

Kommen denn die Daten beim Printserver an?
(Leutet z.B. am Printserver ein Data-Laempchen?)

Mit "telnet xxx.xxx.xxx.xxx 9100"
bzw. "telnet xxx.xxx.xxx.xxx 515" kannst du probieren,
direkt auf den entsprechenden Port des Printservers
zu gelangen (xxx.xxx.xxx.xxx = IP-Adresse vom Printserver).
Eingaben von der Tastatur sollte der Server dann entgegennehmen
und beantworten. Ich weiss allerdings nicht, was so ein Printserver
an Befehlen erwartet (das muesste im Handbuch stehen).

Tschuess
Karl

3

21.11.2005, 20:15

Hallo Karl,


danke f?r die Antwort. Werde mit telnet testen.
Das mit dem Handbuch ist ein netter Hinweis. Es besteht aus sreenshots f?r die Einrichtung unter windows, ansonsten ist es so informativ wie ein kleenex :wink:

Gruss Guido

4

22.11.2005, 19:06

Hallo Karl,

ju der Druckserver reagiert in der Tat auf die Telnetverbindung auf Port 515:

Connected to xxx.xxx.xxx.xxx


Escape Caracter is"irgendwas"

Dann gib ich irgendwas ein:
lpd: invalid printer
connection closed by foreign host

Was ich mich jetzt frage: Warum druckt der nix? Treiber sollte o.k. sein, l?uft ja, wenn direkt an LPT1
:roll:

Gruss Guido

5

22.11.2005, 21:32

Hallo Guido,

> Warum druckt der nix?

ich wuerde mal vermuten, dein Print-Server lauscht auf Port 515
und versteht dort nur das LDP-Protokoll.

Die Daten vom Client, auf dem Cups laeuft, kommen aber
laut ipp-Protokoll.

Server und Client "sprechen/verstehen" unterschiedliche Protokolle.

Abhilfe:

Auf dem Client lpd statt cups verwenden, damit der Client LDP "spricht".

cups dazu bringen, LDP zu "sprechen" (keine Ahnung wie das geht).

Dem Print-Server ipp beibringen (den Hersteller fragen ob und wie
das geht).

Tschuess
Karl

6

22.11.2005, 21:45

Hallo Karl,

danke f?r den Tipp. Jetzt werde ich mich mal n?her mit cups besch?ftigen.

Gruss Guido

7

14.02.2006, 20:19

Ju hab es hinbekommen!!!!!!


Man muss nur den Namen des queues kennen. War bei mir LPD1.
An genau der "1" bin ich anfangs gescheitert - jetzt druckt er :lol:

Dank an Karl

Gruss Guido

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop