21.07.2018, 02:09 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Beiträge: 650

Geschlecht: Männlich

31

26.03.2009, 17:38

Schau mal in dem englischen how to.da steht soweit ich mich erinner von ner globalen startdatei wo knoppix alles abarbeitet.die muss man wohl editieren an der stelle wo die desktop umgebung eingetragen ist.

Beiträge: 650

Geschlecht: Männlich

32

26.03.2009, 17:48

Soll wohl unser etc/init.d sein und knoppix-autoconfig heißen.da nach ner zeile desktop= suchen und dort kde eintragen.

Beiträge: 1 150

Geschlecht: Männlich

33

26.03.2009, 17:53

Ich weiß jetzt net so genau wo auf deiesem "riesen" HowTO ich das finde und eigentlich gibt es da nicht sowas was ich meine aber egal hast du mal einen "genauen" Link?
Wie:
http://www.knoppix.net/wiki/Knoppix_Rema…a_custom_script
Si vis pacem, para bellum

Beiträge: 1 150

Geschlecht: Männlich

34

26.03.2009, 17:58

Ups hast ja zwischendurch schon wieder was geschrieben, sry.
Si vis pacem, para bellum

Beiträge: 1 150

Geschlecht: Männlich

35

26.03.2009, 18:01

Hab geguckt mit "vi" nach "desktop" nichts gefunden...
Si vis pacem, para bellum

Beiträge: 650

Geschlecht: Männlich

36

26.03.2009, 18:12

Dann ist das wohl mich mehr ganz aktuell.kannst ja mal die datei durchsehen ob es jetzt anders heißt oder mr google fragen.komm erst morgen wieder zum testen dann schau ich auch mal nach.

Beiträge: 1 150

Geschlecht: Männlich

37

26.03.2009, 18:16

Hab mir alles angeguckt gab nix in die Richtung...
Ich hatte mal gentoo installiert dort musste man irwie was an die init skripte anhängen vielleicht hat es irwas mit init 5 auf sich aber nur vermutung...
Si vis pacem, para bellum

Beiträge: 1 150

Geschlecht: Männlich

38

26.03.2009, 19:36

Hi,

ich hab mal ei Versuch gestartet ein Knoppix up zu daten "apt-get update" mehr net nur kann ich am Ende die umounts:
umount udev
umount proc
umount sysfs
nicht machen, da kommt dann immer Drive is busy oder so...
Werde mal weiter versuchen...

MFG
Maxi
Si vis pacem, para bellum

Beiträge: 650

Geschlecht: Männlich

39

27.03.2009, 13:10

Knapp vertan würd ich mal sagen ;)

die rel Datei heißt jetzt knoppix-startx und befindet sich ebenfalls unter /etc/init.d

Dort die Variable SESSION="lxde" suchen und abändern in SESSION="kde"

2 Zeilen weiter unten steht dann das bekannte DESKTOP="$SESSION" und sollte nun die KDE starten.

Soweit ich gelesen habe langt ein umount /proc, die anderen musst nicht unmounten.

mfg Jack

Beiträge: 1 150

Geschlecht: Männlich

40

27.03.2009, 20:52

Hi,
die rel Datei heißt jetzt knoppix-startx und befindet sich ebenfalls unter /etc/init.d

Dort die Variable SESSION="lxde" suchen und abändern in SESSION="kde"
das gibt es zwar, wenn ich es jetzt ändere in kde und dann "init 5" eingebe dann startet wieder "LXDE"...
Ist ja auch klar das Skript muss ja auch erst ausgeführt werden denke ich mir, was aber nicht stimmt, denn wenn ich es ausführe wird der Computer heruntergefahren...
Werde mal weiter testen...
//Edit: lag glaube ich daran das ich vorher mit "apt-get update" und "apt-get upgrade" Updates gefahren habe

MFG
Maxi
Si vis pacem, para bellum

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »maxi_king_333« (27.03.2009, 21:41)


Beiträge: 650

Geschlecht: Männlich

41

28.03.2009, 14:14

Das Skript sollte beim Wechsel in den Runlevel 5 automat. getartet werden, zumindest ist der Start dieses Skripts in der Datei /etc/inittab aufgeführt. Warum das nicht klappt ist mir dann ein Rätsel.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »JackCarver« (28.03.2009, 15:57)


Beiträge: 1 150

Geschlecht: Männlich

42

29.03.2009, 09:40

Hi,

Ich muss dir da leider unrecht geben...
Also noch mal um das klarzustellen...
Nach den Updates startete gar keine Desktop Umgebung mehr...
Ohne Updates musst du das skript ausführen sonst startet LXDE...
Ich habe in /etc/rc5.d nachgeguckt und das Skript wird eigentlich nicht ausgeführt oder ich hab was übersehen...
Knoppix führt das Skript denke ich beim Start aus...

//Edit:
Habe die Tests abgeschlossen...
Also du muss das Skript ausführen...
Nun gibt es aber ein paar Probleme...
Und zwar wird der Computer durch das Skript nach dem Abmelden (verlassen von KDE mit init 2 geht irwie nicht) heruntergefahren...
Das kann man abbrechen indem mann wenn das Skript zu Ende ist und noch mal ganz kurz er Promt erscheint init 2 eingibt muss man aber schnell sein...
Ich versuche das Skript so zu ändern das der Computer nicht heruntergefahen wird...

//Edit:
Hab das Skript verändert jetzt geht es...
Aber trotzdem wenn du init 5 eingibst startet wieder LXDE...
Werde mir jetzt noch mal die Skripte aus init 5 anschauen...
Ich schreibe eine neue Anleitung...

MFG
Maxi
Si vis pacem, para bellum

Dieser Beitrag wurde bereits 6 mal editiert, zuletzt von »maxi_king_333« (29.03.2009, 10:51)


Beiträge: 650

Geschlecht: Männlich

43

29.03.2009, 11:25

Hi,

da ich es sebst noch nicht getestet habe kann ich zu diesem Skript leider nix sagen, bin noch mit Kerneln und Grafik beschäftigt. Es müsste aber doch möglich sein, auch ohne Runlevel-Wechsel die Einstellungen zu kopieren. Wenn du unter ner laufenden Sitzung an den KDE-Einstellungen was änderst speichert er das doch schätz ich ma temporär irgendwo. Das müsste man dann in die chroot-Umgebung kopieren und es sollte da auch sein. Mit Iceweasel und co klappt das doch auch.

Beiträge: 1 150

Geschlecht: Männlich

44

29.03.2009, 11:43

Keine Ahnung...
Ich baue gerade ein neues ISO wo ich knoppix-startx modifiziert habe um zu testen ob es klappt...
Das mit dem Skript klappt du musst 2 Zeilen entfernen und schon fährt der Computer nicht mehr herunter und du bist in KDE...
Si vis pacem, para bellum

Beiträge: 650

Geschlecht: Männlich

45

29.03.2009, 12:00

Naja ich werd das mit der CD wahrsch eh nicht testen können es sei denn ich installier die KDE aber btw, find ich diese LKDE gar net mal schlecht und sie fährt sauschnell hoch. Von daher werd ich die LKDE lassen. Mit der neuen KDE 4.2 hatte ich unter Debian nur Ärger, instabil ohne Ende.

Wenn du diese Zeilen entfernst kannst den Rechner dann noch über das Menü herunterfahren?

Beiträge: 1 150

Geschlecht: Männlich

46

29.03.2009, 13:07

Jo, du musst erst die Datei kopieren und dann verändern, steht dann alles ausführlich in der neuen Anleitung
Si vis pacem, para bellum

Beiträge: 650

Geschlecht: Männlich

47

29.03.2009, 13:20

So ich hab jetzt nen 2.6.28.7er Kernel integriert mit AGPGART=m und DRM=m. Zu 99% dieselbe konfig und derselbe Kernel wie unter meinem Debian System wo der verdammte fglrx läuft. Werd jetzt mal testen ob ich den endlich zum Arbeiten bewegen kann...

Gab es vor paar 100 Jahren nich so ne Sitte, dass man Leute bestraft hat, wenn sie schlampige Ware geliefert haben,wie zb den Bäcker wenn sein Brot zuwenig gewogen hat?

Was die mit ATI gemacht hätten wag ich mir gar net auszudenken, lol :D

Beiträge: 1 150

Geschlecht: Männlich

48

29.03.2009, 13:28

Hab die neue Anleitung hochgeladen
//Edit: auch ja und bei init 5 wird das Skript net ausgeführt außer es wird von einem der Skripte aufgerufen...
Aber ich glauber eher nein...
Trotzdem es funktioniert alles KDE Startet einstellungen vorgenommen iso gemacht und siehe da es klappt...
Si vis pacem, para bellum

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »maxi_king_333« (29.03.2009, 13:38)


Beiträge: 650

Geschlecht: Männlich

49

29.03.2009, 14:32

Na das hört sich ja dann gut an. Ich kann auch nen Erfolg verbuchen, siehe:

knoppix@Microknoppix:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 2600 Pro AGP
OpenGL version string: 2.1.8494 Release

Immerhin ca 1500 fps in fgl_glxgears nur Compiz mag noch net so...

Der fglrx läuft erstmal. Werd jetzt mal testen warum es erst nicht klappte. Hab nun ne Knoppix-Version mit dem 2.6.28.7er Kernel und ohne Installierten Nvidia-Treiber. Der war in meiner früheren Testversion fest installiert. Kann sein, dass beide Treiber ein und dieselbe Datei benötigen und es da zu Inkompatibilitäten kommt. Werd ich sehen, wenn ich den Nvidia jetzt gleich noch installiere.

Edit: Compiz läuft wie ne Eins!!! Hatte vorhin ne Einstellung in der xorg gelöscht, die Compiz scheinbar braucht. So nun der Test mit nvidia zusätzlich onboard.
Edit: Ok hätte ich mir denken können. Der Nvidia Installer verweigert das Modulbauen unter ner ATI-Karte :D
Das heißt ich muss erstmal unter meiner Nvidia Maschine das nvidia Modul bauen lassen und diese ISO Datei erstmal brennen um den Test mit ATI auf dem ATI-PC zu machen.
Immerhin weiß ich nun, dass der fglrx läuft, wenn er das nachher nicht mehr macht, wirds schwierig werden beide Treiber auf die CD zu quetschen. Evtl ein Knoppix Nvidia beschleunigt und ein anderes ATI??

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »JackCarver« (29.03.2009, 15:11)


Beiträge: 1 150

Geschlecht: Männlich

50

29.03.2009, 17:19

Hi,

vieleicht gibt es hier jemanden der sich gut mit Shell Skripting auskennt und der ein Shell Skript für das Remastern entwerfen könnte so mit "dialog" und co.
Der möge sich bitte hier melden!!!

MFG
Maxi
Si vis pacem, para bellum

Beiträge: 1 150

Geschlecht: Männlich

51

29.03.2009, 19:53

OK super...
kannst du vieleicht mal alle deine Erkenntnisse niederschreiben in eine Word (Open Office) Datei, damit ich sie in meine Anleitung aufnehmen kann?
Si vis pacem, para bellum

Beiträge: 650

Geschlecht: Männlich

52

29.03.2009, 20:12

Werd ich machen, muss aber vorher noch paar Tests mit den beiden Treibern nvidia und fglrx machen. Kann soviel schonmal sagen, sie vertragen sich definitiv nicht zusammen auf ner CD oder DVD. Prob ist, dass beide zumindest 1 Datei zusammen verwenden, die der NvidiaInstaller zB auf sich verlinkt.
Ich bin jetzt soweit, dass ich zumindest den nvidia Treiber ohne Installation sondern lediglich durch kopieren von extrahierten Datein zum laufen krieg. Also könnte ich übern Skript den Treiber aktivieren ohne dass man über apt-get oder sonstwie was installieren muss.
Ich werd jetzt mal testen, ob es mögl ist den fglrx als erstes zu installieren, so dass dieser auf ner ATI-Maschine aktiviert werden kann und den nvidia Treiber durch kopieren der entsprechenden Dateien gleichzeitig auf ner Nvidia-Maschine zum laufen zu kriegen.

Beiträge: 1 150

Geschlecht: Männlich

53

29.03.2009, 20:20

OK, kein Stress...
Zwei CD's wären nicht verkehrt...
Ich hab nvidia und bei mir geht auch kein Compiz also perfekt wenn das durch en Skript geht :thumbsup: .
Si vis pacem, para bellum

Beiträge: 650

Geschlecht: Männlich

54

30.03.2009, 11:04

Naja ganz so einfach isses nicht. Das Kernelmodul muss in jedem Fall für jeden Kernel individuell erstmal kompiliert werden, dh zumindest eine Installation muss durchgeführt werden, da ja zb der Nvidia-Installer erstmal das Modul kompilieren muss.
Hat man allerdings erstmal dieses Modul kann man den Treiber, wohlgemerkt wiederum nur auf demselben System einfach dadurch installieren, dass man die nötigen Dateien wie Kernelmodul etc an die richtigen Stellen im System kopiert.

Und da ist mein Ansatz:
Da der fglrx nicht funktioniert wenn man ihn in ein System installiert in dem schon der Nvidia-Installer seine Spuren hinterlassen hat, versuch ich zuerst den fglrx in die chroot-Umgebung zu installieren, so dass dieser zumindest schonmal funktioniert und hoffe, dass der Nvidia-Treiber trotz installiertem fglrx lauffähig ist.
Ist dies der Fall, so genügt es diesen über ein Skript, das einfach die benötigten Dateien kopiert zu aktivieren, wenn nicht, ist die einzige Möglichkeit, dass man keinen der beiden Treiber fest installiert, sondern versucht auch den fglrx über kopieren von Dateien zum laufen zu kriegen. Dazu muss man den nat auch wie den Nvidia erstmal fest installieren, damit das Kernelmodul kompiliert wird und dann wieder die benötigten Datein rauskopieren usw

Edit: Hab auch den fglrx durch kopieren von Modul und Dateien zum Laufen gebracht. Damit sollte es möglich sein, beide Treiber ohne Probleme auf ein und demselben System zu integrieren und bei Bedarf den entsprechenden durch kopieren der Dateien usw (das sollten 2 Skripte nvidia und ati zb erledigen wenns ma fertig ist) zu aktivieren.

mfg Jack

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »JackCarver« (30.03.2009, 14:05)


Beiträge: 650

Geschlecht: Männlich

55

30.03.2009, 16:40

Hier mal die Anleitung zum Integrieren eines neuen Kernels, weitere folgen ;)

Umbennen in .odt
»JackCarver« hat folgende Datei angehängt:
  • HowToKernel.txt (25,22 kB - 13 mal heruntergeladen - zuletzt: 12.05.2009, 16:25)

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »JackCarver« (30.03.2009, 20:02)


Beiträge: 650

Geschlecht: Männlich

56

30.03.2009, 17:06

Anleitung zu Nvidia, ebenfalls in .odt umbennen
»JackCarver« hat folgende Datei angehängt:
  • HowToNvidia.txt (24,93 kB - 15 mal heruntergeladen - zuletzt: 20.07.2009, 22:43)

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »JackCarver« (30.03.2009, 17:42)


Beiträge: 650

Geschlecht: Männlich

57

30.03.2009, 18:11

Hab nun als Zwischenstand eine CD mit Nvidia 3D Unterstützung über den Treiber nvidia gebrannt und eine mit ATI 3D Beschleunigung unter fglrx. Ergebnis:

Unter ner 260 GTX läuft Compiz ab Start einwandfrei, soll heißen man sieht kurz nach Start bereits das Compiz Logo.
Edit: Ne GeForce 8400GS lüppt auch unter Compiz vom Start wech.

ebenfalls unter meiner Radeon HD 2600 Pro AGP und zu meinem verwundern genauso unter meiner alten Radeon 9800 Pro. Der fglrx unterstützt also auch ne zieml Bandbreite an Karten.
HowTo dazu kommt Morgen.


mfg Jack

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »JackCarver« (30.03.2009, 18:28)


Beiträge: 1 150

Geschlecht: Männlich

58

30.03.2009, 19:33

Hi,

Zitat

Zunächst gilt es den neuesten Linux Nvidia-Treiber von der offiziellen Seite zu laden.
welche Seite???
Hast du eine URL???

MFG
Maxi
Si vis pacem, para bellum

Beiträge: 650

Geschlecht: Männlich

59

30.03.2009, 19:38

Na aber klar doch ;)

http://www.nvidia.de/Download/index.aspx?lang=de

So die fglrx-Sache ist auch fertich. Wieder in .odt umbenennen.
»JackCarver« hat folgende Datei angehängt:
  • HowToATI.txt (27,46 kB - 6 mal heruntergeladen - zuletzt: 04.05.2009, 13:35)

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »JackCarver« (30.03.2009, 20:07)


Beiträge: 1 150

Geschlecht: Männlich

60

30.03.2009, 19:51

Ich kauf nur noch nvidia "linux treiber" 8o
//Edit: Remastern der KDE einstellungen hat funktioniert nun sieht mein Desktop wie der von meinem Kubuntu :thumbsup:
//Edit: Werde mich mal ein "gnome" probieren...
Si vis pacem, para bellum

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »maxi_king_333« (30.03.2009, 19:57)


Ähnliche Themen

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop