25.05.2018, 11:07 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Beiträge: 650

Geschlecht: Männlich

61

23.06.2009, 18:45

Zitat

Gibt es ein Tool was mir sowas mitprotokolliert?


Jepp, das Tool heißt Krusader. Der hat nen Dateivergleicher. Um die Änderungen zu sehen, würd ich ne Sicherung der initrd machen, dann eine davon patchen und dann beide entpacken in verschiedenen Verz.
Dann lässt Krusader die beiden Verz vergl und er stellt dir alle Unterschiede dar

Beiträge: 1 150

Geschlecht: Männlich

62

23.06.2009, 18:46

OK, ich versuche es mal.

\\Edit:
Ist das ein GUI Tool?
Ich kann es nicht installieren weil es das Paket "kdebase-runtime" benötigt.
Und das geht ja bei mir nicht.

Zitat


E: Kaputte Pakete

Beiträge: 1 150

Geschlecht: Männlich

63

23.06.2009, 19:48

Geht auch einfacher:

Zitat


diff -r verz1 verz2

Vergleicht Datein und alles.

Beiträge: 1 150

Geschlecht: Männlich

64

23.06.2009, 19:55

Also ich kann da irwie nichts erkennen bis darauf, dass die Themes und hinzugefügt werde.

Achja, damit auch etwas angezeigt wird muss man auch immer noch ein paar Cheatcodes mitangeben.
Ich untersuche gerade ein paar FBSplash InitSkripte.

Wie werden die Initskripte den geladen (einfach ausgeführt, wird irgentwas übergeben)?

Beiträge: 650

Geschlecht: Männlich

65

23.06.2009, 21:36

Zitat

Wie werden die Initskripte den geladen (einfach ausgeführt, wird irgentwas übergeben)?


beim Wechsel der Runlevel werden die ausgeführt, die Reihenfolge davon bestimmst mit nem Startlink in den Verz

/etc/rc1.d,rc2.d,rc3.d usw

Beiträge: 1 150

Geschlecht: Männlich

66

24.06.2009, 13:57

OK, mache alles noch mal neu (habe in den alten Dingeren keinen Splash mehr zum Starten bekommen)

//Edit:
Wegen KDE veilleicht habe ich irgentwas in der source.list falsch kannste mir mal deine schicken (hier hochladen).

Beiträge: 650

Geschlecht: Männlich

67

24.06.2009, 14:35

Zitat

Wegen KDE veilleicht habe ich irgentwas in der source.list falsch kannste mir mal deine schicken (hier hochladen).


Ich schick se dir als Codezeilen direkt im Posting:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
deb http://ftp.de.debian.org/debian unstable main contrib non-free
deb-src http://ftp.de.debian.org/debian unstable main contrib non-free

deb http://ftp.de.debian.org/debian testing main contrib non-free
deb-src http://ftp.de.debian.org/debian testing main contrib non-free

deb http://security.debian.org/ squeeze/updates main
deb-src http://security.debian.org/ squeeze/updates main

deb http://ftp.de.debian.org/debian stable main contrib non-free

# Knoppix repository
deb http://debian-knoppix.alioth.debian.org ./

# Multimedia repository
#deb http://debian-multimedia.org/ testing main
deb http://debian-multimedia.org/ unstable main

Beiträge: 650

Geschlecht: Männlich

68

24.06.2009, 14:44

Der neueste fglrx-Treiber läuft übrigens auf den Kerneln ab 2.6.29 nicht mehr. Gibt nen Compile-Error aus. Ich hab ihn über die Kernelsourcen von Debian zum Kompilieren gebracht, die haben die wohl gepatcht. 3D Beschleunigung geht wieder aber nun krieg ich beim Befehl dmesg 1000 Fehlermeldungen vom fglrx bzgl invalid map handle, inconsistent kernel data.

Die fglrx sind echt zum Kotzen...ATI und Linux ist eigentl nur für Masochisten was :D


mfg Jack

Beiträge: 1 150

Geschlecht: Männlich

69

24.06.2009, 15:02

Danke,

scheint zu klappen.

Wie ich schon sagte:

Zitat

Ich kauf nur noch nvidia "linux treiber" 8o


//Edit:

KDE funtzt *freu*

//Edit:
Wie hast du eigentlich den DesktopCube mit VirtualBox zum Laufen bekommen?

Beiträge: 650

Geschlecht: Männlich

70

24.06.2009, 15:17

Zitat

Wie hast du eigentlich den DesktopCube mit VirtualBox zum Laufen bekommen?


der Cube ist aus dem System selber aufgenommen über ksnapshot, die Bootbilder sind aus Virtual Box

Beiträge: 1 150

Geschlecht: Männlich

71

24.06.2009, 15:33

OK.

Ich habs jetzt.
Ich hab anstelle des Kernels 2.6.29 den 2.6.29.2 genommen und alles läuft.
Es kommen zwar keine Statusmeldungen aber egal.
Habe ein Screenshot im Anhang.
»maxi_king_333« hat folgende Dateien angehängt:
  • fbsplash.jpg (30,64 kB - 7 mal heruntergeladen - zuletzt: 25.06.2009, 16:32)
  • fbsplash.jpg (30,04 kB - 2 mal heruntergeladen - zuletzt: 24.06.2009, 15:40)

Beiträge: 1 150

Geschlecht: Männlich

72

24.06.2009, 15:41

Musst du dir umbedingt auch machen.
Die Bilder sind nichts gegen den realen Eindruck.

Das Theme gibt es hier:
http://fbsplash.berlios.de/wiki/doku.php?id=themes:main

Einfach nach /etc/splash herunterladen und dort entpacken, dann die Initrd patchen und noch das an die GrubCfg als Cheatcode dran:

Zitat


Configure the kernel command-line

Take a look at your boot configuration (whereas this is lilo, grub, etc…) and add the followings to the kernel command-line:

splash=silent,fadein,theme:THEME quiet CONSOLE=/dev/tty1

where you put a real theme name instead of THEME! For example, still with the emergence theme that we previously installed:

splash=silent,fadein,theme:emergence quiet CONSOLE=/dev/tty1

Beiträge: 650

Geschlecht: Männlich

73

24.06.2009, 15:41

Die Statusmeldungen kriegst wieder mit F2, also wennst die Bootmeldungen meinst. Sieht gut aus :thumbsup:

Beiträge: 650

Geschlecht: Männlich

74

24.06.2009, 15:46

Zitat

dann die Initrd patchen


das wird etwas problematisch, ich brauch die minirt.gz zum Start des Systems. Müsste halt die patchen frage ist allerdings ob die dann noch funzt. Bei meinem HD-Installaiierten kann ich das aber mal testen.

Beiträge: 1 150

Geschlecht: Männlich

75

24.06.2009, 15:50

Kannst dir ja auch zwei minirts machen.
Eine mit eine ohne Patch.

Werde jetzt erstmal mein eigenes Theme machen.

Beiträge: 650

Geschlecht: Männlich

76

24.06.2009, 15:58

Ja ich werd mal die mal testweise patchen, mal sehen was passiert. Weißt du zufällig was für Codezeilen da eingefügt werden? Du hast doch mit diesem diff mal verglichen oder?

musste grad den mplayer nochmal kompilieren, naja konnt so gleich den neuesten subversion snapshot wieder nehmen. Der ist mir in der ersten Version auf dem AMD-Rechner abgeschmiert, auf dem Intel ging er.

Hab gelesen das kann passieren wenn er unter ner anderen CPU läuft als er kompiliert wurde, da gibts aber ne Option --runtime-cpu-detection. Mit der werd ich mal testen was passiert wenn er nachher wieder auf dem AMD öäuft. Bei nem Live-System kann ich die CPU ja net bestimmen wo das dann läuft.

Beiträge: 1 150

Geschlecht: Männlich

77

24.06.2009, 16:09

Er ändert nicht viel nur eine Zeile aber die weiß ich nicht mehr genau.
Die Hauptfunktionen stecken glaube ich im Kernel, er läd nur die Themes rüber.

Beiträge: 650

Geschlecht: Männlich

78

24.06.2009, 16:24

2.6.28.10er is gepatcht und kompiliert grade, wollte mal sehen wie die performance vom fglrx unterm 28er ist, unterm 29er läufts zwar ist aber unterirdisch...60 Frames beim fgl_glxgears benchmark ist ein Witz, mit meiner Nvidia hab ich unter glxgears 11000 Frames, gut die is zwar bissl schneller aber sooo langsam ist die Radeon2600Pro nun auch net.

Dann hab ich gleich den Patch mit integriert, btw um tile-blitting abzuschalten baruchst nur den VIA und S3 deaktivieren, der ARK kann bleiben.


mfg Jack

Beiträge: 1 150

Geschlecht: Männlich

79

24.06.2009, 16:38

Zitat


Dann hab ich gleich den Patch mit integriert, btw um tile-blitting abzuschalten baruchst nur den VIA und S3 deaktivieren, der ARK kann bleiben.


Danke für die Info.

So habe nun ein naja nicht ganz perfektes Theme für mein LiveSystem(MAXIX)
»maxi_king_333« hat folgende Datei angehängt:
  • fbsplash.jpg (26,67 kB - 5 mal heruntergeladen - zuletzt: 24.06.2009, 16:55)

Beiträge: 650

Geschlecht: Männlich

80

24.06.2009, 16:46

Ah das Emerge World bearbeitet. Ja Themes gibts leider net soviele auf der Seite, Kannst auch das Backgound Image komplett austauschen?

Mann, das kompilieren unter nem alten AMD64 braucht ja ewig...Kein Vgl zu meinem Dual-Core, schätze mit nem 4 Kern gings noch deutl fixer.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »JackCarver« (24.06.2009, 16:52)


Beiträge: 1 150

Geschlecht: Männlich

81

24.06.2009, 16:53

Zitat

Kannst auch das Backgound Image komplett austauschen?

Kann ich.
Hab ich auch.
Ich habe mit Gimp en neues Bild gemacht (gleiche Größe) und dann einfach meinen Schriftzug reingemacht.
Ich find das Theme eigentlich super.

Zitat

Ja Themes gibts leider net soviele auf der Seite

JO.

Ich glaube auf kde-look.org gibts auch noch en paar aber mir reicht das was ich jetzt habe.

//Edit:
Der Balken ist auch Animiert.
Das ist so ein mng Fich kann ich aber nicht öffnen :(

Beiträge: 650

Geschlecht: Männlich

82

24.06.2009, 17:16

Mit Colourpaint kannst den öffnen aber das Bearbeiten damit ist wahrsch recht mühsam

Beiträge: 1 150

Geschlecht: Männlich

83

24.06.2009, 17:28

Egal er gefällt mir ja also lass ich es so wie es ist und tausche nur den Schriftzug aus.

Noch ein Bild.
»maxi_king_333« hat folgende Datei angehängt:
  • fbsplash.jpg (88,73 kB - 6 mal heruntergeladen - zuletzt: 24.06.2009, 21:09)

Beiträge: 1 150

Geschlecht: Männlich

84

24.06.2009, 17:32

Es gibt aber immernoch ein Problem.
Mit Anwendungen alla Aptitude.
»maxi_king_333« hat folgende Datei angehängt:
  • fbsplash.jpg (67,72 kB - 5 mal heruntergeladen - zuletzt: 06.09.2009, 15:20)

Beiträge: 650

Geschlecht: Männlich

85

24.06.2009, 17:42

Du musst in die Anleitung noch mit aufnehmen, dass man vor dem Patchen der initrd noch mind ein Theme ins Verz /etc/splash kopieren muss. Oder ich hab das überlesen :S

Oh das wird falsch dargestellt. Teste mal den mc unter der Konsole


mfg Jack

Beiträge: 1 150

Geschlecht: Männlich

86

24.06.2009, 17:45

Hab ich nicht das mit den Themes.

Beim mc ist es genau so.

//Edit:
Habe aber vielleicht eine Idee...
Das mc Binäry umkopieren und anstelle ein Skript laufen lassen.
  • FBSplash aus
  • mc direkt starten (Link zu kopiertem Binäry)
  • FBSplash an

Beiträge: 650

Geschlecht: Männlich

87

24.06.2009, 17:47

Versuch mal andere vga= Werte, evtl liegts daran

Beiträge: 1 150

Geschlecht: Männlich

88

24.06.2009, 17:48

mach ich

//Edit:
Geht habe einfach die Farben heruntergesetzt.

Beiträge: 650

Geschlecht: Männlich

89

24.06.2009, 18:03

Anleitung funktioniert, allerdings hab ich kein Hintergrundbild auf der Konsole aber das wäre auch net so wild, der Ladebalken kommt gut.

Performance des fglrx unterm 28er Kernel=29er, dann kann ichs auch bei dem lassen

edit:

das hab ich in der menu.lst

/boot/vmlinuz-splash root=/dev/hda5 ro quiet vga=791 splash=silent,fadein,theme:emerge-world CONSOLE=/dev/tty1

Beiträge: 1 150

Geschlecht: Männlich

90

24.06.2009, 21:01

War Abendessen.

Mach mal aus:

Zitat

boot/vmlinuz-splash root=/dev/hda5 ro quiet vga=791 splash=silent,fadein,theme:emerge-world CONSOLE=/dev/tty1

Zitat

boot/vmlinuz-splash root=/dev/hda5 ro quiet vga=791 splash=silent,fadein,theme:emerge-world console=tty1


//Edit:
Also bei mir muss "ARK 2000PV support" deaktiviert sein sonst gehts net.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »maxi_king_333« (24.06.2009, 21:37)


Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop