25.04.2017, 06:51 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Beiträge: 711

Geschlecht: Männlich

1

06.07.2009, 17:37

Überarbeitete Anleitung (Teil III)

Nachdem mein Beitrag auf Seite 10 des 2. Teils nicht aufrufbar ist, mache ich mal hier weiter.

Aber du hast da etwas falsch verstanden...
Du musst erst das Skript mit "-D /media/sda6 -a m" laufen lassen.

Genau das hatte ich getan. Lief aber nicht.

Dann hast du auf "/media/sda6" mehrere Verzeichnisse.
Nun kannst du wie in der Anleitung beschrieben, rein chrooten (chroot /media/sda6/source), nun kannst du alle Änderungen vornehmen.

Ich dachte, ich müsste erst alle Änderungen vornehmen und die würden dann mitkopiert. Was bitte ist "rein chooten"?
MfG. Cottonwood.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Cottonwood« (07.07.2009, 15:17)


Beiträge: 650

Geschlecht: Männlich

2

06.07.2009, 17:47

Hab auch noch etwas zum Skript geschrieben. Es sieht so aus, als ob eine fehlende log Datei die Fehler verursacht, nachdem ich sie per Hand angelegt hatte und die log-Zeile im Skript darauf verwiesen habe, klappte es zunächst, allerdings gibts Probs beim Mounten des containers


mfg Jack

Beiträge: 1 150

Geschlecht: Männlich

3

06.07.2009, 17:53

Zitat

Ich dachte, ich müsste erst alle Änderungen vornehmen und die würden dann mitkopiert. Was bitte ist "rein chooten"?

Ich sage doch du hast was falsch verstanden.
Wie das eigentliche Remastern geht steht in der Anleitung.

Es hat mir grade meine Festplatte zerfetzt *shit*, schreibe nun aus Knoppix.

Also ich weiß echt nicht was ihr habt, bei mir läuft das Skript ohne Probs.

Beiträge: 711

Geschlecht: Männlich

4

06.07.2009, 17:53

Ich hab's jetzt mal laufen lassen. Bis auf so eine blöde Meldung dazwischen sieht's gut aus. Jetzt muss ich noch brennen und testen. Ich melde mich wieder.

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
root@Microknoppix:/home/knoppix# leafpad remasterskript.sh
root@Microknoppix:/home/knoppix# bash remasterskript.sh -a m
Fehler: Konnte /media/sda6/remaster/master nicht anlegen
Fehler: Konnte /media/sda6/remaster/masterbak nicht anlegen
Fehler: Konnte /media/sda6/remaster/source nicht anlegen
Fehler: Konnte /media/sda6/remaster/sourcebak nicht anlegen
Fehler: Konnte /media/sda6/remaster/tmpsource nicht anlegen
Erfolg: Container Datei erfolgreich entpackt
Fehler: Konnte /media/sda6/remaster/knoppix nicht nach /media/sda6/remaster/tmpsource mounten
Erfolg: /mnt-system/* nach /media/sda6/remaster/master kopiert
Erfolg: /mnt-system/* nach /media/sda6/remaster/masterbak kopiert
Fehler: Konnte /media/sda6/remaster/tmpsource  nicht nach /media/sda6/remaster/source kopieren
Fehler: Konnte /media/sda6/remaster/tmpsource  nicht nach /media/sda6/remaster/sourcebak kopieren
Fehler: Konnte /media/sda6/remaster/tmpsource nicht umounten
Erfolg: Container Datei erfolgreich gelöscht
root@Microknoppix:/home/knoppix# bash remasterskript.sh -a p
Erfolg: Container Datei erfolgreich gelöscht
Erfolg: Temporäre ISO für das Knoppix Image erfolgreich angelegt
Erfolg: Container Datei erfolgreich erstellt
Erfolg: Temporäre ISO für das Knoppix Image erfolgreich gelöscht
Erfolg: Erfolgreich nach /media/sda6/remaster/master gewechselt
Erfolg: ISO Image erfolgreich erstellt
root@Microknoppix:/home/knoppix# 


Ich meine diese Zeile:

Quellcode

1
Fehler: Konnte /media/sda6/remaster/knoppix nicht nach /media/sda6/remaster/tmpsource mounten
MfG. Cottonwood.

Beiträge: 650

Geschlecht: Männlich

5

06.07.2009, 18:04

Gleiche auch bei mir, hab das auch geändert, allerdings kann ich nicht auf die schnelle sagen woran es liegt, mit meiner Version krieg ich die Meldung nun nicht mehr.

also nochmal mit dem Befehl

Zitat

./remasterskript -D /media/sdc4 -a m


musste ich folg Änderungen machen, dass es bis auf nun 1 einzige Fehlermeldung läuft.

1. Ne Datei log unter /media/sdc4 anlegen und die log-Zeile ganz oben im Skript darauf verweisen lassen.

2. Beim mounten des containers hab ich das nun so umgeschrieben, statt des alten Befehls mit loop hab ich da nun:

Quellcode

1
2
losetup /dev/cloop /mnt-system/KNOPPIX/KNOPPIX
mount /dev/cloop /media/sdc4/tmpsource -o ro


danach klappte auch das Mounten auf tmpsource

Beiträge: 1 150

Geschlecht: Männlich

6

06.07.2009, 18:06

Ich habe einen Fehler der unter verwendung von -D das Log nicht richtig schreibt...
Update nun das Skript.

Beiträge: 1 150

Geschlecht: Männlich

7

06.07.2009, 18:09

Ich gehe mal davon aus, dass der Fehler daher kommt das ihr nicht /remaster als basis Dir habt und es mit -D setzt.

Beiträge: 650

Geschlecht: Männlich

8

06.07.2009, 18:25

Zitat

Ich gehe mal davon aus, dass der Fehler daher kommt das ihr nicht /remaster als basis Dir habt und es mit -D setzt.


Könnte sein klar. Aber so tragen wir ja dazu bei, dass es immer besser wird :D

mfg Jack

Beiträge: 1 150

Geschlecht: Männlich

9

06.07.2009, 19:49

Zitat

Könnte sein klar. Aber so tragen wir ja dazu bei, dass es immer besser wird :D


Jo, ich werde ma gucken...

//Edit:
Ich habe mal eine Bitte - könnte mal einer von euch mit dem neuen Skript (ich habe ein neues wegen einem Fehler in der Log Datei, wenn nicht sicher bitte neu herunterladen) einen Durchlauf machen und gucken ob es im Main 7 Verzeichnis z.B. /mdia/sda1 eine Datei log.log gibt, wenn ja hier hochladen, wenn nein mir sagen.

Beiträge: 711

Geschlecht: Männlich

10

06.07.2009, 20:35

Gerne. Kann bei mir aber noch etwas dauern. Ich versuche seit Stunden, k3b ans Laufen zu bekommen. :cursing:
MfG. Cottonwood.

Beiträge: 1 150

Geschlecht: Männlich

11

06.07.2009, 20:37

Passt schon.

//Edit:
Wozu ich den Log brauche - dort werden alle Ausgaben der Befehke reingeschrieben und dann kann ich eine bessere Fehleranalyse machen.

Beiträge: 711

Geschlecht: Männlich

12

06.07.2009, 21:03

Ich weiss, dass das hier nicht reingehört. Aber was soll diese Sch...

Immer, wenn ich k3b installiert habe, kann ich kein Terminalfenster mehr öffnen.
MfG. Cottonwood.

Beiträge: 1 150

Geschlecht: Männlich

13

06.07.2009, 21:05

Keine Ahnung...
Kannst du nicht mehr auf die ttys?

Beiträge: 711

Geschlecht: Männlich

14

06.07.2009, 21:08

Ich kann in der Taskleiste praktisch nichts mehr anklicken. Ich boote jetzt neu und mache vorher ein Terminalfenster auf. Um da drinnen den k3b zu starten, nachdem ich ihn installiert habe.

Das ist jetzt schon der dritte PC, an dem es mir so geht.
MfG. Cottonwood.

Beiträge: 1 150

Geschlecht: Männlich

15

06.07.2009, 21:09

Seltsam...

Beiträge: 711

Geschlecht: Männlich

16

06.07.2009, 21:10

Ich kann nicht einmal mehr runterfahren. Nur noch ausschalten.
MfG. Cottonwood.

Beiträge: 1 150

Geschlecht: Männlich

17

06.07.2009, 21:11

Welches Knoppix benutzt du? 6.0.1?

Beiträge: 711

Geschlecht: Männlich

18

06.07.2009, 21:26

Ja, genau.
MfG. Cottonwood.

Beiträge: 1 150

Geschlecht: Männlich

19

06.07.2009, 21:27

Ich werds mal testen, ob es bei mir geht.

//Edit:
Hast du die Parketquellen verändert?

Beiträge: 650

Geschlecht: Männlich

20

06.07.2009, 21:36

Du meinst ein VNC-Terminalfenster oder?

Kann evtl an der LXDE liegen, k3b ist ne KDE Anwendung, ne KDE 3 Anwendung um genau zu sein.

Ich teste mal dein neues Skript mit dem Befehl

Zitat

./remasterskript.sh -D /PFAD -a m


Mail hier dann Fehlermeldungen falls welche kommen und die log-Datei.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »JackCarver« (06.07.2009, 21:41)


Beiträge: 1 150

Geschlecht: Männlich

21

06.07.2009, 21:37

Hä?
VNC-Terminalfenster?
Nein.
Einfach ob du die Paketquellen bearbeitet haste /etc/apt/sources.list

//Edit:
Bei mir lässt sich das nichmal installieren.

Beiträge: 650

Geschlecht: Männlich

22

06.07.2009, 21:42

Ich denke Cottonwood meint ein VNC-Terminalfenster, weil er Knoppix auf ner Eee-Box laufen hat und die fernsteuert.

edit:

Ich konnte das bei einem Remaster installieren, allerdings hatte ich da auch die KDE4 bereits drauf

Beiträge: 1 150

Geschlecht: Männlich

23

06.07.2009, 21:43

Achso, das wusst ich nicht.

Beiträge: 711

Geschlecht: Männlich

24

06.07.2009, 21:45

Nein, kein VNC-Fenster. Unten auf der Taskleiste ist links das LIDE-Symbol. Daneben der Explorer. Dann kommt das Terminalsymbol. Das geht alles, bis ich instelliert habe.

Ich weiss nicht genau, ab wann es nicht mehr geht. Ich installiere bereits. Irgendwann muss ich dann den Xscreensaver beenden. Das ist so ungefähr der Zeitpunkt.
MfG. Cottonwood.

Beiträge: 650

Geschlecht: Männlich

25

06.07.2009, 21:47

Ach du meinst die bash

Beiträge: 1 150

Geschlecht: Männlich

26

06.07.2009, 21:48

Zitat

Nein, kein VNC-Fenster. Unten auf der Taskleiste ist links das LIDE-Symbol. Daneben der Explorer. Dann kommt das Terminalsymbol. Das geht alles, bis ich instelliert habe.

Ich weiss nicht genau, ab wann es nicht mehr geht. Ich installiere bereits. Irgendwann muss ich dann den Xscreensaver beenden. Das ist so ungefähr der Zeitpunkt.

Habe ich doch nichts überlesen, xD.

Keine Ahnung bei mir lässt es sich nichtmal installieren...

Beiträge: 711

Geschlecht: Männlich

27

06.07.2009, 21:51

Es ist ganz kurz vor Abschluss der Installation. Diesmal habe ich vorher alles geöffnet. Mal schauen, ob ich brennen kann.

Edit: Natürlich nicht.

Quellcode

1
2
3
4
5
6
knoppix@Microknoppix:~$ su
root@Microknoppix:/home/knoppix# k3b
/usr/bin/iceauth:  creating new authority file /root/.ICEauthority
kdeinit: ../../src/xcb_lock.c:33: _XCBUnlockDisplay: Assertion `xcb_get_request_sent(dpy->xcb->connection) == dpy->request' failed.
k3b: ../../src/xcb_lock.c:33: _XCBUnlockDisplay: Zusicherung »xcb_get_request_sent(dpy->xcb->connection) == dpy->request« nicht erfüllt.
root@Microknoppix:/home/knoppix# 


Weiss vielleicht jemand, mit welcher Emulation ich die knoppix-data.img mit Nero brennen muss?
Ich habe leider nur zwei DVD's = 2 Versuche.
MfG. Cottonwood.

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Cottonwood« (06.07.2009, 21:59)


Beiträge: 650

Geschlecht: Männlich

28

06.07.2009, 22:08

So zunächst mal die Meldungen vom Skript, Befehl wie oben:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
Erfolg: /media/hda7/master angelegt
Erfolg: /media/hda7/masterbak angelegt
Erfolg: /media/hda7/source angelegt
Erfolg: /media/hda7/sourcebak angelegt
Erfolg: /media/hda7/tmpsource angelegt
Erfolg: Container Datei erfolgreich entpackt
Fehler: Konnte /media/hda7/knoppix nicht nach /media/hda7/tmpsource mounten
Erfolg: /mnt-system/* nach /media/hda7/master kopiert
Erfolg: /mnt-system/* nach /media/hda7/masterbak kopiert
Fehler: Konnte /media/hda7/tmpsource  nicht nach /media/hda7/source kopieren
Fehler: Konnte /media/hda7/tmpsource  nicht nach /media/hda7/sourcebak kopieren
Fehler: Konnte /media/hda7/tmpsource nicht umounten
Erfolg: Container Datei erfolgreich gelöscht


log lad ich hoch.
»JackCarver« hat folgende Datei angehängt:
  • log.txt (1,32 kB - 1 mal heruntergeladen - zuletzt: 07.07.2009, 11:36)

Beiträge: 650

Geschlecht: Männlich

29

06.07.2009, 22:15

Zitat

Weiss vielleicht jemand, mit welcher Emulation ich die knoppix-data.img mit Nero brennen muss?
Ich habe leider nur zwei DVD's = 2 Versuche


Als Datendisk oder soll das ähnlich wie eine iso werden?

Beiträge: 650

Geschlecht: Männlich

30

06.07.2009, 22:19

Die LXDE ist echt übel...Jedesmal wenn ich 2 Fenster auf hab und klicke auf das gerade minimierte, passiert gar nix. Ich muss erst jedesmal das maximierte minimieren und dann aufs andere klicken, damit es sich öffnet...

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop