23.11.2017, 23:22 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Beiträge: 711

Geschlecht: Männlich

1

06.09.2009, 20:39

mkxorgconfig: Fehler in Kommentarzeile ???

Hi,

kann mir bitte jemand erklären, wieso es in einer Kommentarzeile einen Fehler geben kann? Und wie dieser zu beseitigen ist.
[attach]295[/attach]

Das tritt übrigens nach einem apt-get update/apt-get upgrade in der Remaster-chroot-Umgebung auf.
MfG. Cottonwood.

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Cottonwood« (06.09.2009, 23:19)


Beiträge: 711

Geschlecht: Männlich

2

06.09.2009, 23:17

Und wenn man die Kommentarzeilen weglöscht, dann kommt das:
»Cottonwood« hat folgende Datei angehängt:
  • 20090906-1.jpg (41,94 kB - 3 mal heruntergeladen - zuletzt: 22.09.2009, 11:32)
MfG. Cottonwood.

klaus2008

Meister

Beiträge: 2 656

Geschlecht: Männlich

3

07.09.2009, 02:08

Du hast an irgendeiner Stelle ein "-Zeichen, zu dem es kein Gegenstück an der richtigen Stelle gibt. Vielleicht hast Du das fehlende "-Zeichen versehentlich gelöscht. Am einfachsten zeigst Du uns die gesamte Datei /sbin/mkxorgconfig.

Gruss Klaus

Beiträge: 711

Geschlecht: Männlich

4

07.09.2009, 13:34

Die Datei selber hat sich aber zwischen den beiden Ständen nicht verändert.

Eben habe ich festgestellt, dass es hier schon einen Fehler gab, der vorher nicht kam:
[attach]298[/attach]
»Cottonwood« hat folgende Datei angehängt:
MfG. Cottonwood.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Cottonwood« (07.09.2009, 14:57)


Beiträge: 711

Geschlecht: Männlich

5

07.09.2009, 17:40

Ich habe das apt-get update/apt-get upgrade jetzt mal mit dem Original-ISO vom Download der Uni Kaiserslautern getestet. Das Ergebnis ist ähnlich. Die Fehlermeldung mit der Clock kommt auch, der Fehler im Script tritt nicht auf. Stattdessen fährt das Image hoch, bringt aber kein vollständiges Startbild. Stattdessen fährt es sofort wieder runter.

Zwischendurch noch ein Scherz vom Knoppix beim Kopieren des Images:[attach]300[/attach]
MfG. Cottonwood.

Beiträge: 1 150

Geschlecht: Männlich

6

07.09.2009, 20:31

Quellcode

1
apt-get upgrade
Das würde ich mal lieber lassen.
Versuche es mal ohne das...

Beiträge: 711

Geschlecht: Männlich

7

07.09.2009, 23:04

Ich bin gerade dabei. Da ich aber für Asterisk ein aktuelles Knoppix brauche, installiere ich jetzt alles einzeln.

//Edit: Warum laufen die Kommandos in einer bash-Prozedur anders ab, als wenn ich sie einzeln mit copy/paste laufen lasse? Konkret richtet er in der Bash die Programme nicht ein, sondern sammelt sie. Dadurch fehlen ihm sofort Bibliotheken, die bei copy/paste bereits eingerichtet worden wären.
MfG. Cottonwood.

Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von »Cottonwood« (08.09.2009, 07:59)


Beiträge: 1 150

Geschlecht: Männlich

8

08.09.2009, 20:25

Zitat

//Edit: Warum laufen die Kommandos in einer bash-Prozedur anders ab, als wenn ich sie einzeln mit copy/paste laufen lasse? Konkret richtet er in der Bash die Programme nicht ein, sondern sammelt sie. Dadurch fehlen ihm sofort Bibliotheken, die bei copy/paste bereits eingerichtet worden wären.
Wie meinst du das jetzt?
Meinst du mit "bash-Prozedur" ein "Script"?
Und mit "copy/paste" das einfache eingeben?
Wen dem so ist, die Kommandos werden eigentlich alle gleich ausgeführt.

Beiträge: 711

Geschlecht: Männlich

9

08.09.2009, 20:28

Ich denke, wir meinen dasselbe. Aber sie laufen nicht identisch ab. Probier's einfach mal aus.
MfG. Cottonwood.

Beiträge: 1 150

Geschlecht: Männlich

10

08.09.2009, 20:31

Zitat

Ich denke, wir meinen dasselbe.
Ich meine Sowas.

Zitat

Ich denke, wir meinen dasselbe. Aber sie laufen nicht identisch ab. Probier's einfach mal aus.
Habe ich, ich habe haufenweise Scripte, das eine installiert bestimmte Programme, das andere kompiliert mir ein LFS und wieder an anderes remastert mir Knoppix.
Wie sieht denn dein Script aus?

Beiträge: 711

Geschlecht: Männlich

11

08.09.2009, 20:52

Es enthält eine Reihe von "apt-get install" - Anweisungen.
MfG. Cottonwood.

Beiträge: 1 150

Geschlecht: Männlich

12

08.09.2009, 20:57

Eigentlich müsste das klappen, außerdem apt löst die Abhängigkeiten automatisch auf.
Versuche mal alles hintereinander also "apt-get install vim dialog gcc".

Beiträge: 711

Geschlecht: Männlich

13

08.09.2009, 23:41

Danke für den Tipp. Das probiere ich beim nächsten Versuch. Momentan scheitere ich mal wieder an kleineren Dingen. Nämlich bereits in der Paketverwaltung. Da gibt es plötzlich unüberwindliche Abhängigkeiten. Plötzlich will er eine ältere Version, die ich natürlich überhaupt nicht bereitstellen kann.
»Cottonwood« hat folgende Datei angehängt:
  • 20090908.jpg (42,8 kB - 4 mal heruntergeladen - zuletzt: 14.09.2009, 21:55)
MfG. Cottonwood.

Beiträge: 1 150

Geschlecht: Männlich

14

09.09.2009, 19:49

Danke für den Tipp. Das probiere ich beim nächsten Versuch. Momentan scheitere ich mal wieder an kleineren Dingen. Nämlich bereits in der Paketverwaltung. Da gibt es plötzlich unüberwindliche Abhängigkeiten. Plötzlich will er eine ältere Version, die ich natürlich überhaupt nicht bereitstellen kann.
Das könnte an den Unstable Quellen von Debian liegen.
Aber wirklich weiter weiß ich da auch nicht.

Beiträge: 711

Geschlecht: Männlich

15

09.09.2009, 23:55

Ich danke dir trotzdem.

Das mit dem Zusammenfassen in einer Zeile hat eine wesentliche Erleichterung gebracht. Ich weiss jetzt viel schneller, dass es mal wieder nicht geklappt hat. 8| :evil:
MfG. Cottonwood.

Beiträge: 711

Geschlecht: Männlich

16

14.09.2009, 22:15

Inzwischen hat es so in etwa geklappt. Ich habe dann einfach neben der Synaptic-Paketverwaltung die Remaster-chroot-Umgebung geöffnet und jeweils ein Paket zunächst links zum Aktualisieren vorgemerkt und dann bei Erfolg rechts mit apt-get installiert. Dann habe ich so alle ca. 40 Pakete ein neues Image erstellt, das gebootet und damit weitergearbeitet.

Einmal am Tag habe ich dann zwischendurch noch ein Update gemacht.
MfG. Cottonwood.

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop