24.10.2017, 13:32 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Beiträge: 711

Geschlecht: Männlich

1

26.09.2010, 19:04

Problem mit apt-get update: FM "Na so was, Sie haben die Anzahl an Beschreibungen überschritten, mit denen APT umgehen kann."

Hi,

nachdem ich längere Zeit nicht remastered habe, wollte ich jetzt mal wieder was machen. Da ich bei der Installation von Software bereits Problemen habe, wollte ich erst mal mein Knoppix aktualisieren. Und jetzt klappt noch nicht einmal das apt-get update. Dabei bekomme ich die Fehlermeldung
[attach]487[/attach]

Dieselbe Meldung bekomme ich auch, wenn ich mit der Synaptic-Paketverwaltung aktuelisieren möchte:
[attach]488[/attach]

Ich habe auch versucht, dazu eine Lösung zu finden. Folgende Beiträge scheinen mir interessant:
Entmüllung der Sources.list -oder- als Sprache (Locale) Posix einstellen
(da weiss ich nicht, wie das geht)
/etc/apt/apt.conf anpassen
(Die Datei befindet sich nicht am angegebenen Ort)

Was muss ich wirklich tun? Kann mir da vielleicht jemand helfen?
MfG. Cottonwood.

klaus2008

Meister

Beiträge: 2 653

Geschlecht: Männlich

2

26.09.2010, 19:40

Hallo Cottonwood!

Der Fehler ist schon gelegentlich im Forum aufgetaucht, wenn Benutzer mit Knoppix 6.0 oder Knoppix 6.1 die Paketlisten aktualisieren wollten. Versuch doch einmal in einem Root-Terminal

Quellcode

1
LC_ALL=C apt-get update
auszuführen. Wenn das gelingt, würde ich als nächsten Schritt die Paketverwaltungssoftware aktualisieren.

Gruß Klaus

Beiträge: 711

Geschlecht: Männlich

3

26.09.2010, 20:16

LC_ALL=C apt-get update ist in der chroot-Umgebung beim Remastern problemlos durchgegangen. Das anschließende apt-get update brachte aber wieder denselben Fehler.

Im Root-Terminal lief es (nach Neustart) ebenfalls durch und das Neu-laden brachte auch denselben Fehler wie zuvor.
MfG. Cottonwood.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Cottonwood« (26.09.2010, 21:25)


Beiträge: 711

Geschlecht: Männlich

4

26.09.2010, 23:21

Ich habe noch etwas gefunden, was ich nicht umsetzen kann, weil ich nicht verstehe, was gemeint ist:

In zwei Bugreports finden sich außerdem Hinweise, dass der Fehler nicht auftritt, wenn man als locale C verwendet.

Kann mir jemand sagen, was da zu tun wäre?
MfG. Cottonwood.

klaus2008

Meister

Beiträge: 2 653

Geschlecht: Männlich

5

27.09.2010, 21:24

Das Umschalten der Lokalisierung auf POSIX ist nach meiner Erfahrung nur für apt-get update notwendig. Der Rest von apt-get schien bisher nicht davon betroffen zu sein.

Temporär kann man die Spracheinstellung auf die Lokalisierung C umstellen, indem man der Umgebungsvriablen LC_ALL den Wert C zuweist und dann das betreffende Programm aufruft. Ein Beispiel für diesen Vorgehen ist das oben bereits erwähnte

Quellcode

1
LC_ALL=C apt-get update


Der Aufruf von apt-get update aktualisiert die Paketliste, Programme werden dabei keine installiert. Dafür gibt es ja die bekannten Befehle install, upgrade und dist-upgrade. Das erklärt auch, weshalb der erneute Aufruf von apt-get update kein anderes Ergebnis erbrachte.

Beiträge: 711

Geschlecht: Männlich

6

27.09.2010, 21:34

Danke für die Antwort.

Wenn ich dich richtig verstehe, dann sollte ich also nach dem

Quellcode

1
LC_ALL=C apt-get update
das neue Image remastern. Mit diesem müsste ich dann ja in der Synaptic Paketverwaltung die neuen Pakete sehen.

Ich probiere das aus und melde mich wieder.
MfG. Cottonwood.

Beiträge: 711

Geschlecht: Männlich

7

28.09.2010, 11:09

Soweit sieht das gut aus. Gestern habe ich bis spät in die Nacht Pakete aktualisiert. Irgendwann hing sich dann das System auf. :evil:

Nun beginne ich erst einmal von vorne. Da kommen allerdings so zwischendurch immer mal wieder Fehlermeldungen. Hier ein Auszug vom Protokoll:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
Preparing to replace gnome-media-common 2.26.0-1 (using .../gnome-media-common_2.30.0-1_all.deb) ...
Unpacking replacement gnome-media-common ...
Preparing to replace gstreamer0.10-alsa 0.10.20-1 (using .../gstreamer0.10-alsa_0.10.30-1_i386.deb) ...
Unpacking replacement gstreamer0.10-alsa ...
Preparing to replace libgtk2.0-common 2.12.11-4 (using .../libgtk2.0-common_2.20.1-1_all.deb) ...
Unpacking replacement libgtk2.0-common ...
Preparing to replace libobrender21 3.4.7.2-3 (using .../libobrender21_3.4.11.1-1_i386.deb) ...
Unpacking replacement libobrender21 ...
Preparing to replace libstlport4.6ldbl 4.6.2-3.2 (using .../libstlport4.6ldbl_4.6.2-7_i386.deb) ...
Unpacking replacement libstlport4.6ldbl ...
Preparing to replace menu-xdg 0.3 (using .../archives/menu-xdg_0.5_all.deb) ...
Unpacking replacement menu-xdg ...
Processing triggers for man-db ...
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = "de",
	LC_ALL = "de_DE@euro",
	LC_MESSAGES = "de_DE@euro",
	LANG = "de_DE@euro"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
/usr/bin/mandb: can't set the locale; make sure $LC_* and $LANG are correct
manconv: can't set the locale; make sure $LC_* and $LANG are correct
manconv: can't set the locale; make sure $LC_* and $LANG are correct
manconv: can't set the locale; make sure $LC_* and $LANG are correct
manconv: can't set the locale; make sure $LC_* and $LANG are correct
manconv: can't set the locale; make sure $LC_* and $LANG are correct
manconv: can't set the locale; make sure $LC_* and $LANG are correct
manconv: can't set the locale; make sure $LC_* and $LANG are correct
manconv: can't set the locale; make sure $LC_* and $LANG are correct
manconv: can't set the locale; make sure $LC_* and $LANG are correct
manconv: can't set the locale; make sure $LC_* and $LANG are correct
manconv: can't set the locale; make sure $LC_* and $LANG are correct
manconv: can't set the locale; make sure $LC_* and $LANG are correct
manconv: can't set the locale; make sure $LC_* and $LANG are correct
manconv: can't set the locale; make sure $LC_* and $LANG are correct
manconv: can't set the locale; make sure $LC_* and $LANG are correct
manconv: can't set the locale; make sure $LC_* and $LANG are correct
manconv: can't set the locale; make sure $LC_* and $LANG are correct
manconv: can't set the locale; make sure $LC_* and $LANG are correct
manconv: can't set the locale; make sure $LC_* and $LANG are correct
manconv: can't set the locale; make sure $LC_* and $LANG are correct
manconv: can't set the locale; make sure $LC_* and $LANG are correct
Processing triggers for menu ...
Processing triggers for gconf2 ...
Setting up libbsd0 (0.2.0-1) ...
Setting up libedit2 (2.11-20080614-2) ...
Setting up libbluetooth3 (4.70-1) ...
Setting up libcap-ng0 (0.6.4-1) ...
Setting up bluez (4.70-1) ...
Installing new version of config file /etc/dbus-1/system.d/bluetooth.conf ...
Installing new version of config file /etc/bluetooth/audio.conf ...
Installing new version of config file /etc/init.d/bluetooth ...
Installing new version of config file /etc/default/bluetooth ...
Creating device nodes ...
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = "de",
	LC_ALL = "de_DE@euro",
	LC_MESSAGES = "de_DE@euro",
	LANG = "de_DE@euro"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
Reloading system message bus config...Failed to open connection to system message bus: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory
invoke-rc.d: initscript dbus, action "force-reload" failed.
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = "de",
	LC_ALL = "de_DE@euro",
	LC_MESSAGES = "de_DE@euro",
	LANG = "de_DE@euro"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
Starting bluetooth: bluetoothd.
Setting up bluez-alsa (4.70-1) ...
Setting up libgudev-1.0-0 (161-1) ...
Setting up liborc-0.4-0 (1:0.4.6-2) ...
Setting up libtheora0 (1.1.1+dfsg.1-3) ...
Setting up libgstreamer0.10-0 (0.10.30-1) ...
Setting up iso-codes (3.20-1) ...
Setting up libgstreamer-plugins-base0.10-0 (0.10.30-1) ...
Setting up gstreamer0.10-plugins-base (0.10.30-1) ...
Setting up bluez-gstreamer (4.70-1) ...
Setting up bluez-audio (4.70-1) ...
Setting up bluetooth (4.70-1) ...
Setting up bluez-utils (4.70-1) ...
Setting up gnome-media-common (2.30.0-1) ...
Setting up libgnome-media0 (2.30.0-1) ...
Setting up gstreamer0.10-alsa (0.10.30-1) ...
Setting up gnome-media (2.30.0-1) ...
Setting up libgtk2.0-common (2.20.1-1) ...
Setting up libobrender21 (3.4.11.1-1) ...
Setting up libstlport4.6ldbl (4.6.2-7) ...
Setting up menu-xdg (0.5) ...
Installing new version of config file /etc/menu-methods/xdg-desktop-entry-spec-dirs ...
Installing new version of config file /etc/menu-methods/xdg-desktop-entry-spec-apps ...
Installing new version of config file /etc/menu-methods/xdg-desktop-entry-spec-sessions ...
Processing triggers for menu ...
root@Microknoppix:/# echo $LANGUAGE$
de$
root@Microknoppix:/# echo $LC_ALL$
de_DE@euro$
root@Microknoppix:/# echo $LC_MESSAGES$
de_DE@euro$
root@Microknoppix:/# echo $LANG$
de_DE@euro$
root@Microknoppix:/# 


Während anfangs die Fragen auf deutsch kamen, kommen sie jetzt auf englisch:

Quellcode

1
2
After this operation, 77.0MB of additional disk space will be used.
Do you want to continue [Y/n]? 


Vielleicht fällt dir (oder sonst jemandem) dazu ja etwas ein. Ich mache erst mal weiter.

// Edit: Hat leider nicht geklappt. Das erzeugte Image funzt leider nicht. Da kann ich leider erst weiter machen, wenn keine Fehler mehr auftreten.
MfG. Cottonwood.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Cottonwood« (28.09.2010, 13:20)


klaus2008

Meister

Beiträge: 2 653

Geschlecht: Männlich

8

28.09.2010, 15:08

locales als Ersatz für belocs-locales-*

Ich habe neulich versucht, die Knoppix 6.2.1 CD zu remastern. Ich wollte nämlich die Pakete auf den Stand des Testing-Zweiges aktualisieren und ein paar Kleinigkeiten ergänzen. Ein apt-get -t testing dist-upgrade war nur schrittweise möglich, weil immer wieder Konflikte mit den Abhängigkeiten einzelner Pakete auftraten, welche ich mittels geeigneter "dpkg --force"-Anweisungen beheben musste. Am Ende war ich erfolgreich. Jedoch erschien eine ähnliche Fehlersituation mit der Lokalisierung.

Meine Lösung bestand darin, das Paket locales an Stelle der belocs-Pakete zu verwenden. Mit

Quellcode

1
apt-get -t testing install locales
wurden praktischerweise die belocs-Pakete deinstalliert. Leider muss man erst noch die Konfigurationsdatei /etc/locale.gen so bearbeiten, dass die interessierenden Lokalisierungen nicht mehr auskommentiert sind. (Ich entfernte die Kommantarzeichen vor den mit de_DE beginnenden Zeilen.) Dann erst konnte ich die neuen Lokalisierungen mit

Quellcode

1
locale-gen
erstellen. Hinterher beherrschten die Programme wieder die deutsche Sprache.

Heute habe ich einen Fehlerbericht im Internet gefunden: http://www.mail-archive.com/debian-[emai…/msg794256.html Die Lösung ist identisch mit meiner: http://www.mail-archive.com/debian-[emai…/msg795515.html

Zur remasterten CD lässt sich noch anmerken, dass die Aktualisierungen so groß wurden, dass die ISO-Datei nicht mehr auf eine CD passt (ungefähr 1 GB bei bestmöglicher Kompression).

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »klaus2008« (28.09.2010, 15:28)


Beiträge: 711

Geschlecht: Männlich

9

28.09.2010, 20:20

Meine Versuche mit 6.2 finden sich in einem anderen Thread. Deshalb antworte ich jetzt auch dort:
Probleme beim Remastern von KNOPPIX 6.2
MfG. Cottonwood.

Ähnliche Themen

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop